automatic version update by autodist [release 5.2.3-1mamba;Fri Jun 28 2024]
This commit is contained in:
parent
dc5b5c87b3
commit
40631a7250
@ -1,93 +0,0 @@
|
||||
From ace7edcca6ad322581ab39620f21ccf3ffbd3b5a Mon Sep 17 00:00:00 2001
|
||||
From: Timo Gurr <timo.gurr@gmail.com>
|
||||
Date: Fri, 5 Jan 2024 14:04:50 +0000
|
||||
Subject: [PATCH] Fix build with libjxl 0.9.0
|
||||
|
||||
Fix build with libjxl 0.9.0
|
||||
|
||||
BUG:478987
|
||||
|
||||
Test Plan
|
||||
---------
|
||||
|
||||
* Upgrade to libjxl 0.9.0
|
||||
* Apply patch from MR and build krita (5.2.2)
|
||||
* Open/Display a sample image e.g. https://jpegxl.info/test-page/red-room.jxl
|
||||
|
||||
Formalities Checklist
|
||||
---------------------
|
||||
|
||||
- [x] I confirmed this builds.
|
||||
- [x] I confirmed Krita ran and the relevant functions work (Could successfully open/display a sample image https://jpegxl.info/test-page/red-room.jxl).
|
||||
- [ ] I tested the relevant unit tests and can confirm they are not broken. (If not possible, don't hesitate to ask for help!)
|
||||
- [x] I made sure my commits build individually and have good descriptions as per [KDE guidelines](https://community.kde.org/Policies/Commit_Policy).
|
||||
- [x] I made sure my code conforms to the standards set in the HACKING file.
|
||||
- [x] I can confirm the code is licensed and attributed appropriately, and that unattributed code is mine, as per [KDE Licensing Policy](https://community.kde.org/Policies/Licensing_Policy).
|
||||
|
||||
_**Reminder: the reviewer is responsible for merging the patch, this is to ensure at the least two people can build the patch. In case a patch breaks the build, both the author and the reviewer should be contacted to fix the build.**_
|
||||
_**If this is not possible, the commits shall be reverted, and a notification with the reasoning and any relevant logs shall be sent to the mailing list, kimageshop@kde.org.**_
|
||||
---
|
||||
plugins/impex/jxl/JPEGXLImport.cpp | 15 ++++++++++++++-
|
||||
1 file changed, 14 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/plugins/impex/jxl/JPEGXLImport.cpp b/plugins/impex/jxl/JPEGXLImport.cpp
|
||||
index 573bae41247..f5b989b3b70 100644
|
||||
--- a/plugins/impex/jxl/JPEGXLImport.cpp
|
||||
+++ b/plugins/impex/jxl/JPEGXLImport.cpp
|
||||
@@ -511,7 +511,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
|
||||
JxlColorEncoding colorEncoding{};
|
||||
if (JXL_DEC_SUCCESS
|
||||
== JxlDecoderGetColorAsEncodedProfile(dec.get(),
|
||||
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0, 9, 0)
|
||||
nullptr,
|
||||
+#endif
|
||||
JXL_COLOR_PROFILE_TARGET_DATA,
|
||||
&colorEncoding)) {
|
||||
const TransferCharacteristics transferFunction = [&]() {
|
||||
@@ -635,7 +637,12 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
|
||||
size_t iccSize = 0;
|
||||
QByteArray iccProfile;
|
||||
if (JXL_DEC_SUCCESS
|
||||
- != JxlDecoderGetICCProfileSize(dec.get(), nullptr, JXL_COLOR_PROFILE_TARGET_DATA, &iccSize)) {
|
||||
+ != JxlDecoderGetICCProfileSize(dec.get(),
|
||||
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
|
||||
+ nullptr,
|
||||
+#endif
|
||||
+ JXL_COLOR_PROFILE_TARGET_DATA,
|
||||
+ &iccSize)) {
|
||||
errFile << "ICC profile size retrieval failed";
|
||||
document->setErrorMessage(i18nc("JPEG-XL errors", "Unable to read the image profile."));
|
||||
return ImportExportCodes::ErrorWhileReading;
|
||||
@@ -643,7 +650,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
|
||||
iccProfile.resize(static_cast<int>(iccSize));
|
||||
if (JXL_DEC_SUCCESS
|
||||
!= JxlDecoderGetColorAsICCProfile(dec.get(),
|
||||
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
|
||||
nullptr,
|
||||
+#endif
|
||||
JXL_COLOR_PROFILE_TARGET_DATA,
|
||||
reinterpret_cast<uint8_t *>(iccProfile.data()),
|
||||
static_cast<size_t>(iccProfile.size()))) {
|
||||
@@ -657,7 +666,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
|
||||
if (!d.m_info.uses_original_profile) {
|
||||
if (JXL_DEC_SUCCESS
|
||||
!= JxlDecoderGetICCProfileSize(dec.get(),
|
||||
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
|
||||
nullptr,
|
||||
+#endif
|
||||
JXL_COLOR_PROFILE_TARGET_ORIGINAL,
|
||||
&iccTargetSize)) {
|
||||
errFile << "ICC profile size retrieval failed";
|
||||
@@ -667,7 +678,9 @@ JPEGXLImport::convert(KisDocument *document, QIODevice *io, KisPropertiesConfigu
|
||||
iccTargetProfile.resize(static_cast<int>(iccTargetSize));
|
||||
if (JXL_DEC_SUCCESS
|
||||
!= JxlDecoderGetColorAsICCProfile(dec.get(),
|
||||
+#if JPEGXL_NUMERIC_VERSION < JPEGXL_COMPUTE_NUMERIC_VERSION(0,9,0)
|
||||
nullptr,
|
||||
+#endif
|
||||
JXL_COLOR_PROFILE_TARGET_ORIGINAL,
|
||||
reinterpret_cast<uint8_t *>(iccTargetProfile.data()),
|
||||
static_cast<size_t>(iccTargetProfile.size()))) {
|
||||
--
|
||||
GitLab
|
||||
|
24
krita.spec
24
krita.spec
@ -2,8 +2,8 @@
|
||||
%define dirver %(echo %version | cut -d. -f1-3)
|
||||
|
||||
Name: krita
|
||||
Version: 5.2.2
|
||||
Release: 4mamba
|
||||
Version: 5.2.3
|
||||
Release: 1mamba
|
||||
Summary: A free and open source painting tool
|
||||
Group: Graphical Desktop/Applications/Graphics
|
||||
Vendor: openmamba
|
||||
@ -13,7 +13,6 @@ URL: https://krita.org/en/
|
||||
Source: https://download.kde.org/stable/krita/%{version}/krita-%{version}.tar.xz
|
||||
Patch0: krita-5.0.0-gcc-11.2.0.patch
|
||||
Patch1: krita-5.2.2-sip-6.8.2.patch
|
||||
Patch2: krita-5.2.2-libjxl-0.9.1.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -45,7 +44,7 @@ BuildRequires: libkcompletion-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkcrash-devel
|
||||
BuildRequires: libkdcraw-devel
|
||||
BuildRequires: libkdcraw5-devel
|
||||
BuildRequires: libkguiaddons-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkitemviews-devel
|
||||
@ -68,7 +67,6 @@ BuildRequires: libunibreak-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt5-qtdeclarative-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libunibreak-devel >= 6.0-1mamba
|
||||
BuildRequires: libpoppler-devel >= 24.02.0-1mamba
|
||||
@ -119,9 +117,9 @@ This package contains the color schemes provided with %{name}.
|
||||
#:<< _EOF
|
||||
%patch 0 -p1
|
||||
%patch 1 -p1 -b .sip-6.8.2
|
||||
%patch 2 -p1 -b .libjxl-0.9.1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake_kde5 -d build \
|
||||
-DBUILD_TESTING=OFF \
|
||||
-DBUILD_KRITA_QT_DESIGNER_PLUGINS=ON
|
||||
@ -148,16 +146,16 @@ This package contains the color schemes provided with %{name}.
|
||||
%{_bindir}/kritarunner
|
||||
%{_datadir}/applications/krita_*.desktop
|
||||
%{_datadir}/applications/org.kde.krita.desktop
|
||||
%{_datadir}/metainfo/org.kde.krita.appdata.xml
|
||||
%dir %{_datadir}/color/icc/krita
|
||||
%{_datadir}/color/icc/krita/*
|
||||
%{_datadir}/icons/hicolor/*/apps/krita.png
|
||||
%{_datadir}/icons/hicolor/*/mimetypes/application-x-krita.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/krita.svgz
|
||||
%dir %{_datadir}/krita
|
||||
%{_datadir}/krita/*
|
||||
%dir %{_datadir}/kritaplugins
|
||||
%{_datadir}/kritaplugins/*
|
||||
%{_datadir}/metainfo/org.kde.krita.appdata.xml
|
||||
%{_datadir}/icons/hicolor/*/apps/krita.png
|
||||
%{_datadir}/icons/hicolor/*/mimetypes/application-x-krita.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/krita.svgz
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n lib%{name}
|
||||
@ -168,10 +166,9 @@ This package contains the color schemes provided with %{name}.
|
||||
%dir %{_libdir}/krita-python-libs
|
||||
%dir %{_libdir}/krita-python-libs/PyKrita
|
||||
%{_libdir}/krita-python-libs/PyKrita/krita.so
|
||||
%{_libdir}/krita-python-libs/PyKrita/krita.pyi
|
||||
%dir %{_libdir}/krita-python-libs/krita
|
||||
%{_libdir}/krita-python-libs/krita/*
|
||||
%dir %{_libdir}/qt5/qml/org/krita
|
||||
%{_libdir}/qt5/qml/org/krita/*
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
@ -183,6 +180,9 @@ This package contains the color schemes provided with %{name}.
|
||||
%{_datadir}/color-schemes/Krita*.colors
|
||||
|
||||
%changelog
|
||||
* Fri Jun 28 2024 Automatic Build System <autodist@openmamba.org> 5.2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 05 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 5.2.2-4mamba
|
||||
- rebuilt with qt 5.15.7
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user