77 lines
2.2 KiB
RPMSpec
77 lines
2.2 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: kpeoplevcard
|
|
Version: 0.1
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 KPeople VCard Support
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.kde.org
|
|
## GITSOURCE git://anongit.kde.org/kpeoplevcard v0.1
|
|
Source: git://anongit.kde.org/kpeoplevcard/v%{version}/kpeoplevcard-%{version}.tar.bz2
|
|
# Source: http://download.kde.org/stable/frameworks/%{majver}/...-%{version}.tar.xz
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: ldconfig
|
|
BuildRequires: libgcc
|
|
BuildRequires: libkcontacts-devel
|
|
BuildRequires: libkcoreaddons-devel
|
|
BuildRequires: libki18n-devel
|
|
BuildRequires: libkpeople-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
KDE Frameworks 5 KPeople VCard Support.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: KDE Frameworks 5 KPeople VCard Support.
|
|
|
|
%description -n lib%{name}
|
|
KDE Frameworks 5 KPeople VCard Support.
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_kde5_libdir}/cmake/KF5PeopleVCard/KF5PeopleVCardConfig.cmake
|
|
%{_libdir}/qt5/plugins/kpeople/datasource/KPeopleVCard.so
|
|
%doc COPYING
|
|
|
|
%changelog
|
|
* Thu Apr 30 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1-1mamba
|
|
- package created using the webbuild interface
|