automatic version update by autodist [release 17.08.3-1mamba;Fri Nov 17 2017]

This commit is contained in:
Automatic Build System 2024-01-06 02:31:51 +01:00
parent 918d485a51
commit e1e6f4433e
3 changed files with 105 additions and 5 deletions

View File

@ -0,0 +1,11 @@
--- kopete-17.08.3/protocols/jabber/libjingle/CMakeLists.txt.rig 2017-11-17 22:55:06.074779462 +0100
+++ kopete-17.08.3/protocols/jabber/libjingle/CMakeLists.txt 2017-11-17 22:50:58.749685596 +0100
@@ -301,7 +301,7 @@
add_executable ( call ${call_SRCS} )
set_target_properties ( call PROPERTIES OUTPUT_NAME libjingle-call )
-target_link_libraries ( call ${call_LIBS} )
+target_link_libraries ( call ${call_LIBS} -lpthread )
########### install files ###############

View File

@ -0,0 +1,83 @@
diff --git a/cmake/modules/FindMediastreamer.cmake b/cmake/modules/FindMediastreamer.cmake
index 47fe5c3..31802f0 100644
--- a/cmake/modules/FindMediastreamer.cmake
+++ b/cmake/modules/FindMediastreamer.cmake
@@ -24,12 +24,19 @@ IF (MEDIASTREAMER_FOUND)
IF (MEDIASTREAMER_VERSION VERSION_LESS 2.9)
SET(MEDIASTREAMER_LESS_2_9 TRUE)
SET(MEDIASTREAMER_LESS_2_11 TRUE)
+ SET(MEDIASTREAMER_LESS_2_14 TRUE)
ELSEIF (MEDIASTREAMER_VERSION VERSION_LESS 2.11)
SET(MEDIASTREAMER_LESS_2_9 FALSE)
SET(MEDIASTREAMER_LESS_2_11 TRUE)
+ SET(MEDIASTREAMER_LESS_2_14 TRUE)
+ ELSEIF (MEDIASTREAMER_VERSION VERSION_LESS 2.14)
+ SET(MEDIASTREAMER_LESS_2_9 FALSE)
+ SET(MEDIASTREAMER_LESS_2_11 FALSE)
+ SET(MEDIASTREAMER_LESS_2_14 TRUE)
ELSE (MEDIASTREAMER_VERSION VERSION_LESS 2.9)
SET(MEDIASTREAMER_LESS_2_9 FALSE)
SET(MEDIASTREAMER_LESS_2_11 FALSE)
+ SET(MEDIASTREAMER_LESS_2_14 FALSE)
ENDIF (MEDIASTREAMER_VERSION VERSION_LESS 2.9)
ENDIF (NOT MEDIASTREAMER_FIND_QUIETLY)
ELSE (MEDIASTREAMER_FOUND)
diff --git a/protocols/jabber/libjingle/talk/session/phone/linphonemediaengine.cc b/protocols/jabber/libjingle/talk/session/phone/linphonemediaengine.cc
index bd3de2b..9379226 100644
--- a/protocols/jabber/libjingle/talk/session/phone/linphonemediaengine.cc
+++ b/protocols/jabber/libjingle/talk/session/phone/linphonemediaengine.cc
@@ -151,15 +151,25 @@ LinphoneVoiceChannel::LinphoneVoiceChannel(LinphoneMediaEngine*eng)
playport2 = PORT_UNUSED;
#ifdef _DEBUG
+#ifdef MEDIASTREAMER_LESS_2_14
ortp_set_log_level_mask(ORTP_DEBUG|ORTP_MESSAGE|ORTP_WARNING|ORTP_ERROR|ORTP_FATAL);
#else
+ ortp_set_log_level_mask(NULL, ORTP_DEBUG|ORTP_MESSAGE|ORTP_WARNING|ORTP_ERROR|ORTP_FATAL);
+#endif
+#else
+#ifdef MEDIASTREAMER_LESS_2_14
ortp_set_log_level_mask(ORTP_FATAL);
+#else
+ ortp_set_log_level_mask(NULL, ORTP_FATAL);
#endif
-
+#endif
+
#ifdef MEDIASTREAMER_LESS_2_9
audio_stream_ = audio_stream_new(-1, 0); /* -1 means that function will choose some free port */
-#else
+#elseif MEDIASTREAMER_LESS_2_14
audio_stream_ = audio_stream_new(-1, -1, 0); /* -1 means that function will choose some free port */
+#else
+ audio_stream_ = audio_stream_new(NULL, -1, -1, 0); /* -1 means that function will choose some free port */
#endif
}
@@ -344,16 +354,24 @@ void LinphoneVoiceChannel::StartRing(bool bIncomingCall)
if (engine_->GetRingWav().size() > 0)
{
LOG(LS_VERBOSE) << "incoming ring. sound file: " << engine_->GetRingWav().c_str() << "\n";
+#ifdef MEDIASTREAMER_LESS_2_14
ring_stream_ = ring_start (engine_->GetRingWav().c_str(), 1, sndcard);
- }
+#else
+ ring_stream_ = ring_start (NULL, engine_->GetRingWav().c_str(), 1, sndcard);
+#endif
+ }
}
else
{
if (engine_->GetCallWav().size() > 0)
{
LOG(LS_VERBOSE) << "outgoing ring. sound file: " << engine_->GetCallWav().c_str() << "\n";
+#ifdef MEDIASTREAMER_LESS_2_14
ring_stream_ = ring_start (engine_->GetCallWav().c_str(), 1, sndcard);
- }
+#else
+ ring_stream_ = ring_start (NULL, engine_->GetCallWav().c_str(), 1, sndcard);
+#endif
+ }
}
}
}

View File

@ -1,5 +1,5 @@
Name: kopete
Version: 16.08.2
Version: 17.08.3
Release: 1mamba
Summary: Multi-protocol plugin-based instant messenger for the K Desktop Environment
Group: Graphical Desktop/Applications/Internet
@ -8,6 +8,8 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.kde.org
Source: http://download.kde.org/stable/applications/%{version}/src/kopete-%{version}.tar.xz
Patch0: kopete-17.08.3-mediastreamer-2.14.patch
Patch1: kopete-17.08.3-libjingle-pthread.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -15,6 +17,7 @@ BuildRequires: kdelibs-devel
BuildRequires: kdepimlibs-devel
BuildRequires: libX11-devel
BuildRequires: libXScrnSaver-devel
BuildRequires: libbctoolbox-devel
BuildRequires: libexpat-devel
BuildRequires: libgadu-devel
BuildRequires: libgcc
@ -27,12 +30,14 @@ BuildRequires: libjsoncpp-devel
BuildRequires: libmeanwhile-devel
BuildRequires: libmediastreamer-devel
BuildRequires: libmsn-devel
BuildRequires: libnsl-devel
BuildRequires: libopenssl-devel
BuildRequires: libortp-devel
BuildRequires: libotr-devel
BuildRequires: libphonon-devel
BuildRequires: libqca-devel
BuildRequires: libqimageblitz-devel
BuildRequires: libqjson-devel
BuildRequires: libqt4-devel
BuildRequires: libsoprano-devel
BuildRequires: libsrtp-devel
@ -43,13 +48,9 @@ BuildRequires: libxslt-devel
BuildRequires: libz-devel
BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: libjsoncpp-devel >= 1.7.7-1mamba
BuildRequires: automoc4
BuildRequires: cmake
BuildRequires: libotr >= 4.0.0
BuildRequires: libmediastreamer-devel >= 2.12.1
BuildConflicts: libxmms-devel
Requires: kdelibs%{?_kde4_version: >= %{_kde4_version}}
Requires: qca-ossl
Provides: libkopete
Obsoletes: libkopete
@ -79,6 +80,8 @@ This package contains libraries and header files for developing applications tha
%prep
%setup -q
%patch0 -p1
%patch1 -p1
%build
%cmake_kde4 -d build
@ -289,6 +292,9 @@ exit 0
%{_kde4_libdir}/liboscar.so
%changelog
* Fri Nov 17 2017 Automatic Build System <autodist@mambasoft.it> 17.08.3-1mamba
- automatic version update by autodist
* Mon Nov 07 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 16.08.2-1mamba
- update to 16.08.2