patch to revert default TERM from xterm-256color to xterm [release 16.12.1-2mamba;Mon Feb 06 2017]
This commit is contained in:
parent
c0c19c1a51
commit
4ac0d2787f
24
konsole-16.12.1-xterm.patch
Normal file
24
konsole-16.12.1-xterm.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -Nru konsole-16.12.1.orig/src/Profile.cpp konsole-16.12.1/src/Profile.cpp
|
||||
--- konsole-16.12.1.orig/src/Profile.cpp 2017-01-07 19:47:24.000000000 +0100
|
||||
+++ konsole-16.12.1/src/Profile.cpp 2017-02-06 13:05:00.084021493 +0100
|
||||
@@ -158,7 +158,7 @@
|
||||
// See Pty.cpp on why Arguments is populated
|
||||
setProperty(Arguments, QStringList() << qgetenv("SHELL"));
|
||||
setProperty(Icon, "utilities-terminal");
|
||||
- setProperty(Environment, QStringList() << QStringLiteral("TERM=xterm-256color") << QStringLiteral("COLORTERM=truecolor"));
|
||||
+ setProperty(Environment, QStringList() << QStringLiteral("TERM=xterm") << QStringLiteral("COLORTERM=truecolor"));
|
||||
setProperty(LocalTabTitleFormat, "%d : %n");
|
||||
setProperty(RemoteTabTitleFormat, "(%u) %H");
|
||||
setProperty(ShowTerminalSizeHint, true);
|
||||
diff -Nru konsole-16.12.1.orig/src/Pty.cpp konsole-16.12.1/src/Pty.cpp
|
||||
--- konsole-16.12.1.orig/src/Pty.cpp 2017-01-07 19:47:24.000000000 +0100
|
||||
+++ konsole-16.12.1/src/Pty.cpp 2017-02-06 13:05:13.003081726 +0100
|
||||
@@ -218,7 +218,7 @@
|
||||
|
||||
// extra safeguard to make sure $TERM is always set
|
||||
if (!isTermEnvAdded) {
|
||||
- setEnv("TERM", "xterm-256color");
|
||||
+ setEnv("TERM", "xterm");
|
||||
}
|
||||
}
|
||||
|
42
konsole.spec
42
konsole.spec
@ -1,6 +1,6 @@
|
||||
Name: konsole
|
||||
Version: 16.12.1
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Terminal Emulator for the K Desktop Environment
|
||||
Group: Graphical Desktop/Applications/Administration
|
||||
Vendor: openmamba
|
||||
@ -8,26 +8,40 @@ Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://konsole.kde.org/
|
||||
Source: http://download.kde.org/stable/applications/%{version}/src/konsole-%{version}.tar.xz
|
||||
Patch0: konsole-16.12.1-xterm.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkbookmarks-devel
|
||||
BuildRequires: libkcodecs-devel
|
||||
BuildRequires: libkcompletion-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkconfigwidgets-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkcrash-devel
|
||||
BuildRequires: libkdbusaddons-devel
|
||||
BuildRequires: libkguiaddons-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkiconthemes-devel
|
||||
BuildRequires: libkio-devel
|
||||
BuildRequires: libkjobwidgets-devel
|
||||
BuildRequires: libknotifications-devel
|
||||
BuildRequires: libknotifyconfig-devel
|
||||
BuildRequires: libkparts-devel
|
||||
BuildRequires: libkpty-devel
|
||||
BuildRequires: libkservice-devel
|
||||
BuildRequires: libktextwidgets-devel
|
||||
BuildRequires: libkwidgetsaddons-devel
|
||||
BuildRequires: libkwindowsystem-devel
|
||||
BuildRequires: libkxmlgui-devel
|
||||
BuildRequires: libqt5-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libsoprano-devel
|
||||
BuildRequires: libsonnet-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXpm-devel
|
||||
BuildRequires: libXrender-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: extra-cmake-modules
|
||||
BuildRequires: libkpty-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -35,6 +49,7 @@ Konsole is the terminal emulator for the K Desktop Environment.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
@ -85,6 +100,9 @@ exit 0
|
||||
#README
|
||||
|
||||
%changelog
|
||||
* Mon Feb 06 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 16.12.1-2mamba
|
||||
- patch to revert default TERM from xterm-256color to xterm
|
||||
|
||||
* Fri Jan 13 2017 Automatic Build System <autodist@mambasoft.it> 16.12.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user