rebuilt by autoport with build requirements: libspdlog-devel>=1.14.1-1mamba [release 21.0-2mamba;Mon May 27 2024]
This commit is contained in:
parent
8fc68455d3
commit
fb1e3213ae
@ -1,112 +0,0 @@
|
|||||||
From 6a83b674531d980a459057a8fd7c8b5050ba2f7c Mon Sep 17 00:00:00 2001
|
|
||||||
From: graysky <therealgraysky AT proton DOT me>
|
|
||||||
Date: Wed, 2 Aug 2023 14:43:24 -0400
|
|
||||||
Subject: [PATCH] ffmpeg: fix build with binutils update
|
|
||||||
|
|
||||||
---
|
|
||||||
cmake/modules/FindFFMPEG.cmake | 5 +-
|
|
||||||
...1-Fixes-assembling-w-binutil-as-2.41.patch | 76 +++++++++++++++++++
|
|
||||||
2 files changed, 80 insertions(+), 1 deletion(-)
|
|
||||||
create mode 100644 tools/depends/target/ffmpeg/0001-Fixes-assembling-w-binutil-as-2.41.patch
|
|
||||||
|
|
||||||
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
|
||||||
index e53a121..eca8e27 100644
|
|
||||||
--- a/cmake/modules/FindFFMPEG.cmake
|
|
||||||
+++ b/cmake/modules/FindFFMPEG.cmake
|
|
||||||
@@ -85,7 +85,10 @@ macro(buildFFMPEG)
|
|
||||||
-DPKG_CONFIG_PATH=${CMAKE_BINARY_DIR}/${CORE_BUILD_DIR}/lib/pkgconfig)
|
|
||||||
set(PATCH_COMMAND ${CMAKE_COMMAND} -E copy
|
|
||||||
${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/CMakeLists.txt
|
|
||||||
- <SOURCE_DIR>)
|
|
||||||
+ <SOURCE_DIR> &&
|
|
||||||
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-Fixes-assembling-w-binutil-as-2.41.patch &&
|
|
||||||
+ echo "########################################## patched ffmpeg ##############################"
|
|
||||||
+ )
|
|
||||||
|
|
||||||
if(CMAKE_GENERATOR STREQUAL Xcode)
|
|
||||||
set(FFMPEG_GENERATOR CMAKE_GENERATOR "Unix Makefiles")
|
|
||||||
diff --git a/tools/depends/target/ffmpeg/0001-Fixes-assembling-w-binutil-as-2.41.patch b/tools/depends/target/ffmpeg/0001-Fixes-assembling-w-binutil-as-2.41.patch
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..33fd3d4
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/tools/depends/target/ffmpeg/0001-Fixes-assembling-w-binutil-as-2.41.patch
|
|
||||||
@@ -0,0 +1,76 @@
|
|
||||||
+From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
|
|
||||||
+From: =?utf8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
|
|
||||||
+Date: Sun, 16 Jul 2023 18:18:02 +0300
|
|
||||||
+Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
|
|
||||||
+ instructions within inline assembly
|
|
||||||
+
|
|
||||||
+Fixes assembling with binutil as >= 2.41
|
|
||||||
+
|
|
||||||
+Signed-off-by: James Almer <jamrial@gmail.com>
|
|
||||||
+---
|
|
||||||
+ libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
|
|
||||||
+ 1 file changed, 23 insertions(+), 3 deletions(-)
|
|
||||||
+
|
|
||||||
+diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
|
|
||||||
+index 6298f5ed19..ca7e2dffc1 100644
|
|
||||||
+--- a/libavcodec/x86/mathops.h
|
|
||||||
++++ b/libavcodec/x86/mathops.h
|
|
||||||
+@@ -35,12 +35,20 @@
|
|
||||||
+ static av_always_inline av_const int MULL(int a, int b, unsigned shift)
|
|
||||||
+ {
|
|
||||||
+ int rt, dummy;
|
|
||||||
++ if (__builtin_constant_p(shift))
|
|
||||||
+ __asm__ (
|
|
||||||
+ "imull %3 \n\t"
|
|
||||||
+ "shrdl %4, %%edx, %%eax \n\t"
|
|
||||||
+ :"=a"(rt), "=d"(dummy)
|
|
||||||
+- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
|
|
||||||
++ :"a"(a), "rm"(b), "i"(shift & 0x1F)
|
|
||||||
+ );
|
|
||||||
++ else
|
|
||||||
++ __asm__ (
|
|
||||||
++ "imull %3 \n\t"
|
|
||||||
++ "shrdl %4, %%edx, %%eax \n\t"
|
|
||||||
++ :"=a"(rt), "=d"(dummy)
|
|
||||||
++ :"a"(a), "rm"(b), "c"((uint8_t)shift)
|
|
||||||
++ );
|
|
||||||
+ return rt;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+@@ -113,19 +121,31 @@ __asm__ volatile(\
|
|
||||||
+ // avoid +32 for shift optimization (gcc should do that ...)
|
|
||||||
+ #define NEG_SSR32 NEG_SSR32
|
|
||||||
+ static inline int32_t NEG_SSR32( int32_t a, int8_t s){
|
|
||||||
++ if (__builtin_constant_p(s))
|
|
||||||
+ __asm__ ("sarl %1, %0\n\t"
|
|
||||||
+ : "+r" (a)
|
|
||||||
+- : "ic" ((uint8_t)(-s))
|
|
||||||
++ : "i" (-s & 0x1F)
|
|
||||||
+ );
|
|
||||||
++ else
|
|
||||||
++ __asm__ ("sarl %1, %0\n\t"
|
|
||||||
++ : "+r" (a)
|
|
||||||
++ : "c" ((uint8_t)(-s))
|
|
||||||
++ );
|
|
||||||
+ return a;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ #define NEG_USR32 NEG_USR32
|
|
||||||
+ static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
|
|
||||||
++ if (__builtin_constant_p(s))
|
|
||||||
+ __asm__ ("shrl %1, %0\n\t"
|
|
||||||
+ : "+r" (a)
|
|
||||||
+- : "ic" ((uint8_t)(-s))
|
|
||||||
++ : "i" (-s & 0x1F)
|
|
||||||
+ );
|
|
||||||
++ else
|
|
||||||
++ __asm__ ("shrl %1, %0\n\t"
|
|
||||||
++ : "+r" (a)
|
|
||||||
++ : "c" ((uint8_t)(-s))
|
|
||||||
++ );
|
|
||||||
+ return a;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+--
|
|
||||||
+2.30.2
|
|
||||||
+
|
|
||||||
--
|
|
||||||
2.41.0
|
|
||||||
|
|
@ -1,10 +0,0 @@
|
|||||||
diff --git a/xbmc/interfaces/swig/AddonModuleXbmcaddon.i b/xbmc/interfaces/swig/AddonModuleXbmcaddon.i
|
|
||||||
index 6c00a1caa2..d38794c043 100644
|
|
||||||
--- a/xbmc/interfaces/swig/AddonModuleXbmcaddon.i
|
|
||||||
+++ b/xbmc/interfaces/swig/AddonModuleXbmcaddon.i
|
|
||||||
@@ -33,5 +33,6 @@ using namespace xbmcaddon;
|
|
||||||
%include "interfaces/legacy/AddonString.h"
|
|
||||||
|
|
||||||
%include "interfaces/legacy/Addon.h"
|
|
||||||
+%nodefaultctor Settings;
|
|
||||||
%include "interfaces/legacy/Settings.h"
|
|
25
kodi-21.0-gcc-14.patch
Normal file
25
kodi-21.0-gcc-14.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 2bf5ab07731b3d4160196e6b8d9ab9e25bea2ef9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Rudi Heitbaum <rudi@heitbaum.com>
|
||||||
|
Date: Thu, 2 May 2024 08:02:42 +0000
|
||||||
|
Subject: [PATCH] add missing c++ headers
|
||||||
|
|
||||||
|
Add missing headers which are no longer indirectly included by
|
||||||
|
other headers, fixes build with gcc-14
|
||||||
|
|
||||||
|
Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
|
||||||
|
---
|
||||||
|
xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp b/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp
|
||||||
|
index d42c19bb2cd4a..142974591b1a7 100644
|
||||||
|
--- a/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp
|
||||||
|
+++ b/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp
|
||||||
|
@@ -17,6 +17,7 @@
|
||||||
|
|
||||||
|
#include "platform/posix/filesystem/SMBWSDiscovery.h"
|
||||||
|
|
||||||
|
+#include <algorithm>
|
||||||
|
#include <array>
|
||||||
|
#include <chrono>
|
||||||
|
#include <mutex>
|
13
kodi.spec
13
kodi.spec
@ -25,7 +25,7 @@
|
|||||||
|
|
||||||
Name: kodi
|
Name: kodi
|
||||||
Version: 21.0
|
Version: 21.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A media player and entertainment hub for digital media
|
Summary: A media player and entertainment hub for digital media
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -43,8 +43,7 @@ Source7: https://mirrors.kodi.tv/build-deps/sources/flatbuffers-%{_flatbuf
|
|||||||
Source8: https://mirrors.kodi.tv/build-deps/sources/libudfread-%{_libudfread_version}.tar.gz
|
Source8: https://mirrors.kodi.tv/build-deps/sources/libudfread-%{_libudfread_version}.tar.gz
|
||||||
Patch1: xbmc-12.0-set_native_cxxflags.patch
|
Patch1: xbmc-12.0-set_native_cxxflags.patch
|
||||||
Patch2: xbmc-12.0-relax_badcolordepth_check.patch
|
Patch2: xbmc-12.0-relax_badcolordepth_check.patch
|
||||||
Patch3: kodi-20.2-binutils-2.41.patch
|
Patch3: kodi-21.0-gcc-14.patch
|
||||||
Patch4: kodi-20.4-swig-4.2.0.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -122,6 +121,7 @@ BuildRequires: libzstd-devel
|
|||||||
BuildRequires: lirc-devel
|
BuildRequires: lirc-devel
|
||||||
BuildRequires: trousers-devel
|
BuildRequires: trousers-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libspdlog-devel >= 1.14.1-1mamba
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
BuildRequires: gperf
|
BuildRequires: gperf
|
||||||
BuildRequires: java-openjdk17
|
BuildRequires: java-openjdk17
|
||||||
@ -150,7 +150,6 @@ BuildRequires: libdcadec-devel
|
|||||||
BuildRequires: libcrossguid-devel
|
BuildRequires: libcrossguid-devel
|
||||||
BuildRequires: libflatbuffers-devel
|
BuildRequires: libflatbuffers-devel
|
||||||
BuildRequires: librapidjson-devel
|
BuildRequires: librapidjson-devel
|
||||||
BuildRequires: libspdlog-devel >= 1.13.0
|
|
||||||
BuildRequires: libwaylandpp-devel >= 1.0.0
|
BuildRequires: libwaylandpp-devel >= 1.0.0
|
||||||
Requires: mesa-tests
|
Requires: mesa-tests
|
||||||
Requires: xdpyinfo
|
Requires: xdpyinfo
|
||||||
@ -195,8 +194,7 @@ XBMC is an award-winning free and open source (GPL) software media player and en
|
|||||||
%patch 2 -p1
|
%patch 2 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#%patch 3 -p1
|
%patch 3 -p1 -b .gcc-14
|
||||||
#%patch 4 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export JAVA_HOME=%{jvmdir}/java-17
|
export JAVA_HOME=%{jvmdir}/java-17
|
||||||
@ -298,6 +296,9 @@ fi
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 27 2024 Automatic Build System <autodist@mambasoft.it> 21.0-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libspdlog-devel>=1.14.1-1mamba
|
||||||
|
|
||||||
* Thu Apr 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 21.0-1mamba
|
* Thu Apr 11 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 21.0-1mamba
|
||||||
- update to 21.0
|
- update to 21.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user