automatic version update by autodist [release 21.1-1mamba;Tue Sep 03 2024]
This commit is contained in:
parent
f500b4c82b
commit
980e5fae88
@ -1,25 +0,0 @@
|
|||||||
From 2bf5ab07731b3d4160196e6b8d9ab9e25bea2ef9 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rudi Heitbaum <rudi@heitbaum.com>
|
|
||||||
Date: Thu, 2 May 2024 08:02:42 +0000
|
|
||||||
Subject: [PATCH] add missing c++ headers
|
|
||||||
|
|
||||||
Add missing headers which are no longer indirectly included by
|
|
||||||
other headers, fixes build with gcc-14
|
|
||||||
|
|
||||||
Signed-off-by: Rudi Heitbaum <rudi@heitbaum.com>
|
|
||||||
---
|
|
||||||
xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp b/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp
|
|
||||||
index d42c19bb2cd4a..142974591b1a7 100644
|
|
||||||
--- a/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp
|
|
||||||
+++ b/xbmc/platform/posix/filesystem/SMBWSDiscoveryListener.cpp
|
|
||||||
@@ -17,6 +17,7 @@
|
|
||||||
|
|
||||||
#include "platform/posix/filesystem/SMBWSDiscovery.h"
|
|
||||||
|
|
||||||
+#include <algorithm>
|
|
||||||
#include <array>
|
|
||||||
#include <chrono>
|
|
||||||
#include <mutex>
|
|
16
kodi.spec
16
kodi.spec
@ -24,8 +24,8 @@
|
|||||||
|
|
||||||
|
|
||||||
Name: kodi
|
Name: kodi
|
||||||
Version: 21.0
|
Version: 21.1
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: A media player and entertainment hub for digital media
|
Summary: A media player and entertainment hub for digital media
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -43,14 +43,13 @@ Source7: https://mirrors.kodi.tv/build-deps/sources/flatbuffers-%{_flatbuf
|
|||||||
Source8: https://mirrors.kodi.tv/build-deps/sources/libudfread-%{_libudfread_version}.tar.gz
|
Source8: https://mirrors.kodi.tv/build-deps/sources/libudfread-%{_libudfread_version}.tar.gz
|
||||||
Patch1: xbmc-12.0-set_native_cxxflags.patch
|
Patch1: xbmc-12.0-set_native_cxxflags.patch
|
||||||
Patch2: xbmc-12.0-relax_badcolordepth_check.patch
|
Patch2: xbmc-12.0-relax_badcolordepth_check.patch
|
||||||
Patch3: kodi-21.0-gcc-14.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXrandr-devel
|
BuildRequires: libXrandr-devel
|
||||||
BuildRequires: libXv-devel
|
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
BuildRequires: libass-devel
|
BuildRequires: libass-devel
|
||||||
BuildRequires: libatomic-devel
|
BuildRequires: libatomic-devel
|
||||||
@ -68,11 +67,11 @@ BuildRequires: libcrystalhd-devel
|
|||||||
BuildRequires: libcurl-devel
|
BuildRequires: libcurl-devel
|
||||||
BuildRequires: libdav1d-devel
|
BuildRequires: libdav1d-devel
|
||||||
BuildRequires: libdbus-devel
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libdisplay-info-devel
|
||||||
BuildRequires: libdrm-devel
|
BuildRequires: libdrm-devel
|
||||||
BuildRequires: libfmt-devel
|
BuildRequires: libfmt-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libfribidi-devel
|
BuildRequires: libfribidi-devel
|
||||||
BuildRequires: libfstrcmp-devel
|
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgif-devel
|
BuildRequires: libgif-devel
|
||||||
BuildRequires: libglvnd-devel
|
BuildRequires: libglvnd-devel
|
||||||
@ -107,6 +106,7 @@ BuildRequires: libstdc++6-devel
|
|||||||
BuildRequires: libtag-devel
|
BuildRequires: libtag-devel
|
||||||
BuildRequires: libtasn1-devel
|
BuildRequires: libtasn1-devel
|
||||||
BuildRequires: libtinyxml-devel
|
BuildRequires: libtinyxml-devel
|
||||||
|
BuildRequires: libtinyxml2-devel
|
||||||
BuildRequires: libudev-devel
|
BuildRequires: libudev-devel
|
||||||
BuildRequires: libunistring-devel
|
BuildRequires: libunistring-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
@ -195,8 +195,6 @@ XBMC is an award-winning free and open source (GPL) software media player and en
|
|||||||
%patch 2 -p1
|
%patch 2 -p1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%patch 3 -p1 -b .gcc-14
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export JAVA_HOME=%{jvmdir}/java-17
|
export JAVA_HOME=%{jvmdir}/java-17
|
||||||
#:<< ___EOF
|
#:<< ___EOF
|
||||||
@ -285,6 +283,7 @@ fi
|
|||||||
%{_datadir}/wayland-sessions/kodi-gbm.desktop
|
%{_datadir}/wayland-sessions/kodi-gbm.desktop
|
||||||
%{_datadir}/xsessions/kodi.desktop
|
%{_datadir}/xsessions/kodi.desktop
|
||||||
%{_datadir}/icons/hicolor/*/*/*.png
|
%{_datadir}/icons/hicolor/*/*/*.png
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/kodi.svg
|
||||||
%{_prefix}/lib/firewalld/services/kodi-*.xml
|
%{_prefix}/lib/firewalld/services/kodi-*.xml
|
||||||
%dir %{_libdir}/kodi
|
%dir %{_libdir}/kodi
|
||||||
%{_libdir}/kodi/*
|
%{_libdir}/kodi/*
|
||||||
@ -297,6 +296,9 @@ fi
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 03 2024 Automatic Build System <autodist@openmamba.org> 21.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Jun 28 2024 Automatic Build System <autodist@mambasoft.it> 21.0-3mamba
|
* Fri Jun 28 2024 Automatic Build System <autodist@mambasoft.it> 21.0-3mamba
|
||||||
- rebuilt by autoport with build requirements: libdisplay-info-devel>=0:0.2.0-1mamba
|
- rebuilt by autoport with build requirements: libdisplay-info-devel>=0:0.2.0-1mamba
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user