update to 16.0 [release 16.0-1mamba;Mon Mar 14 2016]
This commit is contained in:
parent
22cb35caf1
commit
7b9bfee275
11
kodi-15.2-ffmpeg-x86-asm-impossible-contraints-fix.patch
Normal file
11
kodi-15.2-ffmpeg-x86-asm-impossible-contraints-fix.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ffmpeg-2.3.3/libavutil/x86/asm.h.orig 2016-03-13 16:13:34.212042218 +0100
|
||||
+++ ffmpeg-2.3.3/libavutil/x86/asm.h 2016-03-13 16:13:59.318035937 +0100
|
||||
@@ -71,7 +71,7 @@
|
||||
typedef int x86_reg;
|
||||
#endif
|
||||
|
||||
-#define HAVE_7REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE && HAVE_EBP_AVAILABLE))
|
||||
+#define HAVE_7REGS (ARCH_X86_64)
|
||||
#define HAVE_6REGS (ARCH_X86_64 || (HAVE_EBX_AVAILABLE || HAVE_EBP_AVAILABLE))
|
||||
|
||||
#if ARCH_X86_64 && defined(PIC)
|
34
kodi.spec
34
kodi.spec
@ -12,18 +12,20 @@
|
||||
%define pkgver %(echo %version | cut -d_ -f1)
|
||||
%define pkgrel %(echo %version | cut -d_ -f2)
|
||||
|
||||
%define codenameadd -Isengard
|
||||
%define codenameadd -Jarvis
|
||||
%define ffmpeg_ver 2.8.6
|
||||
|
||||
Name: kodi
|
||||
Version: 15.2
|
||||
Release: 2mamba
|
||||
Version: 16.0
|
||||
Release: 1mamba
|
||||
Summary: A media player and entertainment hub for digital media
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://xbmc.org/
|
||||
Source: http://ftp.df.lth.se/pub/xbmc/releases/source/%{version}%{?codenameadd}.tar.gz
|
||||
Source: http://ftp.df.lth.se/pub/xbmc/releases/source/%{version}%{?codenameadd}.tar.gz
|
||||
Source1: https://github.com/xbmc/FFmpeg/archive/%{ffmpeg_ver}%{?codenameadd}-%{version}.tar.gz
|
||||
Patch0: xbmc-12.0-do_not_require_lsb_release.patch
|
||||
Patch1: xbmc-12.0-inconsistent_operand_constraints_in_an_asm.patch
|
||||
Patch2: xbmc-12.0-systeminfo.patch
|
||||
@ -31,6 +33,7 @@ Patch3: xbmc-12.0-set_native_cxxflags.patch
|
||||
Patch4: xbmc-12.0-relax_badcolordepth_check.patch
|
||||
Patch5: xbmc-12.0-arm-no-fp.patch
|
||||
Patch6: xbmc-13.1-libnfs-1.9.4.patch
|
||||
Patch7: kodi-15.2-ffmpeg-x86-asm-impossible-contraints-fix.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -39,9 +42,7 @@ BuildRequires: libGLU-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libavahi-devel
|
||||
BuildRequires: libbluetooth-devel
|
||||
@ -52,6 +53,7 @@ BuildRequires: libcdio-devel
|
||||
BuildRequires: libcrystalhd-devel
|
||||
%endif
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdcadec-devel
|
||||
BuildRequires: libdrm-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
@ -86,6 +88,7 @@ BuildRequires: libtasn1-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libtinyxml-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libva-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libxcb-devel
|
||||
@ -131,6 +134,8 @@ BuildRequires: libraspberrypi-devel
|
||||
BuildRequires: libcec-devel
|
||||
BuildRequires: libprojectM-devel
|
||||
BuildRequires: libnfs-devel
|
||||
BuildRequires: libdcadec-devel
|
||||
BuildRequires: libcrossguid-devel
|
||||
Requires: mesa-tests
|
||||
Requires: xdpyinfo
|
||||
Requires: libprojectM
|
||||
@ -177,6 +182,15 @@ XBMC is an award-winning free and open source (GPL) software media player and en
|
||||
#%patch5 -p1
|
||||
#%patch6 -p1
|
||||
|
||||
ln -s %{SOURCE1} tools/depends/target/ffmpeg/
|
||||
|
||||
%ifarch %{ix86}
|
||||
cd tools/depends/target/ffmpeg/
|
||||
tar xf %{ffmpeg_ver}%{?codenameadd}-%{version}.tar.gz
|
||||
cd FFmpeg-%{ffmpeg_ver}%{?codenameadd}-%{version}
|
||||
%patch7 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
#:<< ___EOF
|
||||
./bootstrap
|
||||
@ -216,7 +230,7 @@ export LDFLAGS="$LDFLAGS -L/opt/vc/lib"
|
||||
--disable-vtbdecoder \
|
||||
--enable-player=omxplayer \
|
||||
%else
|
||||
--enable-external-libraries \
|
||||
--enable-shared-libraries \
|
||||
%endif
|
||||
%ifarch arm
|
||||
--disable-vaapi \
|
||||
@ -288,6 +302,12 @@ exit 0
|
||||
#%doc README
|
||||
|
||||
%changelog
|
||||
* Mon Mar 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 16.0-1mamba
|
||||
- update to 16.0
|
||||
|
||||
* Sun Feb 14 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 15.2-3mamba
|
||||
- rebuilt with gcc 5.3.0
|
||||
|
||||
* Wed Nov 18 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 15.2-2mamba
|
||||
- fix kodi vs xbmc libdir weirdness
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user