rebuilt with current python (3.11) [release 21.2-2mamba;Thu Jan 23 2025]
This commit is contained in:
parent
8ed9df36f7
commit
248630f765
@ -1,26 +0,0 @@
|
|||||||
From 4ff0ba903bed472cddb0d6e5c53c8176cded6b09 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rudi Heitbaum <rudi@heitbaum.com>
|
|
||||||
Date: Mon, 21 Oct 2024 22:10:29 +1100
|
|
||||||
Subject: [PATCH] [swig] Fix building with swig 4.3.0
|
|
||||||
|
|
||||||
swig 4.3.0 has dropped the -xmllang option used with -xml, which had no effect on the output.
|
|
||||||
|
|
||||||
Ref:
|
|
||||||
- https://github.com/swig/swig/commit/86498e46c6a6218a3d091c12513c40076ac2ce63
|
|
||||||
---
|
|
||||||
xbmc/interfaces/swig/CMakeLists.txt | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/xbmc/interfaces/swig/CMakeLists.txt b/xbmc/interfaces/swig/CMakeLists.txt
|
|
||||||
index 1951b2a336789..46c84c7f7efc5 100644
|
|
||||||
--- a/xbmc/interfaces/swig/CMakeLists.txt
|
|
||||||
+++ b/xbmc/interfaces/swig/CMakeLists.txt
|
|
||||||
@@ -22,7 +22,7 @@ function(generate_file file)
|
|
||||||
|
|
||||||
add_custom_command(OUTPUT ${CPP_FILE}
|
|
||||||
COMMAND ${SWIG_EXECUTABLE}
|
|
||||||
- ARGS -w401 -c++ -o ${file}.xml -xml -I${CMAKE_SOURCE_DIR}/xbmc -xmllang python ${CMAKE_CURRENT_SOURCE_DIR}/../swig/${file}
|
|
||||||
+ ARGS -w401 -c++ -o ${file}.xml -xml -I${CMAKE_SOURCE_DIR}/xbmc ${CMAKE_CURRENT_SOURCE_DIR}/../swig/${file}
|
|
||||||
COMMAND ${Java_JAVA_EXECUTABLE}
|
|
||||||
ARGS ${JAVA_OPEN_OPTS} -cp "${classpath}" groovy.ui.GroovyMain ${CMAKE_SOURCE_DIR}/tools/codegenerator/Generator.groovy ${file}.xml ${CMAKE_CURRENT_SOURCE_DIR}/../python/PythonSwig.cpp.template ${file}.cpp > ${devnull}
|
|
||||||
${CLANG_FORMAT_COMMAND}
|
|
19
kodi.spec
19
kodi.spec
@ -24,8 +24,8 @@
|
|||||||
|
|
||||||
|
|
||||||
Name: kodi
|
Name: kodi
|
||||||
Version: 21.1
|
Version: 21.2
|
||||||
Release: 3mamba
|
Release: 2mamba
|
||||||
Summary: A media player and entertainment hub for digital media
|
Summary: A media player and entertainment hub for digital media
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -45,9 +45,9 @@ Patch1: xbmc-12.0-set_native_cxxflags.patch
|
|||||||
Patch2: xbmc-12.0-relax_badcolordepth_check.patch
|
Patch2: xbmc-12.0-relax_badcolordepth_check.patch
|
||||||
Patch3: kodi-21.1-ffmpeg-6-disable-nv-codec.patch
|
Patch3: kodi-21.1-ffmpeg-6-disable-nv-codec.patch
|
||||||
Patch4: kodi-21.1-libnfs-6.0.2.patch
|
Patch4: kodi-21.1-libnfs-6.0.2.patch
|
||||||
Patch5: kodi-21.1-swig-4.3.0.patch
|
|
||||||
Patch6: kodi-21.1-libudev-256.patch
|
Patch6: kodi-21.1-libudev-256.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
|
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
@ -122,8 +122,6 @@ BuildRequires: libz-devel
|
|||||||
BuildRequires: lirc-devel
|
BuildRequires: lirc-devel
|
||||||
BuildRequires: trousers-devel
|
BuildRequires: trousers-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libspdlog-devel >= 0:1.15.0-1mamba
|
|
||||||
BuildRequires: libdisplay-info-devel >= 0:0.2.0-1mamba
|
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
BuildRequires: gperf
|
BuildRequires: gperf
|
||||||
BuildRequires: java-openjdk17
|
BuildRequires: java-openjdk17
|
||||||
@ -132,8 +130,6 @@ BuildRequires: swig
|
|||||||
BuildRequires: unzip
|
BuildRequires: unzip
|
||||||
BuildRequires: libdvdcss-devel
|
BuildRequires: libdvdcss-devel
|
||||||
BuildRequires: libflac-devel
|
BuildRequires: libflac-devel
|
||||||
BuildRequires: libfmt-devel >= 10.1.0
|
|
||||||
BuildRequires: libGLESv2-devel
|
|
||||||
BuildRequires: liblame-devel
|
BuildRequires: liblame-devel
|
||||||
BuildRequires: libmad-devel
|
BuildRequires: libmad-devel
|
||||||
BuildRequires: libmodplug-devel
|
BuildRequires: libmodplug-devel
|
||||||
@ -184,7 +180,6 @@ Obsoletes: xbmc-rpi < 18.9
|
|||||||
XBMC is an award-winning free and open source (GPL) software media player and entertainment hub for digital media.
|
XBMC is an award-winning free and open source (GPL) software media player and entertainment hub for digital media.
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%global _lto_cflags %{nil}
|
%global _lto_cflags %{nil}
|
||||||
|
|
||||||
@ -200,13 +195,13 @@ XBMC is an award-winning free and open source (GPL) software media player and en
|
|||||||
|
|
||||||
%patch 3 -p1
|
%patch 3 -p1
|
||||||
%patch 4 -p1 -b .libnfs-6.0.2
|
%patch 4 -p1 -b .libnfs-6.0.2
|
||||||
%patch 5 -p1 -b .swig-4.3.0
|
|
||||||
%patch 6 -p1 -b .libudev-256
|
%patch 6 -p1 -b .libudev-256
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export JAVA_HOME=%{jvmdir}/java-17
|
export JAVA_HOME=%{jvmdir}/java-17
|
||||||
#:<< ___EOF
|
#:<< ___EOF
|
||||||
%cmake -d build \
|
%cmake -d build \
|
||||||
|
-DPython3_EXECUTABLE=%{__python3} \
|
||||||
-DENABLE_INTERNAL_RapidJSON=OFF \
|
-DENABLE_INTERNAL_RapidJSON=OFF \
|
||||||
-DENABLE_INTERNAL_FFMPEG=ON \
|
-DENABLE_INTERNAL_FFMPEG=ON \
|
||||||
-DENABLE_INTERNAL_CROSSGUID=ON \
|
-DENABLE_INTERNAL_CROSSGUID=ON \
|
||||||
@ -304,6 +299,12 @@ fi
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 23 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 21.2-2mamba
|
||||||
|
- rebuilt with current python (3.11)
|
||||||
|
|
||||||
|
* Wed Jan 22 2025 Automatic Build System <autodist@openmamba.org> 21.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Wed Dec 25 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 21.1-3mamba
|
* Wed Dec 25 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 21.1-3mamba
|
||||||
- patch to fix assert in libudev >= 256 ( https://github.com/LibreELEC/LibreELEC.tv/pull/8982 )
|
- patch to fix assert in libudev >= 256 ( https://github.com/LibreELEC/LibreELEC.tv/pull/8982 )
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user