automatic version update by autodist [release 20.1-1mamba;Sun Mar 12 2023]

This commit is contained in:
Automatic Build System 2024-01-06 02:21:43 +01:00
parent 1bbcbd9c15
commit 1588aed2c2
1 changed files with 19 additions and 13 deletions

View File

@ -12,11 +12,11 @@
%define pkgver %(echo %version | cut -d_ -f1)
%define pkgrel %(echo %version | cut -d_ -f2)
%define codenameadd -Matrix
%define codenameadd -Nexus
#%define ffmpeg_ver 4.3.2%{codenameadd}-19.1
Name: kodi
Version: 19.5
Version: 20.1
Release: 1mamba
Summary: A media player and entertainment hub for digital media
Group: Graphical Desktop/Applications/Multimedia
@ -25,9 +25,9 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://kodi.tv/
Source: https://github.com/xbmc/xbmc/archive/%{version}%{?codenameadd}.tar.gz
Source1: https://github.com/BlackIkeEagle/kodi-FFmpeg/archive/refs/heads/fix/4.3-kodi-dav1d-1.0.tar.gz
Source2: http://mirrors.kodi.tv/build-deps/sources/fmt-6.1.2.tar.gz
Source3: http://mirrors.kodi.tv/build-deps/sources/spdlog-1.5.0.tar.gz
Source1: https://github.com/xbmc/FFmpeg/archive/4.4.1-Nexus-Alpha1.tar.gz
#Source2: http://mirrors.kodi.tv/build-deps/sources/fmt-6.1.2.tar.gz
#Source3: http://mirrors.kodi.tv/build-deps/sources/spdlog-1.5.0.tar.gz
Patch0: xbmc-12.0-do_not_require_lsb_release.patch
Patch1: xbmc-12.0-inconsistent_operand_constraints_in_an_asm.patch
Patch2: xbmc-12.0-systeminfo.patch
@ -38,9 +38,9 @@ Patch6: xbmc-13.1-libnfs-1.9.4.patch
Patch7: kodi-15.2-ffmpeg-x86-asm-impossible-contraints-fix.patch
Patch8: kodi-16.1-gcc-6.1.0.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libGLU-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXrandr-devel
@ -63,6 +63,7 @@ BuildRequires: libcurl-devel
BuildRequires: libdav1d-devel
BuildRequires: libdbus-devel
BuildRequires: libdrm-devel
BuildRequires: libfmt-devel
BuildRequires: libfreetype-devel
BuildRequires: libfribidi-devel
BuildRequires: libfstrcmp-devel
@ -71,6 +72,7 @@ BuildRequires: libgif-devel
BuildRequires: libglvnd-devel
BuildRequires: libgmp-devel
BuildRequires: libgnutls-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libidn2-devel
BuildRequires: libinput-devel
BuildRequires: libjpeg-devel
@ -85,13 +87,14 @@ BuildRequires: libnfs-devel
BuildRequires: libopenssl-devel
BuildRequires: libp11-kit-devel
BuildRequires: libpcre-devel
BuildRequires: libpipewire-devel
BuildRequires: libplist-devel
BuildRequires: libpng-devel
BuildRequires: libpulseaudio-devel
BuildRequires: libpulseaudio-glib-devel
BuildRequires: libpython3-devel
BuildRequires: libpython39-devel
BuildRequires: libpython310-devel
BuildRequires: libsmbclient-devel
BuildRequires: libspdlog-devel
BuildRequires: libsqlite-devel
BuildRequires: libstdc++6-devel
BuildRequires: libtag-devel
@ -101,6 +104,7 @@ BuildRequires: libudev-devel
BuildRequires: libunistring-devel
BuildRequires: libuuid-devel
BuildRequires: libva-devel
BuildRequires: libvdpau-devel
BuildRequires: libwaylandpp-devel
BuildRequires: libxkbcommon-devel
BuildRequires: libxml2-devel
@ -196,10 +200,6 @@ XBMC is an award-winning free and open source (GPL) software media player and en
%cmake -d build \
-DENABLE_INTERNAL_FFMPEG=ON \
-DFFMPEG_URL="%{SOURCE1}" \
-DENABLE_INTERNAL_FMT=ON \
-DFMT_URL="%{SOURCE2}" \
-DENABLE_INTERNAL_SPDLOG=ON \
-DSPDLOG_URL="%{SOURCE3}" \
%ifarch x86_64 %{ix86}
-DAPP_RENDER_SYSTEM="gl"
%endif
@ -260,8 +260,8 @@ fi
%defattr(-,root,root)
%{_bindir}/kodi
%{_bindir}/kodi-standalone
%{_bindir}/kodi-TexturePacker
%{_bindir}/JsonSchemaBuilder
%{_bindir}/TexturePacker
%dir %{_datadir}/kodi
%{_datadir}/kodi/*
%{_datadir}/applications/kodi.desktop
@ -280,6 +280,12 @@ fi
%doc README.md
%changelog
* Sun Mar 12 2023 Automatic Build System <autodist@mambasoft.it> 20.1-1mamba
- automatic version update by autodist
* Mon Jan 23 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 20.0-1mamba
- update to 20.0
* Sun Dec 25 2022 Automatic Build System <autodist@mambasoft.it> 19.5-1mamba
- automatic version update by autodist