update to 18.9 [release 18.9-1mamba;Thu Mar 25 2021]

This commit is contained in:
Silvan Calarco 2024-01-06 02:21:39 +01:00
parent 4d507d0d35
commit 10715b5a48
1 changed files with 51 additions and 102 deletions

153
kodi.spec
View File

@ -12,18 +12,18 @@
%define pkgver %(echo %version | cut -d_ -f1)
%define pkgrel %(echo %version | cut -d_ -f2)
%define codenameadd -Krypton
%define ffmpeg_ver 3.1.11%{codenameadd}-17.5
%define codenameadd -Leia
%define ffmpeg_ver 4.0.4%{codenameadd}-18.4
Name: kodi
Version: 17.6
Version: 18.9
Release: 1mamba
Summary: A media player and entertainment hub for digital media
Group: Graphical Desktop/Applications/Multimedia
Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: http://xbmc.org/
URL: https://xbmc.org/
Source: https://github.com/xbmc/xbmc/archive/%{version}%{?codenameadd}.tar.gz
#http://ftp.df.lth.se/pub/xbmc/releases/source/%{version}%{?codenameadd}.tar.gz
Source1: https://github.com/xbmc/FFmpeg/archive/%{ffmpeg_ver}.tar.gz
@ -41,75 +41,65 @@ License: GPL
BuildRequires: glibc-devel
BuildRequires: libGL-devel
BuildRequires: libGLU-devel
BuildRequires: libSDL2-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXrandr-devel
BuildRequires: libalsa-devel
BuildRequires: libass-devel
BuildRequires: libavahi-devel
BuildRequires: libavcodec-ffmpeg-devel
BuildRequires: libavfilter-ffmpeg-devel
BuildRequires: libavformat-ffmpeg-devel
BuildRequires: libavutil-ffmpeg-devel
BuildRequires: libbluetooth-devel
BuildRequires: libbzip2-devel
BuildRequires: libbluray-devel
BuildRequires: libcap-devel
BuildRequires: libcdio-devel
%ifnarch arm
BuildRequires: libcrystalhd-devel
%endif
BuildRequires: libcec-devel
BuildRequires: libcurl-devel
BuildRequires: libdbus-devel
BuildRequires: libdcadec-devel
BuildRequires: libdrm-devel
BuildRequires: libexpat-devel
BuildRequires: libfmt-devel
BuildRequires: libfreetype-devel
BuildRequires: libfribidi-devel
BuildRequires: libfstrcmp-devel
BuildRequires: libgcc
BuildRequires: libgcrypt-devel
BuildRequires: libglew-devel
BuildRequires: libglib-devel
BuildRequires: libgmp-devel
BuildRequires: libgnutls-devel
BuildRequires: libgpg-error-devel
BuildRequires: libjasper-devel
BuildRequires: libgif-devel
BuildRequires: libjpeg-devel
BuildRequires: liblzma-devel
BuildRequires: liblcms2-devel
BuildRequires: liblzo-devel
BuildRequires: libmariadb-devel
BuildRequires: libmicrohttpd-devel
BuildRequires: libmysqlclient-devel
BuildRequires: libnettle-devel
BuildRequires: libogg-devel
BuildRequires: libnfs-devel
BuildRequires: libopenssl-devel
BuildRequires: libp11-kit-devel
BuildRequires: libpcre-devel
BuildRequires: libpng-devel
BuildRequires: libpostproc-ffmpeg-devel
BuildRequires: libpulseaudio-devel
BuildRequires: libpulseaudio-glib-devel
BuildRequires: libpython27-devel
BuildRequires: libsmbclient-devel
BuildRequires: libsqlite-devel
BuildRequires: libssh-devel
BuildRequires: libstdc++6-devel
BuildRequires: libswresample-ffmpeg-devel
BuildRequires: libswscale-ffmpeg-devel
BuildRequires: libtag-devel
BuildRequires: libtasn1-devel
BuildRequires: libtiff-devel
BuildRequires: libtinyxml-devel
BuildRequires: libudev-devel
BuildRequires: libuuid-devel
BuildRequires: libva-devel
BuildRequires: libvorbis-devel
BuildRequires: libxcb-devel
BuildRequires: libvdpau-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: libyajl-devel
BuildRequires: libz-devel
BuildRequires: trousers-devel
BuildRequires: lirc-devel
## AUTOBUILDREQ-END
BuildRequires: doxygen
BuildRequires: gperf
BuildRequires: nasm
BuildRequires: swig
BuildRequires: unzip
BuildRequires: java-gcj-compat-runtime
BuildRequires: libalsa-devel
BuildRequires: libass-devel
BuildRequires: libbluray-devel
BuildRequires: libcurl-devel
BuildRequires: libdvdcss-devel
BuildRequires: libflac-devel
BuildRequires: libGLESv2-devel
@ -119,31 +109,25 @@ BuildRequires: libmodplug-devel
BuildRequires: libmpeg2-devel
BuildRequires: libogg-devel
BuildRequires: librtmp-devel
BuildRequires: libpostproc-ffmpeg-devel
BuildRequires: libSDL-devel
BuildRequires: libSDL_gfx-devel
BuildRequires: libSDL_image-devel
BuildRequires: libtag-devel >= 1.8
#BuildRequires: libSDL-devel
#BuildRequires: libSDL_gfx-devel
#BuildRequires: libSDL_image-devel
BuildRequires: libusb-devel
BuildRequires: libvorbis-devel
BuildRequires: libX11-devel
BuildRequires: libXext-devel
BuildRequires: libXrandr-devel
BuildRequires: libzip-devel
%if "%{?_with_raspberrypi}"
BuildRequires: libraspberrypi-devel
%endif
BuildRequires: libcec-devel
BuildRequires: libprojectM-devel
BuildRequires: libnfs-devel
BuildRequires: libdcadec-devel
BuildRequires: libcrossguid-devel
BuildRequires: libflatbuffers-devel
BuildRequires: librapidjson-devel
Requires: mesa-tests
Requires: xdpyinfo
Requires: libprojectM
Provides: xbmc
Obsoletes: xbmc
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Obsoletes: xbmc < 18.9
%description
XBMC is an award-winning free and open source (GPL) software media player and entertainment hub for digital media.
@ -151,9 +135,9 @@ XBMC is an award-winning free and open source (GPL) software media player and en
%package devel
Summary: Development package for %{name}
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
Provides: xbmc-devel
Obsoletes: xbmc-devel
Obsoletes: xbmc-devel < 18.9
%description devel
XBMC is an award-winning free and open source (GPL) software media player and entertainment hub for digital media.
@ -164,25 +148,21 @@ This package contains headers for %{name} development.
Summary: A media player and entertainment hub for digital media
Group: Graphical Desktop/Applications/Multimedia
Provides: xbmc-rpi
Obsoletes: xbmc-rpi
Obsoletes: xbmc-rpi < 18.9
%description -n %{name}-rpi
XBMC is an award-winning free and open source (GPL) software media player and entertainment hub for digital media.
%endif
%prep
%setup -q -n xbmc-%{pkgver}%{?codenameadd} -D -T
:<< ___EOF
#%patch0 -p1
#%patch1 -p1
#%patch2 -p1
%setup -q -n xbmc-%{pkgver}%{?codenameadd}
#-D -T
#:<< ___EOF
%if "%{?_with_raspberrypi}"
%patch3 -p1
%patch4 -p1
%endif
#%patch5 -p1
#%patch6 -p1
#%patch8 -p1
ln -s %{SOURCE1} tools/depends/target/ffmpeg/
@ -195,7 +175,7 @@ cd FFmpeg-%{ffmpeg_ver}
%build
#:<< ___EOF
./bootstrap
%cmake -d build
%if "%{?_with_raspberrypi}"
# -Wno-psabi: just to avoid the annoying flooding of gcc warnings
@ -215,43 +195,11 @@ export CXXFLAGS="$BUILD_FLAGS"
export LDFLAGS="$LDFLAGS -L/opt/vc/lib"
%endif
%configure \
--disable-debug \
%if "%{?_with_raspberrypi}"
--with-platform=raspberry-pi \
--enable-gles \
--disable-joystick \
--disable-sdl \
--disable-x11 \
--disable-xrandr \
--disable-openmax \
--disable-afpclient \
--disable-crystalhd \
--disable-vaapi \
--disable-vdpau \
--disable-vtbdecoder \
--enable-player=omxplayer \
%else
--enable-shared-libraries \
%endif
%ifarch arm
--disable-vaapi \
--disable-vdpau \
%endif
--enable-shared \
--enable-pulse \
--disable-hal \
--enable-optical-drive \
--enable-libcec
# --disable-dvdcss
#___EOF
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%makeinstall -C build
rm -fr %{buildroot}%{_datadir}/doc
%clean
@ -265,46 +213,47 @@ exit 0
%post -n %{pckname}
/bin/touch --no-create %{_datadir}/icons/hicolor >/dev/null 2>&1
exit 0
:
%postun -n %{pckname}
if [ $1 -eq 0 ] ; then
/bin/touch --no-create %{_datadir}/icons/hicolor >/dev/null 2>&1
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor >/dev/null 2>&1
fi
exit 0
:
%posttrans -n %{pckname}
/usr/bin/gtk-update-icon-cache %{_datadir}/icons/hicolor >/dev/null 2>&1
exit 0
:
%files -n %{pckname}
%defattr(-,root,root)
%{_bindir}/xbmc
%{_bindir}/xbmc-standalone
%{_bindir}/kodi
%{_bindir}/kodi-standalone
%{_datadir}/xbmc
%{_bindir}/TexturePacker
%dir %{_datadir}/kodi
%{_datadir}/kodi/*
%attr(0644,root,root) %{_datadir}/applications/kodi.desktop
%{_datadir}/xsessions/kodi.desktop
%{_datadir}/xsessions/xbmc.desktop
%{_datadir}/icons/hicolor/*/*/*.png
%{_libdir}/xbmc
%{_prefix}/lib/firewalld/services/kodi-*.xml
%dir %{_libdir}/kodi
%{_libdir}/kodi/*
%doc docs
%doc copying.txt LICENSE.GPL
%doc LICENSE.md
%files devel
%defattr(-,root,root)
%{_includedir}/xbmc
%dir %{_includedir}/kodi
%{_includedir}/kodi/*
%doc README.md
%changelog
* Thu Mar 25 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 18.9-1mamba
- update to 18.9
* Sun Dec 08 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 18.5-1mamba
- update to 18.5
* Sun Jul 29 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 17.6-1mamba
- update to 17.6