141 lines
4.5 KiB
RPMSpec
141 lines
4.5 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: knotifications
|
|
Version: 5.20.0
|
|
Release: 1mamba
|
|
Summary: Desktop notifications framework
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.kde.org
|
|
Source: http://download.kde.org/stable/frameworks/%{majver}/knotifications-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: kconfig-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libXtst-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libkcodecs-devel
|
|
BuildRequires: libkcoreaddons-devel
|
|
BuildRequires: libkiconthemes-devel
|
|
BuildRequires: libkservice-devel
|
|
BuildRequires: libkwindowsystem-devel
|
|
BuildRequires: libphonon-qt5-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
KNotification is used to notify the user of an event. It covers feedback and persistent events.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Desktop notifications framework
|
|
|
|
%description -n lib%{name}
|
|
KNotification is used to notify the user of an event.
|
|
It covers feedback and persistent events.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%find_lang knotifications5_qt --with-qt --all-name || touch knotifications5_qt.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name} -p /sbin/ldconfig
|
|
%postun -n lib%{name} -p /sbin/ldconfig
|
|
|
|
%files -n lib%{name} -f knotifications5_qt.lang
|
|
%defattr(-,root,root)
|
|
%{_kde5_libdir}/libKF5Notifications.so.*
|
|
%{_kde5_servicetypesdir}/knotificationplugin.desktop
|
|
%{_datadir}/dbus-1/interfaces/kf5_org.kde.StatusNotifierItem.xml
|
|
%{_datadir}/dbus-1/interfaces/kf5_org.kde.StatusNotifierWatcher.xml
|
|
%doc COPYING.LIB
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%{_kde5_includedir}/KNotifications
|
|
%{_kde5_includedir}/knotifications_version.h
|
|
%{_kde5_libdir}/cmake/KF5Notifications
|
|
%{_kde5_libdir}/libKF5Notifications.so
|
|
%{_kde5_mkspecsdir}/qt_KNotifications.pri
|
|
%doc README.md
|
|
|
|
%changelog
|
|
* Tue Mar 29 2016 Automatic Build System <autodist@mambasoft.it> 5.20.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 21 2016 Automatic Build System <autodist@mambasoft.it> 5.19.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 15 2016 Automatic Build System <autodist@mambasoft.it> 5.18.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 17 2015 Automatic Build System <autodist@mambasoft.it> 5.17.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 21 2015 Automatic Build System <autodist@mambasoft.it> 5.16.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 23 2015 Automatic Build System <autodist@mambasoft.it> 5.15.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 25 2015 Automatic Build System <autodist@mambasoft.it> 5.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 04 2015 Automatic Build System <autodist@mambasoft.it> 5.13.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 07 2015 Automatic Build System <autodist@mambasoft.it> 5.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 25 2015 Automatic Build System <autodist@mambasoft.it> 5.11.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 31 2015 Davide Madrisan <davide.madrisan@gmail.com> 5.10.0-2mamba
|
|
- standardize the specfile
|
|
|
|
* Thu May 14 2015 Automatic Build System <autodist@mambasoft.it> 5.10.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 16 2015 Automatic Build System <autodist@mambasoft.it> 5.9.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 24 2015 Automatic Build System <autodist@mambasoft.it> 5.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 22 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 5.7.0-1mamba
|
|
- update to 5.7.0
|
|
|
|
* Sat Feb 14 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 5.6.0-1mamba
|
|
- package created using the webbuild interface
|