update to 4.6.4 [release 4.6.4-1mamba;Sat Oct 12 2013]
This commit is contained in:
parent
b8c47e2a11
commit
4542c3cf11
@ -1,2 +1,4 @@
|
|||||||
# kmymoney
|
# kmymoney
|
||||||
|
|
||||||
|
KMyMoney is the Personal Finance Manager for KDE. It operates similar to MS-Money, supports different account types, categorisation of expenses and incomes, reconciliation of bank accounts and QIF import/export.
|
||||||
|
|
||||||
|
12
kmymoney-4.6.3-gcc-4.8.patch
Normal file
12
kmymoney-4.6.3-gcc-4.8.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff --git a/kmymoney/mymoney/storage/mymoneydatabasemgrtest.cpp b/kmymoney/mymoney/storage/mymoneydatabasemgrtest.cpp
|
||||||
|
index ff217e3..d31bb02 100644
|
||||||
|
--- a/kmymoney/mymoney/storage/mymoneydatabasemgrtest.cpp
|
||||||
|
+++ b/kmymoney/mymoney/storage/mymoneydatabasemgrtest.cpp
|
||||||
|
@@ -16,6 +16,7 @@
|
||||||
|
|
||||||
|
#include "mymoneydatabasemgrtest.h"
|
||||||
|
#include <pwd.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include <iostream>
|
||||||
|
|
||||||
|
#include <QtTest/QtTest>
|
29
kmymoney-4.6.3-libgmp-5.1.patch
Normal file
29
kmymoney-4.6.3-libgmp-5.1.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 77209f84a85360e98d2e805d412956a8f2a77db3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Alex Merry <kde@randomguy3.me.uk>
|
||||||
|
Date: Fri, 1 Feb 2013 15:31:54 +0000
|
||||||
|
Subject: [PATCH] Fix build with GMP 5.1.0
|
||||||
|
|
||||||
|
GMP 5.1.0 no longer has implicit conversions to mpz_class from mpq_class
|
||||||
|
or mpf_class. So we have to have an explicit conversion.
|
||||||
|
|
||||||
|
BUG: 312481
|
||||||
|
---
|
||||||
|
kmymoney/mymoney/mymoneymoney.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/kmymoney/mymoney/mymoneymoney.cpp b/kmymoney/mymoney/mymoneymoney.cpp
|
||||||
|
index aeed135..5de7fa9 100644
|
||||||
|
--- a/kmymoney/mymoney/mymoneymoney.cpp
|
||||||
|
+++ b/kmymoney/mymoney/mymoneymoney.cpp
|
||||||
|
@@ -158,7 +158,7 @@ QString MyMoneyMoney::formatMoney(const QString& currency, const int prec, bool
|
||||||
|
// be much better than using KGlobal::locale()->formatMoney.
|
||||||
|
bool bNegative = false;
|
||||||
|
mpz_class left = value / static_cast<MyMoneyMoney>(convertDenominator(d)).valueRef().get_den();
|
||||||
|
- mpz_class right = (valueRef() - mpq_class(left)) * denom;
|
||||||
|
+ mpz_class right = mpz_class((valueRef() - mpq_class(left)) * denom);
|
||||||
|
|
||||||
|
if (right < 0) {
|
||||||
|
right = -right;
|
||||||
|
--
|
||||||
|
1.8.1.2
|
||||||
|
|
163
kmymoney.spec
Normal file
163
kmymoney.spec
Normal file
@ -0,0 +1,163 @@
|
|||||||
|
Name: kmymoney
|
||||||
|
Version: 4.6.4
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A personal finance manager for KDE
|
||||||
|
Group: Graphical Desktop/Applications/Office
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://kmymoney2.sourceforge.net/index-home.html
|
||||||
|
Source: http://downloads.sourceforge.net/project/kmymoney2/KMyMoney-KDE4/%{version}/kmymoney-%{version}.tar.xz
|
||||||
|
Patch0: kmymoney-4.6.3-libgmp-5.1.patch
|
||||||
|
Patch1: kmymoney-4.6.3-gcc-4.8.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: kdelibs-devel
|
||||||
|
BuildRequires: kdepimlibs-devel
|
||||||
|
BuildRequires: libalkimia-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
BuildRequires: libical-devel
|
||||||
|
BuildRequires: libofx-devel
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: perl-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libalkimia-devel
|
||||||
|
Provides: kmymoney2
|
||||||
|
Obsoletes: kmymoney2
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
KMyMoney is the Personal Finance Manager for KDE. It operates similar to MS-Money, supports different account types, categorisation of expenses and incomes, reconciliation of bank accounts and QIF import/export.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Provides: kmymoney2-devel
|
||||||
|
Obsoletes: kmymoney2-devel
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
KMyMoney is the Personal Finance Manager for KDE. It operates similar to MS-Money, supports different account types, categorisation of expenses and incomes, reconciliation of bank accounts and QIF import/export.
|
||||||
|
|
||||||
|
This package provides library and header files needed for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake_kde4
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall DESTDIR=%{buildroot}
|
||||||
|
|
||||||
|
%find_lang kmymoney
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -f kmymoney.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%config %{_kde4_configdir}/csvimporterrc
|
||||||
|
%{_kde4_bindir}/kmymoney
|
||||||
|
%{_kde4_libdir}/libkmm_*.so.*
|
||||||
|
%{_kde4_libdir}/kde4/*.so
|
||||||
|
%{_kde4_xdgappsdir}/kmymoney.desktop
|
||||||
|
%dir %{_kde4_datadir}/kmymoney
|
||||||
|
%{_kde4_datadir}/kmymoney/*
|
||||||
|
%{_kde4_kcfgdir}/kmymoney.kcfg
|
||||||
|
%dir %{_kde4_datadir}/kmm_csvimport
|
||||||
|
%{_kde4_datadir}/kmm_csvimport/kmm_csvimport.rc
|
||||||
|
%dir %{_kde4_datadir}/kmm_icalendarexport
|
||||||
|
%{_kde4_datadir}/kmm_icalendarexport/kmm_icalendarexport.rc
|
||||||
|
%dir %{_kde4_datadir}/kmm_ofximport
|
||||||
|
%{_kde4_datadir}/kmm_ofximport/kmm_ofximport.rc
|
||||||
|
%dir %{_kde4_datadir}/kmm_printcheck
|
||||||
|
%{_kde4_datadir}/kmm_printcheck/*
|
||||||
|
%{_kde4_servicesdir}/*.desktop
|
||||||
|
%{_kde4_servicetypesdir}/kmymoney*.desktop
|
||||||
|
%{_kde4_icondir}/locolor/*/apps/kmymoney.png
|
||||||
|
%{_kde4_icondir}/hicolor/*/mimetypes/kmy.png
|
||||||
|
%{_kde4_icondir}/hicolor/*/apps/kmymoney.png
|
||||||
|
%{_kde4_mimedir}/packages/x-kmymoney.xml
|
||||||
|
%lang(de) %{_kde4_htmldir}/de/kmymoney
|
||||||
|
%lang(es) %{_kde4_htmldir}/es/kmymoney
|
||||||
|
%lang(en) %{_kde4_htmldir}/en/kmymoney
|
||||||
|
%lang(fr) %{_kde4_htmldir}/fr/kmymoney
|
||||||
|
%lang(it) %{_kde4_htmldir}/it/kmymoney
|
||||||
|
%lang(nl) %{_kde4_htmldir}/nl/kmymoney
|
||||||
|
%lang(pt) %{_kde4_htmldir}/pt/kmymoney
|
||||||
|
%lang(pt_BR) %{_kde4_htmldir}/pt_BR/kmymoney
|
||||||
|
%lang(sv) %{_kde4_htmldir}/sv/kmymoney
|
||||||
|
%lang(uk) %{_kde4_htmldir}/uk/kmymoney
|
||||||
|
%{_mandir}/man1/kmymoney.1.gz
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%dir %{_kde4_includedir}/kmymoney
|
||||||
|
%{_kde4_includedir}/kmymoney/*
|
||||||
|
%{_kde4_libdir}/libkmm_*.so
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Oct 12 2013 Automatic Build System <autodist@mambasoft.it> 4.6.4-1mamba
|
||||||
|
- update to 4.6.4
|
||||||
|
|
||||||
|
* Mon Dec 10 2012 Automatic Build System <autodist@mambasoft.it> 4.6.3-2mamba
|
||||||
|
- rebuilt with libofx 0.9.5
|
||||||
|
|
||||||
|
* Mon Oct 15 2012 Automatic Build System <autodist@mambasoft.it> 4.6.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Mar 28 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.5.3-2mamba
|
||||||
|
- renamed from kmymoney2 to kmymoney
|
||||||
|
|
||||||
|
* Wed Feb 23 2011 Automatic Build System <autodist@mambasoft.it> 4.5.3-1mamba
|
||||||
|
- update to 4.5.3
|
||||||
|
|
||||||
|
* Sun May 16 2010 Automatic Build System <autodist@mambasoft.it> 1.0.5-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Sep 01 2009 Automatic Build System <autodist@mambasoft.it> 1.0.0-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed May 20 2009 Automatic Build System <autodist@mambasoft.it> 0.9.3-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sat Apr 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Feb 18 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.9-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Jul 07 2008 gil <puntogil@libero.it> 0.8.9-1mamba
|
||||||
|
- update to 0.8.9
|
||||||
|
- fixed language support
|
||||||
|
- new buildrequires: libofx-devel
|
||||||
|
- edit configure options: enable-ofxplugin enable-ofxbanking
|
||||||
|
- fixed desktop file location
|
||||||
|
- added %%post, %%postun scripts
|
||||||
|
- edit fields: group vendor distribution packager url
|
||||||
|
|
||||||
|
* Thu Aug 18 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8-1qilnx
|
||||||
|
- update to version 0.8 by autospec
|
||||||
|
|
||||||
|
* Thu Jun 09 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.7.2-1qilnx
|
||||||
|
- new version
|
||||||
|
|
||||||
|
* Wed Apr 20 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 0.6.4-2qilnx
|
||||||
|
- rebuild and moved from devel-contrib repository to devel repository
|
||||||
|
|
||||||
|
* Thu Dec 23 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.6.4-1qilnx
|
||||||
|
- new version
|
||||||
|
|
||||||
|
* Fri Oct 01 2004 Matteo Bernasconi <voyagernm@virgilio.it> 0.6.2-1qilnx
|
||||||
|
- first build
|
Loading…
Reference in New Issue
Block a user