automatic version update by autodist [release 32-1mamba;Fri Mar 08 2024]
This commit is contained in:
parent
bb8f6b91cc
commit
8d8d33cf79
@ -1,38 +0,0 @@
|
||||
diff -Nru kmod-13.orig/libkmod/libkmod-module.c kmod-13/libkmod/libkmod-module.c
|
||||
--- kmod-13.orig/libkmod/libkmod-module.c 2013-04-26 18:23:58.080751735 +0200
|
||||
+++ kmod-13/libkmod/libkmod-module.c 2013-04-26 18:24:44.050393418 +0200
|
||||
@@ -808,19 +808,6 @@
|
||||
return err;
|
||||
}
|
||||
|
||||
- if (kmod_file_get_direct(file)) {
|
||||
- unsigned int kernel_flags = 0;
|
||||
-
|
||||
- if (flags & KMOD_INSERT_FORCE_VERMAGIC)
|
||||
- kernel_flags |= MODULE_INIT_IGNORE_VERMAGIC;
|
||||
- if (flags & KMOD_INSERT_FORCE_MODVERSION)
|
||||
- kernel_flags |= MODULE_INIT_IGNORE_MODVERSIONS;
|
||||
-
|
||||
- err = finit_module(kmod_file_get_fd(file), args, kernel_flags);
|
||||
- if (err == 0 || errno != ENOSYS)
|
||||
- goto init_finished;
|
||||
- }
|
||||
-
|
||||
size = kmod_file_get_size(file);
|
||||
mem = kmod_file_get_contents(file);
|
||||
|
||||
@@ -847,14 +834,6 @@
|
||||
}
|
||||
|
||||
err = init_module(mem, size, args);
|
||||
-init_finished:
|
||||
- if (err < 0) {
|
||||
- err = -errno;
|
||||
- INFO(mod->ctx, "Failed to insert module '%s': %m\n", path);
|
||||
- }
|
||||
-
|
||||
- if (elf != NULL)
|
||||
- kmod_elf_unref(elf);
|
||||
elf_failed:
|
||||
kmod_file_unref(file);
|
||||
|
@ -1,23 +0,0 @@
|
||||
From b9a7da391066768736a2f23a360a3995df4bc097 Mon Sep 17 00:00:00 2001
|
||||
From: Lucas De Marchi <lucas.de.marchi@gmail.com>
|
||||
Date: Tue, 23 Apr 2013 23:47:28 +0000
|
||||
Subject: libkmod-module: Don't pass NULL ctx to kmod_log
|
||||
|
||||
---
|
||||
(limited to 'libkmod/libkmod-module.c')
|
||||
|
||||
diff --git a/libkmod/libkmod-module.c b/libkmod/libkmod-module.c
|
||||
index 6b793cd..1f8ce3c 100644
|
||||
--- a/libkmod/libkmod-module.c
|
||||
+++ b/libkmod/libkmod-module.c
|
||||
@@ -1839,7 +1839,7 @@ KMOD_EXPORT struct kmod_list *kmod_module_get_holders(const struct kmod_module *
|
||||
struct kmod_list *list = NULL;
|
||||
DIR *d;
|
||||
|
||||
- if (mod == NULL)
|
||||
+ if (mod == NULL || mod->ctx == NULL)
|
||||
return NULL;
|
||||
|
||||
snprintf(dname, sizeof(dname), "/sys/module/%s/holders", mod->name);
|
||||
--
|
||||
cgit v0.9.1
|
39
kmod.spec
39
kmod.spec
@ -1,5 +1,5 @@
|
||||
Name: kmod
|
||||
Version: 31
|
||||
Version: 32
|
||||
Release: 1mamba
|
||||
Summary: Utilities for Linux kernel module handling
|
||||
Group: System/Kernel and Hardware
|
||||
@ -8,8 +8,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git
|
||||
Source0: http://www.kernel.org/pub/linux/utils/kernel/kmod/kmod-%{version}.tar.xz
|
||||
Patch0: kmod-13-arm-upstream-null-pointer-fix.patch
|
||||
Patch1: kmod-13-arm-revert-add-finit_module-logic.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -18,7 +16,6 @@ BuildRequires: libopenssl-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: libzstd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libopenssl-devel >= 3.0.1
|
||||
Requires: libkmod = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: module-init-tools
|
||||
Obsoletes: module-init-tools < 28
|
||||
@ -53,15 +50,10 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%ifarch arm
|
||||
#%patch1 -p1
|
||||
#%endif
|
||||
cp libkmod/README README.libkmod
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--bindir=%{_sbindir} \
|
||||
--with-xz \
|
||||
--with-zlib \
|
||||
--with-zstd \
|
||||
@ -76,19 +68,10 @@ cp libkmod/README README.libkmod
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
install -d %{buildroot}%{_bindir}
|
||||
install -d %{buildroot}%{_sysconfdir}/modprobe.d
|
||||
install -d %{buildroot}%{_sysconfdir}/depmod.d
|
||||
install -d %{buildroot}%{_prefix}/lib/depmod.d
|
||||
|
||||
## add symlinks to kmod
|
||||
for tool in depmod insmod lsmod rmmod modinfo modprobe; do
|
||||
ln -s kmod %{buildroot}%{_sbindir}/${tool}
|
||||
done
|
||||
|
||||
## legacy symlink for systemd-kmod service
|
||||
#ln -s ../sbin/kmod %{buildroot}%{_bindir}/lsmod
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
@ -111,14 +94,14 @@ done
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/depmod.d
|
||||
%dir %{_sysconfdir}/modprobe.d
|
||||
%{_sbindir}/kmod
|
||||
%{_sbindir}/depmod
|
||||
%{_sbindir}/insmod
|
||||
%{_sbindir}/lsmod
|
||||
%{_sbindir}/modinfo
|
||||
%{_sbindir}/modprobe
|
||||
%{_sbindir}/rmmod
|
||||
%{_sbindir}/lsmod
|
||||
%{_bindir}/kmod
|
||||
%{_bindir}/depmod
|
||||
%{_bindir}/insmod
|
||||
%{_bindir}/lsmod
|
||||
%{_bindir}/modinfo
|
||||
%{_bindir}/modprobe
|
||||
%{_bindir}/rmmod
|
||||
%{_bindir}/lsmod
|
||||
%dir %{_prefix}/lib/depmod.d
|
||||
%{_datadir}/bash-completion/completions/kmod
|
||||
%{_mandir}/man5/depmod.d.*
|
||||
@ -141,10 +124,14 @@ done
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/libkmod.h
|
||||
%{_libdir}/libkmod.so
|
||||
%{_libdir}/pkgconfig/kmod.pc
|
||||
%{_libdir}/pkgconfig/libkmod.pc
|
||||
%doc NEWS TODO README.libkmod
|
||||
|
||||
%changelog
|
||||
* Fri Mar 08 2024 Automatic Build System <autodist@openmamba.org> 32-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Sep 30 2023 Automatic Build System <autodist@mambasoft.it> 31-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user