automatic version update by autodist [release 24.02.1-1mamba;Sat Mar 23 2024]
This commit is contained in:
parent
db3b7c7621
commit
5d12427c26
@ -1,4 +1,4 @@
|
||||
# kleopatra
|
||||
|
||||
KDE Frameworks 5 certificates manager.
|
||||
KDE certificates manager.
|
||||
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 87d8b00d4b2286489d5fadc9cfa07f1d721cdfe3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Ingo=20Kl=C3=B6cker?= <dev@ingo-kloecker.de>
|
||||
Date: Thu, 4 Aug 2022 12:24:25 +0200
|
||||
Subject: [PATCH] Use ReceiveKeysJob for refreshing OpenPGP keys
|
||||
|
||||
This refreshes the OpenPGP key from the configured key server.
|
||||
|
||||
GnuPG-bug-id: 5903
|
||||
---
|
||||
src/commands/refreshcertificatecommand.cpp | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/commands/refreshcertificatecommand.cpp b/src/commands/refreshcertificatecommand.cpp
|
||||
index 226d791f..6a88bbf4 100644
|
||||
--- a/src/commands/refreshcertificatecommand.cpp
|
||||
+++ b/src/commands/refreshcertificatecommand.cpp
|
||||
@@ -19,7 +19,7 @@
|
||||
#include <QGpgME/Protocol>
|
||||
#ifdef QGPGME_SUPPORTS_KEY_REFRESH
|
||||
#include <QGpgME/RefreshKeysJob>
|
||||
-#include <QGpgME/RefreshOpenPGPKeysJob>
|
||||
+#include <QGpgME/ReceiveKeysJob>
|
||||
#endif
|
||||
|
||||
#include <gpgme++/importresult.h>
|
||||
@@ -44,7 +44,7 @@ public:
|
||||
void cancel();
|
||||
|
||||
#ifdef QGPGME_SUPPORTS_KEY_REFRESH
|
||||
- std::unique_ptr<QGpgME::RefreshOpenPGPKeysJob> startOpenPGPJob();
|
||||
+ std::unique_ptr<QGpgME::ReceiveKeysJob> startOpenPGPJob();
|
||||
std::unique_ptr<QGpgME::RefreshKeysJob> startSMIMEJob();
|
||||
#endif
|
||||
void onOpenPGPJobResult(const ImportResult &result);
|
||||
@@ -136,19 +136,19 @@ void RefreshCertificateCommand::Private::cancel()
|
||||
}
|
||||
|
||||
#ifdef QGPGME_SUPPORTS_KEY_REFRESH
|
||||
-std::unique_ptr<QGpgME::RefreshOpenPGPKeysJob> RefreshCertificateCommand::Private::startOpenPGPJob()
|
||||
+std::unique_ptr<QGpgME::ReceiveKeysJob> RefreshCertificateCommand::Private::startOpenPGPJob()
|
||||
{
|
||||
- std::unique_ptr<QGpgME::RefreshOpenPGPKeysJob> refreshJob{QGpgME::openpgp()->refreshOpenPGPKeysJob()};
|
||||
+ std::unique_ptr<QGpgME::ReceiveKeysJob> refreshJob{QGpgME::openpgp()->receiveKeysJob()};
|
||||
Q_ASSERT(refreshJob);
|
||||
|
||||
- connect(refreshJob.get(), &QGpgME::RefreshOpenPGPKeysJob::result,
|
||||
+ connect(refreshJob.get(), &QGpgME::ReceiveKeysJob::result,
|
||||
q, [this](const GpgME::ImportResult &result) {
|
||||
onOpenPGPJobResult(result);
|
||||
});
|
||||
connect(refreshJob.get(), &QGpgME::Job::progress,
|
||||
q, &Command::progress);
|
||||
|
||||
- const GpgME::Error err = refreshJob->start({key});
|
||||
+ const GpgME::Error err = refreshJob->start({QString::fromLatin1(key.primaryFingerprint())});
|
||||
if (err) {
|
||||
showError(err);
|
||||
return {};
|
||||
--
|
||||
GitLab
|
||||
|
110
kleopatra.spec
110
kleopatra.spec
@ -1,61 +1,69 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
|
||||
Name: kleopatra
|
||||
Version: 23.08.5
|
||||
Version: 24.02.1
|
||||
Release: 1mamba
|
||||
Summary: KDE Frameworks 5 certificates manager
|
||||
Summary: KDE certificates manager
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kde.org/
|
||||
Source: http://download.kde.org/stable/release-service/%{version}/src/kleopatra-%{version}.tar.xz
|
||||
Patch0: kleopatra-22.08.0-libgpgme-1.18.0.patch
|
||||
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/kleopatra-%{version}.tar.xz
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libakonadi-devel
|
||||
BuildRequires: libakonadi-mime-devel
|
||||
BuildRequires: libassuan-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgpgme-devel
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkcmutils-devel
|
||||
BuildRequires: libkcodecs-devel
|
||||
BuildRequires: libkcompletion-devel
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: libkconfigwidgets-devel
|
||||
BuildRequires: libkcoreaddons-devel
|
||||
BuildRequires: libkcrash-devel
|
||||
BuildRequires: libkdbusaddons-devel
|
||||
BuildRequires: libki18n-devel
|
||||
BuildRequires: libkiconthemes-devel
|
||||
BuildRequires: libkio-devel
|
||||
BuildRequires: libkitemmodels-devel
|
||||
BuildRequires: libkjobwidgets-devel
|
||||
BuildRequires: libkf6-kcmutils-devel
|
||||
BuildRequires: libkf6-kcodecs-devel
|
||||
BuildRequires: libkf6-kcolorscheme-devel
|
||||
BuildRequires: libkf6-kcompletion-devel
|
||||
BuildRequires: libkf6-kconfig-devel
|
||||
BuildRequires: libkf6-kconfigwidgets-devel
|
||||
BuildRequires: libkf6-kcoreaddons-devel
|
||||
BuildRequires: libkf6-kcrash-devel
|
||||
BuildRequires: libkf6-kdbusaddons-devel
|
||||
BuildRequires: libkf6-ki18n-devel
|
||||
BuildRequires: libkf6-kiconthemes-devel
|
||||
BuildRequires: libkf6-kio-devel
|
||||
BuildRequires: libkf6-kitemmodels-devel
|
||||
BuildRequires: libkf6-kjobwidgets-devel
|
||||
BuildRequires: libkf6-knotifications-devel
|
||||
BuildRequires: libkf6-kservice-devel
|
||||
BuildRequires: libkf6-kstatusnotifieritem-devel
|
||||
BuildRequires: libkf6-ktextwidgets-devel
|
||||
BuildRequires: libkf6-kwidgetsaddons-devel
|
||||
BuildRequires: libkf6-kwindowsystem-devel
|
||||
BuildRequires: libkf6-kxmlgui-devel
|
||||
BuildRequires: libkf6-solid-devel
|
||||
BuildRequires: libkf6-sonnet-devel
|
||||
BuildRequires: libkidentitymanagement-devel
|
||||
BuildRequires: libkleo-devel
|
||||
BuildRequires: libkmailtransport-devel
|
||||
BuildRequires: libkmbox-devel
|
||||
BuildRequires: libkmime-devel
|
||||
BuildRequires: libknotifications-devel
|
||||
BuildRequires: libkservice-devel
|
||||
BuildRequires: libktextwidgets-devel
|
||||
BuildRequires: libkwidgetsaddons-devel
|
||||
BuildRequires: libkwindowsystem-devel
|
||||
BuildRequires: libkxmlgui-devel
|
||||
BuildRequires: libqgpgme-devel
|
||||
BuildRequires: libsolid-devel
|
||||
BuildRequires: libsonnet-devel
|
||||
BuildRequires: libmimetreeparser-devel
|
||||
BuildRequires: libqgpgme-qt6-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
BuildRequires: qt6-qtbase-devel
|
||||
BuildRequires: qt6-qtdeclarative-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: cmake
|
||||
BuildRequires: rpm-macros-kde5
|
||||
BuildRequires: kf6-rpm-macros
|
||||
BuildRequires: libgpgme-devel >= 1.18.0
|
||||
BuildRequires: extra-cmake-modules
|
||||
BuildRequires: libgpgme-devel >= 1:1.18.0
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description
|
||||
KDE Frameworks 5 certificates manager.
|
||||
KDE certificates manager.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
@ -76,17 +84,16 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1 -b .libgpgme-1.18.0
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
%make
|
||||
%cmake_kf6
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
%cmake_install
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --with-man --with-html --all-name || touch %{name}5_qt.lang
|
||||
%find_lang %{name} --with-qt --with-man --with-html --all-name || touch %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -94,46 +101,43 @@ This package contains libraries and header files for developing applications tha
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}5_qt.lang
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/kleopatra
|
||||
%{_bindir}/kwatchgnupg
|
||||
%{_datadir}/metainfo/org.kde.kleopatra.appdata.xml
|
||||
%{_datadir}/applications/kleopatra_import.desktop
|
||||
%{_datadir}/mime/packages/application-vnd-kde-kleopatra.xml
|
||||
%{_datadir}/applications/org.kde.kwatchgnupg.desktop
|
||||
%{_datadir}/applications/org.kde.kleopatra.desktop
|
||||
%{_datadir}/metainfo/org.kde.kleopatra.appdata.xml
|
||||
%{_datadir}/mime/packages/kleopatra-mime.xml
|
||||
%{_datadir}/mime/packages/application-vnd-kde-kleopatra.xml
|
||||
%{_datadir}/kconf_update/*
|
||||
%dir %{_datadir}/kleopatra
|
||||
%dir %{_datadir}/kleopatra/pics
|
||||
%{_datadir}/kleopatra/pics/*
|
||||
#%{_datadir}/kservices5/kleopatra_*.desktop
|
||||
%{_datadir}/kio/servicemenus/kleopatra_*.desktop
|
||||
%dir %{_datadir}/kwatchgnupg
|
||||
%dir %{_datadir}/kwatchgnupg/pics
|
||||
%{_datadir}/kwatchgnupg/pics/*
|
||||
%{_datadir}/qlogging-categories5/kleopatra.categories
|
||||
%{_datadir}/qlogging-categories5/kleopatra.renamecategories
|
||||
%{_datadir}/qlogging-categories6/kleopatra.categories
|
||||
%{_datadir}/qlogging-categories6/kleopatra.renamecategories
|
||||
%{_datadir}/icons/hicolor/22x22/apps/kwatchgnupg.png
|
||||
%{_datadir}/icons/hicolor/*/apps/kleopatra.png
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libkleopatraclientcore.so
|
||||
%{_libdir}/libkleopatraclientcore.so.*
|
||||
%{_libdir}/libkleopatraclientgui.so
|
||||
%{_libdir}/libkleopatraclientgui.so.*
|
||||
%{_libdir}/qt5/plugins/pim5/kcms/kleopatra/kleopatra_config_gnupgsystem.so
|
||||
%{_qt6_plugindir}/pim6/kcms/kleopatra/kleopatra_config_gnupgsystem.so
|
||||
%doc LICENSES
|
||||
|
||||
#%files -n lib%{name}-devel
|
||||
#%defattr(-,root,root)
|
||||
## note: this list is just an example; modify as required
|
||||
# %{_kde5_includedir}/<KF5Framework>
|
||||
# %{_kde5_includedir}/%{name}_version.h
|
||||
# %{_kde5_libdir}/cmake/<KF5Framework>
|
||||
# %{_kde5_libdir}/*.so
|
||||
# %{_kde5_mkspecsdir}/qt_*.pri
|
||||
|
||||
%changelog
|
||||
* Sat Mar 23 2024 Automatic Build System <autodist@openmamba.org> 24.02.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Mar 09 2024 Automatic Build System <autodist@openmamba.org> 24.02.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Feb 17 2024 Automatic Build System <autodist@openmamba.org> 23.08.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user