standardize the specfile [release 5.10.0-2mamba;Sun May 31 2015]
This commit is contained in:
parent
f342348e32
commit
f42ab726d9
@ -1,6 +1,6 @@
|
||||
# kio
|
||||
|
||||
This framework implements almost all the file management functions you will ever need. In fact, the KDE file manager (Dolphin) and the KDE file dialog also uses this to provide its network-enabled file management.
|
||||
It supports accessing files locally as well as via HTTP and FTP out of the box and can be extended by plugins to support other protocols as well. There is a variety of plugins available, e.g. to support access via SSH.
|
||||
The framework can also be used to bridge a native protocol to a file-based interface. This makes the data accessible in all applications using the KDE file dialog or any other KIO enabled infrastructure.
|
||||
This framework implements almost all the file management functions you will ever need.
|
||||
It supports accessing files locally as well as via HTTP and FTP out of the box and can be extended by plugins to support other protocols as well.
|
||||
The framework can also be used to bridge a native protocol to a file-based interface.
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- kio-5.6.0.orig/KF5KIOConfig.cmake.in 2015-01-03 13:09:16.000000000 +0100
|
||||
+++ kio-5.6.0/KF5KIOConfig.cmake.in 2015-02-16 23:48:58.089370525 +0100
|
||||
@@ -2,8 +2,8 @@
|
||||
|
||||
# Any changes in this ".cmake" file will be overwritten by CMake, the source is the ".cmake.in" file.
|
||||
|
||||
-set(KCookieServer_DBUS_INTERFACE "${PACKAGE_PREFIX_DIR}/@DBUS_INTERFACES_INSTALL_DIR@/kf5_org.kde.KCookieServer.xml")
|
||||
-set(KSlaveLauncher_DBUS_INTERFACE "${PACKAGE_PREFIX_DIR}/@DBUS_INTERFACES_INSTALL_DIR@/kf5_org.kde.KSlaveLauncher.xml")
|
||||
+set(KCookieServer_DBUS_INTERFACE "@DBUS_INTERFACES_INSTALL_DIR@/kf5_org.kde.KCookieServer.xml")
|
||||
+set(KSlaveLauncher_DBUS_INTERFACE "@DBUS_INTERFACES_INSTALL_DIR@/kf5_org.kde.KSlaveLauncher.xml")
|
||||
|
||||
find_dependency(KF5Bookmarks "@KF5_DEP_VERSION@")
|
||||
find_dependency(KF5Completion "@KF5_DEP_VERSION@")
|
98
kio.spec
98
kio.spec
@ -1,7 +1,8 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
|
||||
Name: kio
|
||||
Version: 5.10.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Network transparent access to files and data
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -9,7 +10,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.kde.org
|
||||
Source: http://download.kde.org/stable/frameworks/%{majver}/kio-%{version}.tar.xz
|
||||
Patch0: kio-5.6.0-fix-cmake-prefix.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -46,15 +46,18 @@ BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: extra-cmake-modules
|
||||
BuildRequires: cmake
|
||||
BuildRequires: rpm-macros-kde5
|
||||
BuildRequires: extra-cmake-modules
|
||||
BuildRequires: libkconfig-devel
|
||||
BuildRequires: kdoctools-devel
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This framework implements almost all the file management functions you will ever need. In fact, the KDE file manager (Dolphin) and the KDE file dialog also uses this to provide its network-enabled file management.
|
||||
It supports accessing files locally as well as via HTTP and FTP out of the box and can be extended by plugins to support other protocols as well. There is a variety of plugins available, e.g. to support access via SSH.
|
||||
The framework can also be used to bridge a native protocol to a file-based interface. This makes the data accessible in all applications using the KDE file dialog or any other KIO enabled infrastructure.
|
||||
This framework implements almost all the file management functions you will ever need.
|
||||
It supports accessing files locally as well as via HTTP and FTP out of the box and can be extended by plugins to support other protocols as well.
|
||||
The framework can also be used to bridge a native protocol to a file-based interface.
|
||||
|
||||
%package -n lib%{name}
|
||||
Group: System/Libraries
|
||||
@ -75,7 +78,6 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build
|
||||
@ -85,7 +87,7 @@ This package contains libraries and header files for developing applications tha
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%find_lang kio5
|
||||
%find_lang kio5 --with-man --with-qt --all-name || touch kio5.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -95,40 +97,28 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%files -f kio5.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/xdg/accept-languages.codes
|
||||
%{_sysconfdir}/xdg/kshorturifilterrc
|
||||
%{_bindir}/kcookiejar5
|
||||
%{_bindir}/kmailservice5
|
||||
%{_bindir}/ktelnetservice5
|
||||
%{_bindir}/ktrash5
|
||||
%{_datadir}/applications/kmailservice5.desktop
|
||||
%{_datadir}/applications/ktelnetservice5.desktop
|
||||
%{_datadir}/dbus-1/services/org.kde.kiod5.service
|
||||
%{_datadir}/dbus-1/interfaces/kf5_org.kde.KCookieServer.xml
|
||||
%{_datadir}/dbus-1/interfaces/kf5_org.kde.KDirNotify.xml
|
||||
%{_datadir}/dbus-1/interfaces/kf5_org.kde.KPasswdServer.xml
|
||||
%{_datadir}/dbus-1/interfaces/kf5_org.kde.KSlaveLauncher.xml
|
||||
%{_datadir}/dbus-1/interfaces/kf5_org.kde.kio.FileUndoManager.xml
|
||||
%dir %{_datadir}/doc/HTML/en/kioslave5
|
||||
%{_datadir}/doc/HTML/en/kioslave5/*
|
||||
%{_datadir}/kf5/kcookiejar/domain_info
|
||||
%{_datadir}/knotifications5/proxyscout.notifyrc
|
||||
%{_datadir}/kservices5/*
|
||||
%{_datadir}/kservicetypes5/*
|
||||
%{_mandir}/ca/man8/kcookiejar5.8*
|
||||
%{_mandir}/it/man8/kcookiejar5.8*
|
||||
%{_mandir}/man8/kcookiejar5.8*
|
||||
%{_mandir}/nl/man8/kcookiejar5.8*
|
||||
%{_mandir}/pt_BR/man8/kcookiejar5.8*
|
||||
%{_mandir}/sv/man8/kcookiejar5.8*
|
||||
%{_mandir}/uk/man8/kcookiejar5.8*
|
||||
%{_kde5_bindir}/kcookiejar5
|
||||
%{_kde5_bindir}/kmailservice5
|
||||
%{_kde5_bindir}/ktelnetservice5
|
||||
%{_kde5_bindir}/ktrash5
|
||||
%{_kde5_xdgappsdir}/*.desktop
|
||||
%{_kde5_htmldir}/en/kioslave5/*
|
||||
%{_kde5_sharedir}/kf5/kcookiejar/domain_info
|
||||
%{_kde5_sharedir}/knotifications5/proxyscout.notifyrc
|
||||
%{_kde5_servicesdir}/*
|
||||
%{_kde5_servicetypesdir}/*
|
||||
%{_kde5_configdir}/accept-languages.codes
|
||||
%{_kde5_configdir}/kshorturifilterrc
|
||||
%{_kde5_datadir}/dbus-1/services/org.kde.*.service
|
||||
%{_kde5_datadir}/dbus-1/interfaces/kf5_org.kde.*.xml
|
||||
%{_kde5_mandir}/man8/kcookiejar5.*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libKF5KIOCore.so.*
|
||||
%{_libdir}/libKF5KIOFileWidgets.so.*
|
||||
%{_libdir}/libKF5KIONTLM.so.*
|
||||
%{_libdir}/libKF5KIOWidgets.so.*
|
||||
%{_kde5_libdir}/libKF5KIOCore.so.*
|
||||
%{_kde5_libdir}/libKF5KIOFileWidgets.so.*
|
||||
%{_kde5_libdir}/libKF5KIONTLM.so.*
|
||||
%{_kde5_libdir}/libKF5KIOWidgets.so.*
|
||||
%dir %{_kde5_libexecdir}
|
||||
%{_kde5_libexecdir}/*
|
||||
%{_qt5_plugindir}/kcm_*.so
|
||||
@ -144,28 +134,20 @@ This package contains libraries and header files for developing applications tha
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/KF5/KIOCore
|
||||
%{_includedir}/KF5/KIOCore/*
|
||||
%dir %{_includedir}/KF5/KIOFileWidgets
|
||||
%{_includedir}/KF5/KIOFileWidgets/*
|
||||
%dir %{_includedir}/KF5/KIOWidgets/
|
||||
%{_includedir}/KF5/KIOWidgets/*
|
||||
%dir %{_includedir}/KF5/kio
|
||||
%{_includedir}/KF5/kio/*
|
||||
%{_includedir}/KF5/kio_version.h
|
||||
%dir %{_libdir}/cmake/KF5KIO/
|
||||
%{_libdir}/cmake/KF5KIO/KF5KIO*.cmake
|
||||
%{_libdir}/libKF5KIOCore.so
|
||||
%{_libdir}/libKF5KIOFileWidgets.so
|
||||
%{_libdir}/libKF5KIONTLM.so
|
||||
%{_libdir}/libKF5KIOWidgets.so
|
||||
%{_kde5_mkspecsdir}/qt_KIOCore.pri
|
||||
%{_kde5_mkspecsdir}/qt_KIOFileWidgets.pri
|
||||
%{_kde5_mkspecsdir}/qt_KIOWidgets.pri
|
||||
%{_kde5_mkspecsdir}/qt_KNTLM.pri
|
||||
%{_kde5_includedir}/KIOCore
|
||||
%{_kde5_includedir}/KIOFileWidgets
|
||||
%{_kde5_includedir}/KIOWidgets
|
||||
%{_kde5_includedir}/kio
|
||||
%{_kde5_includedir}/kio_version.h
|
||||
%{_kde5_libdir}/cmake/KF5KIO
|
||||
%{_kde5_libdir}/libKF5*.so
|
||||
%{_kde5_mkspecsdir}/qt_*.pri
|
||||
#%doc README.md
|
||||
|
||||
%changelog
|
||||
* Sun May 31 2015 Davide Madrisan <davide.madrisan@gmail.com> 5.10.0-2mamba
|
||||
- standardize the specfile
|
||||
|
||||
* Fri May 22 2015 Automatic Build System <autodist@mambasoft.it> 5.10.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user