437 lines
16 KiB
RPMSpec
437 lines
16 KiB
RPMSpec
Name: kget
|
|
Version: 24.05.0
|
|
Release: 1mamba
|
|
Summary: An advanced download manager for the K Desktop Environment
|
|
Group: Graphical Desktop/Applications/Internet
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://apps.kde.org/it/kget/
|
|
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/kget-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libX11-devel
|
|
BuildRequires: libassuan-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libgcrypt-devel
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libgmp-devel
|
|
BuildRequires: libgpgme-devel
|
|
BuildRequires: libkf6-karchive-devel
|
|
BuildRequires: libkf6-kcmutils-devel
|
|
BuildRequires: libkf6-kcolorscheme-devel
|
|
BuildRequires: libkf6-kcompletion-devel
|
|
BuildRequires: libkf6-kconfig-devel
|
|
BuildRequires: libkf6-kconfigwidgets-devel
|
|
BuildRequires: libkf6-kcoreaddons-devel
|
|
BuildRequires: libkf6-kcrash-devel
|
|
BuildRequires: libkf6-kdbusaddons-devel
|
|
BuildRequires: libkf6-ki18n-devel
|
|
BuildRequires: libkf6-kiconthemes-devel
|
|
BuildRequires: libkf6-kio-devel
|
|
BuildRequires: libkf6-kitemviews-devel
|
|
BuildRequires: libkf6-kjobwidgets-devel
|
|
BuildRequires: libkf6-knotifications-devel
|
|
BuildRequires: libkf6-knotifyconfig-devel
|
|
BuildRequires: libkf6-kservice-devel
|
|
BuildRequires: libkf6-kstatusnotifieritem-devel
|
|
BuildRequires: libkf6-kwallet-devel
|
|
BuildRequires: libkf6-kwidgetsaddons-devel
|
|
BuildRequires: libkf6-kwindowsystem-devel
|
|
BuildRequires: libkf6-kxmlgui-devel
|
|
BuildRequires: libkf6-solid-devel
|
|
BuildRequires: libktorrent-devel
|
|
BuildRequires: libmms-devel
|
|
BuildRequires: libqgpgme-qt6-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: qt6-qt5compat-devel
|
|
BuildRequires: qt6-qtbase-devel
|
|
BuildRequires: qt6-qtdeclarative-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: automoc4
|
|
BuildRequires: cmake
|
|
Provides: libkget
|
|
Obsoletes: libkget < 21.04.3
|
|
Provides: kget4
|
|
Obsoletes: kget4 < 21.04.3
|
|
Provides: kget-devel
|
|
Obsoletes: kget-devel < 22.04.0
|
|
BuildRequires: libgpgme-devel >= 1.18.0
|
|
|
|
%description
|
|
An advanced download manager for the K Desktop Environment.
|
|
This package is part of KDE.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kf6\
|
|
-DCMAKE_DISABLE_FIND_PACKAGE_NepomukCore=TRUE \
|
|
-DCMAKE_DISABLE_FIND_PACKAGE_KTorrent=TRUE
|
|
|
|
%cmake_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%cmake_install
|
|
|
|
%find_lang %{name} --with-qt --with-man --with-html --all-name || touch %{name}.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
/sbin/ldconfig
|
|
touch --no-create %{_kf6_icondir}/hicolor >/dev/null 2>&1
|
|
exit 0
|
|
|
|
%posttrans
|
|
/sbin/ldconfig
|
|
update-desktop-database -q >/dev/null 2>&1
|
|
update-mime-database -n %{_kf6_mimedir} >/dev/null 2>&1
|
|
gtk-update-icon-cache %{_kf6_icondir}/hicolor >/dev/null 2>&1
|
|
exit 0
|
|
|
|
%postun
|
|
/sbin/ldconfig
|
|
if [ $1 -eq 0 ]; then
|
|
update-desktop-database -q >/dev/null 2>&1
|
|
update-mime-database -n %{_kf6_mimedir} >/dev/null 2>&1
|
|
touch --no-create %{_kf6_icondir}/hicolor >/dev/null 2>&1
|
|
gtk-update-icon-cache %{_kf6_icondir}/hicolor >/dev/null 2>&1
|
|
fi
|
|
exit 0
|
|
|
|
%files -f %{name}.lang
|
|
%defattr(-,root,root)
|
|
%{_kf6_bindir}/kget
|
|
%{_kf6_libdir}/libkgetcore.so.*
|
|
%{_kf6_libdir}/libkgetcore.so
|
|
%dir %{_libdir}/qt6/plugins/kget
|
|
%{_libdir}/qt6/plugins/kget/kget_*.so
|
|
%dir %{_libdir}/qt6/plugins/kget_kcms
|
|
%{_libdir}/qt6/plugins/kget_kcms/kcm_kget_*.so
|
|
%{_datadir}/applications/org.kde.kget.desktop
|
|
%{_datadir}/metainfo/org.kde.kget.appdata.xml
|
|
%{_datadir}/kio/servicemenus/kget_*.desktop
|
|
%dir %{_kf6_datadir}/kget
|
|
%{_datadir}/knotifications6/kget.notifyrc
|
|
%dir %{_kf6_datadir}/kget/pics
|
|
%{_kf6_datadir}/kget/pics/kget_splash.png
|
|
%{_kf6_kcfgdir}/kget*.kcfg
|
|
%{_kf6_icondir}/hicolor/*/apps/kget.png
|
|
%{_datadir}/dbus-1/services/org.kde.kget.service
|
|
%{_datadir}/qlogging-categories6/kget.categories
|
|
%doc AUTHORS COPYING COPYING.DOC COPYING.LIB
|
|
|
|
%changelog
|
|
* Sat May 25 2024 Automatic Build System <autodist@openmamba.org> 24.05.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 21 2024 Automatic Build System <autodist@openmamba.org> 24.04.90-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 13 2024 Automatic Build System <autodist@openmamba.org> 24.02.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 22 2024 Automatic Build System <autodist@openmamba.org> 24.02.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Mar 02 2024 Automatic Build System <autodist@openmamba.org> 24.02.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Feb 11 2024 Automatic Build System <autodist@openmamba.org> 24.01.95-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 08 2023 Automatic Build System <autodist@mambasoft.it> 23.08.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 10 2023 Automatic Build System <autodist@mambasoft.it> 23.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 12 2023 Automatic Build System <autodist@mambasoft.it> 23.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 14 2023 Automatic Build System <autodist@mambasoft.it> 23.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Aug 25 2023 Automatic Build System <autodist@mambasoft.it> 23.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 07 2023 Automatic Build System <autodist@mambasoft.it> 23.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 09 2023 Automatic Build System <autodist@mambasoft.it> 23.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 11 2023 Automatic Build System <autodist@mambasoft.it> 23.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 20 2023 Automatic Build System <autodist@mambasoft.it> 23.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 03 2023 Automatic Build System <autodist@mambasoft.it> 22.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 03 2023 Automatic Build System <autodist@mambasoft.it> 22.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 06 2023 Automatic Build System <autodist@mambasoft.it> 22.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 08 2022 Automatic Build System <autodist@mambasoft.it> 22.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 04 2022 Automatic Build System <autodist@mambasoft.it> 22.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 14 2022 Automatic Build System <autodist@mambasoft.it> 22.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 09 2022 Automatic Build System <autodist@mambasoft.it> 22.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 27 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 22.08.0-2mamba
|
|
- rebuilt with libgpgme 1.18.0
|
|
|
|
* Sun Aug 21 2022 Automatic Build System <autodist@mambasoft.it> 22.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 08 2022 Automatic Build System <autodist@mambasoft.it> 22.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 10 2022 Automatic Build System <autodist@mambasoft.it> 22.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 12 2022 Automatic Build System <autodist@mambasoft.it> 22.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 24 2022 Automatic Build System <autodist@mambasoft.it> 22.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 03 2022 Automatic Build System <autodist@mambasoft.it> 21.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 04 2022 Automatic Build System <autodist@mambasoft.it> 21.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 07 2022 Automatic Build System <autodist@mambasoft.it> 21.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 11 2021 Automatic Build System <autodist@mambasoft.it> 21.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 04 2021 Automatic Build System <autodist@mambasoft.it> 21.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 08 2021 Automatic Build System <autodist@mambasoft.it> 21.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 02 2021 Automatic Build System <autodist@mambasoft.it> 21.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 18 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 21.08.0-1mamba
|
|
- update to 21.08.0
|
|
|
|
* Mon Jul 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 21.04.3-1mamba
|
|
- update to 21.04.3
|
|
|
|
* Thu Jun 10 2021 Automatic Build System <autodist@mambasoft.it> 21.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 13 2021 Automatic Build System <autodist@mambasoft.it> 21.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 22 2021 Automatic Build System <autodist@mambasoft.it> 21.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 05 2021 Automatic Build System <autodist@mambasoft.it> 20.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 05 2021 Automatic Build System <autodist@mambasoft.it> 20.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 07 2021 Automatic Build System <autodist@mambasoft.it> 20.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Dec 11 2020 Automatic Build System <autodist@mambasoft.it> 20.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 05 2020 Automatic Build System <autodist@mambasoft.it> 20.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 10 2020 Automatic Build System <autodist@mambasoft.it> 20.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 03 2020 Automatic Build System <autodist@mambasoft.it> 20.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 15 2020 Automatic Build System <autodist@mambasoft.it> 20.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 10 2020 Automatic Build System <autodist@mambasoft.it> 20.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 12 2020 Automatic Build System <autodist@mambasoft.it> 20.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 15 2020 Automatic Build System <autodist@mambasoft.it> 20.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 24 2020 Automatic Build System <autodist@mambasoft.it> 20.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 06 2020 Automatic Build System <autodist@mambasoft.it> 19.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 06 2020 Automatic Build System <autodist@mambasoft.it> 19.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 10 2020 Automatic Build System <autodist@mambasoft.it> 19.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Dec 31 2019 Automatic Build System <autodist@mambasoft.it> 19.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 07 2019 Automatic Build System <autodist@mambasoft.it> 19.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 10 2019 Automatic Build System <autodist@mambasoft.it> 19.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 10 2019 Automatic Build System <autodist@mambasoft.it> 19.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 03 2019 Automatic Build System <autodist@mambasoft.it> 19.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 12 2019 Automatic Build System <autodist@mambasoft.it> 19.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 07 2019 Automatic Build System <autodist@mambasoft.it> 19.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 11 2019 Automatic Build System <autodist@mambasoft.it> 19.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Apr 20 2019 Automatic Build System <autodist@mambasoft.it> 19.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 07 2019 Automatic Build System <autodist@mambasoft.it> 18.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 07 2019 Automatic Build System <autodist@mambasoft.it> 18.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 11 2019 Automatic Build System <autodist@mambasoft.it> 18.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 19 2018 Automatic Build System <autodist@mambasoft.it> 18.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 12 2018 Automatic Build System <autodist@mambasoft.it> 18.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 11 2018 Automatic Build System <autodist@mambasoft.it> 18.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 06 2018 Automatic Build System <autodist@mambasoft.it> 18.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 22 2018 Automatic Build System <autodist@mambasoft.it> 18.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 13 2018 Automatic Build System <autodist@mambasoft.it> 18.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 08 2018 Automatic Build System <autodist@mambasoft.it> 18.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 10 2018 Automatic Build System <autodist@mambasoft.it> 18.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 01 2018 Automatic Build System <autodist@mambasoft.it> 18.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 08 2018 Automatic Build System <autodist@mambasoft.it> 17.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 09 2018 Automatic Build System <autodist@mambasoft.it> 17.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 11 2018 Automatic Build System <autodist@mambasoft.it> 17.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 08 2018 Automatic Build System <autodist@mambasoft.it> 17.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 10 2017 Automatic Build System <autodist@mambasoft.it> 17.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Oct 21 2017 Automatic Build System <autodist@mambasoft.it> 17.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 13 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 17.08.1-1mamba
|
|
- update to 17.08.1
|
|
|
|
* Thu Nov 20 2014 Automatic Build System <autodist@mambasoft.it> 4.14.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 20 2014 Automatic Build System <autodist@mambasoft.it> 4.14.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 28 2014 Automatic Build System <autodist@mambasoft.it> 4.14.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 21 2014 Automatic Build System <autodist@mambasoft.it> 4.14.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jul 15 2014 Automatic Build System <autodist@mambasoft.it> 4.13.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 13 2014 Automatic Build System <autodist@mambasoft.it> 4.13.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 19 2014 Automatic Build System <autodist@mambasoft.it> 4.13.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 17 2014 Automatic Build System <autodist@mambasoft.it> 4.13.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Apr 03 2014 Automatic Build System <autodist@mambasoft.it> 4.12.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Feb 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 4.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 19 2013 Automatic Build System <autodist@mambasoft.it> 4.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 05 2013 Automatic Build System <autodist@mambasoft.it> 4.11.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 06 2013 Automatic Build System <autodist@mambasoft.it> 4.11.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Oct 02 2013 Automatic Build System <autodist@mambasoft.it> 4.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 06 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.1-2mamba
|
|
- add libktorrent-devel as build requirement
|
|
|
|
* Wed Sep 04 2013 Automatic Build System <autodist@mambasoft.it> 4.11.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 01 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.11.0-1mamba
|
|
- package created by silvan using the webbuild interface
|