349 lines
12 KiB
RPMSpec
349 lines
12 KiB
RPMSpec
%define framework kdav
|
|
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: kf6-kdav
|
|
Epoch: 1
|
|
Version: 6.5.0
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 6 Dav library
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://invent.kde.org/frameworks/kdav
|
|
Source: https://download.kde.org/%{stable_kf6}/frameworks/%{majver}/kdav-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libglvnd-devel
|
|
BuildRequires: libkf6-kcoreaddons-devel
|
|
BuildRequires: libkf6-ki18n-devel
|
|
BuildRequires: libkf6-kio-devel
|
|
BuildRequires: libstdc++6-devel
|
|
BuildRequires: qt6-qtbase-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: kf6-rpm-macros
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description
|
|
KDE Frameworks 6 Dav library.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: Shared libraries for %{name}
|
|
|
|
%description -n lib%{name}
|
|
KDE Frameworks 6 Dav library.
|
|
This package contains shared libraries for %{name}.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -n %{framework}-%{version}
|
|
|
|
%build
|
|
%cmake_kf6
|
|
%cmake_build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%cmake_install
|
|
|
|
%find_lang %{name}5_qt --with-qt --with-man --all-name || touch %{name}5_qt.lang
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%postun -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%files -n lib%{name} -f %{name}5_qt.lang
|
|
%defattr(-,root,root)
|
|
%{_kf6_libdir}/libKF6DAV.so.*
|
|
%{_datadir}/qlogging-categories6/kdav.*categories
|
|
%doc LICENSES
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_kf6_includedir}/KDAV
|
|
%{_kf6_includedir}/KDAV/*
|
|
%{_kf6_libdir}/libKF6DAV.so
|
|
%dir %{_kf6_libdir}/cmake/KF6DAV
|
|
%{_kf6_libdir}/cmake/KF6DAV/KF6DAV*.cmake
|
|
%{_qt6_docdir}/KF6DAV.*
|
|
|
|
%changelog
|
|
* Sat Aug 10 2024 Automatic Build System <autodist@openmamba.org> 6.5.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jul 13 2024 Automatic Build System <autodist@openmamba.org> 6.4.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jun 10 2024 Automatic Build System <autodist@openmamba.org> 6.3.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 14 2024 Automatic Build System <autodist@openmamba.org> 6.2.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 14 2024 Automatic Build System <autodist@openmamba.org> 6.1.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 01 2024 Automatic Build System <autodist@openmamba.org> 6.0.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 08 2024 Automatic Build System <autodist@openmamba.org> 5.249.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Jan 13 2024 Automatic Build System <autodist@mambasoft.it> 5.248.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 18 2023 Automatic Build System <autodist@mambasoft.it> 5.113.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 16 2023 Automatic Build System <autodist@mambasoft.it> 5.112.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Oct 20 2023 Automatic Build System <autodist@mambasoft.it> 5.111.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 11 2023 Automatic Build System <autodist@mambasoft.it> 5.110.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 23 2023 Automatic Build System <autodist@mambasoft.it> 5.109.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jul 13 2023 Automatic Build System <autodist@mambasoft.it> 5.108.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 16 2023 Automatic Build System <autodist@mambasoft.it> 5.107.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 22 2023 Automatic Build System <autodist@mambasoft.it> 5.106.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 14 2023 Automatic Build System <autodist@mambasoft.it> 5.105.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Mar 12 2023 Automatic Build System <autodist@mambasoft.it> 5.104.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 13 2023 Automatic Build System <autodist@mambasoft.it> 5.103.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jan 16 2023 Automatic Build System <autodist@mambasoft.it> 5.102.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 12 2022 Automatic Build System <autodist@mambasoft.it> 5.101.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 17 2022 Automatic Build System <autodist@mambasoft.it> 5.100.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Oct 17 2022 Automatic Build System <autodist@mambasoft.it> 5.99.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 15 2022 Automatic Build System <autodist@mambasoft.it> 5.98.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Aug 18 2022 Automatic Build System <autodist@mambasoft.it> 5.97.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jul 11 2022 Automatic Build System <autodist@mambasoft.it> 5.96.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Jun 15 2022 Automatic Build System <autodist@mambasoft.it> 5.95.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun May 15 2022 Automatic Build System <autodist@mambasoft.it> 5.94.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 11 2022 Automatic Build System <autodist@mambasoft.it> 5.93.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 16 2022 Automatic Build System <autodist@mambasoft.it> 5.92.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 17 2022 Automatic Build System <autodist@mambasoft.it> 5.91.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Jan 09 2022 Automatic Build System <autodist@mambasoft.it> 5.90.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 20 2021 Automatic Build System <autodist@mambasoft.it> 5.89.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Nov 13 2021 Automatic Build System <autodist@mambasoft.it> 5.88.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Oct 12 2021 Automatic Build System <autodist@mambasoft.it> 5.87.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Sep 13 2021 Automatic Build System <autodist@mambasoft.it> 5.86.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Aug 22 2021 Automatic Build System <autodist@mambasoft.it> 5.85.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Jul 12 2021 Automatic Build System <autodist@mambasoft.it> 5.84.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 17 2021 Automatic Build System <autodist@mambasoft.it> 5.83.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon May 10 2021 Automatic Build System <autodist@mambasoft.it> 5.82.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Apr 11 2021 Automatic Build System <autodist@mambasoft.it> 5.81.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Mar 16 2021 Automatic Build System <autodist@mambasoft.it> 5.80.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Feb 15 2021 Automatic Build System <autodist@mambasoft.it> 5.79.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 14 2021 Automatic Build System <autodist@mambasoft.it> 5.78.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Dec 24 2020 Automatic Build System <autodist@mambasoft.it> 5.77.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Nov 17 2020 Automatic Build System <autodist@mambasoft.it> 5.76.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 15 2020 Automatic Build System <autodist@mambasoft.it> 5.75.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sun Sep 20 2020 Automatic Build System <autodist@mambasoft.it> 5.74.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 22 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 5.73.0-1mamba
|
|
- update to 5.73.0
|
|
|
|
* Fri Jul 10 2020 Automatic Build System <autodist@mambasoft.it> 20.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 12 2020 Automatic Build System <autodist@mambasoft.it> 20.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri May 15 2020 Automatic Build System <autodist@mambasoft.it> 20.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 24 2020 Automatic Build System <autodist@mambasoft.it> 20.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Mar 06 2020 Automatic Build System <autodist@mambasoft.it> 19.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 06 2020 Automatic Build System <autodist@mambasoft.it> 19.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 10 2020 Automatic Build System <autodist@mambasoft.it> 19.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Dec 30 2019 Automatic Build System <autodist@mambasoft.it> 19.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Nov 07 2019 Automatic Build System <autodist@mambasoft.it> 19.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 10 2019 Automatic Build System <autodist@mambasoft.it> 19.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 10 2019 Automatic Build System <autodist@mambasoft.it> 19.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Sep 03 2019 Automatic Build System <autodist@mambasoft.it> 19.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 12 2019 Automatic Build System <autodist@mambasoft.it> 19.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jun 07 2019 Automatic Build System <autodist@mambasoft.it> 19.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat May 11 2019 Automatic Build System <autodist@mambasoft.it> 19.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Apr 19 2019 Automatic Build System <autodist@mambasoft.it> 19.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 07 2019 Automatic Build System <autodist@mambasoft.it> 18.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Feb 07 2019 Automatic Build System <autodist@mambasoft.it> 18.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jan 11 2019 Automatic Build System <autodist@mambasoft.it> 18.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Dec 15 2018 Automatic Build System <autodist@mambasoft.it> 18.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Nov 12 2018 Automatic Build System <autodist@mambasoft.it> 18.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 11 2018 Automatic Build System <autodist@mambasoft.it> 18.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 06 2018 Automatic Build System <autodist@mambasoft.it> 18.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Sat Aug 18 2018 Automatic Build System <autodist@mambasoft.it> 18.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Jul 13 2018 Automatic Build System <autodist@mambasoft.it> 18.04.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jun 07 2018 Automatic Build System <autodist@mambasoft.it> 18.04.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu May 10 2018 Automatic Build System <autodist@mambasoft.it> 18.04.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue May 01 2018 Automatic Build System <autodist@mambasoft.it> 18.04.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Mar 08 2018 Automatic Build System <autodist@mambasoft.it> 17.12.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Feb 09 2018 Automatic Build System <autodist@mambasoft.it> 17.12.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Jan 11 2018 Automatic Build System <autodist@mambasoft.it> 17.12.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Dec 20 2017 Automatic Build System <autodist@mambasoft.it> 17.12.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Nov 10 2017 Automatic Build System <autodist@mambasoft.it> 17.08.3-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Oct 12 2017 Automatic Build System <autodist@mambasoft.it> 17.08.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Fri Sep 08 2017 Automatic Build System <autodist@mambasoft.it> 17.08.1-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Tue Aug 22 2017 Automatic Build System <autodist@mambasoft.it> 17.08.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Aug 09 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 17.04.3-1mamba
|
|
- package created using the webbuild interface
|