custom-logo: exclude conflicting files in symlink dirs and add start-here-kde.svg [release 6.3.0-2mamba;Mon Jun 10 2024]
This commit is contained in:
parent
b1420e5583
commit
8c693ab783
@ -0,0 +1,34 @@
|
|||||||
|
From fa44b11bc2b36d5c3cfc5c3403ea75b2fff57253 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Christoph Cullmann <cullmann@kde.org>
|
||||||
|
Date: Sun, 26 May 2024 18:33:33 +0200
|
||||||
|
Subject: [PATCH] use normal resource adding, big resource variant has issue
|
||||||
|
with LTO
|
||||||
|
|
||||||
|
---
|
||||||
|
src/lib/CMakeLists.txt | 6 +++++-
|
||||||
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
|
||||||
|
index e48584010..e8c9e0ac9 100644
|
||||||
|
--- a/src/lib/CMakeLists.txt
|
||||||
|
+++ b/src/lib/CMakeLists.txt
|
||||||
|
@@ -1,6 +1,9 @@
|
||||||
|
# helper functions to ensure we load the icon theme
|
||||||
|
set(kbreezeicons_SRCS breezeicons.cpp)
|
||||||
|
|
||||||
|
+# avoid dependency cycle with add resource
|
||||||
|
+set(CMAKE_AUTOMOC OFF)
|
||||||
|
+
|
||||||
|
# generate resource file for all breeze icons
|
||||||
|
set(RESOURCE_FILE ${CMAKE_CURRENT_BINARY_DIR}/breeze-icons.qrc)
|
||||||
|
set(RESOURCE_FILE_BINARY ${CMAKE_CURRENT_BINARY_DIR}/breeze-icons.rcc)
|
||||||
|
@@ -21,7 +24,8 @@ if(BINARY_ICONS_RESOURCE)
|
||||||
|
install(FILES ${RESOURCE_FILE_BINARY} DESTINATION ${KDE_INSTALL_FULL_ICONDIR}/breeze)
|
||||||
|
endif()
|
||||||
|
|
||||||
|
-qt_add_big_resources(kbreezeicons_resource_SRCS
|
||||||
|
+# use normal resource adding, big resource variant has issue with LTO
|
||||||
|
+qt_add_resources(kbreezeicons_resource_SRCS
|
||||||
|
${RESOURCE_FILE}
|
||||||
|
OPTIONS --root /icons/breeze
|
||||||
|
)
|
@ -2,9 +2,9 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
|
|
||||||
Name: kf6-breeze-icons
|
Name: kf6-breeze-icons
|
||||||
Version: 6.2.0
|
Version: 6.3.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: KDE Frameworks 6 freedesktop.org compatible icon theme.
|
Summary: KDE Frameworks 6 freedesktop.org compatible icon theme
|
||||||
Group: Graphical Desktop/Look 'n' feel
|
Group: Graphical Desktop/Look 'n' feel
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
@ -12,8 +12,14 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://invent.kde.org/frameworks/breeze-icons
|
URL: https://invent.kde.org/frameworks/breeze-icons
|
||||||
Source: https://download.kde.org/%{stable_kf6}/frameworks/%{majver}/breeze-icons-%{version}.tar.xz
|
Source: https://download.kde.org/%{stable_kf6}/frameworks/%{majver}/breeze-icons-%{version}.tar.xz
|
||||||
Source1: openmamba.svg
|
Source1: openmamba.svg
|
||||||
|
Patch0: kf6-breeze-icons-6.3.0-x86-revert-use_normal_resource_adding.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: qt6-qtbase-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
BuildRequires: kf6-rpm-macros
|
BuildRequires: kf6-rpm-macros
|
||||||
@ -26,6 +32,22 @@ Obsoletes: breeze-icons < 5.248.0
|
|||||||
%description
|
%description
|
||||||
Breeze-icons is a freedesktop.org compatible icon theme.
|
Breeze-icons is a freedesktop.org compatible icon theme.
|
||||||
|
|
||||||
|
%package -n lib%{name}
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: KDE Frameworks 6 breeze icon theme library
|
||||||
|
|
||||||
|
%description -n lib%{name}
|
||||||
|
KDE Frameworks 6 breeze icon theme library.
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%package -n lib%{name}-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for lib%{name}
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n lib%{name}-devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
%package custom-logo
|
%package custom-logo
|
||||||
Group: Graphical Desktop/Look 'n' feel
|
Group: Graphical Desktop/Look 'n' feel
|
||||||
Summary: openmamba customized distribution logo for Breeze icons
|
Summary: openmamba customized distribution logo for Breeze icons
|
||||||
@ -35,12 +57,19 @@ Obsoletes: breeze-icons-custom-logo < 5.248.0
|
|||||||
%description custom-logo
|
%description custom-logo
|
||||||
openmamba customized distribution logo for Breeze icons.
|
openmamba customized distribution logo for Breeze icons.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{framework}-%{version}
|
%setup -q -n %{framework}-%{version}
|
||||||
|
%ifarch %{ix86}
|
||||||
|
%patch 0 -R -p1 -b .x86-revert-use_normal_resource_adding
|
||||||
|
%endif
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake_kf6 \
|
%cmake_kf6 \
|
||||||
|
%ifnarch %{ix86}
|
||||||
-DBINARY_ICONS_RESOURCE=ON \
|
-DBINARY_ICONS_RESOURCE=ON \
|
||||||
|
%endif
|
||||||
-DBUILD_TESTING=OFF
|
-DBUILD_TESTING=OFF
|
||||||
|
|
||||||
%cmake_build
|
%cmake_build
|
||||||
@ -64,6 +93,10 @@ for s in 16 22 32 48 64 96; do
|
|||||||
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/breeze/places/$s/start-here-kde-symbolic.svg
|
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/breeze/places/$s/start-here-kde-symbolic.svg
|
||||||
rm -f %{buildroot}%{_datadir}/icons/breeze-dark/places/$s/start-here-kde-symbolic.svg
|
rm -f %{buildroot}%{_datadir}/icons/breeze-dark/places/$s/start-here-kde-symbolic.svg
|
||||||
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/breeze-dark/places/$s/start-here-kde-symbolic.svg
|
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/breeze-dark/places/$s/start-here-kde-symbolic.svg
|
||||||
|
rm -f %{buildroot}%{_datadir}/icons/breeze/places/$s/start-here-kde.svg
|
||||||
|
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/breeze/places/$s/start-here-kde.svg
|
||||||
|
rm -f %{buildroot}%{_datadir}/icons/breeze-dark/places/$s/start-here-kde.svg
|
||||||
|
install -m0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/breeze-dark/places/$s/start-here-kde.svg
|
||||||
done
|
done
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -98,19 +131,46 @@ gtk-update-icon-cache --force %{_datadir}/icons/breeze-dark &>/dev/null || :
|
|||||||
%dir %{_datadir}/icons/breeze
|
%dir %{_datadir}/icons/breeze
|
||||||
%{_datadir}/icons/breeze/*
|
%{_datadir}/icons/breeze/*
|
||||||
%exclude %{_datadir}/icons/breeze/places/*/start-here-kde-symbolic.svg
|
%exclude %{_datadir}/icons/breeze/places/*/start-here-kde-symbolic.svg
|
||||||
|
%exclude %{_datadir}/icons/breeze/places/*/start-here-kde.svg
|
||||||
%dir %{_datadir}/icons/breeze-dark
|
%dir %{_datadir}/icons/breeze-dark
|
||||||
%{_datadir}/icons/breeze-dark/*
|
%{_datadir}/icons/breeze-dark/*
|
||||||
%exclude %{_datadir}/icons/breeze-dark/places/*/start-here-kde-symbolic.svg
|
%exclude %{_datadir}/icons/breeze-dark/places/*/start-here-kde-symbolic.svg
|
||||||
|
%exclude %{_datadir}/icons/breeze-dark/places/*/start-here-kde.svg
|
||||||
%dir %{_kf6_libdir}/cmake/KF6BreezeIcons
|
%dir %{_kf6_libdir}/cmake/KF6BreezeIcons
|
||||||
%{_kf6_libdir}/cmake/KF6BreezeIcons/KF6BreezeIconsConfig*.cmake
|
%{_kf6_libdir}/cmake/KF6BreezeIcons/KF6BreezeIconsConfig*.cmake
|
||||||
%doc COPYING.LIB
|
%doc COPYING.LIB
|
||||||
|
|
||||||
|
%files -n lib%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libKF6BreezeIcons.so.*
|
||||||
|
%doc COPYING.LIB
|
||||||
|
|
||||||
|
%files -n lib%{name}-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_kf6_includedir}/BreezeIcons
|
||||||
|
%{_kf6_includedir}/BreezeIcons/*
|
||||||
|
%{_libdir}/libKF6BreezeIcons.so
|
||||||
|
%dir %{_libdir}/cmake/KF6BreezeIcons
|
||||||
|
%{_libdir}/cmake/KF6BreezeIcons/KF6BreezeIcons*.cmake
|
||||||
|
|
||||||
%files custom-logo
|
%files custom-logo
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_datadir}/icons/breeze/places/*/start-here-kde-symbolic.svg
|
%{_datadir}/icons/breeze/places/*/start-here-kde-symbolic.svg
|
||||||
|
%{_datadir}/icons/breeze/places/*/start-here-kde.svg
|
||||||
|
%exclude %{_datadir}/icons/breeze/places/*@*/start-here-kde-symbolic.svg
|
||||||
|
%exclude %{_datadir}/icons/breeze/places/*@*/start-here-kde.svg
|
||||||
%{_datadir}/icons/breeze-dark/places/*/start-here-kde-symbolic.svg
|
%{_datadir}/icons/breeze-dark/places/*/start-here-kde-symbolic.svg
|
||||||
|
%{_datadir}/icons/breeze-dark/places/*/start-here-kde.svg
|
||||||
|
%exclude %{_datadir}/icons/breeze-dark/places/*@*/start-here-kde-symbolic.svg
|
||||||
|
%exclude %{_datadir}/icons/breeze-dark/places/*@*/start-here-kde.svg
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jun 10 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 6.3.0-2mamba
|
||||||
|
- custom-logo: exclude conflicting files in symlink dirs and add start-here-kde.svg
|
||||||
|
|
||||||
|
* Sun Jun 09 2024 Automatic Build System <autodist@openmamba.org> 6.3.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sun May 12 2024 Automatic Build System <autodist@openmamba.org> 6.2.0-1mamba
|
* Sun May 12 2024 Automatic Build System <autodist@openmamba.org> 6.2.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user