update to 4.4.1.20161020 [release 4.4.1.20161020-1mamba;Thu Nov 10 2016]
This commit is contained in:
parent
1d3743d776
commit
bbb608b49d
@ -5,5 +5,5 @@ The kernel package contains the Linux kernel (%{KIMAGE_DEST}), the operating sys
|
||||
The kernel handles the basic functions of the operating system: memory allocation, process allocation, device input and output, etc.
|
||||
This is the source package used to build kernel for different architectures and targets.
|
||||
|
||||
This kernel was build for %{_target_cpu} architecture and the following target: rpi.
|
||||
This kernel was build for %{_target_cpu} architecture and the following target: .
|
||||
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- linux-3.14.6.20140831git/drivers/usb/core/otg_whitelist.h.orig 2014-09-05 12:02:52.815853952 +0200
|
||||
+++ linux-3.14.6.20140831git/drivers/usb/core/otg_whitelist.h 2014-09-05 12:04:00.539621786 +0200
|
||||
@@ -107,8 +107,10 @@
|
||||
if (dev->descriptor.idVendor == 0x1a0a &&
|
||||
dev->descriptor.idProduct == 0xbadd) {
|
||||
return 0;
|
||||
+#ifndef CONFIG_USB_OTG_WHITELIST
|
||||
} else if (!enable_whitelist) {
|
||||
return 1;
|
||||
+#endif
|
||||
} else {
|
||||
|
||||
#ifdef DEBUG
|
@ -1,25 +0,0 @@
|
||||
--- linux-3.14.6.20140831git/sound/soc/codecs/pcm512x.c.orig 2014-09-08 15:20:08.871270123 +0200
|
||||
+++ linux-3.14.6.20140831git/sound/soc/codecs/pcm512x.c 2014-09-08 15:56:55.506471261 +0200
|
||||
@@ -490,7 +490,6 @@
|
||||
pcm512x->supplies);
|
||||
}
|
||||
|
||||
-/* TODO
|
||||
static int pcm512x_suspend(struct device *dev)
|
||||
{
|
||||
struct pcm512x_priv *pcm512x = dev_get_drvdata(dev);
|
||||
@@ -553,13 +552,11 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
-// END OF PCM512x_suspend and resume calls TODO
|
||||
-*/
|
||||
-
|
||||
static const struct dev_pm_ops pcm512x_pm_ops = {
|
||||
SET_RUNTIME_PM_OPS(pcm512x_suspend, pcm512x_resume, NULL)
|
||||
};
|
||||
|
||||
+
|
||||
#if IS_ENABLED(CONFIG_I2C)
|
||||
static int pcm512x_i2c_probe(struct i2c_client *i2c,
|
||||
const struct i2c_device_id *id)
|
File diff suppressed because it is too large
Load Diff
5932
kernel-rpi-v7-4.4-arm-config
Normal file
5932
kernel-rpi-v7-4.4-arm-config
Normal file
File diff suppressed because it is too large
Load Diff
177
kernel-rpi.spec
177
kernel-rpi.spec
@ -1,22 +1,24 @@
|
||||
# openmamba kernel specfile for embedded kernels
|
||||
# Copyright (C) 2011-2014 by Silvan Calarco
|
||||
# Copyright (C) 2011-2016 by Silvan Calarco
|
||||
#
|
||||
# To build a specific target:
|
||||
#
|
||||
# rpmbuild -ba --define="KERNEL_TARGET <target>" kernel.spec
|
||||
#
|
||||
# To cross-compile:
|
||||
# rpmbuild -ba kernel-rpi.spec --target arm --define="cross_target_cpu arm"
|
||||
# rpmbuild -ba kernel-rpi2.spec --target arm --define="cross_target_cpu arm"
|
||||
#
|
||||
# To cross-compile using an alternative compiler:
|
||||
# rpmbuild -ba kernel-rpi.spec --target arm --define="cross_target_cpu arm" \
|
||||
# rpmbuild -ba kernel-rpi2.spec --target arm --define="cross_target_cpu arm" \
|
||||
# --define="_target_platform arm-openmamba-linux-gnueabi"
|
||||
#
|
||||
|
||||
%define kernel_ver %(echo %version | cut -d. -f1-3)
|
||||
%define gitdirver %(echo %version | cut -d. -f1-2)
|
||||
#% define kernel_ver %(echo %version | cut -d. -f1-3)
|
||||
%define kernel_ver 4.4.26
|
||||
%define kernel_majver %(echo %version | cut -d. -f1-2)
|
||||
%define gitdirver %(echo %version | cut -d. -f3-4)
|
||||
|
||||
%define KERNEL_TARGET rpi
|
||||
#% define KERNEL_TARGET rpi-v7
|
||||
|
||||
# define short kernel target name for Lilo
|
||||
%define KERNEL_TARGET_SHORT %{KERNEL_TARGET}
|
||||
@ -61,7 +63,7 @@
|
||||
%define _use_internal_dependency_generator 1
|
||||
|
||||
Name: kernel-rpi
|
||||
Version: 3.12.34.20141207git
|
||||
Version: 4.4.1.20161020
|
||||
Release: 1mamba
|
||||
Summary: The Linux Kernel, the operating system core itself for the RaspberryPI
|
||||
Group: System/Kernel and Hardware
|
||||
@ -69,11 +71,11 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/raspberrypi/linux
|
||||
Source0: git://github.com/raspberrypi/linux.git/rpi-%{gitdirver}.y/linux-%{version}.tar.bz2
|
||||
Source20: %{name}-logo.png
|
||||
Source100: %{name}-%{version}-arm-config
|
||||
Patch0: kernel-rpi-3.14.6.20140831git-buildfix-otg_whitelist.patch
|
||||
Patch1: kernel-rpi-3.14.6.20140831git-buildfix-pcm512x.patch
|
||||
Source0: git://github.com/raspberrypi/linux.git/raspberrypi-kernel_%{gitdirver}-1/linux-%{version}.tar.bz2
|
||||
#Source0: git://github.com/raspberrypi/linux.git/rpi-%{gitdirver}.y/linux-%{version}.tar.bz2
|
||||
Source20: kernel-rpi-logo.png
|
||||
Source100: %{name}-v7-%{kernel_majver}-arm-config
|
||||
Source101: %{name}-%{kernel_majver}-arm-config
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -96,62 +98,102 @@ This is the source package used to build kernel for different architectures and
|
||||
|
||||
This kernel was build for %{_target_cpu} architecture and the following target: %{?KERNEL_TARGET}.
|
||||
|
||||
%package source
|
||||
%package -n kernel-%{KERNEL_TARGET}
|
||||
Group: Development/Kernel
|
||||
Summary: The Linux Kernel, the operating system core itself for the RaspberryPI (%{KERNEL_TARGET})
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2
|
||||
Obsoletes: kernel-rpi2
|
||||
%endif
|
||||
|
||||
%description -n kernel-%{KERNEL_TARGET}
|
||||
The Linux Kernel, the operating system core itself for the Raspberry PI.
|
||||
The kernel package contains the Linux kernel (%{KIMAGE_DEST}), the operating system core itself.
|
||||
The kernel handles the basic functions of the operating system: memory allocation, process allocation, device input and output, etc.
|
||||
This is the source package used to build kernel for different architectures and targets.
|
||||
|
||||
This kernel was build for %{_target_cpu} architecture and the following target: %{?KERNEL_TARGET}.
|
||||
|
||||
%package -n kernel-%{KERNEL_TARGET}-source
|
||||
Group: Development/Kernel
|
||||
Summary: The source code for the Linux kernel
|
||||
Requires: kernel-%{KERNEL_TARGET}-headers == %{version}-%{release}
|
||||
Provides: kernelsource
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2-source
|
||||
Obsoletes: kernel-rpi2-source
|
||||
%endif
|
||||
|
||||
%description source
|
||||
%description -n kernel-%{KERNEL_TARGET}-source
|
||||
The kernel-source package contains the source code files for the Linux kernel.
|
||||
The source files can be used to build a custom kernel that is better tuned to your particular hardware, if you are so inclined (and you know what you're doing).
|
||||
This kernel sources are configured for %{TARGET_CPU} architecture and the following target: %{?KERNEL_TARGET}.
|
||||
|
||||
%package headers
|
||||
%package -n kernel-%{KERNEL_TARGET}-headers
|
||||
Group: Development/Kernel
|
||||
Summary: Headers, scripts, configuration and Makefile for the linux kernel
|
||||
Provides: kernelheaders
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2-headers
|
||||
Obsoletes: kernel-rpi2-headers
|
||||
%endif
|
||||
|
||||
%description headers
|
||||
%description -n kernel-%{KERNEL_TARGET}-headers
|
||||
The kernel-headers package contains the headers, scripts, configuration and Makefile to develop with the linux kernel
|
||||
The kernel-headers can be used to build modules for the kernel.
|
||||
This kernel headers are configured for %{TARGET_CPU} architecture and the following target: %{?KERNEL_TARGET}.
|
||||
|
||||
%package headers-sanitised
|
||||
%package -n kernel-%{KERNEL_TARGET}-headers-sanitised
|
||||
Group: Development/Kernel
|
||||
Summary: Sanitised kernel headers used for glibc build
|
||||
Provides: kernelsanitisedheaders
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2-headers-sanitised
|
||||
Obsoletes: kernel-rpi2-headers-sanitised
|
||||
%endif
|
||||
|
||||
%description headers-sanitised
|
||||
%description -n kernel-%{KERNEL_TARGET}-headers-sanitised
|
||||
Sanitised kernel headers used for glibc build.
|
||||
This kernel sanitised headers are configured for %{TARGET_CPU} architecture and the following target: %{?KERNEL_TARGET}.
|
||||
|
||||
%package modules
|
||||
%package -n kernel-%{KERNEL_TARGET}-modules
|
||||
Group: System/Kernel and Hardware
|
||||
Summary: The kernel base modules normally used by the device
|
||||
Requires: kernel-%{KERNEL_TARGET} == %{version}-%{release}
|
||||
Provides: kernelmodules
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2-modules
|
||||
Obsoletes: kernel-rpi2-modules
|
||||
%endif
|
||||
|
||||
%description modules
|
||||
%description -n kernel-%{KERNEL_TARGET}-modules
|
||||
The kernel-modules package contains the base modules normally used by the device
|
||||
|
||||
%package modules-extra
|
||||
%package -n kernel-%{KERNEL_TARGET}-modules-extra
|
||||
Group: System/Kernel and Hardware
|
||||
Summary: The kernel extra modules not normally used by the device
|
||||
Requires: kernel-%{KERNEL_TARGET} == %{version}-%{release}
|
||||
Provides: kernelmodulesextra
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2-modules-extra
|
||||
Obsoletes: kernel-rpi2-modules-extra
|
||||
%endif
|
||||
|
||||
%description modules-extra
|
||||
%description -n kernel-%{KERNEL_TARGET}-modules-extra
|
||||
The kernel-modules-extra package contains extra modules not normally used by the device.
|
||||
|
||||
%package firmware
|
||||
%package -n kernel-%{KERNEL_TARGET}-firmware
|
||||
Group: System/Kernel and Hardware
|
||||
Summary: Firmware files used by %{name}
|
||||
Requires: kernel-%{KERNEL_TARGET} == %{version}-%{release}
|
||||
Provides: kernelfirmware = %{version}
|
||||
Provides: linux_firmware
|
||||
%if "%{KERNEL_TARGET}" == "rpi-v7"
|
||||
Provides: kernel-rpi2-firmware
|
||||
Obsoletes: kernel-rpi2-firmware
|
||||
%endif
|
||||
|
||||
%description firmware
|
||||
%description -n kernel-%{KERNEL_TARGET}-firmware
|
||||
Firmware files used by the Linux Kernel.
|
||||
|
||||
%prep
|
||||
@ -176,8 +218,8 @@ make mrproper
|
||||
# and copy proper configuration
|
||||
%if %{_target_cpu} == arm
|
||||
case %{?KERNEL_TARGET} in
|
||||
rpi) kernel_cfg=%{SOURCE100}
|
||||
;;
|
||||
rpi) kernel_cfg=%{SOURCE101} ;;
|
||||
rpi-v7) kernel_cfg=%{SOURCE100} ;;
|
||||
esac
|
||||
%endif
|
||||
cp $kernel_cfg ./.config
|
||||
@ -195,6 +237,7 @@ pngtopnm %{SOURCE20} | ppmquant -plain 224 > drivers/video/logo/logo_linux_clut2
|
||||
#
|
||||
ARCH=%{target_cpu} make oldconfig
|
||||
ARCH=%{target_cpu} make CROSS_COMPILE=%{_target_platform}- %{?_smp_mflags}
|
||||
ARCH=%{target_cpu} make CROSS_COMPILE=%{_target_platform}- %{?_smp_mflags} dtbs
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -214,6 +257,12 @@ rm -f build && ln -sf /usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET} build )
|
||||
cp %{KIMAGE} %{buildroot}/boot/%{KIMAGE_DEST}-%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
cp System.map %{buildroot}/boot/System.map-%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
|
||||
# install dtbs
|
||||
cp arch/arm/boot/dts/*.dtb %{buildroot}/boot/
|
||||
install -d -m0755 %{buildroot}/boot/overlays/
|
||||
cp arch/arm/boot/dts/overlays/*.dtb* %{buildroot}/boot/overlays/
|
||||
#cp arch/arm/boot/dts/overlays/README %{buildroot}/boot/overlays/
|
||||
|
||||
# recreate kernel sources
|
||||
[ -e kernel-headers.files ] && rm -f kernel-headers.files
|
||||
[ -e kernel-source.files ] && rm -f kernel-source.files
|
||||
@ -223,7 +272,8 @@ cd %{buildroot}/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
ARCH=%{target_cpu} make mrproper
|
||||
%if %{_target_cpu} == arm
|
||||
case %{?KERNEL_TARGET} in
|
||||
rpi) kernel_cfg=%{SOURCE100} ;;
|
||||
rpi) kernel_cfg=%{SOURCE101} ;;
|
||||
rpi-v7) kernel_cfg=%{SOURCE100} ;;
|
||||
esac
|
||||
%endif
|
||||
|
||||
@ -234,7 +284,7 @@ ARCH=%{target_cpu} make oldconfig
|
||||
#sed -i "s/\(EXTRAVERSION =.*\)/\1-%{?KERNEL_TARGET}/" Makefile
|
||||
#%if "%{_target_platform}" == "%{_build}"
|
||||
ARCH=%{target_cpu} make \
|
||||
HOSTCC=%{_target_platform}-gcc \
|
||||
HOSTCC=%{_build}-gcc \
|
||||
CROSS_COMPILE=%{_target_platform}- \
|
||||
prepare scripts oldconfig
|
||||
|
||||
@ -258,41 +308,58 @@ ln -s %{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET} %{buildroot}/lib/modu
|
||||
#
|
||||
cd %{buildroot}%{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
|
||||
splitdirs="crypto drivers fs ipc kernel lib mm net security sound"
|
||||
splitdirs="block crypto drivers fs ipc kernel lib mm net security sound"
|
||||
case %{_target_cpu} in
|
||||
i586|x86_64) headers_arch="x86" ;;
|
||||
arm) headers_arch="arm" ;;
|
||||
ppc) headers_arch="ppc" ;;
|
||||
esac
|
||||
|
||||
find $splitdirs -type f -name *.h -exec \
|
||||
find $splitdirs -name *.h -exec \
|
||||
echo "%{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/"{} >> \
|
||||
%{_builddir}/linux-%{version}/kernel-headers.files \;
|
||||
|
||||
find $splitdirs -type f -not -name *.h -exec \
|
||||
%if "%{with_full_source}" == "1"
|
||||
find $splitdirs -not -type d -a -not -name *.h -exec \
|
||||
echo "%{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/"{} >> \
|
||||
%{_builddir}/linux-%{version}/kernel-source.files \;
|
||||
%else
|
||||
touch %{_builddir}/linux-%{version}/kernel-source.files
|
||||
find $splitdirs -not -type d -a -not -name *.h -exec rm -f {} \;
|
||||
rm -rf firmware samples virt
|
||||
%endif
|
||||
|
||||
archs=" `ls %{buildroot}%{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/arch` "
|
||||
|
||||
for i in $archs; do
|
||||
[ "$i" == "$headers_arch" ] || \
|
||||
%if "%{with_full_source}" == "1"
|
||||
echo "%{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/arch/$i" >> \
|
||||
%{_builddir}/linux-%{version}/kernel-source.files
|
||||
%else
|
||||
rm -rf arch/$i
|
||||
%endif
|
||||
done
|
||||
echo "%{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/arch/$headers_arch" >> \
|
||||
%{_builddir}/linux-%{version}/kernel-headers.files
|
||||
|
||||
# install sanitised headers used by glibc
|
||||
ARCH=%{target_cpu} make headers_install \
|
||||
HOSTCC=%{_target_platform}-gcc \
|
||||
HOSTCC=%{_build}-gcc \
|
||||
CROSS_COMPILE=%{_target_platform}- \
|
||||
INSTALL_HDR_PATH=%{buildroot}%{_prefix}/src/linux-%{kernel_ver}-%{KERNEL_TARGET}/usr
|
||||
|
||||
# Do not package cross-platform host tools
|
||||
if [ "%{_build}" != "%{_target_platform}" ]; then
|
||||
for f in asn1_compiler conmakehash extract-cert kallsyms sortextable; do
|
||||
rm -f %{buildroot}/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/scripts/$f
|
||||
done
|
||||
fi
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
%post -n kernel-%{KERNEL_TARGET}
|
||||
# new install or upgrade
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/depmod -A -F /boot/System.map-%{kernel_ver}-%{?KERNEL_TARGET} \
|
||||
@ -305,7 +372,7 @@ fi
|
||||
#}
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
%postun -n kernel-%{KERNEL_TARGET}
|
||||
# erase this package
|
||||
if [ $1 -eq 0 ]; then
|
||||
[ -f /boot/%{KIMAGE_DEST}-%{kernel_ver}-%{?KERNEL_TARGET} ] ||
|
||||
@ -313,12 +380,12 @@ if [ $1 -eq 0 ]; then
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%post headers
|
||||
%post -n kernel-%{KERNEL_TARGET}-headers
|
||||
# touch file so it results up-to-date on make
|
||||
touch %{_prefix}/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/include/config/MARKER
|
||||
exit 0
|
||||
|
||||
%post modules
|
||||
%post -n kernel-%{KERNEL_TARGET}-modules
|
||||
# new install or upgrade
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/depmod -A -F /boot/System.map-%{kernel_ver}-%{?KERNEL_TARGET} \
|
||||
@ -326,7 +393,7 @@ if [ $1 -ge 1 ]; then
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%post modules-extra
|
||||
%post -n kernel-%{KERNEL_TARGET}-modules-extra
|
||||
# new install or upgrade
|
||||
if [ $1 -ge 1 ]; then
|
||||
/sbin/depmod -A -F /boot/System.map-%{kernel_ver}-%{?KERNEL_TARGET} \
|
||||
@ -334,37 +401,41 @@ if [ $1 -ge 1 ]; then
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%files -n kernel-%{KERNEL_TARGET}
|
||||
%defattr (-, root, root)
|
||||
/boot/System.map-%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
/boot/%{KIMAGE_DEST}-%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
/boot/*.dtb*
|
||||
/boot/overlays/*.dtb*
|
||||
|
||||
%files source -f kernel-source.files
|
||||
%files -n kernel-%{KERNEL_TARGET}-source -f kernel-source.files
|
||||
%defattr(-,root,root)
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/arch/.gitignore
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/block
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/Documentation
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/firmware
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/certs
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/init
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/REPORTING-BUGS
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/samples
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/usr/gen_init_cpio.c
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/usr/initramfs_data*.S
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/usr/Kconfig
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/usr/Makefile
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/usr/.gitignore
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/tools
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/virt
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/.missing-syscalls.d
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/.missing-syscalls.d
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/.mailmap
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/Kconfig
|
||||
%if "%{with_full_source}" == "1"
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/block
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/firmware
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/samples
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/virt
|
||||
%endif
|
||||
|
||||
%files headers-sanitised
|
||||
%files -n kernel-%{KERNEL_TARGET}-headers-sanitised
|
||||
%defattr(-,root,root)
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/usr/include
|
||||
|
||||
%files headers -f kernel-headers.files
|
||||
%files -n kernel-%{KERNEL_TARGET}-headers -f kernel-headers.files
|
||||
%defattr(-,root,root)
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/COPYING
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/CREDITS
|
||||
@ -377,10 +448,11 @@ exit 0
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/README
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/scripts
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/.config
|
||||
/usr/src/linux-%{kernel_ver}-%{?KERNEL_TARGET}/.get_maintainer.ignore
|
||||
/lib/modules/%{kernel_ver}-%{?KERNEL_TARGET}/build
|
||||
/lib/modules/%{kernel_ver}-%{?KERNEL_TARGET}/source
|
||||
|
||||
%files modules
|
||||
%files -n kernel-%{KERNEL_TARGET}-modules
|
||||
%defattr (-, root, root)
|
||||
%dir /lib/modules/%{kernel_ver}-%{?KERNEL_TARGET}
|
||||
/lib/modules/%{kernel_ver}-%{?KERNEL_TARGET}/modules.builtin
|
||||
@ -389,12 +461,21 @@ exit 0
|
||||
%dir /lib/modules/%{kernel_ver}-%{?KERNEL_TARGET}/kernel
|
||||
/lib/modules/%{kernel_ver}-%{?KERNEL_TARGET}/kernel/*
|
||||
|
||||
%files firmware
|
||||
%files -n kernel-%{KERNEL_TARGET}-firmware
|
||||
%defattr (-, root, root)
|
||||
%dir /lib/firmware
|
||||
/lib/firmware/*
|
||||
|
||||
%changelog
|
||||
* Thu Nov 10 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.1.20161020-1mamba
|
||||
- update to 4.4.1.20161020
|
||||
|
||||
* Tue Jul 12 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 4.4.1.20160620-1mamba
|
||||
- update to 4.4.1.20160620
|
||||
|
||||
* Fri Feb 27 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 3.18.7.20150227git-1mamba
|
||||
- update to 3.18.7.20150227git
|
||||
|
||||
* Sun Dec 07 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.12.34.20141207git-1mamba
|
||||
- update to 3.12.34.20141207git
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user