automatic version update by autodist [release 1.2.12-1mamba;Sun Feb 09 2014]
This commit is contained in:
parent
0337ce2b98
commit
423f3be68a
13
README.md
13
README.md
@ -1,2 +1,15 @@
|
||||
# keepalived
|
||||
|
||||
The main goal of the keepalived project is to add a strong end robust keepalive
|
||||
facility to the Linux Virtual Server project.
|
||||
This project is written in C with multilayer TCP/IP stack checks.
|
||||
Keepalived implements a framework based on three family checks:
|
||||
Layer3, Layer4 & Layer5.
|
||||
This framework gives the daemon the ability of checking a LVS server pool states.
|
||||
When one of the server of the LVS server pool is down, keepalived informs the linux
|
||||
kernel via a setsockopt call to remove this server entrie from the LVS topology.
|
||||
In addition keepalived implements a VRRPv2 stack to handle director failover.
|
||||
|
||||
So in short keepalived is a userspace daemon for LVS cluster nodes healthchecks
|
||||
and LVS directors failover.
|
||||
|
||||
|
46
keepalived-1.1.10-manpath.patch
Normal file
46
keepalived-1.1.10-manpath.patch
Normal file
@ -0,0 +1,46 @@
|
||||
diff -ru keepalived-1.1.10/genhash/Makefile.in keepalived-1.1.10-fix/genhash/Makefile.in
|
||||
--- keepalived-1.1.10/genhash/Makefile.in 2005-02-14 20:50:31.000000000 +0000
|
||||
+++ keepalived-1.1.10-fix/genhash/Makefile.in 2005-02-15 07:38:40.000000000 +0000
|
||||
@@ -38,13 +38,13 @@
|
||||
|
||||
uninstall:
|
||||
rm -f $(DESTDIR)$(bindir)/$(EXEC)
|
||||
- rm -f $(DESTDIR)@mandir@/man/man1/genhash.1
|
||||
+ rm -f $(DESTDIR)@mandir@/man1/genhash.1
|
||||
|
||||
install:
|
||||
install -d $(DESTDIR)$(bindir)
|
||||
install -m 755 $(BIN)/$(EXEC) $(DESTDIR)$(bindir)/
|
||||
- install -d $(DESTDIR)@mandir@/man/man1
|
||||
- install -m 644 ../doc/man/man1/genhash.1 $(DESTDIR)@mandir@/man/man1
|
||||
+ install -d $(DESTDIR)@mandir@/man1
|
||||
+ install -m 644 ../doc/man/man1/genhash.1 $(DESTDIR)@mandir@/man1
|
||||
|
||||
mrproper: clean distclean
|
||||
rm -f config.*
|
||||
diff -ru keepalived-1.1.10/keepalived/Makefile.in keepalived-1.1.10-fix/keepalived/Makefile.in
|
||||
--- keepalived-1.1.10/keepalived/Makefile.in 2005-02-14 14:02:39.000000000 +0000
|
||||
+++ keepalived-1.1.10-fix/keepalived/Makefile.in 2005-02-15 07:39:14.000000000 +0000
|
||||
@@ -90,8 +90,8 @@
|
||||
rm -f $(DESTDIR)$(sbindir)/$(EXEC)
|
||||
rm -rf $(DESTDIR)$(sysconfdir)/keepalived
|
||||
rm -f $(DESTDIR)$(init_dir)/$(init_script)
|
||||
- rm -f $(DESTDIR)@mandir@/man/man5/keepalived.conf.5
|
||||
- rm -f $(DESTDIR)@mandir@/man/man8/keepalived.8
|
||||
+ rm -f $(DESTDIR)@mandir@/man5/keepalived.conf.5
|
||||
+ rm -f $(DESTDIR)@mandir@/man8/keepalived.8
|
||||
|
||||
install:
|
||||
install -d $(DESTDIR)$(sbindir)
|
||||
@@ -101,7 +101,7 @@
|
||||
install -d $(DESTDIR)$(sysconfdir)/keepalived/samples
|
||||
install -m 644 $(conf_file) $(DESTDIR)$(sysconfdir)/keepalived/
|
||||
install -m 644 ../doc/samples/* $(DESTDIR)$(sysconfdir)/keepalived/samples/
|
||||
- install -d $(DESTDIR)@mandir@/man/man5
|
||||
- install -d $(DESTDIR)@mandir@/man/man8
|
||||
- install -m 644 ../doc/man/man5/keepalived.conf.5 $(DESTDIR)@mandir@/man/man5
|
||||
- install -m 644 ../doc/man/man8/keepalived.8 $(DESTDIR)@mandir@/man/man8
|
||||
+ install -d $(DESTDIR)@mandir@/man5
|
||||
+ install -d $(DESTDIR)@mandir@/man8
|
||||
+ install -m 644 ../doc/man/man5/keepalived.conf.5 $(DESTDIR)@mandir@/man5
|
||||
+ install -m 644 ../doc/man/man8/keepalived.8 $(DESTDIR)@mandir@/man8
|
184
keepalived.spec
Normal file
184
keepalived.spec
Normal file
@ -0,0 +1,184 @@
|
||||
Name: keepalived
|
||||
Version: 1.2.12
|
||||
Release: 1mamba
|
||||
Summary: HA monitor built upon LVS, VRRP and services poller
|
||||
Group: Applications/Networking
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.keepalived.org/
|
||||
Source: http://www.keepalived.org/software/%{name}-%{version}.tar.gz
|
||||
Patch: %{name}-1.1.10-manpath.patch
|
||||
License: GPL
|
||||
BuildRequires: kernel-mamba-source
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libopenssl-devel >= 0.9.8h
|
||||
BuildRequires: libpopt-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The main goal of the keepalived project is to add a strong end robust keepalive
|
||||
facility to the Linux Virtual Server project.
|
||||
This project is written in C with multilayer TCP/IP stack checks.
|
||||
Keepalived implements a framework based on three family checks:
|
||||
Layer3, Layer4 & Layer5.
|
||||
This framework gives the daemon the ability of checking a LVS server pool states.
|
||||
When one of the server of the LVS server pool is down, keepalived informs the linux
|
||||
kernel via a setsockopt call to remove this server entrie from the LVS topology.
|
||||
In addition keepalived implements a VRRPv2 stack to handle director failover.
|
||||
|
||||
So in short keepalived is a userspace daemon for LVS cluster nodes healthchecks
|
||||
and LVS directors failover.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
# --with-kernel-dir="/usr/src/linux-`uname -r`"
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
|
||||
%post
|
||||
/sbin/chkconfig --add keepalived
|
||||
%{_initrddir}/keepalived start
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
if [ $1 -eq 0 ]; then
|
||||
[ -e /var/lock/subsys/keepalived ] && %{_initrddir}/keepalived stop
|
||||
/sbin/chkconfig --del keepalived
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%postun
|
||||
if [ $1 -eq 1 ]; then
|
||||
[ -e /var/lock/subsys/keepalived ] &&
|
||||
%{_initrddir}/keepalived restart
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%dir %{_sysconfdir}/keepalived/
|
||||
%config(noreplace) %{_sysconfdir}/keepalived/*
|
||||
%config(noreplace) %{_sysconfdir}/sysconfig/keepalived
|
||||
%{_initrddir}/keepalived
|
||||
%{_bindir}/genhash
|
||||
%{_sbindir}/keepalived
|
||||
%{_mandir}/man?/*
|
||||
%doc AUTHOR CONTRIBUTORS COPYING
|
||||
#% doc TODO README VERSION ChangeLog
|
||||
#% doc doc/keepalived.conf.SYNOPSIS doc/samples/
|
||||
|
||||
%changelog
|
||||
* Sun Feb 09 2014 Automatic Build System <autodist@mambasoft.it> 1.2.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jan 29 2014 Automatic Build System <autodist@mambasoft.it> 1.2.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 04 2014 Automatic Build System <autodist@mambasoft.it> 1.2.10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 30 2013 Automatic Build System <autodist@mambasoft.it> 1.2.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Sep 05 2013 Automatic Build System <autodist@mambasoft.it> 1.2.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 31 2012 Automatic Build System <autodist@mambasoft.it> 1.2.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 22 2012 Automatic Build System <autodist@mambasoft.it> 1.2.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Aug 16 2012 Automatic Build System <autodist@mambasoft.it> 1.2.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jul 15 2012 Automatic Build System <autodist@mambasoft.it> 1.2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jan 20 2011 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Dec 10 2010 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Jun 28 2010 Automatic Build System <autodist@mambasoft.it> 1.2.0-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri May 14 2010 Automatic Build System <autodist@mambasoft.it> 1.1.20-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Oct 20 2009 Automatic Build System <autodist@mambasoft.it> 1.1.19-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Sep 29 2009 Automatic Build System <autodist@mambasoft.it> 1.1.18-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Apr 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.17-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Feb 22 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.16-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Oct 03 2008 gil <puntogil@libero.it> 1.1.15-1mamba
|
||||
- update to 1.1.15
|
||||
- removed patch;
|
||||
- edit: vendor, distribution, packager, buildrequires (kernel-mamba-source)
|
||||
|
||||
* Tue Oct 17 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.13-1qilnx
|
||||
- update to version 1.1.13 by autospec
|
||||
|
||||
* Mon Mar 13 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.12-1qilnx
|
||||
- update to version 1.1.12 by autospec
|
||||
|
||||
* Mon Nov 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.11-2qilnx
|
||||
- rebuilt with LinkWatch support (kernel 2.6 only)
|
||||
|
||||
* Tue Mar 01 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.11-1qilnx
|
||||
- update to version 1.1.11 by autospec
|
||||
|
||||
* Wed Feb 16 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.10-2qilnx
|
||||
- fixex a signal handler issue (patch from CVS)
|
||||
|
||||
* Tue Feb 15 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.10-1qilnx
|
||||
- update to version 1.1.10 by autospec
|
||||
|
||||
* Thu Feb 10 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.9-1qilnx
|
||||
- update to version 1.1.9 by autospec
|
||||
|
||||
* Wed Jan 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.8-1qilnx
|
||||
- update to version 1.1.8 by autospec
|
||||
|
||||
* Tue Apr 04 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.7-1qilnx
|
||||
- new version rebuilt
|
||||
|
||||
* Tue Mar 02 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.6-1qilnx
|
||||
- new version rebuilt
|
||||
|
||||
* Mon Jan 26 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.5-1qilnx
|
||||
- package update
|
||||
|
||||
* Fri Jan 09 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.4-2qilnx
|
||||
- fixed preun and postun scripts
|
||||
|
||||
* Tue Dec 30 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.4-1qilnx
|
||||
- rebuilt with latest version
|
||||
- enabled IPVS framework and IPVS sync daemon support
|
||||
- LinkWatch not yet enabled (requires the kernel patch
|
||||
http://www.linux-vs.org/~acassen/software/linux-2.4.23-linkwatch.patch.gz)
|
||||
|
||||
* Mon Nov 03 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.1.3-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user