104 lines
3.4 KiB
RPMSpec
104 lines
3.4 KiB
RPMSpec
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: kdewebkit
|
|
Version: 5.9.0
|
|
Release: 1mamba
|
|
Summary: KDE Frameworks 5 - Integration of the HTML rendering engine WebKit
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.kde.org
|
|
Source: http://download.kde.org/stable/frameworks/%{majver}/kdewebkit-%{version}.tar.xz
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
BuildRequires: libkauth-devel
|
|
BuildRequires: libkcodecs-devel
|
|
BuildRequires: libkcompletion-devel
|
|
BuildRequires: libkconfig-devel
|
|
BuildRequires: libkconfigwidgets-devel
|
|
BuildRequires: libkcoreaddons-devel
|
|
BuildRequires: libki18n-devel
|
|
BuildRequires: libkio-devel
|
|
BuildRequires: libkjobwidgets-devel
|
|
BuildRequires: libkparts-devel
|
|
BuildRequires: libkservice-devel
|
|
BuildRequires: libktextwidgets-devel
|
|
BuildRequires: libkwallet-devel
|
|
BuildRequires: libkwidgetsaddons-devel
|
|
BuildRequires: libkxmlgui-devel
|
|
BuildRequires: libqt5-devel
|
|
BuildRequires: libsonnet-devel
|
|
BuildRequires: libstdc++6-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: cmake
|
|
BuildRequires: rpm-macros-kde5
|
|
BuildRequires: extra-cmake-modules
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
This library provides KDE integration of the QtWebKit library. If you are using QtWebKit in your KDE application, you are encouraged to use this layer instead of using the QtWebKit classes directly.
|
|
In particular, you should use KWebView in place of QWebView, KGraphicsWebView in place of QGraphicsWebView and KWebPage in place of QWebPage. See the documentation for those classes for more information.
|
|
|
|
%package -n lib%{name}
|
|
Group: System/Libraries
|
|
Summary: KDE Frameworks 5 - Integration of the HTML rendering engine WebKit
|
|
|
|
%description -n lib%{name}
|
|
This library provides KDE integration of the QtWebKit library. If you are using QtWebKit in your KDE application, you are encouraged to use this layer instead of using the QtWebKit classes directly.
|
|
In particular, you should use KWebView in place of QWebView, KGraphicsWebView in place of QGraphicsWebView and KWebPage in place of QWebPage. See the documentation for those classes for more information.
|
|
|
|
%package -n lib%{name}-devel
|
|
Group: Development/Libraries
|
|
Summary: Development files for %{name}
|
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|
|
|
%description -n lib%{name}-devel
|
|
This package contains libraries and header files for developing applications that use %{name}.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake_kde5 -d build
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall -C build
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%postun -n lib%{name}
|
|
/sbin/ldconfig
|
|
exit 0
|
|
|
|
%files -n lib%{name}
|
|
%defattr(-,root,root)
|
|
%{_kde5_libdir}/libKF5WebKit.so.*
|
|
%doc COPYING.LIB
|
|
|
|
%files -n lib%{name}-devel
|
|
%defattr(-,root,root)
|
|
%dir %{_kde5_includedir}/KDEWebKit
|
|
%{_kde5_includedir}/KDEWebKit/*
|
|
%{_kde5_includedir}/kdewebkit_version.h
|
|
%dir %{_kde5_libdir}/cmake/KF5WebKit
|
|
%{_kde5_libdir}/cmake/KF5WebKit/KF5WebKit*.cmake
|
|
%{_kde5_libdir}/libKF5WebKit.so
|
|
%{_kde5_mkspecsdir}/qt_KDEWebKit.pri
|
|
|
|
%changelog
|
|
* Sun May 10 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 5.9.0-1mamba
|
|
- package created using the webbuild interface
|