rebuilt to remove requirement for db47 [release 2.1.0-3mamba;Fri Mar 01 2024]
This commit is contained in:
parent
62ddba9f71
commit
305f72d038
@ -1,11 +0,0 @@
|
|||||||
--- kdesvn-1.5.5.orig/src/svnfrontend/graphtree/revgraphview.h
|
|
||||||
+++ kdesvn-1.5.5/src/svnfrontend/graphtree/revgraphview.h
|
|
||||||
@@ -49,7 +49,7 @@ typedef svn::SharedPointer<KTemporaryFil
|
|
||||||
/**
|
|
||||||
@author Rajko Albrecht <ral@alwins-world.de>
|
|
||||||
*/
|
|
||||||
-class RevGraphView : virtual public QGraphicsView
|
|
||||||
+class RevGraphView : public QGraphicsView
|
|
||||||
{
|
|
||||||
Q_OBJECT
|
|
||||||
public:
|
|
22
kdesvn.spec
22
kdesvn.spec
@ -5,23 +5,21 @@
|
|||||||
|
|
||||||
Name: kdesvn
|
Name: kdesvn
|
||||||
Version: 2.1.0
|
Version: 2.1.0
|
||||||
Release: 2mamba
|
Release: 3mamba
|
||||||
Summary: A subversion client for KDE
|
Summary: A subversion client for KDE
|
||||||
Group: Graphical Desktop/Applications/Development
|
Group: Graphical Desktop/Applications/Development
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://kdesvn.alwins-world.de
|
URL: https://kdesvn.alwins-world.de/
|
||||||
Source: http://kde.mirror.anlx.net/stable/kdesvn/%{version}/kdesvn-%{version}.tar.xz
|
Source: http://kde.mirror.anlx.net/stable/kdesvn/%{version}/kdesvn-%{version}.tar.xz
|
||||||
#Source: http://kdesvn.alwins-world.de/downloads/kdesvn-%{version}.tar.bz2
|
|
||||||
Patch0: %{name}-1.5.5-qt-4.8.patch
|
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libapr-devel
|
BuildRequires: libapr-devel
|
||||||
BuildRequires: libaprutil-devel
|
BuildRequires: libaprutil-devel
|
||||||
BuildRequires: libdb47-devel
|
BuildRequires: libdb53-devel
|
||||||
BuildRequires: libexpat-devel
|
BuildRequires: libexpat-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libgdbm-devel
|
BuildRequires: libgdbm-devel
|
||||||
@ -47,10 +45,12 @@ BuildRequires: libkwidgetsaddons-devel
|
|||||||
BuildRequires: libkwindowsystem-devel
|
BuildRequires: libkwindowsystem-devel
|
||||||
BuildRequires: libkxmlgui-devel
|
BuildRequires: libkxmlgui-devel
|
||||||
BuildRequires: libopenldap-devel
|
BuildRequires: libopenldap-devel
|
||||||
BuildRequires: libqt5-devel
|
BuildRequires: libsolid-devel
|
||||||
BuildRequires: libsonnet-devel
|
BuildRequires: libsonnet-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
|
BuildRequires: libxcrypt-devel
|
||||||
|
BuildRequires: qt5-qtbase-devel
|
||||||
BuildRequires: subversion-devel
|
BuildRequires: subversion-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -59,7 +59,6 @@ BuildRequires: libjpeg-devel
|
|||||||
BuildRequires: libneon-devel >= 0.24.7
|
BuildRequires: libneon-devel >= 0.24.7
|
||||||
Requires: subversion >= 1.2.3
|
Requires: subversion >= 1.2.3
|
||||||
Requires: kdiff3
|
Requires: kdiff3
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
KDESvn is a frontend to the subversion vcs.
|
KDESvn is a frontend to the subversion vcs.
|
||||||
@ -75,8 +74,7 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
KDESvn is a frontend to the subversion vcs.
|
KDESvn is a frontend to the subversion vcs.
|
||||||
In difference to most other tools it uses the subversion C-Api direct via a c++ wrapper made by Rapid SVN and doesn't parse the output of the subversion client.
|
In difference to most other tools it uses the subversion C-Api direct via a c++ wrapper made by Rapid SVN and doesn't parse the output of the subversion client.
|
||||||
So it is a real client itself instead of a frontend to the command line tool.
|
So it is a real client itself instead of a frontend to the command line tool.
|
||||||
|
This package contains static libraries and header files needed for development
|
||||||
This package contains static libraries and header files need for development
|
|
||||||
|
|
||||||
%package -n %{libname}
|
%package -n %{libname}
|
||||||
Group: Graphical Desktop/Libraries/KDE
|
Group: Graphical Desktop/Libraries/KDE
|
||||||
@ -93,7 +91,6 @@ This package contains the shared library needed to run kdesvn.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake_kde5 \
|
%cmake_kde5 \
|
||||||
@ -137,6 +134,9 @@ This package contains the shared library needed to run kdesvn.
|
|||||||
%doc AUTHORS COPYING
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-3mamba
|
||||||
|
- rebuilt to remove requirement for db47
|
||||||
|
|
||||||
* Wed Sep 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-2mamba
|
* Wed Sep 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.1.0-2mamba
|
||||||
- removed requirement for kdelibs; added debug package
|
- removed requirement for kdelibs; added debug package
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user