rebuilt in /usr; applied recent patches [release 4.14.38-6mamba;Thu Oct 05 2023]
This commit is contained in:
parent
731af17730
commit
db279936bd
@ -1,52 +0,0 @@
|
||||
From: Alex Merry <alex.merry@kde.org>
|
||||
Date: Tue, 15 Dec 2015 19:26:47 +0000
|
||||
Subject: Revert "backport commit b72fc5e56579035bf987075e16324ef95ef8e3d4"
|
||||
X-Git-Url: http://quickgit.kde.org/?p=kdelibs.git&a=commitdiff&h=a02df05e4bd083f98147c86f88da2f818fc6c9f4
|
||||
---
|
||||
Revert "backport commit b72fc5e56579035bf987075e16324ef95ef8e3d4"
|
||||
|
||||
This reverts commit 4f7ea2f770cf062ef22293fbb21a086f3e0cbfcb.
|
||||
|
||||
This change seems to be causing more problems than it fixes - it's
|
||||
probably just too big of a behaviour change for kdelibs. Which means
|
||||
that akregator will probably keep randomly crashing, but the alternative
|
||||
seems to be various other applications consistently crashing at exit.
|
||||
|
||||
If we can fix those applications (Kopete in particular), we can consider
|
||||
re-applying this afterwards.
|
||||
|
||||
BUG: 355275
|
||||
---
|
||||
|
||||
|
||||
--- a/kparts/part.cpp
|
||||
+++ b/kparts/part.cpp
|
||||
@@ -350,7 +350,7 @@
|
||||
d->m_widget = 0;
|
||||
if (d->m_autoDeletePart) {
|
||||
kDebug(1000) << "deleting part" << objectName();
|
||||
- this->deleteLater();
|
||||
+ delete this; // ouch, this should probably be deleteLater()
|
||||
}
|
||||
}
|
||||
|
||||
|
||||
--- a/kparts/tests/parttest.cpp
|
||||
+++ b/kparts/tests/parttest.cpp
|
||||
@@ -48,7 +48,6 @@
|
||||
KParts::Part* part = new TestPart(0, 0);
|
||||
QPointer<KParts::Part> partPointer(part);
|
||||
delete part->widget();
|
||||
- QCoreApplication::sendPostedEvents(0, QEvent::DeferredDelete);
|
||||
QVERIFY(partPointer.isNull());
|
||||
}
|
||||
|
||||
@@ -58,7 +57,6 @@
|
||||
QPointer<KParts::Part> partPointer(part);
|
||||
QPointer<QWidget> widgetPointer(part->widget());
|
||||
delete part;
|
||||
- QCoreApplication::sendPostedEvents(0, QEvent::DeferredDelete);
|
||||
QVERIFY(widgetPointer.isNull());
|
||||
}
|
||||
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up kdelibs-4.14.17/ConfigureChecks.cmake.gcc6 kdelibs-4.14.17/ConfigureChecks.cmake
|
||||
--- kdelibs-4.14.17/ConfigureChecks.cmake.gcc6 2016-02-11 23:06:08.000000000 -0600
|
||||
+++ kdelibs-4.14.17/ConfigureChecks.cmake 2016-02-12 19:14:07.707788177 -0600
|
||||
@@ -244,7 +244,7 @@ check_prototype_exists(unsetenv stdlib.h
|
||||
check_prototype_exists(usleep unistd.h HAVE_USLEEP_PROTO)
|
||||
check_prototype_exists(initgroups "unistd.h;sys/types.h;unistd.h;grp.h" HAVE_INITGROUPS_PROTO)
|
||||
check_prototype_exists(setreuid unistd.h HAVE_SETREUID_PROTO)
|
||||
-check_prototype_exists(trunc math.h HAVE_TRUNC)
|
||||
+check_prototype_exists(truncf math.h HAVE_TRUNC)
|
||||
|
||||
# check for existing datatypes
|
||||
|
@ -1,43 +0,0 @@
|
||||
diff -up kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp.gcc6 kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp
|
||||
--- kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp.gcc6 2016-02-11 23:06:08.000000000 -0600
|
||||
+++ kdelibs-4.14.17/solid/solid/backends/shared/cpufeatures.cpp 2016-02-12 19:14:07.708788182 -0600
|
||||
@@ -51,23 +51,23 @@ static void sighandler( int )
|
||||
#endif
|
||||
|
||||
#ifdef __i386__
|
||||
- #define ASM_REG(reg) "%e"reg
|
||||
- #define ASM_POP(reg) "popl %%e"reg" \n\t"
|
||||
- #define ASM_PUSH(reg) "pushl %%e"reg" \n\t"
|
||||
- #define ASM_XOR_REG(reg1, reg2) "xorl %%e"reg1", %%e"reg2" \n\t"
|
||||
- #define ASM_XOR_VAR(var, reg) "xorl "var", %%e"reg" \n\t"
|
||||
- #define ASM_CMP_REG(reg1, reg2) "cmpl %%e"reg1", %%e"reg2" \n\t"
|
||||
- #define ASM_MOV_REG(reg1, reg2) "movl %%e"reg1", %%e"reg2" \n\t"
|
||||
- #define ASM_MOV_VAR(var, reg) "movl "var", %%e"reg" \n\t"
|
||||
+ #define ASM_REG(reg) "%e" reg
|
||||
+ #define ASM_POP(reg) "popl %%e" reg " \n\t"
|
||||
+ #define ASM_PUSH(reg) "pushl %%e" reg " \n\t"
|
||||
+ #define ASM_XOR_REG(reg1, reg2) "xorl %%e" reg1 ", %%e" reg2 " \n\t"
|
||||
+ #define ASM_XOR_VAR(var, reg) "xorl " var ", %%e" reg " \n\t"
|
||||
+ #define ASM_CMP_REG(reg1, reg2) "cmpl %%e" reg1 ", %%e" reg2 " \n\t"
|
||||
+ #define ASM_MOV_REG(reg1, reg2) "movl %%e" reg1 ", %%e" reg2 " \n\t"
|
||||
+ #define ASM_MOV_VAR(var, reg) "movl " var ", %%e" reg " \n\t"
|
||||
#elif defined(__x86_64__)
|
||||
- #define ASM_REG(reg) "%r"reg
|
||||
- #define ASM_POP(reg) "popq %%r"reg" \n\t"
|
||||
- #define ASM_PUSH(reg) "pushq %%r"reg" \n\t"
|
||||
- #define ASM_XOR_REG(reg1, reg2) "xorq %%r"reg1", %%r"reg2" \n\t"
|
||||
- #define ASM_XOR_VAR(var, reg) "xorq "var", %%r"reg" \n\t"
|
||||
- #define ASM_CMP_REG(reg1, reg2) "cmpq %%r"reg1", %%r"reg2" \n\t"
|
||||
- #define ASM_MOV_REG(reg1, reg2) "movq %%r"reg1", %%r"reg2" \n\t"
|
||||
- #define ASM_MOV_VAR(var, reg) "movq "var", %%r"reg" \n\t"
|
||||
+ #define ASM_REG(reg) "%r" reg
|
||||
+ #define ASM_POP(reg) "popq %%r" reg " \n\t"
|
||||
+ #define ASM_PUSH(reg) "pushq %%r" reg " \n\t"
|
||||
+ #define ASM_XOR_REG(reg1, reg2) "xorq %%r" reg1 ", %%r" reg2 " \n\t"
|
||||
+ #define ASM_XOR_VAR(var, reg) "xorq " var ", %%r" reg " \n\t"
|
||||
+ #define ASM_CMP_REG(reg1, reg2) "cmpq %%r" reg1 ", %%r" reg2 " \n\t"
|
||||
+ #define ASM_MOV_REG(reg1, reg2) "movq %%r" reg1 ", %%r" reg2 " \n\t"
|
||||
+ #define ASM_MOV_VAR(var, reg) "movq " var ", %%r" reg " \n\t"
|
||||
#endif
|
||||
|
||||
#ifdef __PPC__
|
17
kdelibs-4.14.38-klocale-kde.cpp.patch
Normal file
17
kdelibs-4.14.38-klocale-kde.cpp.patch
Normal file
@ -0,0 +1,17 @@
|
||||
contains() returns bool or QBool, and clang7 picks the an
|
||||
overload that casts to void *, and then fails on the ordered
|
||||
comparison. Drop the strange comparison instead.
|
||||
|
||||
--- kdelibs-4.14.38/kdecore/localization/klocale_kde.cpp.orig 2018-08-23 20:23:08 UTC
|
||||
+++ kdelibs-4.14.38/kdecore/localization/klocale_kde.cpp
|
||||
@@ -2438,8 +2438,8 @@ QString KLocalePrivate::formatLocaleTime
|
||||
|
||||
bool KLocalePrivate::use12Clock() const
|
||||
{
|
||||
- if ((timeFormat().contains(QString::fromLatin1("%I")) > 0) ||
|
||||
- (timeFormat().contains(QString::fromLatin1("%l")) > 0)) {
|
||||
+ if (bool(timeFormat().contains(QString::fromLatin1("%I"))) ||
|
||||
+ bool(timeFormat().contains(QString::fromLatin1("%l")))) {
|
||||
return true;
|
||||
} else {
|
||||
return false;
|
23
kdelibs-4.14.38-kopenwitrhdialog-orderd-comparison.patch
Normal file
23
kdelibs-4.14.38-kopenwitrhdialog-orderd-comparison.patch
Normal file
@ -0,0 +1,23 @@
|
||||
--- kdelibs-4.14.38/kio/kfile/kpropertiesdialog.cpp
|
||||
+++ kdelibs-4.14.38/kio/kfile/kpropertiesdialog.cpp
|
||||
@@ -3306,7 +3306,7 @@
|
||||
|
||||
if (preferredTerminal == "konsole")
|
||||
{
|
||||
- terminalCloseBool = (d->m_terminalOptionStr.contains( "--noclose" ) > 0);
|
||||
+ terminalCloseBool = (0 != d->m_terminalOptionStr.contains( "--noclose" ));
|
||||
w.terminalCloseCheck->setChecked(terminalCloseBool);
|
||||
d->m_terminalOptionStr.remove( "--noclose");
|
||||
}
|
||||
|
||||
--- kdelibs-4.14.38/kio/kfile/kopenwithdialog.cpp
|
||||
+++ kdelibs-4.14.38/kio/kfile/kopenwithdialog.cpp
|
||||
@@ -713,7 +713,7 @@
|
||||
// ### indicate that default value was restored
|
||||
d->terminal->setChecked(d->curService->terminal());
|
||||
QString terminalOptions = d->curService->terminalOptions();
|
||||
- d->nocloseonexit->setChecked((terminalOptions.contains(QLatin1String("--noclose")) > 0));
|
||||
+ d->nocloseonexit->setChecked((0 != terminalOptions.contains(QLatin1String("--noclose"))));
|
||||
d->m_terminaldirty = false; // slotTerminalToggled changed it
|
||||
}
|
||||
}
|
6
kdelibs-4.14.38-libjasper-2.0.33.patch
Normal file
6
kdelibs-4.14.38-libjasper-2.0.33.patch
Normal file
@ -0,0 +1,6 @@
|
||||
diff -r -U0 kdelibs-4.14.38.orig/kimgio/jp2.cpp kdelibs-4.14.38.patched/kimgio/jp2.cpp
|
||||
--- kdelibs-4.14.38.orig/kimgio/jp2.cpp 2017-11-05 02:51:22.000000000 +0100
|
||||
+++ kdelibs-4.14.38.patched/kimgio/jp2.cpp 2023-02-27 14:43:31.139956360 +0100
|
||||
@@ -388 +388 @@
|
||||
- int i = jp2_encode( ji, stream, rateBuffer);
|
||||
+ int i = jas_image_encode(ji, stream, -1, rateBuffer);
|
@ -1,99 +0,0 @@
|
||||
commit 42d40d1d351588a71bef0af1d62a8f6dc586f141
|
||||
Author: Mario Bensi <mbensi@ipsquad.net>
|
||||
Date: Mon Jan 31 10:28:51 2011 +0100
|
||||
|
||||
Fix crash during the QFileSystemWatcher destruction
|
||||
|
||||
The QFileSystemWatcher doesn't work correctly in a singleton
|
||||
The solution so far was to destroy the QFileSystemWatcher when the
|
||||
application quits but we have some crash with this solution.
|
||||
For the moment to workaround the problem, we detach the
|
||||
QFileSystemWatcher from the parent effectively leaking it on purpose.
|
||||
|
||||
diff --git a/solid/solid/backends/fstab/fstabwatcher.cpp b/solid/solid/backends/fstab/fstabwatcher.cpp
|
||||
index 1d763fa..45282fa 100644
|
||||
--- a/solid/solid/backends/fstab/fstabwatcher.cpp
|
||||
+++ b/solid/solid/backends/fstab/fstabwatcher.cpp
|
||||
@@ -40,6 +40,9 @@ FstabWatcher::FstabWatcher()
|
||||
: m_isRoutineInstalled(false)
|
||||
, m_fileSystemWatcher(new QFileSystemWatcher(this))
|
||||
{
|
||||
+ if (qApp) {
|
||||
+ connect(qApp, SIGNAL(aboutToQuit()), this, SLOT(orphanFileSystemWatcher()));
|
||||
+ }
|
||||
m_fileSystemWatcher->addPath(MTAB);
|
||||
m_fileSystemWatcher->addPath(FSTAB);
|
||||
connect(m_fileSystemWatcher, SIGNAL(fileChanged(QString)), this, SLOT(onFileChanged(QString)));
|
||||
@@ -47,11 +50,23 @@ FstabWatcher::FstabWatcher()
|
||||
|
||||
FstabWatcher::~FstabWatcher()
|
||||
{
|
||||
- qRemovePostRoutine(globalFstabWatcher.destroy);
|
||||
+ // The QFileSystemWatcher doesn't work correctly in a singleton
|
||||
+ // The solution so far was to destroy the QFileSystemWatcher when the application quits
|
||||
+ // But we have some crash with this solution.
|
||||
+ // For the moment to workaround the problem, we detach the QFileSystemWatcher from the parent
|
||||
+ // effectively leaking it on purpose.
|
||||
+
|
||||
+ //qRemovePostRoutine(globalFstabWatcher.destroy);
|
||||
+}
|
||||
+
|
||||
+void FstabWatcher::orphanFileSystemWatcher()
|
||||
+{
|
||||
+ m_fileSystemWatcher->setParent(0);
|
||||
}
|
||||
|
||||
FstabWatcher *FstabWatcher::instance()
|
||||
{
|
||||
+#if 0
|
||||
FstabWatcher *fstabWatcher = globalFstabWatcher;
|
||||
|
||||
if (fstabWatcher && !fstabWatcher->m_isRoutineInstalled) {
|
||||
@@ -59,6 +74,9 @@ FstabWatcher *FstabWatcher::instance()
|
||||
fstabWatcher->m_isRoutineInstalled = true;
|
||||
}
|
||||
return fstabWatcher;
|
||||
+#else
|
||||
+ return globalFstabWatcher;
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
||||
diff --git a/solid/solid/backends/fstab/fstabwatcher.h b/solid/solid/backends/fstab/fstabwatcher.h
|
||||
index 1992c91..2ca6511 100644
|
||||
--- a/solid/solid/backends/fstab/fstabwatcher.h
|
||||
+++ b/solid/solid/backends/fstab/fstabwatcher.h
|
||||
@@ -46,6 +46,7 @@ namespace Fstab
|
||||
|
||||
private Q_SLOTS:
|
||||
void onFileChanged(const QString &path);
|
||||
+ void orphanFileSystemWatcher();
|
||||
|
||||
private:
|
||||
bool m_isRoutineInstalled;
|
||||
commit 350a5d8de016b6daa36c6e29d5d5f83ad6c2b38d
|
||||
Author: Mario Bensi <mbensi@ipsquad.net>
|
||||
Date: Tue Feb 1 11:11:58 2011 +0100
|
||||
|
||||
Fix solid test
|
||||
|
||||
I need to detach parent on QFileSystemWatcher when the FstabWatcher
|
||||
destructor are called if the aboutToQuit is not called. It's the case in
|
||||
test.
|
||||
|
||||
diff --git a/solid/solid/backends/fstab/fstabwatcher.cpp b/solid/solid/backends/fstab/fstabwatcher.cpp
|
||||
index 45282fa..449d5ce 100644
|
||||
--- a/solid/solid/backends/fstab/fstabwatcher.cpp
|
||||
+++ b/solid/solid/backends/fstab/fstabwatcher.cpp
|
||||
@@ -56,7 +56,11 @@ FstabWatcher::~FstabWatcher()
|
||||
// For the moment to workaround the problem, we detach the QFileSystemWatcher from the parent
|
||||
// effectively leaking it on purpose.
|
||||
|
||||
+#if 0
|
||||
//qRemovePostRoutine(globalFstabWatcher.destroy);
|
||||
+#else
|
||||
+ m_fileSystemWatcher->setParent(0);
|
||||
+#endif
|
||||
}
|
||||
|
||||
void FstabWatcher::orphanFileSystemWatcher()
|
124
kdelibs.spec
124
kdelibs.spec
@ -1,8 +1,7 @@
|
||||
#%ifnarch arm
|
||||
#% define build_apidocs 1
|
||||
#%endif
|
||||
%if "%{stage1}" == "1"
|
||||
%define _kde4_prefix /opt/kde
|
||||
%define _kde4_prefix /usr
|
||||
%define _kde4_sysconfdir %_sysconfdir
|
||||
%define _kde4_autostartdir %_kde4_prefix/share/autostart
|
||||
%define _kde4_bindir %_kde4_prefix/bin
|
||||
@ -31,27 +30,21 @@
|
||||
%define _kde4_xdgdirectorydir %_kde4_prefix/share/desktop-directories
|
||||
%define _kde4_xdgmimedir %_kde4_prefix/share/mime/packages
|
||||
%define _kde4_wallpaperdir %_kde4_prefix/share/wallpapers
|
||||
%endif
|
||||
Name: kdelibs
|
||||
Version: 4.14.38
|
||||
Release: 5mamba
|
||||
Release: 6mamba
|
||||
Summary: KDE Software Compilation - Core Libraries
|
||||
Group: Graphical Desktop/Libraries/KDE
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://www.kde.org/
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://kde.org/
|
||||
Source0: https://download.kde.org/Attic/applications/17.08.3/src/kdelibs-%{version}.tar.xz
|
||||
Source1: kdelibs4-rpmmacros_kde4.in
|
||||
Patch0: %{name}4-4.1.2-fix_fixx11.patch
|
||||
Patch1: %{name}-4.7.0-openmamba_wallpaper.patch
|
||||
Patch2: %{name}-4.6.1-no_kbookmark_write_error.patch
|
||||
Patch3: %{name}-4.6.2-fix_kded_high_cpu_load.patch
|
||||
Patch4: kdelibs-4.14.0-arm-offscreen-fix.patch
|
||||
Patch5: kdelibs-4.14.15-upstream-backport-to-fix-kopete-crash.patch
|
||||
Patch6: kdelibs-4.14.21-gcc-6.1.0-solid.patch
|
||||
Patch7: kdelibs-4.14.21-gcc-6.1.0-1.patch
|
||||
Patch8: kdelibs-4.14.21-gcc-6.1.0-2.patch
|
||||
Patch9: kdelibs-4.14.38-qt4.patch
|
||||
Patch10: kdelibs-4.14.38-openssl-1.1.patch
|
||||
Patch11: kdelibs-4.14.38-no-kdewebkit.patch
|
||||
@ -60,10 +53,12 @@ Patch13: kdelibs-4.14.38-gcc-10.patch
|
||||
Patch14: kdelibs-4.14.38-CVE-2019-14744.patch
|
||||
Patch15: kdelibs-4.14.38-Drop-Nepomuk-from-KParts-LINK_INTERFACE_LIBRARIES.patch
|
||||
Patch16: kdelibs-4.14.38-disable-soprano-nepomuk.patch
|
||||
Patch17: kdelibs-4.14.38-klocale-kde.cpp.patch
|
||||
Patch18: kdelibs-4.14.38-kopenwitrhdialog-orderd-comparison.patch
|
||||
Patch19: kdelibs-4.14.38-libjasper-2.0.33.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
%ifnarch aarch64
|
||||
BuildRequires: libHUpnp-devel
|
||||
%endif
|
||||
@ -97,7 +92,6 @@ BuildRequires: libjpeg-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libnsl-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libphonon4-devel
|
||||
@ -105,7 +99,6 @@ BuildRequires: libpng-devel
|
||||
BuildRequires: libpolkit-qt-1-devel
|
||||
BuildRequires: libqca-qt4-devel
|
||||
BuildRequires: libqt4-devel
|
||||
BuildRequires: libsoprano-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libutempter-devel
|
||||
@ -131,8 +124,6 @@ BuildRequires: libdbusmenu-qt-devel
|
||||
BuildRequires: media-player-info
|
||||
BuildRequires: libsoprano-devel >= 1:2.9.4-2mamba
|
||||
BuildRequires: shared-desktop-ontologies-devel
|
||||
Obsoletes: kdelibs-experimental
|
||||
Provides: kdelibs-experimental
|
||||
Requires: libqt4 >= %_qt4_version
|
||||
Requires: hicolor-icon-theme >= 0.5
|
||||
# shared-desktop-ontologies is really required?
|
||||
@ -140,17 +131,15 @@ Requires: shared-desktop-ontologies
|
||||
Requires: shared-mime-info
|
||||
# FIXME: libphonon needs an explicit requirement to avoid use of library from package libqt4-phonon
|
||||
Requires: libphonon
|
||||
#Requires: PyQt4
|
||||
#Requires: python-dbus
|
||||
Requires: udev
|
||||
Requires: udisks2
|
||||
Requires: upower
|
||||
Requires: media-player-info
|
||||
Provides: kdelibs4
|
||||
Obsoletes: kdelibs4
|
||||
Obsoletes: kwebkitpart
|
||||
#Requires: /etc/ld.so.conf.d
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: kdelibs4 < 4.14.38-6mamba
|
||||
Obsoletes: kwebkitpart < 4.14.38-6mamba
|
||||
Provides: kdelibs-experimental
|
||||
Obsoletes: kdelibs-experimental < 4.14.38-6mamba
|
||||
|
||||
%description
|
||||
This package includes libraries that are central to the development and execution of a KDE program, as well as internationalization files for these libraries, misc HTML documentation, theme modules, and regression tests.
|
||||
@ -160,10 +149,10 @@ This package is absolutely necessary for using KDE.
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for KDE libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Obsoletes: kdelibs-experimental-devel
|
||||
Provides: kdelibs-experimental-devel
|
||||
Obsoletes: kdelibs-experimental-devel < 4.14.38-6mamba
|
||||
Provides: kdelibs4-devel
|
||||
Obsoletes: kdelibs4-devel
|
||||
Obsoletes: kdelibs4-devel < 4.14.38-6mamba
|
||||
|
||||
%description devel
|
||||
This package includes the development files needed to build KDE applications using the KDE libraries.
|
||||
@ -173,7 +162,7 @@ Group: Documentation
|
||||
Summary: KDE API documentation
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: kdelibs4-apidocs
|
||||
Obsoletes: kdelibs4-apidocs
|
||||
Obsoletes: kdelibs4-apidocs < 4.14.38-6mamba
|
||||
|
||||
%description apidocs
|
||||
This package includes the KDE API documentation needed by the developers of KDE applications.
|
||||
@ -184,57 +173,29 @@ This package includes the KDE API documentation needed by the developers of KDE
|
||||
%setup -q
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
#%patch3 -p1
|
||||
%patch 1 -p1
|
||||
%patch 2 -p1
|
||||
%ifarch arm
|
||||
%patch4 -p1
|
||||
%patch 4 -p1
|
||||
%endif
|
||||
#%patch5 -p1
|
||||
#%patch6 -p1
|
||||
%patch7 -p1
|
||||
#%patch8 -p1
|
||||
%patch9 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
%patch13 -p1
|
||||
%patch14 -p1
|
||||
%patch15 -p1
|
||||
#%patch16 -p1
|
||||
%patch 7 -p1
|
||||
%patch 9 -p1
|
||||
%patch 10 -p1
|
||||
%patch 11 -p1
|
||||
%patch 12 -p1
|
||||
%patch 13 -p1
|
||||
%patch 14 -p1
|
||||
%patch 15 -p1
|
||||
%patch 17 -p1 -b .klocale-kde.cpp
|
||||
%patch 18 -p1 -b .kopenwitrhdialog-orderd-comparison
|
||||
%patch 19 -p1 -b .libjasper-2.0.33
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%if "%{stage1}" == "1"
|
||||
QTDIR="%{_qt4_prefix}" ; export QTDIR ; \
|
||||
PATH="%{_qt4_bindir}:$PATH" ; export PATH ; \
|
||||
CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
|
||||
CXXFLAGS="${CXXFLAGS:-%optflags} -Wno-narrowing -std=gnu++98" ; export CXXFLAGS ; \
|
||||
FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
|
||||
# Can't use macros.kde4 as it is provided by this package
|
||||
mkdir -p build ; cd build ; \
|
||||
%{__cmake} \
|
||||
%if "%{_lib}" == "lib64"
|
||||
-DLIB_SUFFIX=64 \
|
||||
%endif
|
||||
-DCMAKE_BUILD_TYPE=%{_kde4_debug} \
|
||||
-DCMAKE_INSTALL_PREFIX:PATH=%{_kde4_prefix} \
|
||||
-DDBUS_INTERFACES_INSTALL_DIR:PATH=%{_kde4_dbusinterfacesdir} \
|
||||
-DDBUS_SERVICES_INSTALL_DIR:PATH=%{_kde4_dbusservicesdir} \
|
||||
-DDBUS_SYSTEM_SERVICES_INSTALL_DIR:PATH=%{_kde4_dbussystemservicesdir} \
|
||||
-DINFO_INSTALL_DIR:PATH=%{_infodir} \
|
||||
-DMAN_INSTALL_DIR:PATH=%{_mandir} \
|
||||
-DSYSCONF_INSTALL_DIR:PATH=%{_kde4_sysconfdir} \
|
||||
-DXDG_APPS_INSTALL_DIR:PATH=%{_kde4_xdgappsdir} \
|
||||
-DXDG_MIME_INSTALL_DIR:PATH=%{_kde4_xdgmimedir} .. \
|
||||
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
|
||||
-DWITH_FAM=OFF \
|
||||
-DKDE_DISTRIBUTION_TEXT="%{_openmamba_release}" \
|
||||
-DKDE_DEFAULT_HOME=".kde4"
|
||||
%else
|
||||
%cmake_kde4 -d build \
|
||||
-Wno-dev \
|
||||
-DCMAKE_CXX_FLAGS="%{optflags} -Wno-narrowing" \
|
||||
-Wno-dev \
|
||||
-DCMAKE_CXX_FLAGS="%{optflags} -fpermissive -Wno-narrowing" \
|
||||
-DCMAKE_INSTALL_PREFIX=%{_prefix} \
|
||||
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
|
||||
-DWITH_FAM=OFF \
|
||||
-DKDE_DISTRIBUTION_TEXT="%{_openmamba_release}" \
|
||||
@ -242,8 +203,8 @@ This package includes the KDE API documentation needed by the developers of KDE
|
||||
-DKDE4_BUILD_TESTS=OFF \
|
||||
-DHUPNP_ENABLED:BOOL=ON \
|
||||
-DKIO_NO_SOPRANO:BOOL=ON \
|
||||
-DWITH_Soprano=OFF \
|
||||
-DWITH_SOLID_UDISKS2:BOOL=ON
|
||||
%endif
|
||||
|
||||
%make
|
||||
|
||||
@ -291,8 +252,8 @@ install -d %{buildroot}%{_sysconfdir}/ld.so.conf.d
|
||||
echo "%{_kde4_libdir}" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/kde4.conf
|
||||
%endif
|
||||
|
||||
install -d %{buildroot}%{_sysconfdir}/rpm
|
||||
cat %{S:1} | sed -e "s,@version@,%{version}," > %{buildroot}%{_sysconfdir}/rpm/macros.kde4
|
||||
install -d %{buildroot}%{_rpmmacrodir}
|
||||
cat %{S:1} | sed -e "s,@version@,%{version}," > %{buildroot}%{_rpmmacrodir}/macros.kde4
|
||||
|
||||
rm -f %{buildroot}%{_kde4_datadir}/kssl/ca-bundle.crt
|
||||
ln -sf /etc/pki/tls/certs/ca-bundle.crt \
|
||||
@ -369,9 +330,9 @@ exit 0
|
||||
%{_kde4_libdir}/libkunitconversion.so.*
|
||||
%{_kde4_libdir}/libkunittest.so.*
|
||||
%{_kde4_libdir}/libkutils.so.*
|
||||
%{_kde4_libdir}/libnepomukquery.so.*
|
||||
%{_kde4_libdir}/libnepomuk.so.*
|
||||
%{_kde4_libdir}/libnepomukutils.so.*
|
||||
#%{_kde4_libdir}/libnepomukquery.so.*
|
||||
#%{_kde4_libdir}/libnepomuk.so.*
|
||||
#%{_kde4_libdir}/libnepomukutils.so.*
|
||||
%{_kde4_libdir}/libplasma.so.*
|
||||
%{_kde4_libdir}/libsolid.so.*
|
||||
%{_kde4_libdir}/libthreadweaver.so.*
|
||||
@ -413,7 +374,7 @@ exit 0
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/rpm/macros.kde4
|
||||
%{_rpmmacrodir}/macros.kde4
|
||||
%{_kde4_bindir}/kconfig_compiler
|
||||
%{_kde4_includedir}/
|
||||
#%{_kde4_libdir}/libkactivities.so
|
||||
@ -448,9 +409,9 @@ exit 0
|
||||
%{_kde4_libdir}/libkunitconversion.so
|
||||
%{_kde4_libdir}/libkunittest.so
|
||||
%{_kde4_libdir}/libkutils.so
|
||||
%{_kde4_libdir}/libnepomukquery.so
|
||||
%{_kde4_libdir}/libnepomuk.so
|
||||
%{_kde4_libdir}/libnepomukutils.so
|
||||
#%{_kde4_libdir}/libnepomukquery.so
|
||||
#%{_kde4_libdir}/libnepomuk.so
|
||||
#%{_kde4_libdir}/libnepomukutils.so
|
||||
%{_kde4_libdir}/libplasma.so
|
||||
%{_kde4_libdir}/libsolid.so
|
||||
%{_kde4_libdir}/libthreadweaver.so
|
||||
@ -467,6 +428,9 @@ exit 0
|
||||
%{_kde4_htmldir}/en/kioslave/
|
||||
|
||||
%changelog
|
||||
* Thu Oct 05 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.38-6mamba
|
||||
- rebuilt in /usr; applied recent patches
|
||||
|
||||
* Sat Oct 17 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.38-5mamba
|
||||
- rename /etc/xdg/menus/applications.menu to applications-kde4.menu to allow kservice installation of kf5 application.menu
|
||||
|
||||
|
@ -1,15 +0,0 @@
|
||||
diff -Nru kdelibs-4.1.2.orig/kdeui/util/fixx11h.h kdelibs-4.1.2/kdeui/util/fixx11h.h
|
||||
--- kdelibs-4.1.2.orig/kdeui/util/fixx11h.h 2008-05-21 13:08:51.000000000 +0200
|
||||
+++ kdelibs-4.1.2/kdeui/util/fixx11h.h 2008-10-09 03:40:31.000000000 +0200
|
||||
@@ -28,6 +28,11 @@
|
||||
|
||||
#include <QtCore/QtGlobal>
|
||||
|
||||
+/*
|
||||
+ Workaround: see http://bugs.kde.org/show_bug.cgi?id=151930
|
||||
+*/
|
||||
+#include <X11/extensions/Xrender.h>
|
||||
+
|
||||
#ifdef Q_WS_X11
|
||||
|
||||
/* Usage:
|
@ -1,6 +1,6 @@
|
||||
%_kde4_version @version@
|
||||
|
||||
%_kde4_prefix /opt/kde
|
||||
%_kde4_prefix /usr
|
||||
%_kde4_sysconfdir %_sysconfdir
|
||||
|
||||
%_kde4_autostartdir %_kde4_prefix/share/autostart
|
||||
|
Loading…
Reference in New Issue
Block a user