re-enable building nepomuk lib [release 4.14.38-4mamba;Mon Sep 21 2020]

This commit is contained in:
Silvan Calarco 2024-01-06 01:07:17 +01:00
parent c075045a9f
commit 1bf0ec6aa8
9 changed files with 4370 additions and 15 deletions

View File

@ -0,0 +1,111 @@
From 2c3762feddf7e66cf6b64d9058f625a715694a00 Mon Sep 17 00:00:00 2001
From: Kai Uwe Broulik <kde@privat.broulik.de>
Date: Wed, 7 Aug 2019 09:47:46 +0200
Subject: Security: remove support for $(...) in config keys with [$e] marker.
It is very unclear at this point what a valid use case for this feature
would possibly be. The old documentation only mentions $(hostname) as
an example, which can be done with $HOSTNAME instead.
Note that $(...) is still supported in Exec lines of desktop files,
this does not require [$e] anyway (and actually works better without it,
otherwise the $ signs need to be doubled to obey kconfig $e escaping rules...).
Thanks to Fabian Vogt for testing.
(This is a backport of KDE Frameworks 5 kconfig patch to kdelibs)
Differential Revision: https://phabricator.kde.org/D22989
---
kdecore/config/kconfig.cpp | 32 +-------------------------------
kdecore/doc/README.kiosk | 12 ------------
kdecore/tests/kconfigtest.cpp | 6 +-----
3 files changed, 2 insertions(+), 48 deletions(-)
diff --git a/kdecore/config/kconfig.cpp b/kdecore/config/kconfig.cpp
index 7ea26a5..b30584b 100644
--- a/kdecore/config/kconfig.cpp
+++ b/kdecore/config/kconfig.cpp
@@ -160,37 +160,7 @@ QString KConfigPrivate::expandString(const QString& value)
int nDollarPos = aValue.indexOf( QLatin1Char('$') );
while( nDollarPos != -1 && nDollarPos+1 < aValue.length()) {
// there is at least one $
- if( aValue[nDollarPos+1] == QLatin1Char('(') ) {
- int nEndPos = nDollarPos+1;
- // the next character is not $
- while ( (nEndPos <= aValue.length()) && (aValue[nEndPos]!=QLatin1Char(')')) )
- nEndPos++;
- nEndPos++;
- QString cmd = aValue.mid( nDollarPos+2, nEndPos-nDollarPos-3 );
-
- QString result;
- QByteArray oldpath = qgetenv( "PATH" );
- QByteArray newpath;
- if (KGlobal::hasMainComponent()) {
- newpath = QFile::encodeName(KGlobal::dirs()->resourceDirs("exe").join(QChar::fromLatin1(KPATH_SEPARATOR)));
- if (!newpath.isEmpty() && !oldpath.isEmpty())
- newpath += KPATH_SEPARATOR;
- }
- newpath += oldpath;
- setenv( "PATH", newpath, 1/*overwrite*/ );
-// FIXME: wince does not have pipes
-#ifndef _WIN32_WCE
- FILE *fs = popen(QFile::encodeName(cmd).data(), "r");
- if (fs) {
- QTextStream ts(fs, QIODevice::ReadOnly);
- result = ts.readAll().trimmed();
- pclose(fs);
- }
-#endif
- setenv( "PATH", oldpath, 1/*overwrite*/ );
- aValue.replace( nDollarPos, nEndPos-nDollarPos, result );
- nDollarPos += result.length();
- } else if( aValue[nDollarPos+1] != QLatin1Char('$') ) {
+ if( aValue[nDollarPos+1] != QLatin1Char('$') ) {
int nEndPos = nDollarPos+1;
// the next character is not $
QString aVarName;
diff --git a/kdecore/doc/README.kiosk b/kdecore/doc/README.kiosk
index b95002d..d902c61 100644
--- a/kdecore/doc/README.kiosk
+++ b/kdecore/doc/README.kiosk
@@ -640,18 +640,6 @@ The following syntax is also supported:
Name[$ei]=${USER}
-Shell Commands in KDE config files.
-===================================
-
-Since KDE-3.1 arbitrary entries in configuration files can contain shell
-commands. This way the value of a configuration entry can be determined
-dynamically at runtime. In order to use this the entry must be marked
-with [$e].
-
-Example:
-Host[$e]=$(hostname)
-
-
KDE Kiosk Application API
==========================
diff --git a/kdecore/tests/kconfigtest.cpp b/kdecore/tests/kconfigtest.cpp
index 78e6ad1..37ea3c2 100644
--- a/kdecore/tests/kconfigtest.cpp
+++ b/kdecore/tests/kconfigtest.cpp
@@ -479,12 +479,8 @@ void KConfigTest::testPath()
QCOMPARE(group.readPathEntry("withBraces", QString()), QString("file://" + HOMEPATH) );
QVERIFY(group.hasKey("URL"));
QCOMPARE(group.readEntry("URL", QString()), QString("file://" + HOMEPATH) );
-#if !defined(Q_OS_WIN32) && !defined(Q_OS_MAC)
- // I don't know if this will work on windows
- // This test hangs on OS X
QVERIFY(group.hasKey("hostname"));
- QCOMPARE(group.readEntry("hostname", QString()), QHostInfo::localHostName());
-#endif
+ QCOMPARE(group.readEntry("hostname", QString()), QString("(hostname)")); // the $ got removed because empty var name
QVERIFY(group.hasKey("noeol"));
QCOMPARE(group.readEntry("noeol", QString()), QString("foo"));
}
--
cgit v1.1

View File

@ -0,0 +1,27 @@
From 02966e348e37ebf6269aaed238e7ce67fbe958e7 Mon Sep 17 00:00:00 2001
From: Hrvoje Senjan <hrvoje.senjan@gmail.com>
Date: Sun, 25 May 2014 00:36:08 +0200
Subject: [PATCH 1/1] Drop Nepomuk from KParts' LINK_INTERFACE_LIBRARIES
Nepomuk is only used in a private header, browserrun_p.h,
thus it is not needed as KParts public dependancy
Makes it possible to drop libsoprano-devel from libkde4-devel Requires
---
kparts/CMakeLists.txt | 1 -
1 file changed, 1 deletion(-)
diff --git a/kparts/CMakeLists.txt b/kparts/CMakeLists.txt
index 2eab2e8..e17ef5e 100644
--- a/kparts/CMakeLists.txt
+++ b/kparts/CMakeLists.txt
@@ -39,7 +39,6 @@ target_link_libraries(kparts ${KDE4_KDECORE_LIBS} kdeui kio)
target_link_libraries(kparts LINK_PUBLIC kio kdeui kdecore ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY} )
if(HAVE_NEPOMUK)
target_link_libraries(kparts LINK_PRIVATE nepomuk nepomukutils)
- target_link_libraries(kparts LINK_PUBLIC nepomuk nepomukutils )
endif(HAVE_NEPOMUK)
set_target_properties(kparts PROPERTIES VERSION ${GENERIC_LIB_VERSION}
--
1.9.3

View File

@ -0,0 +1,30 @@
--- kdelibs-4.14.38/CMakeLists.txt.orig 2020-09-19 19:49:40.542000000 +0200
+++ kdelibs-4.14.38/CMakeLists.txt 2020-09-19 19:27:03.401000000 +0200
@@ -122,17 +122,17 @@
PURPOSE "Enables KDE to be available in many different languages"
)
-macro_optional_find_package(Soprano 2.7.56 COMPONENTS PLUGIN_RAPTORPARSER PLUGIN_REDLANDBACKEND)
-set_package_properties(Soprano PROPERTIES DESCRIPTION "Support for the Nepomuk semantic desktop system"
- URL "http://soprano.sourceforge.net"
- TYPE OPTIONAL
- )
+#macro_optional_find_package(Soprano 2.7.56 COMPONENTS PLUGIN_RAPTORPARSER PLUGIN_REDLANDBACKEND)
+#set_package_properties(Soprano PROPERTIES DESCRIPTION "Support for the Nepomuk semantic desktop system"
+# URL "http://soprano.sourceforge.net"
+# TYPE OPTIONAL
+# )
-macro_optional_find_package(SharedDesktopOntologies 0.10)
-set_package_properties(SharedDesktopOntologies PROPERTIES DESCRIPTION "Support for the Nepomuk semantic desktop system"
- URL "http://oscaf.sourceforge.net"
- TYPE OPTIONAL
- )
+#macro_optional_find_package(SharedDesktopOntologies 0.10)
+#set_package_properties(SharedDesktopOntologies PROPERTIES DESCRIPTION "Support for the Nepomuk semantic desktop system"
+# URL "http://oscaf.sourceforge.net"
+# TYPE OPTIONAL
+# )
macro_optional_find_package(QCA2 2.0.0)
set_package_properties(QCA2 PROPERTIES DESCRIPTION "Support for remote plasma widgets"

View File

@ -0,0 +1,12 @@
diff -up kdelibs-4.14.38/dnssd/servicemodel.cpp.me kdelibs-4.14.38/dnssd/servicemodel.cpp
--- kdelibs-4.14.38/dnssd/servicemodel.cpp.me 2019-09-25 10:46:44.673557894 +0200
+++ kdelibs-4.14.38/dnssd/servicemodel.cpp 2019-09-25 10:56:35.515894652 +0200
@@ -87,7 +87,7 @@ QVariant ServiceModel::data(const QModel
case Host: return srv[index.row()]->hostName();
case Port: return srv[index.row()]->port();
}
- case ServicePtrRole: QVariant ret;
+ case int(ServicePtrRole): QVariant ret;
ret.setValue(srv[index.row()]);
return ret;
}

View File

@ -0,0 +1,100 @@
diff -up kdelibs-4.14.16/CMakeLists.txt.webkit kdelibs-4.14.16/CMakeLists.txt
--- kdelibs-4.14.16/CMakeLists.txt.webkit 2016-01-07 00:02:22.000000000 +0100
+++ kdelibs-4.14.16/CMakeLists.txt 2016-01-28 13:03:53.556194927 +0100
@@ -356,7 +356,6 @@ if(NOT WINCE)
add_subdirectory( plasma )
endif(NOT WINCE)
add_subdirectory( kunitconversion )
-add_subdirectory( kdewebkit )
add_subdirectory( includes )
add_subdirectory( experimental )
diff -up kdelibs-4.14.16/kdewidgets/CMakeLists.txt.webkit kdelibs-4.14.16/kdewidgets/CMakeLists.txt
--- kdelibs-4.14.16/kdewidgets/CMakeLists.txt.webkit 2016-01-28 13:03:53.527196020 +0100
+++ kdelibs-4.14.16/kdewidgets/CMakeLists.txt 2016-01-28 13:03:53.556194927 +0100
@@ -88,41 +88,6 @@ if(QT_QTDESIGNER_FOUND)
install(TARGETS kdedeprecated DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/designer )
endif(NOT KDE_NO_DEPRECATED)
-
- # kdewebkit widgets
- include_directories(
- ${CMAKE_SOURCE_DIR}/kdewebkit
- )
-
- add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kdewebkitwidgets.cpp
- COMMAND "${MAKEKDEWIDGETS_EXECUTABLE}" -o ${CMAKE_CURRENT_BINARY_DIR}/kdewebkitwidgets.cpp ${CMAKE_CURRENT_SOURCE_DIR}/kdewebkit.widgets
- MAIN_DEPENDENCY kdewebkit.widgets DEPENDS makekdewidgets)
-
- set(kdewebkitwidgets_PART_SRCS
- classpreviews.cpp
- ${CMAKE_CURRENT_BINARY_DIR}/kdewebkitwidgets.cpp
- )
-
- qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/kdewebkitwidgets.cpp ${CMAKE_CURRENT_BINARY_DIR}/kdewebkitwidgets.moc)
-
-
- qt4_add_resources(kdewebkitwidgets_PART_SRCS kdewebkitwidgets.qrc)
-
- kde4_add_plugin(kdewebkitwidgets ${kdewebkitwidgets_PART_SRCS})
-
- target_link_libraries(kdewebkitwidgets ${KDE4_KDEUI_LIBS} ${KDE4_KDEWEBKIT_LIBS} ${QT_QTWEBKIT_LIBRARY})
- if(NOT WIN32)
- set_target_properties(kdewebkitwidgets PROPERTIES
- INSTALL_RPATH_USE_LINK_PATH TRUE
- SKIP_BUILD_RPATH TRUE
- BUILD_WITH_INSTALL_RPATH TRUE
- INSTALL_RPATH ${LIB_INSTALL_DIR}
- )
- endif(NOT WIN32)
-
- install(TARGETS kdewebkitwidgets DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/designer )
-
-
if (QT_QT3SUPPORT_FOUND)
include_directories(
diff -up kdelibs-4.14.16/plasma/CMakeLists.txt.webkit kdelibs-4.14.16/plasma/CMakeLists.txt
--- kdelibs-4.14.16/plasma/CMakeLists.txt.webkit 2016-01-07 00:02:22.000000000 +0100
+++ kdelibs-4.14.16/plasma/CMakeLists.txt 2016-01-28 13:26:55.730137496 +0100
@@ -11,6 +11,7 @@ if(KDE_PLATFORM_FEATURE_BINARY_COMPATIBL
endif(KDE_PLATFORM_FEATURE_BINARY_COMPATIBLE_FEATURE_REDUCTION)
set(PLASMA_NO_PACKAGEKIT TRUE)
+set(PLASMA_NO_KDEWEBKIT TRUE)
include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${KDE4_KDECORE_INCLUDES}
@@ -121,7 +122,6 @@ set(plasma_LIB_SRCS
framesvg.cpp
plasma.cpp
popupapplet.cpp
- private/animablegraphicswebview.cpp
private/applethandle.cpp
private/associatedapplicationmanager.cpp
private/componentinstaller.cpp
@@ -211,7 +211,6 @@ set(plasma_LIB_SRCS
widgets/textbrowser.cpp
widgets/treeview.cpp
widgets/textedit.cpp
- widgets/webview.cpp
#Temporary QtJolie branch
private/qtjolie-branch/qtjolie/abstractadaptor.cpp
@@ -275,7 +274,7 @@ endif(PHONON_FOUND)
kde4_add_library(plasma ${LIBRARY_TYPE} ${plasma_LIB_SRCS})
-target_link_libraries(plasma LINK_PRIVATE ${QT_QTUITOOLS_LIBRARY} ${QT_QTWEBKIT_LIBRARY}
+target_link_libraries(plasma LINK_PRIVATE ${QT_QTUITOOLS_LIBRARY}
${QT_QTSCRIPT_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTSQL_LIBRARY} ${QT_QTDECLARATIVE_LIBRARY}
${KDE4_KDEUI_LIBS} ${KDE4_KDNSSD_LIBS} ${KDE4_THREADWEAVER_LIBS} ${PLASMA_EXTRA_LIBS})
@@ -415,7 +414,6 @@ install(FILES
widgets/textbrowser.h
widgets/treeview.h
widgets/textedit.h
- widgets/webview.h
DESTINATION ${INCLUDE_INSTALL_DIR}/plasma/widgets COMPONENT Devel)
install(FILES

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,19 @@
diff -up kdelibs-4.14.38/kimgio/jp2.cpp.me kdelibs-4.14.38/kimgio/jp2.cpp
--- kdelibs-4.14.38/kimgio/jp2.cpp.me 2020-08-27 17:41:44.809195175 +0200
+++ kdelibs-4.14.38/kimgio/jp2.cpp 2020-08-27 17:55:29.534742787 +0200
@@ -103,13 +103,13 @@ static void jas_stream_initbuf(jas_strea
stream->bufmode_ |= bufmode & JAS_STREAM_BUFMODEMASK;
}
-static int qiodevice_read(jas_stream_obj_t *obj, char *buf, int cnt)
+static int qiodevice_read(jas_stream_obj_t *obj, char *buf, unsigned int cnt)
{
QIODevice *io = (QIODevice*) obj;
return io->read(buf, cnt);
}
-static int qiodevice_write(jas_stream_obj_t *obj, char *buf, int cnt)
+static int qiodevice_write(jas_stream_obj_t *obj, char *buf, unsigned int cnt)
{
QIODevice *io = (QIODevice*) obj;
return io->write(buf, cnt);

11
kdelibs-4.14.38-qt4.patch Normal file
View File

@ -0,0 +1,11 @@
--- kdelibs-4.10.1/cmake/modules/FindQt4.cmake~ 2013-03-07 16:57:29.735552097 +0000
+++ kdelibs-4.10.1/cmake/modules/FindQt4.cmake 2013-03-07 16:57:52.038725421 +0000
@@ -446,7 +446,7 @@
# check for qmake
# Debian uses qmake-qt4
# macports' Qt uses qmake-mac
-FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake qmake4 qmake-qt4 qmake-mac PATHS
+FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake4 qmake-qt4 qmake-mac PATHS
"[HKEY_CURRENT_USER\\Software\\Trolltech\\Qt3Versions\\4.0.0;InstallDir]/bin"
"[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\4.0.0;InstallDir]/bin"
"[HKEY_CURRENT_USER\\Software\\Trolltech\\Versions\\${qt_install_version};InstallDir]/bin"

View File

@ -34,7 +34,7 @@
%endif
Name: kdelibs
Version: 4.14.38
Release: 1mamba
Release: 4mamba
Summary: KDE Software Compilation - Core Libraries
Group: Graphical Desktop/Libraries/KDE
Vendor: openmamba
@ -52,9 +52,19 @@ Patch5: kdelibs-4.14.15-upstream-backport-to-fix-kopete-crash.patch
Patch6: kdelibs-4.14.21-gcc-6.1.0-solid.patch
Patch7: kdelibs-4.14.21-gcc-6.1.0-1.patch
Patch8: kdelibs-4.14.21-gcc-6.1.0-2.patch
Patch9: kdelibs-4.14.38-qt4.patch
Patch10: kdelibs-4.14.38-openssl-1.1.patch
Patch11: kdelibs-4.14.38-no-kdewebkit.patch
Patch12: kdelibs-4.14.38-qiodevice.patch
Patch13: kdelibs-4.14.38-gcc-10.patch
Patch14: kdelibs-4.14.38-CVE-2019-14744.patch
Patch15: kdelibs-4.14.38-Drop-Nepomuk-from-KParts-LINK_INTERFACE_LIBRARIES.patch
Patch16: kdelibs-4.14.38-disable-soprano-nepomuk.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: ldconfig
BuildRequires: libHUpnp-devel
BuildRequires: libICE-devel
BuildRequires: libQtDeclarative
BuildRequires: libSM-devel
@ -76,21 +86,22 @@ BuildRequires: libattr-devel
BuildRequires: libbzip2-devel
BuildRequires: libdbusmenu-qt-devel
BuildRequires: libe2fs-devel
BuildRequires: libenchant-devel
BuildRequires: libenchant1-devel
BuildRequires: libgcc
BuildRequires: libgif-devel
BuildRequires: libhspell-devel
BuildRequires: libilmbase-devel
BuildRequires: libjasper-devel
BuildRequires: libjpeg-devel
BuildRequires: libkrb5-devel
BuildRequires: liblzma-devel
BuildRequires: libnsl-devel
BuildRequires: libopenexr-devel
BuildRequires: libopenssl-devel
BuildRequires: libpcre-devel
BuildRequires: libphonon-devel
BuildRequires: libphonon4-devel
BuildRequires: libpng-devel
BuildRequires: libpolkit-qt-1-devel
BuildRequires: libqca-devel
BuildRequires: libqca-qt4-devel
BuildRequires: libqt4-devel
BuildRequires: libsoprano-devel
BuildRequires: libstdc++6-devel
@ -110,13 +121,14 @@ BuildRequires: libxml2-utils
BuildRequires: gettext-devel
BuildRequires: hicolor-icon-theme
BuildRequires: hspell
BuildRequires: shared-desktop-ontologies >= 0.10.0
#BuildRequires: shared-desktop-ontologies >= 0.10.0
BuildRequires: avahi-compat-libdns_sd-devel
#BuildConflicts: libqt4-phonon-devel
BuildRequires: libgrantlee-devel
BuildRequires: libHUpnp-devel
BuildRequires: libdbusmenu-qt-devel
BuildRequires: media-player-info
BuildRequires: libsoprano-devel >= 1:2.9.4-2mamba
Obsoletes: kdelibs-experimental
Provides: kdelibs-experimental
Requires: libqt4 >= %_qt4_version
@ -134,6 +146,7 @@ Requires: upower
Requires: media-player-info
Provides: kdelibs4
Obsoletes: kdelibs4
Obsoletes: kwebkitpart
#Requires: /etc/ld.so.conf.d
BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -163,9 +176,7 @@ Obsoletes: kdelibs4-apidocs
%description apidocs
This package includes the KDE API documentation needed by the developers of KDE applications.
%ifnarch arm
%debug_package
%endif
%prep
%setup -q
@ -181,16 +192,24 @@ This package includes the KDE API documentation needed by the developers of KDE
#%patch6 -p1
%patch7 -p1
#%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
#%patch16 -p1
%build
#:<< _EOF
%if "%{stage1}" == "1"
# Can't use macros.kde4 as it is provided by this package
QTDIR="%{_qt4_prefix}" ; export QTDIR ; \
PATH="%{_qt4_bindir}:$PATH" ; export PATH ; \
CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
CXXFLAGS="${CXXFLAGS:-%optflags} -Wno-narrowing -std=gnu++98" ; export CXXFLAGS ; \
FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
# Can't use macros.kde4 as it is provided by this package
mkdir -p build ; cd build ; \
%{__cmake} \
%if "%{_lib}" == "lib64"
@ -212,10 +231,16 @@ This package includes the KDE API documentation needed by the developers of KDE
-DKDE_DEFAULT_HOME=".kde4"
%else
%cmake_kde4 -d build \
-Wno-dev \
-DCMAKE_CXX_FLAGS="%{optflags} -Wno-narrowing" \
-DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
-DWITH_FAM=OFF \
-DKDE_DISTRIBUTION_TEXT="%{_openmamba_release}" \
-DKDE_DEFAULT_HOME=".kde4"
-DKDE_DEFAULT_HOME=".kde4" \
-DKDE4_BUILD_TESTS=OFF \
-DHUPNP_ENABLED:BOOL=ON \
-DKIO_NO_SOPRANO:BOOL=ON \
-DWITH_SOLID_UDISKS2:BOOL=ON
%endif
%make
@ -267,6 +292,10 @@ echo "%{_kde4_libdir}" > %{buildroot}%{_sysconfdir}/ld.so.conf.d/kde4.conf
install -d %{buildroot}%{_sysconfdir}/rpm
cat %{S:1} | sed -e "s,@version@,%{version}," > %{buildroot}%{_sysconfdir}/rpm/macros.kde4
rm -f %{buildroot}%{_kde4_datadir}/kssl/ca-bundle.crt
ln -sf /etc/pki/tls/certs/ca-bundle.crt \
%{buildroot}%{_kde4_datadir}/kssl/ca-bundle.crt
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@ -313,7 +342,7 @@ exit 0
%{_kde4_libdir}/libkdefakes.so.*
%{_kde4_libdir}/libkdesu.so.*
%{_kde4_libdir}/libkdeui.so.*
%{_kde4_libdir}/libkdewebkit.so.*
#%{_kde4_libdir}/libkdewebkit.so.*
%{_kde4_libdir}/libkdnssd.so.*
%{_kde4_libdir}/libkemoticons.so.*
%{_kde4_libdir}/libkfile.so.*
@ -393,7 +422,7 @@ exit 0
%{_kde4_libdir}/libkdefakes.so
%{_kde4_libdir}/libkdesu.so
%{_kde4_libdir}/libkdeui.so
%{_kde4_libdir}/libkdewebkit.so
#%{_kde4_libdir}/libkdewebkit.so
%{_kde4_libdir}/libkdnssd.so
%{_kde4_libdir}/libkemoticons.so
%{_kde4_libdir}/libkfile.so
@ -436,6 +465,15 @@ exit 0
%{_kde4_htmldir}/en/kioslave/
%changelog
* Mon Sep 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.38-4mamba
- re-enable building nepomuk lib
* Wed Sep 16 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.38-3mamba
- obsolete kwebkitpart
* Sun Sep 13 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.38-2mamba
- rebuilt
* Wed Feb 13 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 4.14.38-1mamba
- update to 4.14.38
@ -769,7 +807,7 @@ exit 0
- update to 4.1.0
- use KDE_DEFAULT_HOME=".kde4" for now
* Thu Jun 10 2008 Aleph0 <aleph0@openmamba.org> 4.0.81-1mamba
* Tue Jun 10 2008 Aleph0 <aleph0@openmamba.org> 4.0.81-1mamba
- update to 4.0.81 (KDE4.1 beta2)
* Wed May 07 2008 Aleph0 <aleph0@openmamba.org> 4.0.4-1mamba
@ -795,7 +833,7 @@ exit 0
* Wed Nov 14 2007 Aleph0 <aleph0@openmamba.org> 3.95.2-1mamba
- update to 3.95.2
* Fri Oct 31 2007 Aleph0 <aleph0@openmamba.org> 3.95.0-1mamba
* Wed Oct 31 2007 Aleph0 <aleph0@openmamba.org> 3.95.0-1mamba
- update to 3.95.0 (KDE4 beta4)
* Mon Oct 29 2007 Aleph0 <aleph0@openmamba.org> 3.94.0-1mamba