remove compatibility cmake symlinks [release 0.3.1-2mamba;Sun Mar 03 2024]
This commit is contained in:
parent
16b53b8e2e
commit
ee5c508bdf
12
kcolorpicker-0.3.1-rename-qt5-version.patch
Normal file
12
kcolorpicker-0.3.1-rename-qt5-version.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 1d15048..a96250d 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -65,6 +65,7 @@ set_target_properties(kColorPicker
|
||||
RUNTIME_OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bin
|
||||
VERSION ${PROJECT_VERSION}
|
||||
SOVERSION 0
|
||||
+ OUTPUT_NAME kColorPicker-Qt5
|
||||
)
|
||||
|
||||
install(TARGETS kColorPicker
|
@ -1,6 +1,6 @@
|
||||
Name: kcolorpicker
|
||||
Version: 0.3.0
|
||||
Release: 3mamba
|
||||
Version: 0.3.1
|
||||
Release: 2mamba
|
||||
Summary: Qt based Color Picker with popup menu
|
||||
Group: Applications/Graphics
|
||||
Vendor: openmamba
|
||||
@ -8,6 +8,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/ksnip/kColorPicker
|
||||
Source: https://github.com/ksnip/kColorPicker.git/v%{version}/kColorPicker-%{version}.tar.bz2
|
||||
Patch0: kcolorpicker-0.3.1-rename-qt5-version.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -57,29 +58,28 @@ This package contains libraries and header files for developing applications tha
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n kColorPicker-%{version}
|
||||
%setup -q -c
|
||||
mv kColorPicker-%{version} %{name}-qt5
|
||||
cp -a %{name}-qt5 %{name}-qt6
|
||||
cd %{name}-qt5
|
||||
%patch 0 -p1 -b .rename-qt5-version
|
||||
|
||||
%build
|
||||
cd %{name}-qt5
|
||||
%cmake -d build
|
||||
%make
|
||||
cd ..
|
||||
|
||||
%cmake -d build-qt6 \
|
||||
cd ../../%{name}-qt6
|
||||
|
||||
%cmake -d build \
|
||||
-DBUILD_WITH_QT6=ON
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
%makeinstall -C build-qt6
|
||||
|
||||
# Symlinks for backwards compatibility
|
||||
mkdir -p %{buildroot}%{_libdir}/cmake/kColorPicker
|
||||
ln -s ../kColorPicker-Qt5/kColorPicker-Qt5Config.cmake %{buildroot}%{_libdir}/cmake/kColorPicker/kColorPickerConfig.cmake
|
||||
ln -s ../kColorPicker-Qt5/kColorPicker-Qt5Config-version.cmake %{buildroot}%{_libdir}/cmake/kColorPicker/kColorPickerConfig-version.cmake
|
||||
ln -s ../kColorPicker-Qt5/kColorPicker-Qt5-targets.cmake %{buildroot}%{_libdir}/cmake/kColorPicker/
|
||||
ln -s ../kColorPicker-Qt5/kColorPicker-Qt5-targets-noconfig.cmake %{buildroot}%{_libdir}/cmake/kColorPicker/
|
||||
%makeinstall -C %{name}-qt5/build
|
||||
%makeinstall -C %{name}-qt6/build
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -90,7 +90,7 @@ ln -s ../kColorPicker-Qt5/kColorPicker-Qt5-targets-noconfig.cmake %{buildroot}%{
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libkColorPicker-Qt5.so.*
|
||||
%doc LICENSE
|
||||
%doc %{name}-qt5/LICENSE
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
@ -98,26 +98,30 @@ ln -s ../kColorPicker-Qt5/kColorPicker-Qt5-targets-noconfig.cmake %{buildroot}%{
|
||||
%dir %{_includedir}/kColorPicker-Qt5/kColorPicker
|
||||
%{_includedir}/kColorPicker-Qt5/kColorPicker/*
|
||||
%{_libdir}/libkColorPicker-Qt5.so
|
||||
%dir %{_libdir}/cmake/kColorPicker
|
||||
%{_libdir}/cmake/kColorPicker/kColorPicker*.cmake
|
||||
%dir %{_libdir}/cmake/kColorPicker-Qt5
|
||||
%{_libdir}/cmake/kColorPicker-Qt5/kColorPicker*.cmake
|
||||
%doc README.md
|
||||
%doc %{name}-qt5/README.md
|
||||
|
||||
%files -n lib%{name}-qt6
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libkColorPicker-Qt6.so.*
|
||||
%doc LICENSE
|
||||
%{_libdir}/libkColorPicker.so.*
|
||||
%doc %{name}-qt6/LICENSE
|
||||
|
||||
%files -n lib%{name}-qt6-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/kColorPicker-Qt6/kColorPicker
|
||||
%{_includedir}/kColorPicker-Qt6/kColorPicker/*
|
||||
%dir %{_libdir}/cmake/kColorPicker-Qt6
|
||||
%{_libdir}/cmake/kColorPicker-Qt6/kColorPicker-Qt6*.cmake
|
||||
%{_libdir}/libkColorPicker-Qt6.so
|
||||
%{_libdir}/cmake/kColorPicker-Qt6/kColorPicker-*.cmake
|
||||
%{_libdir}/libkColorPicker.so
|
||||
|
||||
%changelog
|
||||
* Sun Mar 03 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.1-2mamba
|
||||
- remove compatibility cmake symlinks
|
||||
|
||||
* Sun Mar 03 2024 Automatic Build System <autodist@openmamba.org> 0.3.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 27 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.0-3mamba
|
||||
- further fix of legacy symlinks
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user