automatic version update by autodist [release 2.0.1-1mamba;Mon Nov 18 2013]

This commit is contained in:
Automatic Build System 2024-01-06 00:38:24 +01:00
parent 71424a5882
commit 92715e3ea3
6 changed files with 394 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# kbd
The kbd package contains tools for managing a Linux system's console's behavior, including the keyboard, the screen fonts, the virtual terminals and font files.

View File

@ -0,0 +1,55 @@
# DIY Linux Patch
Date: 2005-08-26
Author: Refer Origin
Origin: http://cvs.fedora.redhat.com/viewcvs/*checkout*/devel/kbd/kbd-1.12-alias.patch?rev=1.2
Maker: Greg Schafer <gschafer@zip.com.au>
Upstream Status: Sent 2005-08-26, waiting..
Description: Make `setfont' work when compiled with GCC4.
diff -Naur kbd-1.12.orig/src/psffontop.c kbd-1.12/src/psffontop.c
--- kbd-1.12.orig/src/psffontop.c 2004-01-16 19:45:31.000000000 +0000
+++ kbd-1.12/src/psffontop.c 2005-08-26 10:36:55.000000000 +0000
@@ -59,7 +59,6 @@
static unsigned int
assemble_ucs2(char **inptr, int cnt) {
- unsigned char **in = (unsigned char **) inptr;
unsigned int u1, u2;
if (cnt < 2) {
@@ -68,8 +67,8 @@
exit(EX_DATAERR);
}
- u1 = *(*in)++;
- u2 = *(*in)++;
+ u1 = (unsigned char)*(*inptr)++;
+ u2 = (unsigned char)*(*inptr)++;
return (u1 | (u2 << 8));
}
@@ -110,7 +109,6 @@
*/
static void
get_uni_entry(char **inptr, char **endptr, struct unicode_list *up, int utf8) {
- unsigned char **in = (unsigned char **) inptr;
unsigned char uc;
unicode unichar;
int inseq = 0;
@@ -126,14 +124,14 @@
exit(EX_DATAERR);
}
if (utf8) {
- uc = *(*in)++;
+ uc = *(*inptr)++;
if (uc == PSF2_SEPARATOR)
break;
if (uc == PSF2_STARTSEQ) {
inseq = 1;
continue;
}
- --(*in);
+ --(*inptr);
unichar = assemble_utf8(inptr, *endptr - *inptr);
} else {
unichar = assemble_ucs2(inptr, *endptr - *inptr);

157
kbd-1.12-it-macbook.patch Normal file
View File

@ -0,0 +1,157 @@
diff -Nru kbd-1.12.orig/data/keymaps/i386/qwerty/it-macbook.map kbd-1.12/data/keymaps/i386/qwerty/it-macbook.map
--- kbd-1.12.orig/data/keymaps/i386/qwerty/it-macbook.map 1970-01-01 01:00:00.000000000 +0100
+++ kbd-1.12/data/keymaps/i386/qwerty/it-macbook.map 2006-10-02 22:03:56.000000000 +0200
@@ -0,0 +1,153 @@
+# Italian keymap with emacs enhancements
+# Beta version Mon May 2 19:57:25 WET DST 1994
+# Available for anon. ftp at cnuce_arch.cnr.it:/pub/Linux-local/kbd/it.map
+#
+# Based on all other keymaps available in Slackware-1.2.0.
+#
+# '@', '#', '[', and ']' are obtained by AltGr with the appropriate key.
+#
+# I have added '{', '}', '~', '`', iacute and uacute.
+# They can be obtained by AltGr-(, AltGr-), AltGr-=, AltGr-', AltGr-igrave
+# and AltGr-ugrave respectively.
+#
+# I have also added most Alt-Shift and Ctrl-Alt codes needed for emacs
+# with the standard keymap of the fundamental mode.
+#
+# Place in your ~/.emacs the following two lines:
+# (standard-display-european t)
+# (set-input-mode nil nil 1)
+#
+# Place in your /usr/lib/X11/Xconfig:
+# LeftAlt Meta
+# RightAlt ModeShift
+#
+# To use high characters with other programs, read the documentation ;-)
+# Please report all bugs and improvement proposals to the address below.
+#
+# Buona fortuna,
+# Dario Besseghini <besseghi@dm.unipi.it>
+#
+keymaps 0-2,4,6,8-9,12
+include "linux-with-alt-and-altgr"
+strings as usual
+
+keycode 1 = Escape Escape
+ alt keycode 1 = Meta_Escape
+keycode 2 = one exclam
+ alt keycode 2 = Meta_one
+ shift alt keycode 2 = Meta_exclam
+keycode 3 = two quotedbl
+ control keycode 3 = nul
+ alt keycode 3 = Meta_two
+ control alt keycode 3 = Meta_nul
+keycode 4 = three sterling
+ control keycode 4 = Escape
+ alt keycode 4 = Meta_three
+ control alt keycode 4 = Meta_Escape
+keycode 5 = four dollar
+ control keycode 5 = Control_backslash
+ alt keycode 5 = Meta_four
+ shift alt keycode 5 = Meta_dollar
+ control alt keycode 5 = Meta_Control_backslash
+keycode 6 = five percent
+ control keycode 6 = Control_bracketright
+ alt keycode 6 = Meta_five
+ shift alt keycode 6 = Meta_percent
+keycode 7 = six ampersand
+ control keycode 7 = Control_asciicircum
+ alt keycode 7 = Meta_six
+keycode 8 = seven slash
+ control keycode 8 = Control_underscore
+ alt keycode 8 = Meta_seven
+ shift alt keycode 8 = Meta_slash
+keycode 9 = eight parenleft braceleft
+ control keycode 9 = Delete
+ alt keycode 9 = Meta_eight
+ shift alt keycode 9 = Meta_parenleft
+ control alt keycode 9 = Meta_Delete
+keycode 10 = nine parenright braceright
+ alt keycode 10 = Meta_nine
+ shift alt keycode 10 = Meta_parenright
+keycode 11 = zero equal asciitilde
+ alt keycode 11 = Meta_zero
+ shift alt keycode 11 = Meta_equal
+keycode 12 = apostrophe question grave
+ control keycode 12 = Delete
+ alt keycode 12 = Meta_minus
+ control alt keycode 12 = Meta_Delete
+keycode 13 = igrave asciicircum iacute
+ control keycode 13 = Control_asciicircum
+ alt keycode 13 = Meta_equal
+ shift alt keycode 13 = Meta_asciicircum
+keycode 14 = Delete Delete
+ control keycode 14 = Control_underscore
+ alt keycode 14 = Meta_Delete
+keycode 15 = Tab Tab
+ alt keycode 15 = Meta_Tab
+keycode 16 = q
+keycode 17 = w
+keycode 18 = e
+keycode 19 = r
+keycode 20 = t
+keycode 21 = y
+keycode 22 = u
+keycode 23 = i
+keycode 24 = o
+keycode 25 = p
+keycode 26 = egrave eacute bracketleft
+ control keycode 26 = Escape
+ alt keycode 26 = Meta_bracketleft
+keycode 27 = plus asterisk bracketright
+ control keycode 27 = Control_bracketright
+ alt keycode 27 = Meta_bracketright
+keycode 28 = Return
+ alt keycode 28 = Meta_Control_m
+keycode 29 = Control
+keycode 30 = a
+keycode 31 = s
+keycode 32 = d
+keycode 33 = f
+keycode 34 = g
+keycode 35 = h
+keycode 36 = j
+keycode 37 = k
+keycode 38 = l
+keycode 39 = ograve ccedilla at
+ control keycode 39 = nul
+ alt keycode 39 = Meta_at
+ control alt keycode 39 = Meta_nul
+keycode 40 = agrave degree numbersign
+ control keycode 40 = Control_g
+keycode 41 = backslash bar
+ control keycode 41 = Control_backslash
+ alt keycode 41 = Meta_backslash
+ shift alt keycode 41 = Meta_bar
+keycode 42 = Shift
+keycode 43 = ugrave section uacute
+keycode 44 = z
+keycode 45 = x
+keycode 46 = c
+keycode 47 = v
+keycode 48 = b
+keycode 49 = n
+keycode 50 = m
+keycode 51 = comma semicolon
+ alt keycode 51 = Meta_comma
+ shift alt keycode 51 = Meta_semicolon
+keycode 52 = period colon
+ alt keycode 52 = Meta_period
+keycode 53 = minus underscore
+ control keycode 53 = Control_underscore
+ alt keycode 53 = Meta_minus
+keycode 54 = Shift
+keycode 56 = Alt
+keycode 57 = space
+ control keycode 57 = nul
+ alt keycode 57 = Meta_space
+ control alt keycode 57 = Meta_nul
+keycode 58 = Caps_Lock
+keycode 86 = less greater
+ alt keycode 86 = Meta_less
+ shift alt keycode 86 = Meta_greater
+keycode 97 = Control
+keycode 126 = AltGr

View File

@ -0,0 +1,18 @@
Submitted By: Jonathan Norman <jonathan dot bluesquarelinux.co.uk>
Date: 2011-05-17
Initial Package Version: 1.15.3
Origin: Arch Linux
Upstream Status: Unknown
Description: Fixes mistake in es.po file.
--- kbd-1.15.3/po/es.old 2011-05-14 23:12:49.000000000 +0200
+++ kbd-1.15.3/po/es.po 2011-05-15 21:07:02.120669404 +0200
@@ -1363,7 +1363,7 @@
#: src/setfont.c:682
#, c-format
msgid "Saved %d-char %dx%d font file on %s\n"
-msgstr "Se ha guardado el fichero de tipos %2$dx%3$d de %1$d caracteres en %s\n"
+msgstr "Se ha guardado el fichero de tipos %dx%d de %d caracteres en %s\n"
#: src/setkeycodes.c:21
#, c-format

9
kbd-sysconfig-console Normal file
View File

@ -0,0 +1,9 @@
#
# kbd console configuration file
#
# Load the following font at boot time and apply to all ttys
CONSOLE_FONT="lat9w-16.psfu"
# Specify a unicode map for fonts that don't have one internal (.psfu have it)
CONSOLE_UNICODEMAP=""

153
kbd.spec Normal file
View File

@ -0,0 +1,153 @@
Name: kbd
Version: 2.0.1
Release: 1mamba
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
Group: System/Kernel and Hardware
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
#URL: http://www.kernel.org/pub/linux/utils/kbd/
URL: http://www.kernel.org
#http://www.kernel.org/pub/linux/utils/kbd/%{name}-%{version}.tar.bz2
Source: ftp://devel.altlinux.org/legion/kbd/kbd-%{version}.tar.gz
Source2: kbd-sysconfig-console
Patch0: kbd-1.12-gcc4-fixes-1.patch
Patch1: kbd-1.12-it-macbook.patch
Patch2: kbd-1.15.3-es.po_fix-1.patch
Requires: initscripts
License: GPL
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
%description
The kbd package contains tools for managing a Linux system's console's behavior, including the keyboard, the screen fonts, the virtual terminals and font files.
%prep
%setup -q
#%patch0 -p1
%patch1 -p1
#%patch2 -p1
%if %{_target_cpu} != "i586"
sed -i "s|resizecons\.c||" src/Makefile.in
sed -i "s|resizecons||" src/Makefile.in
%endif
%build
%configure
# \
# --prefix=%{_prefix} \
# --datadir=%{_datadir}/%{name}
%make CC=%{_target_platform}-gcc
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%makeinstall
install -d %{buildroot}/bin
mv %{buildroot}%{_bindir}/unicode_{start,stop} \
%{buildroot}/bin
# see FHS 2.3
install -d %{buildroot}/sbin
mv %{buildroot}%{_bindir}/kbdrate \
%{buildroot}/sbin
install -D -m 0644 %{S:2} \
%{buildroot}%{_sysconfdir}/sysconfig/console
%find_lang %{name}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files -f %{name}.lang
%defattr(-,root,root)
%config %{_sysconfdir}/sysconfig/console
/bin/*
/sbin/kbdrate
%{_bindir}/*
%dir %{_datadir}/consolefonts
%{_datadir}/consolefonts/*
%dir %{_datadir}/consoletrans
%{_datadir}/consoletrans/*
%dir %{_datadir}/keymaps
%{_datadir}/keymaps/*
%dir %{_datadir}/unimaps
%{_datadir}/unimaps/*
%{_mandir}/man?/*
%doc COPYING
%changelog
* Mon Nov 18 2013 Automatic Build System <autodist@mambasoft.it> 2.0.1-1mamba
- automatic version update by autodist
* Tue Aug 20 2013 Automatic Build System <autodist@mambasoft.it> 2.0.0-1mamba
- automatic version update by autodist
* Sat Dec 15 2012 Automatic Build System <autodist@mambasoft.it> 1.15.5-1mamba
- automatic version update by autodist
* Mon Apr 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.3-5mamba
- require initscript, not prereq
* Mon Dec 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.3-4mamba
- remove post code for creating /etc/vconsole.conf moved to initscripts package
* Wed Nov 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.3-3mamba
- remove kbd initscript to let console init be managed by initscripts package
* Thu Sep 01 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.3-2mamba
- create file /etc/vconsole.conf using /etc/sysconfig/keyboard and /etc/sysconfig/console which will get obsoleted
- initscript: use /etc/vconsole.conf instead of /etc/sysconfig/keyboard and /etc/sysconfig/console
* Sun Jun 05 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15.3-1mamba
- update to 1.15.3
- initscript: export LC_ALL=$LANG
* Fri Jun 25 2010 Automatic Build System <autodist@mambasoft.it> 1.15.2-1mamba
- automatic update by autodist
* Wed Jan 21 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.15-1mamba
- update to 1.15
* Tue Mar 11 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-11mamba
- initscript: removed splash repaint no longer useful
- specfile updates
* Sat Feb 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-10qilnx
- initscript: initialize only tty0-5
* Mon Nov 20 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-9qilnx
- it-macbook: fix for 2.6.18.3 kernel
* Mon Oct 02 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-8qilnx
- added map for macbook italian keyboard (it-macbook)
* Tue Jun 27 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.12-7qilnx
- fixed to avoid installation of binary file in /etc
* Thu Mar 23 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-6qilnx
- rebuild
* Wed Feb 08 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-5qilnx
- added initscript prereq
* Tue Feb 07 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-4qilnx
- move datadir files to /usr/share/kbd
- add kbd initscript with unicode support
* Tue Sep 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12-3qilnx
- cross platform build support added
* Mon Apr 04 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.12-2qilnx
- fixed path for kbdrate (FHS 2.3 specifications)
* Thu Oct 28 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.12-1qilnx
- update to version 1.12 by autospec
* Sun Apr 27 2003 Silvan Calarco <silvan.calarco@qinet.it>
- fixed datadir configure
* Mon Apr 07 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it>
- Creation of kbd package