automatic version update by autodist [release 4.13.0-1mamba;Wed Apr 23 2014]
This commit is contained in:
parent
bef710b5d5
commit
2ae9d45944
@ -1,2 +1,5 @@
|
|||||||
# kate
|
# kate
|
||||||
|
|
||||||
|
A fast and advanced text editor, extensible with nice plugins.
|
||||||
|
This package is part of KDE4.
|
||||||
|
|
||||||
|
11
kate-4.10.0-python-2.6.patch
Normal file
11
kate-4.10.0-python-2.6.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- kate-4.10.0/kate/plugins/pate/src/engine.cpp.orig 2013-02-16 12:38:38.511115875 +0100
|
||||||
|
+++ kate-4.10.0/kate/plugins/pate/src/engine.cpp 2013-02-16 12:37:41.919587402 +0100
|
||||||
|
@@ -195,7 +195,7 @@
|
||||||
|
bool Pate::Engine::init()
|
||||||
|
{
|
||||||
|
kDebug() << "Construct the Python engine for Python" << PY_MAJOR_VERSION << PY_MINOR_VERSION;
|
||||||
|
- if (0 != PyImport_AppendInittab(Python::PATE_ENGINE, PATE_INIT)) {
|
||||||
|
+ if (0 != PyImport_AppendInittab((char*)Python::PATE_ENGINE, PATE_INIT)) {
|
||||||
|
kError() << "Cannot extend inittab";
|
||||||
|
return false;
|
||||||
|
}
|
214
kate.spec
Normal file
214
kate.spec
Normal file
@ -0,0 +1,214 @@
|
|||||||
|
Name: kate
|
||||||
|
Version: 4.13.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A fast and advanced text editor
|
||||||
|
Group: Graphical Desktop/Applications/Development
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.kde.org/
|
||||||
|
Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kate-%{version}.tar.xz
|
||||||
|
Patch0: kate-4.10.0-python-2.6.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: kdelibs-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libsoprano-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
A fast and advanced text editor, extensible with nice plugins.
|
||||||
|
This package is part of KDE4.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for for Kate
|
||||||
|
Group: Development/Applications
|
||||||
|
Requires: kate = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
Kate editor development headers.
|
||||||
|
This package is part of KDE4.
|
||||||
|
|
||||||
|
%package -n kwrite
|
||||||
|
Summary: K Desktop Enviroment - KDE Text Editor
|
||||||
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
|
|
||||||
|
%description -n kwrite
|
||||||
|
KWrite is a text editor of the K desktop environment.
|
||||||
|
This package is part of KDE4.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake_kde4 -d build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
# workaround:
|
||||||
|
install -d -m0755 %{buildroot}%{python_sitearch}
|
||||||
|
mv %{buildroot}%{_kde4_libdir}/python*/site-packages/PyKate4 \
|
||||||
|
%{buildroot}%{python_sitearch}/
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -n kwrite
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_kde4_bindir}/kwrite
|
||||||
|
%{_kde4_datadir}/kwrite
|
||||||
|
%{_kde4_libdir}/libkdeinit4_kwrite.so
|
||||||
|
%{_kde4_xdgappsdir}/kwrite.desktop
|
||||||
|
%doc %lang(en) %{_kde4_htmldir}/en/kwrite/*
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_kde4_bindir}/kate
|
||||||
|
%{_kde4_configdir}/katerc
|
||||||
|
%{_kde4_configdir}/katemoderc
|
||||||
|
%{_kde4_configdir}/kateschemarc
|
||||||
|
%{_kde4_configdir}/katesyntaxhighlightingrc
|
||||||
|
%{_kde4_configdir}/ktexteditor_codesnippets_core.knsrc
|
||||||
|
%{_kde4_datadir}/kate
|
||||||
|
%{_kde4_datadir}/katepart
|
||||||
|
%{_kde4_datadir}/katexmltools
|
||||||
|
%{_kde4_datadir}/ktexteditor_*
|
||||||
|
%{_kde4_kconfupdatedir}/kate-2.4.upd
|
||||||
|
%{_kde4_libdir}/kde4/kate*.so
|
||||||
|
%{_kde4_libdir}/kde4/plasma_applet_katesession.so
|
||||||
|
%{_kde4_libdir}/kde4/ktexteditor_*.so
|
||||||
|
#%{_kde4_libdir}/kde4/pateplugin.so
|
||||||
|
%{_kde4_libdir}/libkateinterfaces.so.*
|
||||||
|
%{_kde4_libdir}/libkatepartinterfaces.so.*
|
||||||
|
%{_kde4_libdir}/libkdeinit4_kate.so
|
||||||
|
%dir %{python_sitearch}/PyKate4
|
||||||
|
%{python_sitearch}/PyKate4/__init__.py
|
||||||
|
%{python_sitearch}/PyKate4/kate.so
|
||||||
|
%{_kde4_servicesdir}/kate*.desktop
|
||||||
|
%{_kde4_servicesdir}/pate.desktop
|
||||||
|
%{_kde4_servicesdir}/plasma-applet-katesession.desktop
|
||||||
|
%{_kde4_servicesdir}/ktexteditor_*.desktop
|
||||||
|
%{_kde4_servicetypesdir}/kateplugin.desktop
|
||||||
|
%{_kde4_servicetypesdir}/katepythonplugin.desktop
|
||||||
|
%{_kde4_xdgappsdir}/kate.desktop
|
||||||
|
%{_kde4_icondir}/*/*/apps/kate.png
|
||||||
|
%{_kde4_icondir}/*/scalable/apps/*.svgz
|
||||||
|
%{_kde4_icondir}/hicolor/*/actions/debug-kategdb.png
|
||||||
|
%{_mandir}/man1/kate.*
|
||||||
|
%doc %lang(en) %{_kde4_htmldir}/en/kate
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_kde4_includedir}/kate
|
||||||
|
%{_kde4_includedir}/kate/*
|
||||||
|
%{_kde4_includedir}/kate_export.h
|
||||||
|
%{_kde4_libdir}/libkateinterfaces.so
|
||||||
|
%{_kde4_libdir}/libkatepartinterfaces.so
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Apr 23 2014 Automatic Build System <autodist@mambasoft.it> 4.13.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Apr 03 2014 Automatic Build System <autodist@mambasoft.it> 4.12.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Mar 05 2014 Automatic Build System <autodist@mambasoft.it> 4.12.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Feb 09 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.12.2-1mamba
|
||||||
|
- update to 4.12.2
|
||||||
|
|
||||||
|
* Tue Jan 14 2014 Automatic Build System <autodist@mambasoft.it> 4.12.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Dec 19 2013 Automatic Build System <autodist@mambasoft.it> 4.12.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Dec 05 2013 Automatic Build System <autodist@mambasoft.it> 4.11.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Nov 06 2013 Automatic Build System <autodist@mambasoft.it> 4.11.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Oct 02 2013 Automatic Build System <autodist@mambasoft.it> 4.11.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Sep 04 2013 Automatic Build System <autodist@mambasoft.it> 4.11.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Aug 16 2013 Automatic Build System <autodist@mambasoft.it> 4.11.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Jul 02 2013 Automatic Build System <autodist@mambasoft.it> 4.10.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jun 06 2013 Automatic Build System <autodist@mambasoft.it> 4.10.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.10.3-2mamba
|
||||||
|
- python 2.7 rebuild
|
||||||
|
|
||||||
|
* Wed May 08 2013 Automatic Build System <autodist@mambasoft.it> 4.10.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Apr 03 2013 Automatic Build System <autodist@mambasoft.it> 4.10.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 05 2013 Automatic Build System <autodist@mambasoft.it> 4.10.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Feb 17 2013 Automatic Build System <autodist@mambasoft.it> 4.10.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 4.9.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Dec 05 2012 Automatic Build System <autodist@mambasoft.it> 4.9.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Nov 08 2012 Automatic Build System <autodist@mambasoft.it> 4.9.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Oct 04 2012 Automatic Build System <autodist@mambasoft.it> 4.9.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 06 2012 Automatic Build System <autodist@mambasoft.it> 4.9.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 15 2012 Automatic Build System <autodist@mambasoft.it> 4.9.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jun 10 2012 Automatic Build System <autodist@mambasoft.it> 4.8.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat May 05 2012 Automatic Build System <autodist@mambasoft.it> 4.8.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sat Apr 07 2012 Automatic Build System <autodist@mambasoft.it> 4.8.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Mar 27 2012 Automatic Build System <autodist@mambasoft.it> 4.8.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Dec 11 2011 Automatic Build System <autodist@mambasoft.it> 4.7.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Nov 03 2011 Automatic Build System <autodist@mambasoft.it> 4.7.3-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Oct 14 2011 Automatic Build System <autodist@mambasoft.it> 4.7.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 08 2011 Automatic Build System <autodist@mambasoft.it> 4.7.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 31 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 4.7.0-1mamba
|
||||||
|
- package created from kdesdk4
|
Loading…
Reference in New Issue
Block a user