update to 2.0.2 [release 2.0.2-1mamba;Sat Jun 11 2016]
This commit is contained in:
parent
19af76c405
commit
7be1302382
11
kaffeine-1.3.1-cmake-3.4.0.patch
Normal file
11
kaffeine-1.3.1-cmake-3.4.0.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- kaffeine-1.3.1/CMakeLists.txt.orig 2015-11-25 21:38:13.346064201 +0100
|
||||||
|
+++ kaffeine-1.3.1/CMakeLists.txt 2015-11-25 21:37:49.592267869 +0100
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
-DQT_NO_URL_CAST_FROM_STRING -DQT_STRICT_ITERATORS)
|
||||||
|
endif(STRICT_BUILD)
|
||||||
|
|
||||||
|
-check_include_files(${CMAKE_CURRENT_SOURCE_DIR}/include/frontend.h HAVE_DVB)
|
||||||
|
+check_include_file(${CMAKE_CURRENT_SOURCE_DIR}/include/frontend.h HAVE_DVB)
|
||||||
|
|
||||||
|
if(NOT HAVE_DVB)
|
||||||
|
MESSAGE(STATUS "Disabled features:\nDVB Digital television support for Linux\n")
|
@ -1,26 +1,44 @@
|
|||||||
%define require_libdvdcss 0
|
%define require_libdvdcss 0
|
||||||
|
|
||||||
Name: kaffeine
|
Name: kaffeine
|
||||||
Version: 1.2.2
|
Version: 2.0.2
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: A Media Player for KDE 4
|
Summary: A Media Player for KDE 4
|
||||||
Group: Graphical Desktop/Applications/Multimedia
|
Group: Graphical Desktop/Applications/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||||
URL: http://kaffeine.sourceforge.net
|
URL: http://kaffeine.sourceforge.net
|
||||||
Source: http://downloads.sourceforge.net/kaffeine/kaffeine-%{version}.tar.gz
|
Source: http://download.kde.org/stable/kaffeine/%{version}/src/kaffeine-%{version}.tar.xz
|
||||||
Patch0: kaffeine-1.2.2-gcc-4.7.patch
|
Patch0: kaffeine-1.2.2-gcc-4.7.patch
|
||||||
|
Patch1: kaffeine-1.3.1-cmake-3.4.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: kdelibs-devel
|
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libqt4-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libxine1-devel
|
|
||||||
BuildRequires: libXScrnSaver-devel
|
BuildRequires: libXScrnSaver-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libkauth-devel
|
||||||
|
BuildRequires: libkbookmarks-devel
|
||||||
|
BuildRequires: libkcodecs-devel
|
||||||
|
BuildRequires: libkcompletion-devel
|
||||||
|
BuildRequires: libkconfig-devel
|
||||||
|
BuildRequires: libkconfigwidgets-devel
|
||||||
|
BuildRequires: libkcoreaddons-devel
|
||||||
|
BuildRequires: libkdbusaddons-devel
|
||||||
|
BuildRequires: libki18n-devel
|
||||||
|
BuildRequires: libkidletime-devel
|
||||||
|
BuildRequires: libkio-devel
|
||||||
|
BuildRequires: libkitemviews-devel
|
||||||
|
BuildRequires: libkjobwidgets-devel
|
||||||
|
BuildRequires: libknotifications-devel
|
||||||
|
BuildRequires: libkservice-devel
|
||||||
|
BuildRequires: libkwidgetsaddons-devel
|
||||||
|
BuildRequires: libkxmlgui-devel
|
||||||
|
BuildRequires: libqt5-devel
|
||||||
|
BuildRequires: libsolid-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libv4l-devel
|
||||||
|
BuildRequires: libvlc-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libphonon-devel
|
BuildRequires: libphonon-devel
|
||||||
%if %require_libdvdcss
|
%if %require_libdvdcss
|
||||||
@ -41,10 +59,11 @@ Bookmarks and playlist are available.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake_kde4 -d build
|
%cmake_kde5 -d build
|
||||||
%make
|
%make
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -58,35 +77,42 @@ Bookmarks and playlist are available.
|
|||||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
%post
|
%post
|
||||||
touch --no-create %{_kde4_icondir}/hicolor &>/dev/null
|
touch --no-create %{_kde5_icondir}/hicolor &>/dev/null
|
||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
if [ $1 -eq 0 ] ; then
|
if [ $1 -eq 0 ] ; then
|
||||||
update-desktop-database -q &>/dev/null
|
update-desktop-database -q &>/dev/null
|
||||||
touch --no-create %{_kde4_icondir}/hicolor &>/dev/null
|
touch --no-create %{_kde5_icondir}/hicolor &>/dev/null
|
||||||
gtk-update-icon-cache %{_kde4_icondir}/hicolor &>/dev/null
|
gtk-update-icon-cache %{_kde5_icondir}/hicolor &>/dev/null
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%posttrans
|
%posttrans
|
||||||
update-desktop-database -q &>/dev/null
|
update-desktop-database -q &>/dev/null
|
||||||
gtk-update-icon-cache %{_kde4_icondir}/hicolor &>/dev/null
|
gtk-update-icon-cache %{_kde5_icondir}/hicolor &>/dev/null
|
||||||
|
|
||||||
%files -f kaffeine.lang
|
%files -f kaffeine.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_kde4_bindir}/kaffeine
|
%{_kde5_bindir}/dtvdaemon
|
||||||
%{_kde4_bindir}/kaffeine-xbu
|
%{_kde5_bindir}/kaffeine
|
||||||
%dir %{_kde4_datadir}/kaffeine
|
%dir %{_kde5_datadir}/kaffeine
|
||||||
%{_kde4_datadir}/kaffeine/scanfile.dvb
|
%{_kde5_datadir}/kaffeine/scanfile.dvb
|
||||||
%{_kde4_datadir}/profiles/kaffeine.profile.xml
|
%{_kde5_datadir}/profiles/kaffeine.profile.xml
|
||||||
%{_kde4_xdgappsdir}/kaffeine.desktop
|
%{_kde5_xdgappsdir}/org.kde.kaffeine.desktop
|
||||||
%{_kde4_datadir}/solid/actions/kaffeine_play*.desktop
|
%{_kde5_datadir}/appdata/org.kde.kaffeine.appdata.xml
|
||||||
%{_kde4_icondir}/hicolor/*/apps/kaffeine.png
|
%{_kde5_datadir}/solid/actions/kaffeine_play*.desktop
|
||||||
%{_kde4_icondir}/hicolor/scalable/apps/kaffeine.svgz
|
%{_kde5_icondir}/hicolor/*/apps/kaffeine.png
|
||||||
%{_kde4_icondir}/oxygen/*/actions/*.png
|
%{_kde5_icondir}/hicolor/scalable/apps/kaffeine.svgz
|
||||||
|
%{_kde5_icondir}/hicolor/*/actions/*.png
|
||||||
%doc COPYING Changelog NOTES
|
%doc COPYING Changelog NOTES
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jun 11 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.2-1mamba
|
||||||
|
- update to 2.0.2
|
||||||
|
|
||||||
|
* Thu Nov 26 2015 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Jan 21 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.2-3mamba
|
* Mon Jan 21 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.2-3mamba
|
||||||
- remove InitialPreference to make kaffeine no longer the default player
|
- remove InitialPreference to make kaffeine no longer the default player
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user