automatic version update by autodist [release 24.08.0-1mamba;Fri Aug 30 2024]
This commit is contained in:
parent
dd9766a8c3
commit
ab3085ce81
28
k3b-24.08.0-kf6-kio-6.5.0.patch
Normal file
28
k3b-24.08.0-kf6-kio-6.5.0.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
--- k3b-24.08.0/src/k3bmusicbrainz.cpp.orig 2024-08-31 11:58:00.315944063 +0200
|
||||||
|
+++ k3b-24.08.0/src/k3bmusicbrainz.cpp 2024-08-31 11:58:07.177958260 +0200
|
||||||
|
@@ -44,11 +44,6 @@
|
||||||
|
d->titles.clear();
|
||||||
|
d->artists.clear();
|
||||||
|
|
||||||
|
- if( KProtocolManager::useProxy() ) {
|
||||||
|
- QUrl proxy( KProtocolManager::proxyFor("http") );
|
||||||
|
- mb_SetProxy( d->mb, const_cast<char*>(proxy.host().toLatin1().constData()), short(proxy.port()) );
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
const char* args[2];
|
||||||
|
args[0] = trm.data();
|
||||||
|
args[1] = 0;
|
||||||
|
--- k3b-24.08.0/src/k3btrm.cpp.orig 2024-08-31 11:58:47.154040966 +0200
|
||||||
|
+++ k3b-24.08.0/src/k3btrm.cpp 2024-08-31 11:59:24.944119172 +0200
|
||||||
|
@@ -42,11 +42,6 @@
|
||||||
|
|
||||||
|
void K3b::TRM::start( const K3b::Msf& length )
|
||||||
|
{
|
||||||
|
- if( KProtocolManager::useProxy() ) {
|
||||||
|
- QUrl proxy( KProtocolManager::proxyFor("http") );
|
||||||
|
- trm_SetProxy( d->trm, const_cast<char*>(proxy.host().toLatin1().constData()), short(proxy.port()) );
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
trm_SetPCMDataInfo( d->trm, 44100, 2, 16 );
|
||||||
|
trm_SetSongLength( d->trm, length.totalFrames()/75 );
|
||||||
|
}
|
95
k3b.spec
95
k3b.spec
@ -1,7 +1,7 @@
|
|||||||
%define dirver %(echo %version | sed "s,alpha.*,,;s,rc.*,,")
|
%define dirver %(echo %version | sed "s,alpha.*,,;s,rc.*,,")
|
||||||
%define pkgver %(echo %version | sed "s|[a-z]||")
|
%define pkgver %(echo %version | sed "s|[a-z]||")
|
||||||
Name: k3b
|
Name: k3b
|
||||||
Version: 24.05.2
|
Version: 24.08.0
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: The CD/DVD/Blu-Ray Creator for KDE
|
Summary: The CD/DVD/Blu-Ray Creator for KDE
|
||||||
License: GPL
|
License: GPL
|
||||||
@ -11,43 +11,41 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://userbase.kde.org/K3b
|
URL: https://userbase.kde.org/K3b
|
||||||
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/k3b-%{version}.tar.xz
|
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/k3b-%{version}.tar.xz
|
||||||
Patch2: k3b-2.0.3-disable-lsof-check.patch
|
Patch0: k3b-2.0.3-disable-lsof-check.patch
|
||||||
|
Patch1: k3b-24.08.0-kf6-kio-6.5.0.patch
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libQt5Positioning-devel
|
BuildRequires: libavcodec-devel
|
||||||
BuildRequires: libQt5WebChannel-devel
|
BuildRequires: libavformat-devel
|
||||||
BuildRequires: libQt5WebEngine-devel
|
BuildRequires: libavutil-devel
|
||||||
BuildRequires: libX11-devel
|
|
||||||
BuildRequires: libattica5-devel
|
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
|
||||||
BuildRequires: libdvdread-devel
|
BuildRequires: libdvdread-devel
|
||||||
BuildRequires: libflac-devel
|
BuildRequires: libflac-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libkarchive-devel
|
BuildRequires: libglvnd-devel
|
||||||
BuildRequires: libkauth-devel
|
BuildRequires: libkcddb-devel
|
||||||
BuildRequires: libkbookmarks-devel
|
BuildRequires: libkf6-attica-devel
|
||||||
BuildRequires: libkcddb5-devel
|
BuildRequires: libkf6-karchive-devel
|
||||||
BuildRequires: libkcmutils-devel
|
BuildRequires: libkf6-kauth-devel
|
||||||
BuildRequires: libkcodecs-devel
|
BuildRequires: libkf6-kbookmarks-devel
|
||||||
BuildRequires: libkcompletion-devel
|
BuildRequires: libkf6-kcmutils-devel
|
||||||
BuildRequires: libkconfig-devel
|
BuildRequires: libkf6-kcolorscheme-devel
|
||||||
BuildRequires: libkconfigwidgets-devel
|
BuildRequires: libkf6-kcompletion-devel
|
||||||
BuildRequires: libkcoreaddons-devel
|
BuildRequires: libkf6-kconfig-devel
|
||||||
BuildRequires: libkfilemetadata-devel
|
BuildRequires: libkf6-kconfigwidgets-devel
|
||||||
BuildRequires: libki18n-devel
|
BuildRequires: libkf6-kcoreaddons-devel
|
||||||
BuildRequires: libkiconthemes-devel
|
BuildRequires: libkf6-kfilemetadata-devel
|
||||||
BuildRequires: libkio-devel
|
BuildRequires: libkf6-ki18n-devel
|
||||||
BuildRequires: libkitemviews-devel
|
BuildRequires: libkf6-kiconthemes-devel
|
||||||
BuildRequires: libkjobwidgets-devel
|
BuildRequires: libkf6-kio-devel
|
||||||
BuildRequires: libknewstuff-devel
|
BuildRequires: libkf6-kitemviews-devel
|
||||||
BuildRequires: libknotifications-devel
|
BuildRequires: libkf6-kjobwidgets-devel
|
||||||
BuildRequires: libknotifyconfig-devel
|
BuildRequires: libkf6-knewstuff-devel
|
||||||
BuildRequires: libkservice-devel
|
BuildRequires: libkf6-knotifications-devel
|
||||||
BuildRequires: libkwidgetsaddons-devel
|
BuildRequires: libkf6-knotifyconfig-devel
|
||||||
BuildRequires: libkwindowsystem-devel
|
BuildRequires: libkf6-kservice-devel
|
||||||
BuildRequires: libkxmlgui-devel
|
BuildRequires: libkf6-kwidgetsaddons-devel
|
||||||
|
BuildRequires: libkf6-kxmlgui-devel
|
||||||
|
BuildRequires: libkf6-solid-devel
|
||||||
BuildRequires: liblame-devel
|
BuildRequires: liblame-devel
|
||||||
BuildRequires: libmad-devel
|
BuildRequires: libmad-devel
|
||||||
BuildRequires: libmusepack-devel
|
BuildRequires: libmusepack-devel
|
||||||
@ -55,12 +53,14 @@ BuildRequires: libmusicbrainz2-devel
|
|||||||
BuildRequires: libogg-devel
|
BuildRequires: libogg-devel
|
||||||
BuildRequires: libsamplerate-devel
|
BuildRequires: libsamplerate-devel
|
||||||
BuildRequires: libsndfile-devel
|
BuildRequires: libsndfile-devel
|
||||||
BuildRequires: libsolid-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtag-devel
|
BuildRequires: libtag-devel
|
||||||
BuildRequires: libvorbis-devel
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt6-qtbase-devel
|
||||||
BuildRequires: qt5-qtdeclarative-devel
|
BuildRequires: qt6-qtdeclarative-devel
|
||||||
|
BuildRequires: qt6-qtpositioning-devel
|
||||||
|
BuildRequires: qt6-qtwebchannel-devel
|
||||||
|
BuildRequires: qt6-qtwebengine-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libmad-devel >= 0:0.16.3-1mamba
|
BuildRequires: libmad-devel >= 0:0.16.3-1mamba
|
||||||
BuildRequires: gettext-devel
|
BuildRequires: gettext-devel
|
||||||
@ -133,12 +133,16 @@ This package contains static libraries and header files needed for development.
|
|||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{pkgver}
|
%setup -q
|
||||||
%patch 2 -p1
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
%patch 0 -p1
|
||||||
|
%patch 1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#:<< _EOF
|
||||||
%cmake_kf6 \
|
%cmake_kf6 \
|
||||||
-DBUILD_WITH_QT6=OFF \
|
-DBUILD_TESTING=OFF \
|
||||||
-Wno-dev
|
-Wno-dev
|
||||||
|
|
||||||
%cmake_build
|
%cmake_build
|
||||||
@ -163,8 +167,6 @@ update-desktop-database -q &>/dev/null
|
|||||||
update-mime-database -n %{_kf6_mimedir} >&/dev/null
|
update-mime-database -n %{_kf6_mimedir} >&/dev/null
|
||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%post -n lib%{name} -p /sbin/ldconfig
|
|
||||||
%postun -n lib%{name} -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -174,8 +176,8 @@ exit 0
|
|||||||
%{_datadir}/mime/packages/x-k3b.xml
|
%{_datadir}/mime/packages/x-k3b.xml
|
||||||
%{_datadir}/polkit-1/actions/org.kde.k3b.policy
|
%{_datadir}/polkit-1/actions/org.kde.k3b.policy
|
||||||
%{_datadir}/kio/servicemenus/k3b_*.desktop
|
%{_datadir}/kio/servicemenus/k3b_*.desktop
|
||||||
%{_datadir}/knotifications5/k3b.notifyrc
|
%{_datadir}/knotifications6/k3b.notifyrc
|
||||||
%{_datadir}/qlogging-categories5/k3b.categories
|
%{_datadir}/qlogging-categories6/k3b.categories
|
||||||
%{_datadir}/dbus-1/system-services/org.kde.k3b.service
|
%{_datadir}/dbus-1/system-services/org.kde.k3b.service
|
||||||
%{_datadir}/dbus-1/system.d/org.kde.k3b.conf
|
%{_datadir}/dbus-1/system.d/org.kde.k3b.conf
|
||||||
%{_kf6_datadir}/k3b/cdi/*
|
%{_kf6_datadir}/k3b/cdi/*
|
||||||
@ -194,12 +196,12 @@ exit 0
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_kf6_libdir}/libk3bdevice.so.*
|
%{_kf6_libdir}/libk3bdevice.so.*
|
||||||
%{_kf6_libdir}/libk3blib.so.*
|
%{_kf6_libdir}/libk3blib.so.*
|
||||||
%{_qt6_plugindir}/kf5/kio/videodvd.so
|
%{_kf6_plugindir}/kio/videodvd.so
|
||||||
%dir %{_libdir}/qt6/plugins/k3b_plugins
|
%dir %{_libdir}/qt6/plugins/k3b_plugins
|
||||||
%{_libdir}/qt6/plugins/k3b_plugins/k3b*.so
|
%{_libdir}/qt6/plugins/k3b_plugins/k3b*.so
|
||||||
%dir %{_libdir}/qt6/plugins/k3b_plugins/kcms
|
%dir %{_libdir}/qt6/plugins/k3b_plugins/kcms
|
||||||
%{_libdir}/qt6/plugins/k3b_plugins/kcms/kcm_*.so
|
%{_libdir}/qt6/plugins/k3b_plugins/kcms/kcm_*.so
|
||||||
%{_libexecdir}/kf5/kauth/k3bhelper
|
%{_libexecdir}/kf6/kauth/k3bhelper
|
||||||
%doc LICENSES
|
%doc LICENSES
|
||||||
|
|
||||||
%files -n lib%{name}-devel
|
%files -n lib%{name}-devel
|
||||||
@ -210,6 +212,9 @@ exit 0
|
|||||||
%doc ChangeLog
|
%doc ChangeLog
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 30 2024 Automatic Build System <autodist@openmamba.org> 24.08.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Fri Jul 05 2024 Automatic Build System <autodist@openmamba.org> 24.05.2-1mamba
|
* Fri Jul 05 2024 Automatic Build System <autodist@openmamba.org> 24.05.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user