automatic version update by autodist [release 24.02.1-2mamba;Tue Mar 26 2024]
This commit is contained in:
parent
b91f8808eb
commit
2f7a562319
@ -1,10 +0,0 @@
|
||||
--- k3b-1.0.4/configure.orig 2007-11-07 16:42:41.000000000 +0100
|
||||
+++ k3b-1.0.4/configure 2007-11-07 16:43:26.000000000 +0100
|
||||
@@ -36482,6 +36482,7 @@
|
||||
# The ffmpeg decoder plugin needs ffmpeg 0.4.9 or higher
|
||||
#
|
||||
have_ffmpeg=no
|
||||
+LIBS="$LIBS -ldl"
|
||||
if test "$ac_cv_use_ffmpeg" = "yes"; then
|
||||
k3b_cxxflags_save="$CXXFLAGS"
|
||||
CXXFLAGS="$CXXFLAGS -D__STDC_CONSTANT_MACROS"
|
@ -1,96 +0,0 @@
|
||||
commit 61ca30beb978f68e72257408777c6433f33129bd
|
||||
Author: Michal Malek <michalm@jabster.pl>
|
||||
Date: Sun Aug 28 20:18:53 2011 +0200
|
||||
|
||||
Fixed compilation with new FFMPEG
|
||||
|
||||
BUG: 274817
|
||||
FIXED-IN: 2.0.3
|
||||
|
||||
diff --git a/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp b/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
|
||||
index 0ad59fc..0c5f366 100644
|
||||
--- a/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
|
||||
+++ b/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
|
||||
@@ -109,7 +109,13 @@ bool K3bFFMpegFile::open()
|
||||
#else
|
||||
::AVCodecContext* codecContext = d->formatContext->streams[0]->codec;
|
||||
#endif
|
||||
- if( codecContext->codec_type != CODEC_TYPE_AUDIO ) {
|
||||
+ if( codecContext->codec_type !=
|
||||
+#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(52, 64, 0)
|
||||
+ AVMEDIA_TYPE_AUDIO)
|
||||
+#else
|
||||
+ CODEC_TYPE_AUDIO)
|
||||
+#endif
|
||||
+ {
|
||||
kDebug() << "(K3bFFMpegFile) not a simple audio stream: " << m_filename;
|
||||
return false;
|
||||
}
|
||||
@@ -225,8 +231,11 @@ QString K3bFFMpegFile::typeComment() const
|
||||
QString K3bFFMpegFile::title() const
|
||||
{
|
||||
// FIXME: is this UTF8 or something??
|
||||
- if( d->formatContext->title[0] != '\0' )
|
||||
- return QString::fromLocal8Bit( d->formatContext->title );
|
||||
+ AVDictionaryEntry *ade = av_dict_get( d->formatContext->metadata, "TITLE", NULL, 0 );
|
||||
+ if( ade == NULL )
|
||||
+ return QString();
|
||||
+ if( ade->value != '\0' )
|
||||
+ return QString::fromLocal8Bit( ade->value );
|
||||
else
|
||||
return QString();
|
||||
}
|
||||
@@ -235,8 +244,11 @@ QString K3bFFMpegFile::title() const
|
||||
QString K3bFFMpegFile::author() const
|
||||
{
|
||||
// FIXME: is this UTF8 or something??
|
||||
- if( d->formatContext->author[0] != '\0' )
|
||||
- return QString::fromLocal8Bit( d->formatContext->author );
|
||||
+ AVDictionaryEntry *ade = av_dict_get( d->formatContext->metadata, "ARTIST", NULL, 0 );
|
||||
+ if( ade == NULL )
|
||||
+ return QString();
|
||||
+ if( ade->value != '\0' )
|
||||
+ return QString::fromLocal8Bit( ade->value );
|
||||
else
|
||||
return QString();
|
||||
}
|
||||
@@ -245,8 +257,11 @@ QString K3bFFMpegFile::author() const
|
||||
QString K3bFFMpegFile::comment() const
|
||||
{
|
||||
// FIXME: is this UTF8 or something??
|
||||
- if( d->formatContext->comment[0] != '\0' )
|
||||
- return QString::fromLocal8Bit( d->formatContext->comment );
|
||||
+ AVDictionaryEntry *ade = av_dict_get( d->formatContext->metadata, "COMMENT", NULL, 0 );
|
||||
+ if( ade == NULL )
|
||||
+ return QString();
|
||||
+ if( ade->value != '\0' )
|
||||
+ return QString::fromLocal8Bit( ade->value );
|
||||
else
|
||||
return QString();
|
||||
}
|
||||
@@ -309,8 +324,13 @@ int K3bFFMpegFile::fillOutputBuffer()
|
||||
#if LIBAVCODEC_VERSION_MAJOR < 52
|
||||
int len = ::avcodec_decode_audio(
|
||||
#else
|
||||
+ #if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(52, 64, 0)
|
||||
+ int len = ::avcodec_decode_audio3(
|
||||
+ #else
|
||||
int len = ::avcodec_decode_audio2(
|
||||
+ #endif
|
||||
#endif
|
||||
+
|
||||
#ifdef FFMPEG_BUILD_PRE_4629
|
||||
&d->formatContext->streams[0]->codec,
|
||||
#else
|
||||
@@ -318,7 +338,11 @@ int K3bFFMpegFile::fillOutputBuffer()
|
||||
#endif
|
||||
(short*)d->alignedOutputBuffer,
|
||||
&d->outputBufferSize,
|
||||
+#if LIBAVCODEC_VERSION_INT >= AV_VERSION_INT(52, 64, 0)
|
||||
+ &d->packet );
|
||||
+#else
|
||||
d->packetData, d->packetSize );
|
||||
+#endif
|
||||
|
||||
if( d->packetSize <= 0 || len < 0 )
|
||||
::av_free_packet( &d->packet );
|
@ -1,10 +0,0 @@
|
||||
--- k3b-2.0.3/CMakeLists.txt.orig 2015-11-12 14:44:25.688573247 +0100
|
||||
+++ k3b-2.0.3/CMakeLists.txt 2015-11-12 14:44:16.978645415 +0100
|
||||
@@ -339,7 +339,6 @@
|
||||
add_subdirectory( src )
|
||||
add_subdirectory( kioslaves )
|
||||
add_subdirectory( plugins )
|
||||
-add_subdirectory( doc )
|
||||
if(BUILD_K3BSETUP)
|
||||
add_subdirectory(k3bsetup)
|
||||
endif(BUILD_K3BSETUP)
|
@ -1,72 +0,0 @@
|
||||
diff -up k3b-21.12.1/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp.omv~ k3b-21.12.1/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp
|
||||
--- k3b-21.12.1/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp.omv~ 2022-01-17 19:44:11.314744839 +0100
|
||||
+++ k3b-21.12.1/plugins/decoder/ffmpeg/k3bffmpegwrapper.cpp 2022-01-17 19:55:07.045724184 +0100
|
||||
@@ -38,7 +38,20 @@ extern "C" {
|
||||
#include <math.h>
|
||||
|
||||
|
||||
+#if LIBAVCODEC_VERSION_MAJOR < 59
|
||||
#define FFMPEG_CODEC(s) (s->codec)
|
||||
+#else
|
||||
+static QMap<AVStream*,AVCodecContext*> k3b_codec_contexts;
|
||||
+static inline AVCodecContext *FFMPEG_CODEC(AVStream *s) {
|
||||
+ if(!k3b_codec_contexts.contains(s)) {
|
||||
+ const AVCodec *codec = avcodec_find_decoder(s->codecpar->codec_id);
|
||||
+ AVCodecContext *ctx = avcodec_alloc_context3(codec);
|
||||
+ avcodec_parameters_to_context(ctx, s->codecpar);
|
||||
+ k3b_codec_contexts.insert(s, ctx);
|
||||
+ }
|
||||
+ return k3b_codec_contexts.value(s);
|
||||
+}
|
||||
+#endif
|
||||
|
||||
#ifndef HAVE_FFMPEG_AVFORMAT_OPEN_INPUT
|
||||
// this works because the parameters/options are not used
|
||||
@@ -70,7 +83,7 @@ class K3bFFMpegFile::Private
|
||||
{
|
||||
public:
|
||||
::AVFormatContext* formatContext;
|
||||
- ::AVCodec* codec;
|
||||
+ const ::AVCodec* codec;
|
||||
::AVStream *audio_stream;
|
||||
|
||||
K3b::Msf length;
|
||||
@@ -320,11 +333,28 @@ int K3bFFMpegFile::fillOutputBuffer()
|
||||
}
|
||||
|
||||
int gotFrame = 0;
|
||||
+#if LIBAVCODEC_VERSION_MAJOR < 59
|
||||
int len = ::avcodec_decode_audio4(
|
||||
FFMPEG_CODEC(d->audio_stream),
|
||||
d->frame,
|
||||
&gotFrame,
|
||||
&d->packet );
|
||||
+#else
|
||||
+ int ret = ::avcodec_receive_frame(
|
||||
+ FFMPEG_CODEC(d->audio_stream),
|
||||
+ d->frame);
|
||||
+
|
||||
+ gotFrame = (ret == 0);
|
||||
+
|
||||
+ ret = avcodec_send_packet(
|
||||
+ FFMPEG_CODEC(d->audio_stream),
|
||||
+ &d->packet );
|
||||
+ if (ret < 0) {
|
||||
+ qDebug() << "(K3bFFMpegFile) decoding failed for " << m_filename;
|
||||
+ return -1;
|
||||
+ }
|
||||
+ int len = d->packet.size;
|
||||
+#endif
|
||||
|
||||
if( d->packetSize <= 0 || len < 0 )
|
||||
::av_packet_unref( &d->packet );
|
||||
@@ -393,7 +423,9 @@ bool K3bFFMpegFile::seek( const K3b::Msf
|
||||
|
||||
K3bFFMpegWrapper::K3bFFMpegWrapper()
|
||||
{
|
||||
+#if LIBAVCODEC_VERSION_MAJOR < 59
|
||||
::av_register_all();
|
||||
+#endif
|
||||
}
|
||||
|
||||
|
90
k3b.spec
90
k3b.spec
@ -1,8 +1,8 @@
|
||||
%define dirver %(echo %version | sed "s,alpha.*,,;s,rc.*,,")
|
||||
%define pkgver %(echo %version | sed "s|[a-z]||")
|
||||
Name: k3b
|
||||
Version: 23.08.5
|
||||
Release: 1mamba
|
||||
Version: 24.02.1
|
||||
Release: 2mamba
|
||||
Summary: The CD/DVD/Blu-Ray Creator for KDE
|
||||
License: GPL
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
@ -10,12 +10,8 @@ Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://userbase.kde.org/K3b
|
||||
Source: https://download.kde.org/stable/release-service/%{version}/src/k3b-%{version}.tar.xz
|
||||
Patch0: %{name}-1.0.4-configure_ffmpeg.patch
|
||||
Patch1: k3b-2.0.2-ffmpeg.patch
|
||||
Source: https://download.kde.org/%{stable_kde6}/release-service/%{version}/src/k3b-%{version}.tar.xz
|
||||
Patch2: k3b-2.0.3-disable-lsof-check.patch
|
||||
Patch3: k3b-2.0.3a-CMakeLists.patch
|
||||
Patch4: k3b-21.12.2-ffmpeg-5.0.patch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5Positioning-devel
|
||||
@ -32,7 +28,7 @@ BuildRequires: libgcc
|
||||
BuildRequires: libkarchive-devel
|
||||
BuildRequires: libkauth-devel
|
||||
BuildRequires: libkbookmarks-devel
|
||||
BuildRequires: libkcddb-devel
|
||||
BuildRequires: libkcddb5-devel
|
||||
BuildRequires: libkcmutils-devel
|
||||
BuildRequires: libkcodecs-devel
|
||||
BuildRequires: libkcompletion-devel
|
||||
@ -138,24 +134,20 @@ This package contains static libraries and header files needed for development.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{pkgver}
|
||||
#%patch1 -p1
|
||||
%patch 2 -p1
|
||||
#%patch3 -p1
|
||||
#%patch4 -p1 -b .ffmpeg-5.0
|
||||
|
||||
#rm -f doc/*/CMakeLists.txt
|
||||
|
||||
%build
|
||||
%cmake_kde5 -d build \
|
||||
%cmake_kf6 \
|
||||
-DBUILD_WITH_QT6=OFF \
|
||||
-Wno-dev
|
||||
|
||||
%make
|
||||
%cmake_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
%cmake_install
|
||||
|
||||
%find_lang %{name}5_qt --with-qt --with-man --with-html --all-name || touch %{name}5_qt.lang
|
||||
%find_lang %{name} --with-qt --with-man --with-html --all-name || touch %{name}.lang
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -163,64 +155,70 @@ This package contains static libraries and header files needed for development.
|
||||
%postun
|
||||
if [ $1 -eq 0 ]; then
|
||||
update-desktop-database -q &>/dev/null
|
||||
update-mime-database -n %{_kde5_mimedir} &>/dev/null
|
||||
update-mime-database -n %{_kf6_mimedir} &>/dev/null
|
||||
fi
|
||||
|
||||
%posttrans
|
||||
update-desktop-database -q &>/dev/null
|
||||
update-mime-database -n %{_kde5_mimedir} >&/dev/null
|
||||
update-mime-database -n %{_kf6_mimedir} >&/dev/null
|
||||
exit 0
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}5_qt.lang
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_kde5_bindir}/k3b
|
||||
%{_kf6_bindir}/k3b
|
||||
%{_datadir}/applications/org.kde.k3b.desktop
|
||||
%{_datadir}/knotifications5/k3b.notifyrc
|
||||
%dir %{_datadir}/kxmlgui5/k3b
|
||||
%{_datadir}/kxmlgui5/k3b/k3b*.rc
|
||||
%{_datadir}/metainfo/org.kde.k3b.appdata.xml
|
||||
%{_datadir}/mime/packages/x-k3b.xml
|
||||
%{_datadir}/polkit-1/actions/org.kde.k3b.policy
|
||||
%{_datadir}/kio/servicemenus/k3b_*.desktop
|
||||
%{_datadir}/knotifications5/k3b.notifyrc
|
||||
%{_datadir}/qlogging-categories5/k3b.categories
|
||||
%{_datadir}/dbus-1/system-services/org.kde.k3b.service
|
||||
%{_datadir}/dbus-1/system.d/org.kde.k3b.conf
|
||||
%{_datadir}/polkit-1/actions/org.kde.k3b.policy
|
||||
%{_kde5_xdgmimedir}/x-k3b.xml
|
||||
%{_kde5_datadir}/k3b/cdi/*
|
||||
%{_kde5_datadir}/k3b/extra/k3bphoto*.mpg
|
||||
%{_kde5_datadir}/k3b/icons
|
||||
%{_kde5_datadir}/k3b/pics
|
||||
%{_kf6_datadir}/k3b/cdi/*
|
||||
%{_kf6_datadir}/k3b/extra/k3bphoto*.mpg
|
||||
%{_kf6_datadir}/k3b/icons
|
||||
%{_kf6_datadir}/k3b/pics
|
||||
%{_datadir}/knsrcfiles/k3btheme.knsrc
|
||||
%{_kf6_datadir}/solid/actions/k3b*.desktop
|
||||
%{_datadir}/icons/hicolor/*/mimetypes/application-x-k3b.png
|
||||
%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-k3b.svgz
|
||||
%{_kde5_datadir}/konqsidebartng/virtual_folders/services/videodvd.desktop
|
||||
%{_datadir}/knsrcfiles/k3btheme.knsrc
|
||||
%{_kde5_datadir}/solid/actions/k3b*.desktop
|
||||
%{_kde5_servicesdir}/ServiceMenus/k3b*.desktop
|
||||
%{_kde5_servicetypesdir}/k3bplugin.desktop
|
||||
%{_kde5_icondir}/hicolor/*/apps/k3b.png
|
||||
%{_kde5_icondir}/hicolor/*/apps/k3b.svgz
|
||||
%{_kf6_datadir}/konqsidebartng/virtual_folders/services/videodvd.desktop
|
||||
%{_kf6_icondir}/hicolor/*/apps/k3b.png
|
||||
%{_kf6_icondir}/hicolor/*/apps/k3b.svgz
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_kde5_libdir}/libk3bdevice.so.*
|
||||
%{_kde5_libdir}/libk3blib.so.*
|
||||
%{_libdir}/qt5/plugins/kf5/kio/videodvd.so
|
||||
%dir %{_libdir}/qt5/plugins/k3b_plugins
|
||||
%{_libdir}/qt5/plugins/k3b_plugins/k3b*.so
|
||||
%dir %{_libdir}/qt5/plugins/k3b_plugins/kcms
|
||||
%{_libdir}/qt5/plugins/k3b_plugins/kcms/kcm_*.so
|
||||
%{_kf6_libdir}/libk3bdevice.so.*
|
||||
%{_kf6_libdir}/libk3blib.so.*
|
||||
%{_qt6_plugindir}/kf5/kio/videodvd.so
|
||||
%dir %{_libdir}/qt6/plugins/k3b_plugins
|
||||
%{_libdir}/qt6/plugins/k3b_plugins/k3b*.so
|
||||
%dir %{_libdir}/qt6/plugins/k3b_plugins/kcms
|
||||
%{_libdir}/qt6/plugins/k3b_plugins/kcms/kcm_*.so
|
||||
%{_libexecdir}/kf5/kauth/k3bhelper
|
||||
%doc LICENSES
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/k3b*.h
|
||||
%{_kde5_libdir}/libk3bdevice.so
|
||||
%{_kde5_libdir}/libk3blib.so
|
||||
%{_kf6_libdir}/libk3bdevice.so
|
||||
%{_kf6_libdir}/libk3blib.so
|
||||
%doc ChangeLog
|
||||
|
||||
%changelog
|
||||
* Tue Mar 26 2024 Automatic Build System <autodist@openmamba.org> 24.02.1-2mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Mar 25 2024 Automatic Build System <autodist@openmamba.org> 24.02.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Mar 07 2024 Automatic Build System <autodist@openmamba.org> 24.02.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Feb 16 2024 Automatic Build System <autodist@openmamba.org> 23.08.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user