fix apxs path [release 2.5.8-2mamba;Sun Oct 20 2013]
This commit is contained in:
parent
daa49c39d3
commit
7b76f350ce
14
joomla-1.5.9-safe_mode_disable_warnings.patch
Normal file
14
joomla-1.5.9-safe_mode_disable_warnings.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -Nru joomla-1.5.9.org/libraries/joomla/filesystem/path.php joomla-1.5.9/libraries/joomla/filesystem/path.php
|
||||||
|
--- joomla-1.5.9.org/libraries/joomla/filesystem/path.php 2009-01-10 03:53:07.000000000 +0100
|
||||||
|
+++ joomla-1.5.9/libraries/joomla/filesystem/path.php 2009-03-26 19:17:37.000000000 +0100
|
||||||
|
@@ -244,8 +244,8 @@
|
||||||
|
{
|
||||||
|
// not a stream, so do a realpath() to avoid directory
|
||||||
|
// traversal attempts on the local file system.
|
||||||
|
- $path = realpath($path); // needed for substr() later
|
||||||
|
- $fullname = realpath($fullname);
|
||||||
|
+ @$path = realpath($path); // needed for substr() later
|
||||||
|
+ @$fullname = realpath($fullname);
|
||||||
|
}
|
||||||
|
|
||||||
|
// the substr() check added to make sure that the realpath()
|
161
joomla.spec
Normal file
161
joomla.spec
Normal file
@ -0,0 +1,161 @@
|
|||||||
|
%define serverdir %(apxs -q htdocsdir 2>/dev/null)
|
||||||
|
|
||||||
|
# To create a customized installation:
|
||||||
|
# autospec -u joomla -a5 \
|
||||||
|
# -d "installdir=%serverdir/../www.example.com, \
|
||||||
|
# sitename=example, \
|
||||||
|
# adminmail=webmaster@example.com"
|
||||||
|
|
||||||
|
%if "%{?installdir}" == ""
|
||||||
|
%define installdir %{serverdir}/joomla
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%if "%{?sitename}" != ""
|
||||||
|
%if "%{?servername}" == ""
|
||||||
|
%define servername %(basename %installdir 2>/dev/null)
|
||||||
|
%endif
|
||||||
|
%define serverlogdir %(apxs -q logfiledir 2>/dev/null)
|
||||||
|
%else
|
||||||
|
%if "%{?aliasdir}" == ""
|
||||||
|
%define aliasdir /magento
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
Name: %{?sitename:%sitename-website-}joomla
|
||||||
|
Version: 2.5.8
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A PHP based content management system (CMS)
|
||||||
|
Group: Applications/Web
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://joomla.org
|
||||||
|
Source: http://joomlacode.org/gf/download/frsrelease/17715/77262/Joomla_%{version}-Stable-Full_Package.zip
|
||||||
|
Patch0: joomla-1.5.9-safe_mode_disable_warnings.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
Requires: php
|
||||||
|
Requires: mysql
|
||||||
|
Requires: apache
|
||||||
|
Requires: apache-mod_php
|
||||||
|
Requires: php-mysql
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
A PHP based content management system (CMS).
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q -c %{name}-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
install -d %{buildroot}%{installdir}
|
||||||
|
cp -a * %{buildroot}%{installdir}
|
||||||
|
|
||||||
|
install -d %{buildroot}%{_sysconfdir}/httpd/httpd.d
|
||||||
|
%if "%{?sitename}" != ""
|
||||||
|
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/%{servername}.conf << EOF
|
||||||
|
%else
|
||||||
|
cat > %{buildroot}%{_sysconfdir}/httpd/httpd.d/%{name}.conf << EOF
|
||||||
|
%endif
|
||||||
|
%if "%{?sitename}" == ""
|
||||||
|
%if "%(dirname %installdir)" != "%{serverdir}"
|
||||||
|
Alias %{aliasdir} %{installdir}
|
||||||
|
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
<Directory %{installdir}>
|
||||||
|
AllowOverride All
|
||||||
|
RewriteEngine On
|
||||||
|
Order allow,deny
|
||||||
|
Allow from All
|
||||||
|
</Directory>
|
||||||
|
%if "%{?sitename}" != ""
|
||||||
|
%if "%(dirname %installdir)" != "%{serverdir}"
|
||||||
|
|
||||||
|
<VirtualHost *:80>
|
||||||
|
%{?adminmail:ServerAdmin %adminmail}
|
||||||
|
DocumentRoot %{installdir}
|
||||||
|
ServerName %{servername}
|
||||||
|
ErrorLog %{serverlogdir}/%{servername}-error_log
|
||||||
|
CustomLog %{serverlogdir}/%{servername}-access_log common
|
||||||
|
</VirtualHost>
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
EOF
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
if [ $1 -ge 1 ]; then
|
||||||
|
[ -e %{_localstatedir}/lock/subsys/httpd ] && service httpd reload || :
|
||||||
|
fi
|
||||||
|
:
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%if "%{?sitename}" != ""
|
||||||
|
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/%{servername}.conf
|
||||||
|
%else
|
||||||
|
%config(noreplace) %{_sysconfdir}/httpd/httpd.d/%{name}.conf
|
||||||
|
%endif
|
||||||
|
%dir %{installdir}
|
||||||
|
%{installdir}/administrator
|
||||||
|
%{installdir}/cache
|
||||||
|
%{installdir}/components
|
||||||
|
%{installdir}/htaccess.txt
|
||||||
|
%{installdir}/images
|
||||||
|
%{installdir}/includes
|
||||||
|
%{installdir}/index.php
|
||||||
|
%{installdir}/installation
|
||||||
|
%{installdir}/joomla.xml
|
||||||
|
%{installdir}/language
|
||||||
|
%{installdir}/libraries
|
||||||
|
%{installdir}/LICENSE.txt
|
||||||
|
%{installdir}/README.txt
|
||||||
|
%{installdir}/cli
|
||||||
|
%{installdir}/logs
|
||||||
|
%{installdir}/media
|
||||||
|
%{installdir}/modules
|
||||||
|
%{installdir}/plugins
|
||||||
|
%{installdir}/robots.txt
|
||||||
|
%{installdir}/templates
|
||||||
|
%{installdir}/tmp
|
||||||
|
%{installdir}/web.config.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Oct 20 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.8-2mamba
|
||||||
|
- fix apxs path
|
||||||
|
|
||||||
|
* Wed Nov 21 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.8-1mamba
|
||||||
|
- update to 2.5.8
|
||||||
|
|
||||||
|
* Fri Sep 21 2012 Automatic Build System <autodist@mambasoft.it> 2.5.7-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Oct 09 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.14-1mamba
|
||||||
|
- update to 1.5.14
|
||||||
|
|
||||||
|
* Tue Jul 07 2009 Automatic Build System <autodist@mambasoft.it> 1.5.12-1mamba
|
||||||
|
- update to 1.5.12
|
||||||
|
|
||||||
|
* Tue Jul 07 2009 Automatic Build System <autodist@mambasoft.it> 1.5.11-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 1.5.10-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Mar 20 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.9-1mamba
|
||||||
|
- update to 1.5.9
|
||||||
|
|
||||||
|
* Mon Dec 22 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.8-2mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Sep 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.5.7-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user