update to 5.6.0 [release 5.6.0-1mamba;Sat Apr 10 2021]
This commit is contained in:
parent
8546fd2b21
commit
d2d984e354
@ -1,10 +1,8 @@
|
||||
# jedit
|
||||
|
||||
jEdit is a mature programmer's text editor with hundreds (counting the time
|
||||
developing plugins) of person-years of development behind it.
|
||||
jEdit is a mature programmer's text editor with hundreds (counting the time developing plugins) of person-years of development behind it.
|
||||
|
||||
Some of jEdit's features include:
|
||||
|
||||
* Written in Java, so it runs on Mac OS X, OS/2, Unix, VMS and Windows.
|
||||
* Built-in macro language; extensible plugin architecture. Dozens of macros and plugins available.
|
||||
* Plugins can be downloaded and installed from within jEdit using the "plugin manager" feature.
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- jEdit/build.xml 2009-12-22 21:02:58.000000000 +0100
|
||||
+++ jEdit/build.xml-gil 2010-01-05 05:33:44.000000000 +0100
|
||||
@@ -608,7 +608,7 @@
|
||||
classname="org.apache.fop.tools.anttasks.Fop"
|
||||
classpath="${config.fop.dir}/build/fop.jar">
|
||||
<classpath>
|
||||
- <fileset dir="${config.fop.dir}/lib"
|
||||
+ <fileset dir="${config.fop.dir}"
|
||||
includes="*.jar" />
|
||||
</classpath>
|
||||
</taskdef>
|
@ -1,57 +0,0 @@
|
||||
--- jEdit/installer/OperatingSystem.java 2009-12-22 21:02:27.000000000 +0100
|
||||
+++ jEdit/installer/OperatingSystem.java-gil 2010-01-05 05:28:47.000000000 +0100
|
||||
@@ -158,54 +158,6 @@
|
||||
public void perform(String installDir,
|
||||
Vector filesets) throws IOException
|
||||
{
|
||||
- if(!enabled)
|
||||
- {
|
||||
- return;
|
||||
- }
|
||||
-
|
||||
- mkdirs(directory);
|
||||
-
|
||||
- String name = installer.getProperty("app.name");
|
||||
-
|
||||
- // create app start script
|
||||
- String script = directory + File.separatorChar
|
||||
- + name.toLowerCase();
|
||||
-
|
||||
- // Delete existing copy
|
||||
- new File(script).delete();
|
||||
-
|
||||
- // Write simple script
|
||||
- FileWriter out = new FileWriter(script);
|
||||
- out.write("#!/bin/sh\n");
|
||||
- out.write("#\n");
|
||||
- out.write("# Runs jEdit - Programmer's Text Editor.\n");
|
||||
- out.write("#\n");
|
||||
- out.write("\n");
|
||||
- out.write("# Set jvm heap initial and maximum sizes (in megabytes).\n");
|
||||
- out.write("JAVA_HEAP_MAX_SIZE=192\n");
|
||||
- out.write("\n");
|
||||
- out.write("DEFAULT_JAVA_HOME=\""
|
||||
- + System.getProperty("java.home")
|
||||
- + "\"\n");
|
||||
- out.write("if [ -z \"$JAVA_HOME\" ]; then\n");
|
||||
- out.write("\tJAVA_HOME=\"$DEFAULT_JAVA_HOME\"\n");
|
||||
- out.write("fi\n");
|
||||
- out.write("\n");
|
||||
- out.write("# Launch application.\n");
|
||||
- out.write("\n");
|
||||
-
|
||||
- String jar = "\""+ installDir + File.separator
|
||||
- + name.toLowerCase() + ".jar"+"\"";
|
||||
-
|
||||
-
|
||||
- out.write("exec \"$JAVA_HOME/bin/java\"" +
|
||||
- " -Xmx${JAVA_HEAP_MAX_SIZE}M -jar " +
|
||||
- jar + " \"$@\"\n");
|
||||
- out.close();
|
||||
-
|
||||
- // Make it executable
|
||||
- String[] chmodArgs = { "chmod", "755", script };
|
||||
- exec(chmodArgs);
|
||||
}
|
||||
}
|
||||
|
63
jedit.props
Normal file
63
jedit.props
Normal file
@ -0,0 +1,63 @@
|
||||
# --- Arch Linux defaults for jEdit ---
|
||||
#
|
||||
# Just remove this file (~/.jedit/properties) to use the original jEdit defaults.
|
||||
#
|
||||
# startup
|
||||
firstTime=false
|
||||
tip.show=false
|
||||
# buffers
|
||||
buffer.tabSize=4
|
||||
buffer.indentSize=4
|
||||
buffer.encoding=UTF-8
|
||||
buffer.maxLineLen=99
|
||||
# look and feel, fonts and colors
|
||||
icon-theme=tango
|
||||
lookAndFeel=com.sun.java.swing.plaf.gtk.GTKLookAndFeel
|
||||
view.fontsize=14
|
||||
view.font=Noto Mono
|
||||
view.selectionFg=false
|
||||
view.antiAlias=standard
|
||||
view.caretColor=\#333333
|
||||
view.lineHighlightColor=\#deebfb
|
||||
view.thickCaret=false
|
||||
view.selectionFgColor=\#000000
|
||||
view.extendedState=0
|
||||
view.wrapGuideColor=\#dedede
|
||||
view.structureHighlightColor=\#3d9bc4
|
||||
view.selectionColor=\#cccccc
|
||||
view.status.show-caret-virtual=true
|
||||
view.status.foreground=\#000000
|
||||
view.status.show-caret-linenumber=true
|
||||
view.status.show-caret-bufferlength=true
|
||||
view.status.background=\#ffffff
|
||||
view.status.show-caret-dot=true
|
||||
view.status.memory.background=\#66699a
|
||||
view.status.show-caret-offset=true
|
||||
view.style.invalid=color\:\#ff1e00 bgColor\:\#ffffcc
|
||||
view.style.digit=color\:\#330066
|
||||
view.style.literal4=color\:\#0182bc
|
||||
view.style.literal3=color\:\#0700cc
|
||||
view.style.literal2=color\:\#760000
|
||||
view.style.literal1=color\:\#90001c
|
||||
view.style.comment4=color\:\#a2a2a2
|
||||
view.style.label=color\:\#009500
|
||||
view.style.comment3=color\:\#868686
|
||||
view.style.comment2=color\:\#383838
|
||||
view.style.comment1=color\:\#434343
|
||||
view.style.keyword4=color\:\#00a228
|
||||
view.style.keyword3=color\:\#0b2700
|
||||
view.style.keyword2=color\:\#000066
|
||||
view.style.keyword1=color\:\#0033cc
|
||||
view.style.function=color\:\#006600
|
||||
view.style.operator=color\:\#000000
|
||||
view.gutter.fontsize=14
|
||||
view.gutter.font=Courier 10 Pitch
|
||||
view.gutter.highlightColor=\#660000
|
||||
view.gutter.selectionAreaBgColor=\#f0f0f0
|
||||
view.gutter.highlightInterval=10
|
||||
view.gutter.focusBorderColor=\#ececec
|
||||
view.gutter.highlightCurrentLine=false
|
||||
view.gutter.bgColor=\#f0f0f0
|
||||
view.gutter.currentLineColor=\#006699
|
||||
view.gutter.fgColor=\#3c3c3c
|
||||
view.gutter.selectionAreaWidth=12
|
17
jedit.sh
Normal file
17
jedit.sh
Normal file
@ -0,0 +1,17 @@
|
||||
#!/bin/sh
|
||||
# Run jEdit - Programmer's Text Editor
|
||||
|
||||
# If both $HOME/.jedit and $HOME/.jedit/properties doesn't exist,
|
||||
# copy in a default property file.
|
||||
if [ ! -e $HOME/.jedit ]; then
|
||||
if [ ! -e $HOME/.jedit/properties ]; then
|
||||
mkdir -p "$HOME/.jedit"
|
||||
cp /usr/share/jedit/default.props "$HOME/.jedit/properties"
|
||||
fi
|
||||
fi
|
||||
|
||||
# Set the initial and maximum JVM heap size
|
||||
JAVA_HEAP_MAX_SIZE=192
|
||||
|
||||
# Start jEdit
|
||||
exec java -Xmx${JAVA_HEAP_MAX_SIZE}M -Dawt.useSystemAAFontSettings=lcd -jar /usr/share/java/jedit/jedit.jar "$@"
|
231
jedit.spec
231
jedit.spec
@ -1,51 +1,27 @@
|
||||
Name: jedit
|
||||
Version: 4.3.2
|
||||
Version: 5.6.0
|
||||
Release: 1mamba
|
||||
Summary: Programmer's Text Editor
|
||||
Group: Graphical Desktop/Applications/Development
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: gil <puntogil@libero.it>
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.jedit.org/
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/jedit/jedit%{version}source.tar.bz2
|
||||
Source0: https://sourceforge.net/projects/jedit/files/jedit/%{version}/jedit-%{version}-noarch-1sao.tgz
|
||||
Source1: jedit.desktop
|
||||
Source2: jedit-script
|
||||
Patch0: jedit-4.3-installer.patch
|
||||
Patch1: jedit-4.3-fop-dir.patch
|
||||
Source3: jedit.props
|
||||
Source4: jedit.sh
|
||||
Source5: jeditbg.sh
|
||||
License: GPL
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: apache-ant-nodeps
|
||||
BuildRequires: apache-batik = 1.7
|
||||
BuildRequires: apache-fop = 0.95
|
||||
BuildRequires: docbook-dtds
|
||||
BuildRequires: docbook-xsl
|
||||
BuildRequires: jakarta-commons-logging
|
||||
BuildRequires: jakarta-commons-io = 1.4
|
||||
BuildRequires: java-bsh2
|
||||
BuildRequires: java-bsh2-classgen
|
||||
BuildRequires: java-excalibur-avalon-framework
|
||||
BuildRequires: java-saxon6-aelfred
|
||||
BuildRequires: java-gnu-regexp
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: objectweb-asm = 3.2
|
||||
BuildRequires: rsync
|
||||
BuildRequires: xerces-j2
|
||||
BuildRequires: xml-commons
|
||||
BuildRequires: xmlgraphics-commons = 1.3.1
|
||||
Requires: antlr = 2.7.7
|
||||
Requires: java-bsh2
|
||||
Requires: java-gnu-regexp
|
||||
Requires: java-saxon6-aelfred
|
||||
Requires: jpackage-utils
|
||||
Requires: objectweb-asm = 3.2
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: javapackages
|
||||
|
||||
%description
|
||||
jEdit is a mature programmer's text editor with hundreds (counting the time
|
||||
developing plugins) of person-years of development behind it.
|
||||
jEdit is a mature programmer's text editor with hundreds (counting the time developing plugins) of person-years of development behind it.
|
||||
|
||||
Some of jEdit's features include:
|
||||
|
||||
* Written in Java, so it runs on Mac OS X, OS/2, Unix, VMS and Windows.
|
||||
* Built-in macro language; extensible plugin architecture. Dozens of macros and plugins available.
|
||||
* Plugins can be downloaded and installed from within jEdit using the "plugin manager" feature.
|
||||
@ -57,156 +33,23 @@ Some of jEdit's features include:
|
||||
* Every other feature, both basic and advanced, you would expect to find in a text editor.
|
||||
See the Features page for a full list.
|
||||
|
||||
%package javadoc
|
||||
Group: Documentation
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
jEdit is a mature programmer's text editor with hundreds (counting the time
|
||||
developing plugins) of person-years of development behind it.
|
||||
|
||||
This package contains javadoc for %{name}.
|
||||
|
||||
%package manual
|
||||
Group: Documentation
|
||||
Summary: Manual for %{name}
|
||||
|
||||
%description manual
|
||||
jEdit is a mature programmer's text editor with hundreds (counting the time
|
||||
developing plugins) of person-years of development behind it.
|
||||
|
||||
This package contains documentation for %{name}.
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -c %{name}-%{version}
|
||||
# -D -T
|
||||
#:<< ___GIL
|
||||
%patch0 -p0
|
||||
%patch1 -p0
|
||||
|
||||
# todo edit /usr/share/sgml/docbook/xsl-stylesheets-1.76.1/fo/fop.xsl change http://xml.apache.org/fop/extensions with http://xmlgraphics.apache.org/fop/extensions
|
||||
|
||||
pushd jEdit
|
||||
cat > build.properties << __GIL
|
||||
build.dir=build
|
||||
dist.dir=dist
|
||||
docbook.xsl=`rpm -ql docbook-xsl | grep /html/chunk.xsl | sed 's|/html/chunk.xsl||'`
|
||||
rsync.executable=%{_bindir}/rsync
|
||||
xsltproc.executable=%{_bindir}/xsltproc
|
||||
fop.dir=%{_javadir}
|
||||
build.debug=true
|
||||
build.debuglevel=lines,vars,source
|
||||
__GIL
|
||||
rm -rf bsh
|
||||
rm -rf com
|
||||
rm -rf gnu
|
||||
rm -rf org/objectweb
|
||||
|
||||
popd
|
||||
|
||||
#___GIL
|
||||
%build
|
||||
#:<< ___GIL
|
||||
pushd jEdit
|
||||
|
||||
JAVA_HOME=/usr/lib/jvm/jdk-sun
|
||||
perl -p -i -e 's|compress="false"|compress="true"|' build.xml
|
||||
perl -p -i -e 's|app.version=.*|app.version=%{version}-%{release}|' installer/install.props
|
||||
|
||||
PDF_DOC="fop fop-pdf-transcoder fop-hyph fop-sandbox fop-transcoder-allinone commons-logging commons-io xmlgraphics-commons excalibur/avalon-framework batik-svg-dom batik-dom batik-util batik-bridge batik-css"
|
||||
|
||||
export CLASSPATH=$(build-classpath bsh2/bsh-classgen bsh2/bsh-commands bsh2/bsh-core bsh2/bsh-reflect saxon-aelfred gnu-regexp \
|
||||
objectweb-asm/asm $PDF_DOC xercesImpl ant/ant-nodeps)
|
||||
ant
|
||||
|
||||
mkdir -p dist/jars
|
||||
export SGML_CATALOG_FILES=%{_sysconfdir}/sgml/catalog
|
||||
ant docs-html dist
|
||||
|
||||
(cd jars/LatestVersion && ant)
|
||||
|
||||
(cd jars/QuickNotepad && ant)
|
||||
|
||||
ant -Dj2se.api=%{_javadocdir}/java docs-javadoc
|
||||
|
||||
popd
|
||||
#___GIL
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
pushd jEdit
|
||||
|
||||
export JAVA_HOME=/usr/lib/jvm/jdk-sun
|
||||
export CLASSPATH="."
|
||||
install -d %{buildroot}%{_javadir}
|
||||
cp -r usr/share/%{name}-%{version} %{buildroot}%{_javadir}/jedit
|
||||
|
||||
java -cp dist/jedit%{version}install.jar installer.Install auto %{buildroot}%{_datadir}/jedit unix-man=%{buildroot}%{_mandir}/man1
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_datadir}/jedit/doc
|
||||
rm -rf api
|
||||
ln -sf %{_javadocdir}/jedit api
|
||||
)
|
||||
|
||||
#mkdir -p %{buildroot}%{_datadir}/jedit
|
||||
|
||||
mkdir -p %{buildroot}%{_javadocdir}/jedit-%{version}
|
||||
cp -pr build/doc/api/* %{buildroot}%{_javadocdir}/jedit-%{version}
|
||||
ln -s jedit-%{version} %{buildroot}%{_javadocdir}/jedit
|
||||
|
||||
#rm -rf build/doc/api
|
||||
|
||||
#cp -pr build/{doc,macros,modes,properties,startup} %{buildroot}%{_datadir}/jedit
|
||||
|
||||
cp -pr build/doc/FAQ %{buildroot}%{_datadir}/jedit/doc
|
||||
cp -pr build/doc/news43 %{buildroot}%{_datadir}/jedit/doc
|
||||
cp -pr build/doc/tips %{buildroot}%{_datadir}/jedit/doc
|
||||
cp -pr build/doc/users-guide %{buildroot}%{_datadir}/jedit/doc
|
||||
cp -pr build/doc/*.png %{buildroot}%{_datadir}/jedit/doc
|
||||
cp -pr build/doc/*.txt %{buildroot}%{_datadir}/jedit/doc
|
||||
cp -pr build/doc/*.html %{buildroot}%{_datadir}/jedit/doc
|
||||
|
||||
# conflicts with file from package antlr 2.7.7
|
||||
rm -rf %{buildroot}%{_datadir}/jedit/modes/antlr.xml
|
||||
|
||||
#mkdir -p %{buildroot}%{_mandir}/man1
|
||||
#install -pm 644 package-files/linux/jedit.1 %{buildroot}%{_mandir}/man1
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
desktop-file-install %{SOURCE1} --mode=644 --dir=%{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/jedit.desktop
|
||||
|
||||
mkdir -p %{buildroot}%{_bindir}
|
||||
install -pm 755 %{SOURCE2} %{buildroot}%{_bindir}/jedit
|
||||
|
||||
for i in 16 22 24 32 48 64 72 96 ; do
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
|
||||
convert -geometry ${i}x${i} doc/jedit.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/jedit.png
|
||||
done
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/128x128/apps
|
||||
install -pm 644 doc/jedit.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/pixmaps
|
||||
install -pm 644 icons/jedit-icon48.png %{buildroot}%{_datadir}/pixmaps/jedit.png
|
||||
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
install -m 644 build/jedit.jar \
|
||||
%{buildroot}%{_javadir}/jedit-%{version}.jar
|
||||
|
||||
rm -rf %{buildroot}%{_datadir}/jedit/jedit.jar
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_javadir}
|
||||
for jar in *-%{version}*; do
|
||||
ln -sf ${jar} ${jar/-%{version}/}
|
||||
done
|
||||
ln -sf ../java/jedit-%{version}.jar %{buildroot}%{_datadir}/jedit/jedit.jar
|
||||
)
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/jedit/jars
|
||||
cat > %{buildroot}%{_datadir}/jedit/jars/readme.txt << __GIL
|
||||
default plugins directory
|
||||
__GIL
|
||||
popd
|
||||
install -Dm755 %{SOURCE4} %{buildroot}%{_bindir}/jedit
|
||||
install -Dm755 %{SOURCE5} %{buildroot}%{_bindir}/jeditbg
|
||||
install -Dm644 %{SOURCE3} %{buildroot}%{_datadir}/jedit/default.props
|
||||
install -Dm644 usr/share/%{name}-%{version}/doc/jedit.png \
|
||||
%{buildroot}%{_datadir}/pixmaps/jedit.png
|
||||
install -Dm644 %{SOURCE1} %{buildroot}%{_datadir}/applications/jedit.desktop
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -227,36 +70,20 @@ fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%attr(0755,root,root) %{_bindir}/jedit
|
||||
%{_javadir}/jedit-%{version}.jar
|
||||
%{_javadir}/jedit.jar
|
||||
%dir %{_datadir}/jedit
|
||||
%{_datadir}/jedit/@LongLink
|
||||
%{_datadir}/jedit/jedit.jar
|
||||
%{_datadir}/jedit/doc
|
||||
%exclude %{_datadir}/jedit/doc/api
|
||||
%{_datadir}/jedit/macros
|
||||
%{_datadir}/jedit/modes
|
||||
%{_datadir}/jedit/properties
|
||||
%{_datadir}/jedit/startup
|
||||
%dir %{_datadir}/jedit/jars
|
||||
%{_datadir}/jedit/jars/readme.txt
|
||||
%{_datadir}/pixmaps/jedit.png
|
||||
%{_datadir}/icons/hicolor/*x*/apps/jedit.png
|
||||
%{_bindir}/jedit
|
||||
%{_bindir}/jeditbg
|
||||
%{_datadir}/applications/jedit.desktop
|
||||
%{_mandir}/man1/jedit.1.gz
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/jedit/doc/api
|
||||
%{_javadocdir}/jedit-%{version}
|
||||
%{_javadocdir}/jedit
|
||||
|
||||
%files manual
|
||||
%defattr(-,root,root)
|
||||
%doc jEdit/dist/*.pdf
|
||||
%{_datadir}/pixmaps/jedit.png
|
||||
%dir %{_datadir}/jedit
|
||||
%{_datadir}/jedit/default.props
|
||||
%dir %{_datadir}/java/jedit
|
||||
%{_datadir}/java/jedit/*
|
||||
%doc usr/doc/jedit-%{version}/COPYING.* usr/doc/jedit-%{version}/Apache.LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Sat Apr 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 5.6.0-1mamba
|
||||
- update to 5.6.0
|
||||
|
||||
* Fri Jun 25 2010 gil <puntogil@libero.it> 4.3.2-1mamba
|
||||
- update to 4.3.2
|
||||
|
||||
|
3
jeditbg.sh
Normal file
3
jeditbg.sh
Normal file
@ -0,0 +1,3 @@
|
||||
#!/bin/sh
|
||||
# Runs jEdit in background-mode, ready to reuse the running instance
|
||||
jedit -background -reuseview "$@"
|
Loading…
Reference in New Issue
Block a user