rebuilt with java-gcj-compat support [release 1.2.1-3mamba;Thu Mar 24 2011]
This commit is contained in:
parent
f8d4918a77
commit
bcf0d74b31
@ -1,2 +1,4 @@
|
||||
# java-xom
|
||||
|
||||
XOM is a new XML object model. It is an open source (LGPL), tree-based API for processing XML with Java that strives for correctness, simplicity, and performance, in that order XOM is designed to be easy to learn and easy to use. It works very straight-forwardly, and has a very shallow learning curve. Assuming you're already familiar with XML you should be able to get up and running with XOM very quickly
|
||||
|
||||
|
15
java-xom-1.0-betterdocclasspath.patch
Normal file
15
java-xom-1.0-betterdocclasspath.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- XOM/build.xml 2009-03-08 20:42:21.000000000 +0100
|
||||
+++ XOM/build.xml-gil 2009-03-08 20:43:55.000000000 +0100
|
||||
@@ -368,7 +368,11 @@
|
||||
encoding="UTF-8"
|
||||
includes="nu/xom/tools/*">
|
||||
<classpath>
|
||||
- <pathelement path="${compile.class.path}"/>
|
||||
+ <pathelement location="${xml-apis.jar}"/>
|
||||
+ <pathelement location="${parser.jar}"/>
|
||||
+ <pathelement location="${normalizer.jar}"/>
|
||||
+ <pathelement location="${junit.jar}"/>
|
||||
+ <pathelement location="${servlet.jar}"/>
|
||||
<pathelement path="${tagsoup.jar}"/>
|
||||
</classpath>
|
||||
</javac>
|
18
java-xom-1.0-gjdocissues.patch
Normal file
18
java-xom-1.0-gjdocissues.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- XOM/build.xml 2009-03-08 20:48:48.000000000 +0100
|
||||
+++ XOM/build.xml-gil 2009-03-08 20:50:22.000000000 +0100
|
||||
@@ -295,6 +295,7 @@
|
||||
docencoding="UTF-8"
|
||||
charset="UTF-8"
|
||||
link="http://www.junit.org/junit/javadoc/3.8.1"
|
||||
+ linkoffline="http://www.junit.org/junit/javadoc/3.8.1 org.junit"
|
||||
doctitle="${Name} ${version}"
|
||||
bottom="Copyright 2002-${year} <a href='http://www.elharo.com/'>Elliotte Rusty Harold</a>
|
||||
<br/> <a href='mailto:elharo@metalab.unc.edu?Subject=XOM'>elharo@metalab.unc.edu</a>">
|
||||
@@ -348,6 +349,7 @@
|
||||
charset="UTF-8"
|
||||
noqualifier="java.lang:java.io"
|
||||
link="http://www.junit.org/junit/javadoc/3.8.1"
|
||||
+ linkoffline="http://www.junit.org/junit/javadoc/3.8.1 org.junit"
|
||||
doctitle="${Name} ${version}"
|
||||
bottom="Copyright 2002-${year} <a href='http://www.elharo.com/'>Elliotte Rusty Harold</a>
|
||||
<br/> <a href='mailto:elharo@metalab.unc.edu?Subject=XOM'>elharo@metalab.unc.edu</a>">
|
10
java-xom-1.2.1-betterdoc-stack-size.patch
Normal file
10
java-xom-1.2.1-betterdoc-stack-size.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- build.xml 2010-01-18 15:09:57.000000000 +0100
|
||||
+++ build.xml-gil 2010-01-18 15:11:57.000000000 +0100
|
||||
@@ -429,6 +429,7 @@
|
||||
description="Generate the API documentation">
|
||||
<mkdir dir="${build.javadocs}"/>
|
||||
<javadoc packagenames="nu.xom.xslt, nu.xom.canonical, nu.xom.xinclude, nu.xom, nu.xom.converters"
|
||||
+ additionalparam="-J-Xss1m"
|
||||
sourcepath="${build.src}"
|
||||
destdir="${build.javadocs}"
|
||||
author="true"
|
10
java-xom-1.2.1-clean-dist.patch
Normal file
10
java-xom-1.2.1-clean-dist.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- build.xml 2010-01-18 15:04:09.000000000 +0100
|
||||
+++ build.xml-gil 2010-01-18 15:06:56.000000000 +0100
|
||||
@@ -590,6 +590,7 @@
|
||||
<delete>
|
||||
<fileset dir="." includes="junit*properties"/>
|
||||
</delete>
|
||||
+ <delete dir="${dist.dir}"/>
|
||||
</target>
|
||||
|
||||
|
11
java-xom-1.2.1-compile15.patch
Normal file
11
java-xom-1.2.1-compile15.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- build.xml 2010-01-18 15:01:34.000000000 +0100
|
||||
+++ build.xml-gil 2010-01-18 15:02:49.000000000 +0100
|
||||
@@ -188,7 +188,7 @@
|
||||
</target>
|
||||
|
||||
|
||||
- <target name="compile-core" depends="prepare"
|
||||
+ <target name="compile-core" depends="prepare, compile15"
|
||||
description="Compile the source code">
|
||||
<javac srcdir="${build.src}"
|
||||
destdir="${build.dest}"
|
34
java-xom-1.2.1-crosslinks.patch
Normal file
34
java-xom-1.2.1-crosslinks.patch
Normal file
@ -0,0 +1,34 @@
|
||||
--- build.xml 2011-03-24 10:55:16.000000000 +0100
|
||||
+++ build.xml-gil 2011-03-24 10:58:35.000000000 +0100
|
||||
@@ -394,13 +394,13 @@
|
||||
windowtitle="${Name} ${version} API"
|
||||
docencoding="UTF-8"
|
||||
charset="UTF-8"
|
||||
- link="http://www.junit.org/junit/javadoc/3.8.1"
|
||||
linkoffline="http://www.junit.org/junit/javadoc/3.8.1 org.junit"
|
||||
doctitle="${Name} ${version}"
|
||||
bottom="Copyright 2002-${year} <a href='http://www.elharo.com/'>Elliotte Rusty Harold</a>
|
||||
<br /> <a href='mailto:elharo%40metalab%2Eunc%2Eedu?Subject=XOM'>elharo@metalab.unc.edu</a>">
|
||||
<classpath refid="test.class.path"/>
|
||||
-
|
||||
+ <link href="${j2se.api}"/>
|
||||
+ <link href="${junit.api}"/>
|
||||
<fileset dir="${build.src}" defaultexcludes="yes">
|
||||
<include name="nu/xom/tests/XOMTestCase.java" />
|
||||
</fileset>
|
||||
@@ -448,13 +448,13 @@
|
||||
docencoding="UTF-8"
|
||||
charset="UTF-8"
|
||||
noqualifier="java.lang:java.io"
|
||||
- link="http://www.junit.org/junit/javadoc/3.8.1"
|
||||
linkoffline="http://www.junit.org/junit/javadoc/3.8.1 org.junit"
|
||||
doctitle="${Name} ${version}"
|
||||
bottom="Copyright 2002-${year} <a href='http://www.elharo.com/'>Elliotte Rusty Harold</a>
|
||||
<br/> <a href='mailto:elharo@metalab.unc.edu?Subject=XOM'>elharo@metalab.unc.edu</a>">
|
||||
<classpath refid="test.class.path"/>
|
||||
-
|
||||
+ <link href="${j2se.api}"/>
|
||||
+ <link href="${junit.api}"/>
|
||||
<fileset dir="${build.src}" defaultexcludes="yes">
|
||||
<include name="nu/xom/tests/XOMTestCase.java" />
|
||||
</fileset>
|
10
java-xom-1.2.1-javadoc-stack-size.patch
Normal file
10
java-xom-1.2.1-javadoc-stack-size.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- build.xml 2010-01-18 14:04:34.000000000 +0100
|
||||
+++ build.xml-gil 2010-01-18 14:19:43.000000000 +0100
|
||||
@@ -382,6 +382,7 @@
|
||||
<mkdir dir="${build.javadocs}"/>
|
||||
|
||||
<javadoc packagenames="nu.xom.xslt, nu.xom.canonical, nu.xom.xinclude, nu.xom, nu.xom.converters"
|
||||
+ additionalparam="-J-Xss1m"
|
||||
sourcepath="${build.src}"
|
||||
destdir="${build.javadocs}"
|
||||
author="true"
|
94
java-xom-1.2.1-remove_jaxen.patch
Normal file
94
java-xom-1.2.1-remove_jaxen.patch
Normal file
@ -0,0 +1,94 @@
|
||||
--- build.xml 2010-01-18 14:51:23.000000000 +0100
|
||||
+++ build.xml-gil 2010-01-18 15:00:25.000000000 +0100
|
||||
@@ -56,7 +56,6 @@
|
||||
<property name="dist.dir" value="./dist"/>
|
||||
<property name="clover.dir" value="./clover"/>
|
||||
<property name="testreports.dir" value="./testreports" />
|
||||
- <property name="jaxen.dir" value="${build.dir}/jaxen-classes"/>
|
||||
|
||||
<property name="xml-apis.jar" value="${lib.dir}/xml-apis.jar"/>
|
||||
<property name="parser.jar" value="${lib.dir}/dtd-xercesImpl.jar"/>
|
||||
@@ -93,7 +92,6 @@
|
||||
<pathelement location="${xml-apis.jar}"/>
|
||||
<pathelement location="${parser.jar}"/>
|
||||
<pathelement location="${junit.jar}"/>
|
||||
- <pathelement location="${jaxen.dir}"/>
|
||||
<pathelement location="${servlet.jar}"/>
|
||||
</path>
|
||||
|
||||
@@ -101,7 +99,6 @@
|
||||
<pathelement location="${xml-apis.jar}"/>
|
||||
<pathelement location="${parser.jar}"/>
|
||||
<pathelement location="${xom-core}"/>
|
||||
- <pathelement location="${jaxen.dir}"/>
|
||||
<pathelement location="${xslt.jar}"/>
|
||||
<pathelement location="${serializer.jar}"/>
|
||||
</path>
|
||||
@@ -171,8 +168,6 @@
|
||||
<mkdir dir="${dist.dir}"/>
|
||||
<mkdir dir="${testoutput.dir}"/>
|
||||
<mkdir dir="${build.dir}"/>
|
||||
- <mkdir dir="${build.dir}/jaxen"/>
|
||||
- <mkdir dir="${build.dir}/jaxen-classes"/>
|
||||
<mkdir dir="${build15.dir}"/>
|
||||
<mkdir dir="${build.src}"/>
|
||||
<mkdir dir="${build.dest}"/>
|
||||
@@ -193,7 +188,7 @@
|
||||
</target>
|
||||
|
||||
|
||||
- <target name="compile-core" depends="prepare, compile-jaxen"
|
||||
+ <target name="compile-core" depends="prepare"
|
||||
description="Compile the source code">
|
||||
<javac srcdir="${build.src}"
|
||||
destdir="${build.dest}"
|
||||
@@ -302,9 +297,6 @@
|
||||
includes="nu/xom/* nu/xom/xslt/* nu/xom/xinclude/* nu/xom/converters/* nu/xom/canonical/* nu/xom/tests/XOMTestCase.class"
|
||||
excludes="nu/xom/samples/* nu/xom/benchmarks/* nu/xom/pantry/* nu/xom/tools/*">
|
||||
|
||||
- <fileset dir="${jaxen.dir}"
|
||||
- excludes="**Demo.class **/package.html org/jaxen/xom/** org/jaxen/XPathTestBase.class org/jaxen/jdom/** org/jaxen/dom4j/** org/jaxen/javabean/** org/jaxen/dom/** org/jaxen/**Test.class org/jaxen/saxpath/base/**Test.class org/jaxen/saxpath/helpers/**Test.class org/jaxen/saxpath/helpers/**Test.class org/jaxen/pattern/** org/jaxen/saxpath/SAXPathParseException.class org/jaxen/pattern/PriorityTest.class">
|
||||
- </fileset>
|
||||
|
||||
<manifest>
|
||||
<attribute name="Built-By" value="${user.name}"/>
|
||||
@@ -322,12 +314,14 @@
|
||||
<attribute name="Implementation-Version" value="${version}"/>
|
||||
<attribute name="Implementation-Vendor" value="Elliotte Rusty Harold"/>
|
||||
</section>
|
||||
+<!--
|
||||
<section name="org/jaxen/">
|
||||
<attribute name="Specification-Title" value="Jaxen XPath engine"/>
|
||||
<attribute name="Implementation-Title" value="org.jaxen"/>
|
||||
<attribute name="Implementation-Version" value="1.1.2"/>
|
||||
<attribute name="Implementation-Vendor" value="CodeHaus"/>
|
||||
</section>
|
||||
+-->
|
||||
<section name="nu/xom/xslt/">
|
||||
<attribute name="Sealed" value="true"/>
|
||||
<attribute name="Specification-Title" value="XOM XSLT interface"/>
|
||||
@@ -703,7 +697,7 @@
|
||||
<fileset file="${package.jar}" />
|
||||
</jar>
|
||||
</target>
|
||||
-
|
||||
+<!--
|
||||
<target name="compile-jaxen" description="Compile Jaxen" depends="get-jaxen">
|
||||
<javac srcdir="${build.dir}/jaxen-1.1.2/src/java/main"
|
||||
destdir="${build.dir}/jaxen-classes"
|
||||
@@ -732,11 +726,13 @@
|
||||
<classpath refid="compile.class.path"/>
|
||||
</javac>
|
||||
</target>
|
||||
-
|
||||
+-->
|
||||
+
|
||||
+<!--
|
||||
<target name="get-jaxen" description="Download Jaxen source code" depends="prepare">
|
||||
<unzip src="jaxen-1.1.2-src.zip" dest="${build.dir}" />
|
||||
</target>
|
||||
-
|
||||
+-->
|
||||
<target name="debug" depends="init" description="Print various Ant properties">
|
||||
<echoproperties/>
|
||||
<java classname="org.apache.xalan.Version" fork="yes">
|
26
java-xom-1.2.1-remove_sun_import.patch
Normal file
26
java-xom-1.2.1-remove_sun_import.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- src15/nu/xom/JDK15XML1_0Parser.java 2004-08-17 15:48:30.000000000 +0200
|
||||
+++ src15/nu/xom/JDK15XML1_0Parser.java-gil 2010-01-18 14:35:13.000000000 +0100
|
||||
@@ -24,9 +24,9 @@
|
||||
|
||||
import org.xml.sax.SAXException;
|
||||
|
||||
-import com.sun.org.apache.xerces.internal.parsers.SAXParser;
|
||||
-import com.sun.org.apache.xerces.internal.parsers.DTDConfiguration;
|
||||
-import com.sun.org.apache.xerces.internal.impl.Constants
|
||||
+import org.apache.xerces.parsers.SAXParser;
|
||||
+import org.apache.xerces.parsers.DTDConfiguration;
|
||||
+import org.apache.xerces.impl.Constants
|
||||
;
|
||||
/**
|
||||
* <p>
|
||||
@@ -47,8 +47,8 @@
|
||||
|
||||
super(new DTDConfiguration());
|
||||
// workaround for Java 1.5 beta 2 bugs
|
||||
- com.sun.org.apache.xerces.internal.util.SecurityManager manager
|
||||
- = new com.sun.org.apache.xerces.internal.util.SecurityManager();
|
||||
+ org.apache.xerces.util.SecurityManager manager
|
||||
+ = new org.apache.xerces.util.SecurityManager();
|
||||
setProperty(Constants.XERCES_PROPERTY_PREFIX + Constants.SECURITY_MANAGER_PROPERTY, manager);
|
||||
|
||||
}
|
220
java-xom.spec
Normal file
220
java-xom.spec
Normal file
@ -0,0 +1,220 @@
|
||||
%define javahome %{_jvmdir}/jdk
|
||||
%define with_test 0
|
||||
Name: java-xom
|
||||
Version: 1.2.1
|
||||
Release: 3mamba
|
||||
Summary: XML Pull Parser
|
||||
Group: Development/Libraries/Java
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.xom.nu/
|
||||
Source0: http://www.cafeconleche.org/XOM/xom-%{version}.tar.gz
|
||||
# for stage1 bootstrap
|
||||
Source1: jaxen-1.1.1.jar
|
||||
Patch0: java-xom-1.0-betterdocclasspath.patch
|
||||
Patch1: java-xom-1.0-gjdocissues.patch
|
||||
Patch2: java-xom-1.2.1-javadoc-stack-size.patch
|
||||
Patch3: java-xom-1.2.1-crosslinks.patch
|
||||
Patch4: java-xom-1.2.1-remove_sun_import.patch
|
||||
Patch5: java-xom-1.2.1-remove_jaxen.patch
|
||||
Patch6: java-xom-1.2.1-compile15.patch
|
||||
Patch7: java-xom-1.2.1-clean-dist.patch
|
||||
Patch8: java-xom-1.2.1-betterdoc-stack-size.patch
|
||||
License: LGPL
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: apache-ant-junit
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: apache-tomcat5-servletapi5
|
||||
BuildRequires: java-icu4j
|
||||
BuildRequires: java-jaxen
|
||||
BuildRequires: java-saxon6
|
||||
BuildRequires: java-saxon6-aelfred
|
||||
BuildRequires: java-tagsoup
|
||||
%endif
|
||||
BuildRequires: java-gnujaxp
|
||||
BuildRequires: java-dom4j
|
||||
BuildRequires: java-junit3
|
||||
BuildRequires: java-junit3-javadoc
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: xalan-j2
|
||||
BuildRequires: xerces-j2
|
||||
BuildRequires: xml-commons-apis
|
||||
BuildRequires: xml-commons-resolver
|
||||
%if "%{stage1}" != "1"
|
||||
Requires: java-icu4j
|
||||
%endif
|
||||
Requires: xalan-j2
|
||||
Requires: xerces-j2
|
||||
Requires: xml-commons-apis
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
XOM is a new XML object model. It is an open source (LGPL), tree-based API for processing XML with Java that strives for correctness, simplicity, and performance, in that order XOM is designed to be easy to learn and easy to use. It works very straight-forwardly, and has a very shallow learning curve. Assuming you're already familiar with XML you should be able to get up and running with XOM very quickly
|
||||
|
||||
%package demo
|
||||
Group: Development/Tools
|
||||
Summary: Demos for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description demo
|
||||
XOM is a new XML object model. It is an open source (LGPL), tree-based API for processing XML with Java that strives for correctness, simplicity, and performance, in that order XOM is designed to be easy to learn and easy to use. It works very straight-forwardly, and has a very shallow learning curve. Assuming you're already familiar with XML you should be able to get up and running with XOM very quickly
|
||||
|
||||
This package contains demonstrations and samples for %{name}.
|
||||
|
||||
%package javadoc
|
||||
Group: Documentation
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
XOM is a new XML object model. It is an open source (LGPL), tree-based API for processing XML with Java that strives for correctness, simplicity, and performance, in that order XOM is designed to be easy to learn and easy to use. It works very straight-forwardly, and has a very shallow learning curve. Assuming you're already familiar with XML, you should be able to get up and running with XOM very quickly
|
||||
|
||||
This package contains javadoc for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n XOM
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2
|
||||
%patch3 -p0
|
||||
%patch4
|
||||
%patch5
|
||||
%patch6
|
||||
%patch7
|
||||
%patch8
|
||||
|
||||
perl -pi -e 's/\r$//g' *.html *.txt
|
||||
perl -pi -e 's/compress="no"/compress="yes"/g' build.xml
|
||||
|
||||
for j in $(find . -name "*.jar"); do
|
||||
mv $j ${j}.no
|
||||
done
|
||||
|
||||
for j in $(find . -name "*.class"); do
|
||||
rm -rf $j
|
||||
done
|
||||
|
||||
#cp %{S:1} .
|
||||
|
||||
%build
|
||||
pushd lib
|
||||
ln -sf $(build-classpath junit-3.8.2) junit.jar
|
||||
ln -sf $(build-classpath dtd-xercesImpl) dtd-xercesImpl.jar
|
||||
ln -sf $(build-classpath xalan-j2) xalan.jar
|
||||
ln -sf $(build-classpath xercesImpl) serializer.jar
|
||||
ln -sf $(build-classpath icu4j) normalizer.jar
|
||||
ln -sf $(build-classpath xml-commons-apis) xmlParserAPIs.jar
|
||||
ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
|
||||
popd
|
||||
mkdir lib2
|
||||
pushd lib2
|
||||
ln -sf $(build-classpath tagsoup) tagsoup-1.2.jar
|
||||
ln -sf $(build-classpath xml-commons-resolver) resolver.jar
|
||||
ln -sf $(build-classpath dom4j) dom4j-1.5.1.jar
|
||||
ln -sf $(build-classpath servletapi5) servlet.jar
|
||||
ln -sf $(build-classpath saxon) saxon.jar
|
||||
ln -sf $(build-classpath saxon-aelfred) saxon-aelfred.jar
|
||||
ln -sf $(build-classpath gnujaxp) gnujaxp.jar
|
||||
popd
|
||||
export JAVA_HOME=%javahome
|
||||
export CLASSPATH=""
|
||||
%if "%{stage1}" != "1"
|
||||
export CLASSPATH=$(build-classpath xercesImpl dtd-xercesImpl xml-commons-apis tagsoup icu4j-3.8.1 ant/ant-junit junit-3.8.2)
|
||||
%else
|
||||
cp %{SOURCE1} lib/jaxen.jar
|
||||
export CLASSPATH=$(build-classpath xercesImpl dtd-xercesImpl xml-commons-apis ant/ant-junit junit-3.8.2)
|
||||
CLASSPATH=$CASSPATH:lib/jaxen.jar
|
||||
%endif
|
||||
ant \
|
||||
-Dant.build.javac.source=1.4 \
|
||||
-Dant.build.javac.target=1.4 \
|
||||
-Dbuild.sysclasspath=first \
|
||||
-Dj2se.api=%{_javadocdir}/java-gcj-compat \
|
||||
-Djunit.api=%{_javadocdir}/junit \
|
||||
jar betterdoc
|
||||
|
||||
export CLASSPATH=$CLASSPATH:build/classes
|
||||
ant \
|
||||
-Dant.build.javac.source=1.4 \
|
||||
-Dant.build.javac.target=1.4 \
|
||||
-Dbuild.sysclasspath=first \
|
||||
samples
|
||||
|
||||
%if %with_test
|
||||
export CLASSPATH=$CLASSPATH
|
||||
ant \
|
||||
-Dant.build.javac.source=1.4 \
|
||||
-Dant.build.javac.target=1.4 \
|
||||
-Dbuild.sysclasspath=first \
|
||||
test
|
||||
%endif
|
||||
|
||||
sed -i 's/\r//g' LICENSE.txt
|
||||
pushd apidocs
|
||||
for f in `find -name \*.css -o -name \*.html`; do
|
||||
sed -i 's/\r//g' $f
|
||||
done
|
||||
popd
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
install -m 644 build/xom-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/xom-%{version}.jar
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_javadir}
|
||||
for jar in *-%{version}.jar; do
|
||||
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||
done
|
||||
)
|
||||
|
||||
mkdir -p %{buildroot}%{_javadocdir}/xom-%{version}
|
||||
cp -pr apidocs/* %{buildroot}%{_javadocdir}/xom-%{version}
|
||||
ln -s xom-%{version} %{buildroot}%{_javadocdir}/xom
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/xom
|
||||
install -m 644 build/xom-samples.jar \
|
||||
%{buildroot}%{_datadir}/xom/xom-samples-%{version}.jar
|
||||
|
||||
# %{_bindir}/aot-compile-rpm
|
||||
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_javadir}/xom-%{version}.jar
|
||||
%{_javadir}/xom.jar
|
||||
%doc LICENSE.txt lgpl.txt overview.html README.txt Todo.txt XOM.pdf xom.graffle
|
||||
|
||||
%files demo
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/xom
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root)
|
||||
%{_javadocdir}/xom-%{version}
|
||||
%{_javadocdir}/xom
|
||||
|
||||
%changelog
|
||||
* Thu Mar 24 2011 gil <puntogil@libero.it> 1.2.1-3mamba
|
||||
- rebuilt with java-gcj-compat support
|
||||
|
||||
* Fri Nov 26 2010 gil <puntogil@libero.it> 1.2.1-2mamba
|
||||
- rebuilt devel
|
||||
|
||||
* Sat Apr 18 2009 gil <puntogil@libero.it> 1.2.1-1mamba
|
||||
- update to 1.2.1
|
||||
|
||||
* Wed Mar 11 2009 gil <puntogil@libero.it> 1.0-3mamba
|
||||
- rebuilt
|
||||
|
||||
* Sun Mar 08 2009 gil <puntogil@libero.it> 1.0-2mamba
|
||||
- added java-dom4j java-tagsoup support
|
||||
- added demo pakage
|
||||
|
||||
* Sun Mar 01 2009 gil <puntogil@libero.it> 1.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user