update to 7.4.0 [release 7.4.0-1mamba;Sun Jul 25 2021]
This commit is contained in:
parent
57e1873444
commit
a58cc9bce8
@ -1,11 +0,0 @@
|
|||||||
--- testng-5.9/build.xml 2008-06-16 08:03:22.000000000 +0200
|
|
||||||
+++ testng-5.9/build.xml-gil 2009-06-27 15:34:58.000000000 +0200
|
|
||||||
@@ -76,7 +76,7 @@
|
|
||||||
|
|
||||||
|
|
||||||
<target name="dev"
|
|
||||||
- depends="prepare,validate,copy-resources,build,dist-jar,test-15,test-15-jdk14,test-14,test-ant" />
|
|
||||||
+ depends="prepare,validate,copy-resources,build,dist-jar" />
|
|
||||||
|
|
||||||
<target name="all"
|
|
||||||
depends="prepare,validate,copy-resources,build,dist-jar,test-15,test-15-jdk14,test-14,test-ant,javadocs,dist" />
|
|
172
java-testng.spec
172
java-testng.spec
@ -1,183 +1,57 @@
|
|||||||
Name: java-testng
|
Name: java-testng
|
||||||
Version: 5.9
|
Version: 7.4.0
|
||||||
Release: 5mamba
|
Release: 1mamba
|
||||||
Summary: A testing framework inspired from JUnit and NUnit
|
Summary: A testing framework inspired from JUnit and NUnit
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://testng.org/doc/documentation-main.html
|
URL: https://testng.org/doc/
|
||||||
# http://testng.googlecode.com/svn/tags/5.10/
|
Source: https://github.com/cbeust/testng.git/%{version}/testng-%{version}.tar.bz2
|
||||||
Source0: http://testng.org/testng-%{version}.zip
|
License: Apache License 2.0
|
||||||
Source1: http://testng.googlecode.com/svn/tags/%{version}/pom.xml
|
|
||||||
# svn export http://testng.googlecode.com/svn/trunk/test-14/
|
|
||||||
# svn export http://testng.googlecode.com/svn/trunk/maven/ maven
|
|
||||||
# tar czf testng-5.9-maven-plugin-src-svn.tar.gz maven
|
|
||||||
Source2: testng-%{version}-maven-plugin-src-svn.tar.gz
|
|
||||||
Patch: java-testng-5.9-build_xml-notest.patch
|
|
||||||
# svn export http://testng.googlecode.com/svn/trunk/test/
|
|
||||||
License: Apache Software License Version 2.0
|
|
||||||
Group: Documentation
|
Group: Documentation
|
||||||
BuildRequires: apache-ant
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: apache-ant-junit
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: jakarta-commons-logging
|
BuildRequires: gradle
|
||||||
%if "%{stage1}" != "1"
|
BuildRequires: javapackages
|
||||||
BuildRequires: jakarta-commons-jelly-tags-jsl
|
BuildRequires: java-environment
|
||||||
BuildRequires: jakarta-commons-jelly-tags-xml
|
|
||||||
%endif
|
|
||||||
BuildRequires: java-backport-util-concurrent
|
|
||||||
BuildRequires: java-DTDDoc
|
|
||||||
BuildRequires: java-bsh2
|
|
||||||
BuildRequires: java-junit3
|
|
||||||
BuildRequires: java-qdox16
|
|
||||||
#BuildRequires: spring-framework >= 2.0.2 todo
|
|
||||||
BuildRequires: jpackage-utils
|
|
||||||
BuildRequires: xalan-j2
|
|
||||||
Requires: java-backport-util-concurrent
|
|
||||||
Requires: java-bsh2
|
|
||||||
Requires: java-qdox16
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more powerful and easier to use.
|
TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more powerful and easier to use.
|
||||||
|
|
||||||
%package javadoc
|
|
||||||
Group: Documentation
|
|
||||||
Summary: Javadoc for %{name}
|
|
||||||
|
|
||||||
%description javadoc
|
|
||||||
TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more powerful and easier to use.
|
|
||||||
|
|
||||||
This package contains javadoc for %{name}.
|
|
||||||
|
|
||||||
%package manual
|
|
||||||
Group: Documentation
|
|
||||||
Summary: Documents for %{name}
|
|
||||||
|
|
||||||
%description manual
|
|
||||||
TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more powerful and easier to use.
|
|
||||||
|
|
||||||
This package contains documents for %{name}.
|
|
||||||
|
|
||||||
%package -n testng-maven-plugin
|
|
||||||
Group: Development/Libraries/Java
|
|
||||||
Summary: TestNG Maven Plugin
|
|
||||||
%if "%{stage1}" != "1"
|
|
||||||
Requires: apache-maven2
|
|
||||||
Requires: jakarta-commons-jelly-tags-jsl
|
|
||||||
Requires: jakarta-commons-jelly-tags-xml
|
|
||||||
%endif
|
|
||||||
Requires: %{name}
|
|
||||||
|
|
||||||
%description -n testng-maven-plugin
|
|
||||||
TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more powerful and easier to use.
|
|
||||||
|
|
||||||
This package contains TestNG Maven Plugin.
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n testng-%{version} -a 2
|
%setup -q -n testng-%{version}
|
||||||
%patch -p1
|
|
||||||
|
|
||||||
for f in $(find . -name "*.jar"); do
|
|
||||||
mv $f $f.no
|
|
||||||
done
|
|
||||||
|
|
||||||
pushd 3rdparty
|
|
||||||
ln -sf $(build-classpath backport-util-concurrent) backport-util-concurrent-2.2.jar
|
|
||||||
ln -sf $(build-classpath bsh2/bsh) bsh-2.0b4.jar
|
|
||||||
ln -sf $(build-classpath qdox16) qdox-1.6.1.jar
|
|
||||||
ln -sf $(build-classpath junit-3.8.2) junit.jar
|
|
||||||
popd
|
|
||||||
|
|
||||||
# ln -sf $(build-classpath commons-logging) spring/3rdparty/commons-logging-1.0.4.jar
|
|
||||||
# mv ./spring/3rdparty/spring-mock.jar ./spring/3rdparty/spring-mock.jar.no 2.0.2
|
|
||||||
# mv ./spring/3rdparty/spring.jar ./spring/3rdparty/spring.jar.no 2.0.2
|
|
||||||
# mv ./spring/3rdparty/commons-logging-1.0.4.jar ./spring/3rdparty/commons-logging-1.0.4.jar.no
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export JAVA_HOME=%{_jvmdir}/jdk
|
gradle --daemon clean build -x test
|
||||||
export CLASSPATH=$(build-classpath junit-3.8.2 qdox16 xalan-j2-serializer \
|
|
||||||
DTDDoc bsh2/bsh backport-util-concurrent ant/ant-junit)
|
|
||||||
ant dev
|
|
||||||
|
|
||||||
%if "%{stage1}" != "1"
|
|
||||||
export CLASSPATH=$CLASSPATH:$(build-classpath commons-jelly-tags-xml commons-jelly-tags-jsl):testng-%{version}-jdk15.jar:testng-%{version}-jdk14.jar
|
|
||||||
%endif
|
|
||||||
ant -Dtestng-maven.version=2.2.0 maven-plugin
|
|
||||||
|
|
||||||
export CLASSPATH=$CLASSPATH:testng-%{version}-jdk15.jar:testng-%{version}-jdk14.jar
|
|
||||||
ant javadocs
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_javadir}
|
install -D -m644 \
|
||||||
mkdir -p %{buildroot}%{_datadir}/maven2/poms
|
build/libs/testng-%{version}.jar \
|
||||||
mkdir -p %{buildroot}%{_datadir}/maven2/plugins
|
%{buildroot}%{_javadir}/testng/testng-%{version}.jar
|
||||||
|
|
||||||
install -pm 644 testng-%{version}-jdk14.jar %{buildroot}%{_javadir}/testng-jdk14-%{version}.jar
|
|
||||||
%add_to_maven_depmap org.testng testng-jdk14 %{version} JPP testng-jdk14
|
|
||||||
install -pm 644 testng-%{version}-jdk15.jar %{buildroot}%{_javadir}/testng-jdk15-%{version}.jar
|
|
||||||
%add_to_maven_depmap org.testng testng-jdk15 %{version} JPP testng-jdk15
|
|
||||||
%add_to_maven_depmap org.testng testng %{version} JPP testng-jdk15
|
|
||||||
|
|
||||||
(
|
(
|
||||||
cd %{buildroot}%{_javadir}
|
cd %{buildroot}%{_javadir}/testng
|
||||||
for jar in *-%{version}*.jar; do
|
for jar in *-%{version}*.jar; do
|
||||||
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||||
done
|
done
|
||||||
)
|
)
|
||||||
|
|
||||||
install -pm 644 maven-testng-plugin-2.2.0.jar \
|
|
||||||
%{buildroot}%{_javadir}/testng-maven-plugin-2.2.0.jar
|
|
||||||
install -pm 644 maven/project.xml \
|
|
||||||
%{buildroot}%{_datadir}/maven2/poms/JPP-testng-maven-plugin.pom
|
|
||||||
%add_to_maven_depmap org.testng maven-testng-plugin 1.2 JPP testng-maven-plugin
|
|
||||||
|
|
||||||
(
|
|
||||||
cd %{buildroot}%{_javadir}
|
|
||||||
for jar in *-2.2.0*; do
|
|
||||||
ln -sf ${jar} `echo $jar| sed "s|-2.2.0||g"`
|
|
||||||
done
|
|
||||||
)
|
|
||||||
|
|
||||||
install -pm 644 %{S:1} \
|
|
||||||
%{buildroot}%{_datadir}/maven2/poms/JPP-testng.pom
|
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_javadocdir}/testng-%{version}
|
|
||||||
cp -pr javadocs/* %{buildroot}%{_javadocdir}/testng-%{version}
|
|
||||||
ln -s testng-%{version} %{buildroot}%{_javadocdir}/testng
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_javadir}/testng-jdk14-%{version}.jar
|
%dir %{_javadir}/testng
|
||||||
%{_javadir}/testng-jdk14.jar
|
%{_javadir}/testng/testng-%{version}.jar
|
||||||
%{_javadir}/testng-jdk15-%{version}.jar
|
%{_javadir}/testng/testng.jar
|
||||||
%{_javadir}/testng-jdk15.jar
|
|
||||||
%{_datadir}/maven2/poms
|
|
||||||
%exclude %{_datadir}/maven2/poms/JPP-testng-maven-plugin.pom
|
|
||||||
%{_mavendepmapfragdir}
|
|
||||||
%doc README
|
|
||||||
|
|
||||||
%files javadoc
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_javadocdir}/testng-%{version}
|
|
||||||
%{_javadocdir}/testng
|
|
||||||
|
|
||||||
%files manual
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%doc doc *.txt
|
|
||||||
|
|
||||||
%files -n testng-maven-plugin
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_javadir}/testng-maven-plugin-2.2.0.jar
|
|
||||||
%{_javadir}/testng-maven-plugin.jar
|
|
||||||
%{_datadir}/maven2/poms/JPP-testng-maven-plugin.pom
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Jul 25 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 7.4.0-1mamba
|
||||||
|
- update to 7.4.0
|
||||||
|
|
||||||
* Sun Aug 14 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 5.9-5mamba
|
* Sun Aug 14 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 5.9-5mamba
|
||||||
- testng-maven-plugin: require apache-maven2 insted of apache-maven to fix dependencies. Will test this better later
|
- testng-maven-plugin: require apache-maven2 insted of apache-maven to fix dependencies. Will test this better later
|
||||||
|
|
||||||
|
320
pom.xml
320
pom.xml
@ -1,320 +0,0 @@
|
|||||||
<project xmlns="http://maven.apache.org/POM/4.0.0"
|
|
||||||
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
|
||||||
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
|
||||||
<!--
|
|
||||||
~ Generously contributed by Brett Porter of maven, brett.porter@gmail.com.
|
|
||||||
~
|
|
||||||
~ The build instructions given were:
|
|
||||||
~
|
|
||||||
~ POM for TestNG. Usage:
|
|
||||||
~
|
|
||||||
~ mvn clean install -P jdk14
|
|
||||||
~ mvn clean install -P jdk15
|
|
||||||
~
|
|
||||||
~ gotchas:
|
|
||||||
~
|
|
||||||
~ * can't build them both in one go. This would be done by having a -core, -jdk14 and -jdk15 library instead
|
|
||||||
~ * you end up with a testng-$version.jar as well as the per-jdk versions
|
|
||||||
~ * doesn't run tests
|
|
||||||
~ * the backport library is not a version that I can find anywhere on the web.
|
|
||||||
~
|
|
||||||
~ There are certainly better ways to do this (especially if restructuring is an option), but this
|
|
||||||
~ was teh most expedient to get things in the local repo.
|
|
||||||
~
|
|
||||||
~
|
|
||||||
~ Creating an ibiblio upload bundle(added by jesse) :
|
|
||||||
~
|
|
||||||
~ Main instructions here: http://maven.apache.org/guides/mini/guide-ibiblio-upload.html
|
|
||||||
~
|
|
||||||
~ For either jdk15/jdk14 replace the -P option with the bundle type you want to create.
|
|
||||||
~
|
|
||||||
~ mvn source:jar repository:bundle-create -P jdk15
|
|
||||||
~ mv target/testng-<version>-bundle.jar target/testng-<version>-<jdk15/jdk14>-bundle.jar (this step is weird, but necessary)
|
|
||||||
~
|
|
||||||
~ Repeat for jdk14. I usually run the bundle command with a 1.4 jre to be sure I've done it right.
|
|
||||||
~
|
|
||||||
~
|
|
||||||
~ When you are all done, open a JIRA upload request as was done here: http://jira.codehaus.org/browse/MAVENUPLOAD-1010
|
|
||||||
-->
|
|
||||||
<modelVersion>4.0.0</modelVersion>
|
|
||||||
<groupId>org.testng</groupId>
|
|
||||||
<artifactId>testng</artifactId>
|
|
||||||
<name>TestNG</name>
|
|
||||||
<version>5.6</version>
|
|
||||||
<description>TestNG is a unit testing framework.</description>
|
|
||||||
<url>http://testng.org</url>
|
|
||||||
|
|
||||||
<licenses>
|
|
||||||
<license>
|
|
||||||
<name>Apache License, Version 2.0</name>
|
|
||||||
<url>http://apache.org/licenses/LICENSE-2.0</url>
|
|
||||||
</license>
|
|
||||||
</licenses>
|
|
||||||
|
|
||||||
<scm>
|
|
||||||
<connection>scm:svn:a${scm.url}</connection>
|
|
||||||
<url>http://testng.googlecode.com/svn/trunk</url>
|
|
||||||
</scm>
|
|
||||||
|
|
||||||
<properties>
|
|
||||||
|
|
||||||
</properties>
|
|
||||||
|
|
||||||
<profiles>
|
|
||||||
<profile>
|
|
||||||
<id>jdk14</id>
|
|
||||||
<activation>
|
|
||||||
<jdk>1.4</jdk>
|
|
||||||
</activation>
|
|
||||||
<build>
|
|
||||||
<plugins>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.codehaus.mojo</groupId>
|
|
||||||
<artifactId>build-helper-maven-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<sources>
|
|
||||||
<source>src/jdk14</source>
|
|
||||||
</sources>
|
|
||||||
</configuration>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<goals>
|
|
||||||
<goal>add-source</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-compiler-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<source>1.5</source>
|
|
||||||
<target>1.4</target>
|
|
||||||
</configuration>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-jar-plugin</artifactId>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<configuration>
|
|
||||||
<classifier>jdk14</classifier>
|
|
||||||
</configuration>
|
|
||||||
<goals>
|
|
||||||
<goal>jar</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.codehaus.mojo</groupId>
|
|
||||||
<artifactId>dependency-maven-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<artifactItems>
|
|
||||||
<artifactItem>
|
|
||||||
<groupId>backport-util-concurrent</groupId>
|
|
||||||
<artifactId>backport-util-concurrent</artifactId>
|
|
||||||
<version>2.2</version>
|
|
||||||
</artifactItem>
|
|
||||||
</artifactItems>
|
|
||||||
</configuration>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-antrun-plugin</artifactId>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<phase>process-sources</phase>
|
|
||||||
<configuration>
|
|
||||||
<tasks>
|
|
||||||
<unzip dest="target/classes" src="3rdparty/backport-util-concurrent-2.2.jar" />
|
|
||||||
</tasks>
|
|
||||||
</configuration>
|
|
||||||
<goals>
|
|
||||||
<goal>run</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
</plugins>
|
|
||||||
</build>
|
|
||||||
</profile>
|
|
||||||
<profile>
|
|
||||||
<id>jdk15</id>
|
|
||||||
<activation>
|
|
||||||
<jdk>!1.4</jdk>
|
|
||||||
</activation>
|
|
||||||
<build>
|
|
||||||
<plugins>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-jar-plugin</artifactId>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<configuration>
|
|
||||||
<classifier>jdk15</classifier>
|
|
||||||
</configuration>
|
|
||||||
<goals>
|
|
||||||
<goal>jar</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-install-plugin</artifactId>
|
|
||||||
<version>2.2</version>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-compiler-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<source>1.5</source>
|
|
||||||
<target>1.5</target>
|
|
||||||
</configuration>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.codehaus.mojo</groupId>
|
|
||||||
<artifactId>build-helper-maven-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<sources>
|
|
||||||
<source>src/jdk15</source>
|
|
||||||
</sources>
|
|
||||||
</configuration>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<goals>
|
|
||||||
<goal>add-source</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
</plugins>
|
|
||||||
</build>
|
|
||||||
</profile>
|
|
||||||
<profile>
|
|
||||||
<id>default-tools.jar</id>
|
|
||||||
<activation>
|
|
||||||
<property>
|
|
||||||
<name>java.vendor</name>
|
|
||||||
<value>Sun Microsystems Inc.</value>
|
|
||||||
</property>
|
|
||||||
</activation>
|
|
||||||
<dependencies>
|
|
||||||
<dependency>
|
|
||||||
<groupId>com.sun</groupId>
|
|
||||||
<artifactId>tools</artifactId>
|
|
||||||
<version>1.4.2</version>
|
|
||||||
<scope>system</scope>
|
|
||||||
<optional>true</optional>
|
|
||||||
<systemPath>${java.home}/../lib/tools.jar</systemPath>
|
|
||||||
</dependency>
|
|
||||||
</dependencies>
|
|
||||||
</profile>
|
|
||||||
</profiles>
|
|
||||||
|
|
||||||
<dependencies>
|
|
||||||
<dependency>
|
|
||||||
<groupId>ant</groupId>
|
|
||||||
<artifactId>ant</artifactId>
|
|
||||||
<version>1.6.5</version>
|
|
||||||
<optional>true</optional>
|
|
||||||
</dependency>
|
|
||||||
<dependency>
|
|
||||||
<groupId>junit</groupId>
|
|
||||||
<artifactId>junit</artifactId>
|
|
||||||
<version>3.8.1</version>
|
|
||||||
</dependency>
|
|
||||||
<dependency>
|
|
||||||
<groupId>qdox</groupId>
|
|
||||||
<artifactId>qdox</artifactId>
|
|
||||||
<version>1.6.1</version>
|
|
||||||
<scope>provided</scope>
|
|
||||||
</dependency>
|
|
||||||
<dependency>
|
|
||||||
<groupId>org.beanshell</groupId>
|
|
||||||
<artifactId>bsh</artifactId>
|
|
||||||
<version>2.0b4</version>
|
|
||||||
<scope>provided</scope>
|
|
||||||
</dependency>
|
|
||||||
</dependencies>
|
|
||||||
|
|
||||||
<build>
|
|
||||||
<sourceDirectory>src/main</sourceDirectory>
|
|
||||||
<resources>
|
|
||||||
<resource>
|
|
||||||
<directory>src/main</directory>
|
|
||||||
<includes>
|
|
||||||
<include>**/*.dtd</include>
|
|
||||||
</includes>
|
|
||||||
</resource>
|
|
||||||
</resources>
|
|
||||||
|
|
||||||
<plugins>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.codehaus.mojo</groupId>
|
|
||||||
<artifactId>dependency-maven-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<outputDirectory>${project.build.outputDirectory}</outputDirectory>
|
|
||||||
<artifactItems>
|
|
||||||
<artifactItem>
|
|
||||||
<groupId>qdox</groupId>
|
|
||||||
<artifactId>qdox</artifactId>
|
|
||||||
<version>1.6.1</version>
|
|
||||||
</artifactItem>
|
|
||||||
<artifactItem>
|
|
||||||
<groupId>org.beanshell</groupId>
|
|
||||||
<artifactId>bsh</artifactId>
|
|
||||||
<version>2.0b4</version>
|
|
||||||
</artifactItem>
|
|
||||||
</artifactItems>
|
|
||||||
</configuration>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<goals>
|
|
||||||
<goal>unpack</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-clean-plugin</artifactId>
|
|
||||||
<version>2.2</version>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-jar-plugin</artifactId>
|
|
||||||
<configuration>
|
|
||||||
<archive>
|
|
||||||
<index>true</index>
|
|
||||||
<compress>true</compress>
|
|
||||||
<manifest>
|
|
||||||
<mainClass>org.testng.TestNG</mainClass>
|
|
||||||
</manifest>
|
|
||||||
</archive>
|
|
||||||
</configuration>
|
|
||||||
</plugin>
|
|
||||||
<plugin>
|
|
||||||
<groupId>org.apache.maven.plugins</groupId>
|
|
||||||
<artifactId>maven-source-plugin</artifactId>
|
|
||||||
<executions>
|
|
||||||
<execution>
|
|
||||||
<goals>
|
|
||||||
<goal>jar</goal>
|
|
||||||
</goals>
|
|
||||||
</execution>
|
|
||||||
</executions>
|
|
||||||
</plugin>
|
|
||||||
</plugins>
|
|
||||||
|
|
||||||
</build>
|
|
||||||
|
|
||||||
<distributionManagement>
|
|
||||||
<snapshotRepository>
|
|
||||||
<id>snapshots</id>
|
|
||||||
<url>scp://beaver.codehaus.org/home/projects/maven/repository-staging/snapshots/maven2</url>
|
|
||||||
</snapshotRepository>
|
|
||||||
</distributionManagement>
|
|
||||||
|
|
||||||
</project>
|
|
Loading…
Reference in New Issue
Block a user