124 lines
3.2 KiB
RPMSpec
124 lines
3.2 KiB
RPMSpec
Name: java-skinlf
|
|
Version: 6.7
|
|
Release: 1mamba
|
|
Summary: Skin Look And Feel
|
|
Group: Development/Libraries/Java
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: gil <puntogil@libero.it>
|
|
URL: http://skinlf.dev.java.net/
|
|
# wget https://skinlf.dev.java.net/files/documents/66/37801/skinlf-6.7-20060722.zip --no-check-certificate
|
|
Source0: skinlf-%{version}-clean.tar.gz
|
|
# invoke this script to regenerate the source archive
|
|
Source1: java-skinlf-generate-tarball.sh
|
|
License: Apache Software License 1.1, Apache Software License 2.0, zlib
|
|
Patch0: java-skinlf-6.7-nosun-jimi-patch.patch
|
|
Patch1: java-skinlf-6.7-build-xml-patch.patch
|
|
Patch2: java-skinlf-6.7-common-xml-patch.patch
|
|
Patch3: java-skinlf-6.7-sun-jdk1.5-xpath-patch.patch
|
|
|
|
BuildRequires: apache-ant
|
|
#BuildRequires: apache-ant-nodeps
|
|
BuildRequires: hd2u
|
|
#BuildRequires: java-laf-plugin
|
|
BuildRequires: jpackage-utils
|
|
BuildRequires: java-laf-plugin
|
|
Requires: jpackage-utils
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Skin Look And Feel is a java framework that is able to read GTK (The
|
|
Gimp ToolKit) and KDE (The K Desktop Environment) skins to enhance
|
|
your application.
|
|
SkinLF supports GUI controls such as Buttons, Checks, Radios, Scrollbars,
|
|
Progress Bar, Lists, Tables, Internal Frames, Colors, Background
|
|
Textures, Regular Windows.
|
|
|
|
%package javadoc
|
|
Summary: Javadoc for %{name}
|
|
Group: Documentation
|
|
|
|
%description javadoc
|
|
Skin Look And Feel is a java framework that is able to read GTK (The
|
|
Gimp ToolKit) and KDE (The K Desktop Environment) skins to enhance
|
|
your application.
|
|
SkinLF supports GUI controls such as Buttons, Checks, Radios, Scrollbars,
|
|
Progress Bar, Lists, Tables, Internal Frames, Colors, Background
|
|
Textures, Regular Windows.
|
|
|
|
This package contains javadoc for %{name}
|
|
|
|
%prep
|
|
|
|
%setup -q -n skinlf-%{version}
|
|
%patch0 -p1
|
|
%patch1 -p1
|
|
%patch2 -p1
|
|
%patch3 -p1
|
|
for i in "CHANGES README LICENSE LICENSE_nanoxml" ;
|
|
do
|
|
dos2unix -T $i;
|
|
done
|
|
|
|
rm -f ./lib/examples.jar
|
|
rm -f ./lib/nativeskin.jar
|
|
rm -f ./lib/skinlf.jar
|
|
|
|
#rm due to dubious license
|
|
rm -f ./src/examples/Clock.java
|
|
|
|
JAR_files=""
|
|
for j in $(find -name \*.jar); do
|
|
if [ ! -L $j ] ; then
|
|
JAR_files="$JAR_files $j"
|
|
fi
|
|
done
|
|
|
|
if [ ! -z "$JAR_files" ] ; then
|
|
echo "These JAR files should be deleted and symlinked to system JAR files: $JAR_files"
|
|
#Uncomment this line before accepting package
|
|
exit 1
|
|
fi
|
|
|
|
%build
|
|
ant
|
|
|
|
pushd build/classes
|
|
jar cf skinlf-%{version}.jar .
|
|
popd
|
|
|
|
javadoc -d javadoc \
|
|
`find src/ -name \*.java`
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
mkdir -p %{buildroot}/%{_javadir}
|
|
install -pm 644 build/classes/skinlf-%{version}.jar \
|
|
%{buildroot}%{_javadir}/
|
|
|
|
(
|
|
cd %{buildroot}%{_javadir}
|
|
ln -sf skinlf-%{version}.jar skinlf.jar
|
|
|
|
)
|
|
|
|
mkdir -p %{buildroot}%{_javadocdir}/
|
|
cp -pr javadoc %{buildroot}%{_javadocdir}/skinlf-%{version}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_javadir}/skinlf-%{version}.jar
|
|
%{_javadir}/skinlf.jar
|
|
%doc AUTHORS CHANGES LICENSE* README THANKS
|
|
|
|
%files javadoc
|
|
%defattr(-,root,root)
|
|
%{_javadocdir}/skinlf-%{version}
|
|
|
|
%changelog
|
|
* Wed Apr 22 2009 gil <puntogil@libero.it> 6.7-1mamba
|
|
- package created by autospec
|