package created by autospec [release 6.7-1mamba;Wed Apr 22 2009]
This commit is contained in:
parent
be8a9322c5
commit
91f779cbc6
@ -1,2 +1,9 @@
|
|||||||
# java-skinlf
|
# java-skinlf
|
||||||
|
|
||||||
|
Skin Look And Feel is a java framework that is able to read GTK (The
|
||||||
|
Gimp ToolKit) and KDE (The K Desktop Environment) skins to enhance
|
||||||
|
your application.
|
||||||
|
SkinLF supports GUI controls such as Buttons, Checks, Radios, Scrollbars,
|
||||||
|
Progress Bar, Lists, Tables, Internal Frames, Colors, Background
|
||||||
|
Textures, Regular Windows.
|
||||||
|
|
||||||
|
325
java-skinlf-6.7-build-xml-patch.patch
Normal file
325
java-skinlf-6.7-build-xml-patch.patch
Normal file
@ -0,0 +1,325 @@
|
|||||||
|
diff -Nru skinlf-6.7/build.xml skinlf-6.7-gil/build.xml
|
||||||
|
--- skinlf-6.7/build.xml 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ skinlf-6.7-gil/build.xml 2009-04-22 03:34:39.000000000 +0200
|
||||||
|
@@ -0,0 +1,321 @@
|
||||||
|
+<!DOCTYPE project [
|
||||||
|
+ <!ENTITY build-COMMON SYSTEM "common.xml">
|
||||||
|
+]>
|
||||||
|
+
|
||||||
|
+<!--
|
||||||
|
+ Skin Look And Feel Build
|
||||||
|
+-->
|
||||||
|
+
|
||||||
|
+<project name="skinlf" default="compile.java" basedir=".">
|
||||||
|
+<!-- Allow user to override settings -->
|
||||||
|
+<property file="${user.home}/skinlf-ant.properties"/>
|
||||||
|
+<property file="build.properties"/>
|
||||||
|
+<!-- Project Identification -->
|
||||||
|
+<property name="project" value="skinlf"/>
|
||||||
|
+<property name="version" value="6.7"/>
|
||||||
|
+<property name="year" value="2000-2006"/>
|
||||||
|
+<property name="project.fullname" value="Skin Look And Feel"/>
|
||||||
|
+<property name="project.nativeskin" value="nativeskin"/>
|
||||||
|
+<property name="javadoc.packagenames" value="com.l2fprod.gui,com.l2fprod.gui.plaf.skin,com.l2fprod.gui.region,com.l2fprod.gui.nativeskin"/>
|
||||||
|
+
|
||||||
|
+<path id="classpath">
|
||||||
|
+<pathelement location="/usr/share/java/imageconversion.jar"/>
|
||||||
|
+<pathelement location="/usr/share/java/JimiProClasses.zip"/>
|
||||||
|
+<pathelement location="/usr/share/java/xalan.jar"/>
|
||||||
|
+<pathelement location="/usr/share/java/xercesImpl.jar"/>
|
||||||
|
+<pathelement location="/usr/share/java/xml-apis.jar"/>
|
||||||
|
+<pathelement location="/usr/share/java/laf-plugin.jar"/>
|
||||||
|
+</path>
|
||||||
|
+<property name="classpath.asprop" refid="classpath"/>
|
||||||
|
+
|
||||||
|
+<!--
|
||||||
|
+ get some of the dependant jars from maven repository
|
||||||
|
+-->
|
||||||
|
+
|
||||||
|
+<target name="init.jars">
|
||||||
|
+<get src="http://www.ibiblio.org/maven/javacc/jars/JavaCC.zip" dest="lib/JavaCC.zip" verbose="true" usetimestamp="true"/>
|
||||||
|
+<get src="http://www.ibiblio.org/maven/xalan/jars/xalan-2.5.1.jar" dest="lib/xalan.jar" verbose="true" usetimestamp="true"/>
|
||||||
|
+<get src="http://www.ibiblio.org/maven/xerces/jars/xercesImpl-2.4.0.jar" dest="lib/xercesImpl.jar" verbose="true" usetimestamp="true"/>
|
||||||
|
+<get src="http://www.ibiblio.org/maven/xml-apis/jars/xml-apis-2.0.2.jar" dest="lib/xml-apis.jar" verbose="true" usetimestamp="true"/>
|
||||||
|
+</target>
|
||||||
|
+
|
||||||
|
+<target name="compile.javacc" depends="init">
|
||||||
|
+<javacc target="src/com/l2fprod/gui/plaf/skin/impl/gtk/parser/GtkParser.jj" outputdirectory="src/com/l2fprod/gui/plaf/skin/impl/gtk/parser" javacchome="lib" static="false" javaunicodeescape="true"/>
|
||||||
|
+</target>
|
||||||
|
+<target name="compile" depends="init">
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+<!--
|
||||||
|
+
|
||||||
|
+ Utility targets to use the style converters
|
||||||
|
+
|
||||||
|
+-->
|
||||||
|
+
|
||||||
|
+<target name="convert.msstyles">
|
||||||
|
+<fail unless="msstyle" message="Specify path to msstyle xml -Dmsstyle=pathtoxml"/>
|
||||||
|
+<fail unless="skin" message="Specify themepack folder -Dskin=pathtothemepackdir"/>
|
||||||
|
+
|
||||||
|
+<java classname="com.l2fprod.tools.msstyles.MsStylesToSkinLF" classpath="${classpath.asprop}:${java.src.dir}:${build.classes}" fork="yes">
|
||||||
|
+<arg value="${msstyle}"/>
|
||||||
|
+<arg value="${msstyle}.xml"/>
|
||||||
|
+<arg value="${skin}"/>
|
||||||
|
+</java>
|
||||||
|
+
|
||||||
|
+<copy todir="${skin}">
|
||||||
|
+<fileset dir="src/themepacks/skeletonthemepack" includes="**"/>
|
||||||
|
+</copy>
|
||||||
|
+</target>
|
||||||
|
+<!--
|
||||||
|
+ Start Demos
|
||||||
|
+ -->
|
||||||
|
+
|
||||||
|
+<target name="demo">
|
||||||
|
+
|
||||||
|
+<java classname="examples.demo" classpath="${classpath.asprop}:${java.src.dir}:${build.classes}" fork="yes">
|
||||||
|
+<arg value="${skin}"/>
|
||||||
|
+</java>
|
||||||
|
+</target>
|
||||||
|
+<!-- Dist targets -->
|
||||||
|
+
|
||||||
|
+<target name="jar" depends="compile.java">
|
||||||
|
+<!-- uncompress laf-plugin jar -->
|
||||||
|
+<unjar src="lib/laf-plugin.jar" dest="${build.classes}/"/>
|
||||||
|
+
|
||||||
|
+<jar destfile="${build.dir}/${project}.jar">
|
||||||
|
+<fileset dir="${build.classes}" includes="*.class,nanoxml/**,org/jvnet/**,com/**/*.class" excludes="**/region/**,**/nativeskin/**"/>
|
||||||
|
+<fileset dir="${java.src.dir}" includes="com/**/*.properties"/>
|
||||||
|
+<fileset dir="${java.src.dir}" includes="com/**/*.template"/>
|
||||||
|
+<fileset dir="${java.src.dir}" includes="com/**/*.gif"/>
|
||||||
|
+
|
||||||
|
+<manifest>
|
||||||
|
+<attribute name="Built-by" value="${user.name}"/>
|
||||||
|
+<attribute name="Main-Class" value="com.l2fprod.gui.plaf.skin.Skinit"/>
|
||||||
|
+
|
||||||
|
+<section name="com/l2fprod/gui/plaf/skin">
|
||||||
|
+<attribute name="Specification-Title" value="${project.fullname}"/>
|
||||||
|
+<attribute name="Specification-Version" value="${version}"/>
|
||||||
|
+<attribute name="Specification-Vendor" value="L2FProd.com"/>
|
||||||
|
+<attribute name="Implementation-Title" value="${project.fullname}"/>
|
||||||
|
+<attribute name="Implementation-Version" value="${version}"/>
|
||||||
|
+<attribute name="Implementation-Vendor" value="L2FProd.com"/>
|
||||||
|
+</section>
|
||||||
|
+</manifest>
|
||||||
|
+</jar>
|
||||||
|
+</target>
|
||||||
|
+
|
||||||
|
+<target name="obfuscate" depends="jar">
|
||||||
|
+<taskdef name="proguard" classname="proguard.ant.ProGuardTask" classpath="lib/proguard.jar"/>
|
||||||
|
+<move file="${build.dir}/${project}.jar" tofile="${build.dir}/${project}-toobfuscate.jar"/>
|
||||||
|
+
|
||||||
|
+<proguard outjar="${build.dir}/${project}.jar" obfuscate="yes" usemixedclassnames="no" overloadaggressively="yes" printmapping="obfuscatemapping.txt" printusage="obfuscateusage.txt">
|
||||||
|
+<libraryjar name="${java.home}/lib/rt.jar"/>
|
||||||
|
+<injar name="${build.dir}/${project}-toobfuscate.jar"/>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="Skinit">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.SkinApplet">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.SkinChooser">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.WindowSnapping">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.nativeskin.**">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.CompoundSkin">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.IncorrectVersionException">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.LinuxLookAndFeel">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.Skin">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinButton">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinFrame">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.Skinit">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinLookAndFeel">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinPersonality">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinPreviewWindow">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinProgress">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinScrollbar">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinSeparator">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinSlider">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinSplitPane">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.SkinTab">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.impl.*">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.impl.gtk.GtkSkin">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.plaf.skin.impl.kde.KdeSkin">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.gui.region.*">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep access="public" type="class" name="com.l2fprod.tools.**">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+
|
||||||
|
+<keep type="class" name="com.l2fprod.util.**">
|
||||||
|
+<method name="*"/>
|
||||||
|
+</keep>
|
||||||
|
+</proguard>
|
||||||
|
+</target>
|
||||||
|
+
|
||||||
|
+<target name="dist.pre" depends="jar">
|
||||||
|
+<!-- examples.jar -->
|
||||||
|
+
|
||||||
|
+<jar destfile="${build.dist.lib}/examples.jar">
|
||||||
|
+<fileset dir="${build.classes}" includes="examples/**.class"/>
|
||||||
|
+<fileset dir="${java.src.dir}" includes="examples/**.properties,examples/**.gif,examples/**.jpg"/>
|
||||||
|
+</jar>
|
||||||
|
+<!-- nativeskin.jar -->
|
||||||
|
+
|
||||||
|
+<jar jarfile="${build.dist.lib}/nativeskin.jar">
|
||||||
|
+<fileset dir="${build.classes}" includes="com/l2fprod/gui/region/**,com/l2fprod/gui/nativeskin/**,com/l2fprod/util/OS**,,com/l2fprod/util/Access**" excludes="**/*.html"/>
|
||||||
|
+</jar>
|
||||||
|
+<!-- batch files -->
|
||||||
|
+
|
||||||
|
+<copy todir="${build.dist.bin}" flatten="yes" preservelastmodified="yes">
|
||||||
|
+<fileset dir="src" includes="**/*.bat"/>
|
||||||
|
+</copy>
|
||||||
|
+<!-- dlls -->
|
||||||
|
+
|
||||||
|
+<copy todir="${build.dist.lib}">
|
||||||
|
+<fileset dir="src/native/win32" includes="*.dll"/>
|
||||||
|
+</copy>
|
||||||
|
+<!-- default theme -->
|
||||||
|
+
|
||||||
|
+<zip destfile="${build.dist.lib}/themepack.zip">
|
||||||
|
+<zipfileset dir="src/themepacks/whistlerthemepack"/>
|
||||||
|
+</zip>
|
||||||
|
+</target>
|
||||||
|
+<!--
|
||||||
|
+ Publish the new version of SKinLF
|
||||||
|
+ -->
|
||||||
|
+
|
||||||
|
+<target name="publish" depends="init">
|
||||||
|
+<!-- copy zip to dist folder -->
|
||||||
|
+<copy todir="${publish.download.dir}" file="${project}-${version}-${build.version}.zip"/>
|
||||||
|
+<filter token="WEB" value="${publish.web.url}"/>
|
||||||
|
+<!-- update the jnlp website with the new release -->
|
||||||
|
+<!-- put skinlf.jar in jnlp folder -->
|
||||||
|
+
|
||||||
|
+<copy todir="${publish.skinlf.home}/jnlp/" filtering="on" overwrite="yes">
|
||||||
|
+<fileset dir="src/jnlp" includes="*.jnlp"/>
|
||||||
|
+</copy>
|
||||||
|
+<copy file="${build.dist.lib}/${project}.jar" todir="${publish.skinlf.home}/jnlp/"/>
|
||||||
|
+<copy file="${build.dist.lib}/examples.jar" todir="${publish.skinlf.home}/jnlp/"/>
|
||||||
|
+<copy file="${build.dist.lib}/themepack.zip" todir="${publish.skinlf.home}/jnlp/"/>
|
||||||
|
+<copy file="${build.dist.lib}/nativeskin.jar" todir="${publish.skinlf.home}/jnlp"/>
|
||||||
|
+<jar destfile="${publish.skinlf.home}/jnlp/nativeskinlibs.jar" basedir="${build.dist.lib}" includes="*.dll"/>
|
||||||
|
+
|
||||||
|
+<!--
|
||||||
|
+ copy the documentation
|
||||||
|
+ <copy todir="${web.skinlf.home}/documentation">
|
||||||
|
+ <fileset dir="${javadoc.destdir}"/>
|
||||||
|
+ </copy>
|
||||||
|
+
|
||||||
|
+-->
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+</target>
|
||||||
|
+
|
||||||
|
+<target name="themes">
|
||||||
|
+<zip destfile="${build.www.themedir}/cellshadedthemepack.zip" basedir="src/themepacks/cellshadedthemepack"/>
|
||||||
|
+<zip destfile="${build.www.themedir}/whistlerthemepack.zip" basedir="src/themepacks/whistlerthemepack"/>
|
||||||
|
+<zip destfile="${build.www.themedir}/xplunathemepack.zip" basedir="src/themepacks/xplunathemepack"/>
|
||||||
|
+<zip destfile="${build.www.themedir}/toxicthemepack.zip" basedir="src/themepacks/toxicthemepack"/>
|
||||||
|
+<zip destfile="${build.www.themedir}/beigeazulthemepack.zip" basedir="src/themepacks/beigeazulthemepack"/>
|
||||||
|
+<!-- png for these themepacks are not in cvs -->
|
||||||
|
+<zip destfile="${build.www.themedir}/aquathemepack.zip" basedir="src/themepacks/aquathemepack"/>
|
||||||
|
+<zip destfile="${build.www.themedir}/alloythemepack.zip" basedir="src/themepacks/alloythemepack"/>
|
||||||
|
+</target>
|
||||||
|
+
|
||||||
|
+<target name="nativeskin">
|
||||||
|
+<javah destdir="src/native/x11" classpath="${build.classes}" class="com.l2fprod.gui.nativeskin.x11.X11NativeSkin"/>
|
||||||
|
+<javah class="com.l2fprod.gui.nativeskin.win32.Win32NativeSkin" destdir="src/native/win32" classpath="${build.classes}"/>
|
||||||
|
+
|
||||||
|
+<antcall target="createdll">
|
||||||
|
+<param name="java.home" value="${jdk14.home}"/>
|
||||||
|
+<param name="dir" value="src\native\win32"/>
|
||||||
|
+<param name="file" value="regionJAWT"/>
|
||||||
|
+<param name="dll" value="nativeskinwin32JAWT.dll"/>
|
||||||
|
+</antcall>
|
||||||
|
+</target>
|
||||||
|
+
|
||||||
|
+<target name="createdll">
|
||||||
|
+
|
||||||
|
+<exec executable="${bcc55.home}\bin\bcc32.exe" dir="${dir}">
|
||||||
|
+<arg line="-w-"/>
|
||||||
|
+<arg value="-I${bcc55.home}\include;${java.home}\include;${java.home}\include\win32"/>
|
||||||
|
+<arg value="-c"/>
|
||||||
|
+<arg value="${file}.c"/>
|
||||||
|
+</exec>
|
||||||
|
+
|
||||||
|
+<exec executable="${bcc55.home}\bin\ilink32.exe" dir="${dir}">
|
||||||
|
+<arg value="-L${bcc55.home}\lib;${bcc55.home}\lib\psdk;${java.home}\lib;${basedir}\..\common\lib"/>
|
||||||
|
+<arg line="-Gn -Tpd -x c0d32.obj ${file}.obj ,${dll},,user32 gdi32 bccjawt import32 cw32mt,,"/>
|
||||||
|
+</exec>
|
||||||
|
+</target>
|
||||||
|
+&build-COMMON;
|
||||||
|
+</project>
|
175
java-skinlf-6.7-common-xml-patch.patch
Normal file
175
java-skinlf-6.7-common-xml-patch.patch
Normal file
@ -0,0 +1,175 @@
|
|||||||
|
diff -Nru skinlf-6.7/common.xml skinlf-6.7-gil/common.xml
|
||||||
|
--- skinlf-6.7/common.xml 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ skinlf-6.7-gil/common.xml 2009-04-22 03:34:39.000000000 +0200
|
||||||
|
@@ -0,0 +1,171 @@
|
||||||
|
+<!--
|
||||||
|
+ Common Target which could be reused by other projects later.
|
||||||
|
+-->
|
||||||
|
+
|
||||||
|
+<!-- COMMON PROPERTIES -->
|
||||||
|
+
|
||||||
|
+ <property name="debug" value="true"/>
|
||||||
|
+ <property name="optimize" value="false"/>
|
||||||
|
+
|
||||||
|
+ <!-- Java Related -->
|
||||||
|
+ <property name="java.src.dir" value="src"/>
|
||||||
|
+ <property name="javac.compiler" value="modern"/>
|
||||||
|
+
|
||||||
|
+ <!-- Destination Directory for the build -->
|
||||||
|
+ <property name="build.dir" value="build"/>
|
||||||
|
+ <property name="build.classes" value="${build.dir}/classes"/>
|
||||||
|
+ <property name="build.src" value="${build.dir}/src"/>
|
||||||
|
+ <property name="build.dist.dir" value="${project}-${version}"/>
|
||||||
|
+ <property name="build.dist.src" value="${build.dist.dir}/src"/>
|
||||||
|
+ <property name="build.dist.lib" value="${build.dist.dir}/lib"/>
|
||||||
|
+ <property name="build.dist.bin" value="${build.dist.dir}/bin"/>
|
||||||
|
+ <property name="build.www.dir" value="${build.dir}/www"/>
|
||||||
|
+
|
||||||
|
+<!-- COMMON TARGETS -->
|
||||||
|
+
|
||||||
|
+ <target name="init.properties">
|
||||||
|
+ <tstamp>
|
||||||
|
+ <format property="build.time" pattern="MM/dd/yyyy hh:mm aa" locale="en"/>
|
||||||
|
+ <format property="build.version" pattern="yyyyMMdd" locale="en"/>
|
||||||
|
+ </tstamp>
|
||||||
|
+ <filter token="VERSION" value="${version}"/>
|
||||||
|
+ <filter token="PROJECT.FULLNAME" value="${project.fullname}"/>
|
||||||
|
+ <filter token="DATE" value="${build.time}"/>
|
||||||
|
+ <filter token="YEAR" value="${year}"/>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+ <target name="init.directories">
|
||||||
|
+ <mkdir dir="${build.dir}"/>
|
||||||
|
+ <mkdir dir="${build.classes}"/>
|
||||||
|
+ <mkdir dir="${build.dist.dir}"/>
|
||||||
|
+ <mkdir dir="${build.dist.src}"/>
|
||||||
|
+ <mkdir dir="${build.dist.lib}"/>
|
||||||
|
+ <mkdir dir="${build.dist.bin}"/>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+ <target name="init" depends="init.properties,init.directories">
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+ <target name="clean">
|
||||||
|
+ <delete dir="${build.dir}"/>
|
||||||
|
+ <delete dir="${build.dist.dir}"/>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+ <target name="fixcrlf">
|
||||||
|
+ <fixcrlf srcdir="${basedir}" eol="cr">
|
||||||
|
+ <include name="AUTHORS,LICENSE*,README,THANKS" />
|
||||||
|
+ <include name="**/*.java" />
|
||||||
|
+ </fixcrlf>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+<!-- Java Related Targets -->
|
||||||
|
+
|
||||||
|
+ <target name="compile.java" depends="init">
|
||||||
|
+ <depend srcdir="${java.src.dir}"
|
||||||
|
+ destdir="${build.classes}"
|
||||||
|
+ cache="${build.dir}/dependcache"
|
||||||
|
+ closure="yes"/>
|
||||||
|
+
|
||||||
|
+ <copy todir="${build.src}" filtering="yes">
|
||||||
|
+ <fileset dir="${java.src.dir}">
|
||||||
|
+ <include name="**/*.java"/>
|
||||||
|
+ </fileset>
|
||||||
|
+ </copy>
|
||||||
|
+ <javac srcdir="${build.src}"
|
||||||
|
+ destdir="${build.classes}"
|
||||||
|
+ classpathref="classpath"
|
||||||
|
+ compiler="${javac.compiler}"
|
||||||
|
+ includeAntRuntime="false"
|
||||||
|
+ includeJavaRuntime="false"
|
||||||
|
+ debug="${debug}"
|
||||||
|
+ optimize="${optimize}"
|
||||||
|
+ target="1.3" source="1.3">
|
||||||
|
+ </javac>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+<!-- Distribution Target -->
|
||||||
|
+
|
||||||
|
+ <target name="dist" depends="jar,dist.pre">
|
||||||
|
+ <!-- project.jar -->
|
||||||
|
+ <copy todir="${build.dist.lib}"
|
||||||
|
+ file="${build.dir}/${project}.jar"
|
||||||
|
+ preservelastmodified="yes"/>
|
||||||
|
+ <!-- source code -->
|
||||||
|
+ <copy todir="${build.dist.src}"
|
||||||
|
+ preservelastmodified="yes">
|
||||||
|
+ <fileset dir="${build.src}" includes="**/*.java"/>
|
||||||
|
+ <fileset dir="${java.src.dir}" includes="**/*.properties"/>
|
||||||
|
+ </copy>
|
||||||
|
+ <!-- regular files -->
|
||||||
|
+ <copy todir="${build.dist.dir}"
|
||||||
|
+ filtering="yes"
|
||||||
|
+ preservelastmodified="yes">
|
||||||
|
+ <fileset dir="${basedir}">
|
||||||
|
+ <include name="AUTHORS"/>
|
||||||
|
+ <include name="INSTALL"/>
|
||||||
|
+ <include name="README"/>
|
||||||
|
+ <include name="THANKS"/>
|
||||||
|
+ <include name="LICENSE"/>
|
||||||
|
+ <include name="LICENSE_*"/>
|
||||||
|
+ </fileset>
|
||||||
|
+ </copy>
|
||||||
|
+ <xslt in="xdocs/CHANGES.xml"
|
||||||
|
+ out="${build.dist.dir}/CHANGES"
|
||||||
|
+ style="xdocs/xsl/text.xsl"/>
|
||||||
|
+ <!-- zip file -->
|
||||||
|
+ <zip destfile="${project}-${version}-${build.version}.zip">
|
||||||
|
+ <zipfileset dir="${build.dist.dir}"
|
||||||
|
+ prefix="${project}-${version}" />
|
||||||
|
+ </zip>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+<!-- Source code formatting -->
|
||||||
|
+
|
||||||
|
+ <target name="jalopy" depends="init">
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+<!-- Project Web Documentation -->
|
||||||
|
+
|
||||||
|
+ <target name="www" depends="init">
|
||||||
|
+ <mkdir dir="${build.www.dir}"/>
|
||||||
|
+ <xslt in="xdocs/www.xml"
|
||||||
|
+ out="${build.www.dir}/empty.html"
|
||||||
|
+ style="xdocs/xsl/tohtml.xsl">
|
||||||
|
+ <param name="output.dir" expression="${build.www.dir}"/>
|
||||||
|
+ <param name="timestamp" expression="${build.time}"/>
|
||||||
|
+ </xslt>
|
||||||
|
+ <copy todir="${build.www.dir}">
|
||||||
|
+ <fileset dir="xdocs">
|
||||||
|
+ <include name="images/**"/>
|
||||||
|
+ <include name="**.java"/>
|
||||||
|
+ </fileset>
|
||||||
|
+ </copy>
|
||||||
|
+ <mkdir dir="${build.www.dir}/javadoc"/>
|
||||||
|
+ <javadoc sourcepath="${java.src.dir}"
|
||||||
|
+ classpath="${classpath}"
|
||||||
|
+ destdir="${build.www.dir}/javadoc"
|
||||||
|
+ packagenames="${javadoc.packagenames}"
|
||||||
|
+ private="false" protected="true"
|
||||||
|
+ windowtitle="${project.fullname} ${version} API"
|
||||||
|
+ doctitle="${project.fullname} ${version}"
|
||||||
|
+ version="false" author="false" use="false"
|
||||||
|
+ stylesheetfile="xdocs/javadoc.css"
|
||||||
|
+ splitindex="true"
|
||||||
|
+ bottom="Copyright © ${year} L2FProd.com. All Rights Reserved."/>
|
||||||
|
+ <delete file="${build.www.dir}/empty.html"/>
|
||||||
|
+ </target>
|
||||||
|
+
|
||||||
|
+ <target name="www.sync" depends="init">
|
||||||
|
+ <ftp server="${build.www.server}"
|
||||||
|
+ userid="${build.www.userid}"
|
||||||
|
+ password="${build.www.password}"
|
||||||
|
+ remotedir="${build.www.remotedir}"
|
||||||
|
+ action="put"
|
||||||
|
+ verbose="yes"
|
||||||
|
+ depends="yes">
|
||||||
|
+ <fileset dir="${build.www.dir}">
|
||||||
|
+ <include name="**/**"/>
|
||||||
|
+ </fileset>
|
||||||
|
+ </ftp>
|
||||||
|
+ </target>
|
||||||
|
+
|
78
java-skinlf-6.7-nosun-jimi-patch.patch
Normal file
78
java-skinlf-6.7-nosun-jimi-patch.patch
Normal file
@ -0,0 +1,78 @@
|
|||||||
|
--- skinlf-6.7/src/com/l2fprod/tools/ImageUtils.java 2006-07-22 13:46:18.000000000 +0200
|
||||||
|
+++ skinlf-6.7/src/com/l2fprod/tools/ImageUtils.java-gil 2009-04-22 03:45:46.000000000 +0200
|
||||||
|
@@ -6,15 +6,11 @@
|
||||||
|
|
||||||
|
import javax.swing.ImageIcon;
|
||||||
|
|
||||||
|
-import com.ibm.imageconversion.*;
|
||||||
|
-import com.sun.jimi.core.*;
|
||||||
|
-
|
||||||
|
+import javax.imageio.*;
|
||||||
|
public class ImageUtils {
|
||||||
|
|
||||||
|
public static Component bitmapCreator = new javax.swing.JLabel();
|
||||||
|
|
||||||
|
- static BMPDecoder decoder = new BMPDecoder();
|
||||||
|
- static BMPEncoder encoder = new BMPEncoder();
|
||||||
|
|
||||||
|
public static Image loadPng(String pathToImage) throws Exception {
|
||||||
|
ImageIcon icon = new ImageIcon(new File(pathToImage).toURL());
|
||||||
|
@@ -22,7 +18,21 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
public static void savePng(Image image, String pathToImage) throws Exception {
|
||||||
|
- Jimi.putImage(image, pathToImage);
|
||||||
|
+ ImageIO.write((RenderedImage)image, "png", new File(pathToImage));
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ private static String getFileFmt(String pathToImage) throws Exception {
|
||||||
|
+ String fmt;
|
||||||
|
+ if (pathToImage.toLowerCase().endsWith(".png")) {
|
||||||
|
+ return "png";
|
||||||
|
+ }
|
||||||
|
+ if (pathToImage.toLowerCase().endsWith(".gif")) {
|
||||||
|
+ return "gif";
|
||||||
|
+ }
|
||||||
|
+ if (pathToImage.toLowerCase().endsWith(".bmp")) {
|
||||||
|
+ return "bmp";
|
||||||
|
+ }
|
||||||
|
+ return "";
|
||||||
|
}
|
||||||
|
|
||||||
|
public static void createPicture(String pathToImage, int index, int maxParts,
|
||||||
|
@@ -31,20 +41,10 @@
|
||||||
|
System.out.println("working with " + pathToImage);
|
||||||
|
Image image = null;
|
||||||
|
|
||||||
|
- if (pathToImage.toLowerCase().endsWith(".png") ||
|
||||||
|
- pathToImage.toLowerCase().endsWith(".gif")) {
|
||||||
|
- image = loadPng(pathToImage);
|
||||||
|
- } else if (pathToImage.toLowerCase().endsWith(".bmp")) {
|
||||||
|
- decoder.setInputFilename(pathToImage);
|
||||||
|
- decoder.triggerAction();
|
||||||
|
- image = decoder.getResult();
|
||||||
|
- } else {
|
||||||
|
- throw new Error("do not know how to load " + pathToImage);
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
+ image = Toolkit.getDefaultToolkit().getImage(pathToImage);
|
||||||
|
// if only one image, dump it as it
|
||||||
|
- if (index == 0 && maxParts == 1) {
|
||||||
|
- Jimi.putImage(image, filename);
|
||||||
|
+ if (index == 0 && maxParts == 1) {
|
||||||
|
+ ImageIO.write((RenderedImage)image, getFileFmt(pathToImage), new File(pathToImage));
|
||||||
|
} else {
|
||||||
|
if (horizontal) {
|
||||||
|
int partHeight = image.getHeight(bitmapCreator) / maxParts;
|
||||||
|
@@ -54,9 +54,9 @@
|
||||||
|
int partWidth = image.getWidth(bitmapCreator) / maxParts;
|
||||||
|
image = grab(image, partWidth * index, 0,
|
||||||
|
partWidth, image.getHeight(bitmapCreator));
|
||||||
|
- }
|
||||||
|
- Jimi.putImage(image, filename);
|
||||||
|
+ };
|
||||||
|
}
|
||||||
|
+ ImageIO.write((RenderedImage)image, getFileFmt(pathToImage), new File(pathToImage));
|
||||||
|
} catch (Exception e) {
|
||||||
|
System.out.println("error while working with " + pathToImage);
|
||||||
|
e.printStackTrace();
|
11
java-skinlf-6.7-sun-jdk1.5-xpath-patch.patch
Normal file
11
java-skinlf-6.7-sun-jdk1.5-xpath-patch.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- skinlf-6.7/src/com/l2fprod/tools/msstyles/MsStylesToSkinLF.java 2006-07-22 13:46:22.000000000 +0200
|
||||||
|
+++ skinlf-6.7/src/com/l2fprod/tools/msstyles/MsStylesToSkinLF.java-gil 2009-04-22 03:52:30.000000000 +0200
|
||||||
|
@@ -9,7 +9,7 @@
|
||||||
|
import javax.xml.parsers.DocumentBuilder;
|
||||||
|
import javax.xml.parsers.DocumentBuilderFactory;
|
||||||
|
|
||||||
|
-import org.apache.xpath.XPathAPI;
|
||||||
|
+import com.sun.org.apache.xpath.internal.XPathAPI;
|
||||||
|
import org.w3c.dom.Document;
|
||||||
|
import org.w3c.dom.Element;
|
||||||
|
|
12
java-skinlf-generate-tarball.sh
Normal file
12
java-skinlf-generate-tarball.sh
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
VERSION=$1
|
||||||
|
|
||||||
|
#Original source is located at https://skinlf.dev.java.net/servlets/ProjectDocumentList?folderID=242&expandFolder=242&folderID=0
|
||||||
|
# https://skinlf.dev.java.net/files/documents/66/37801/skinlf-6.7-20060722.zip --no-check-certificate
|
||||||
|
|
||||||
|
rm -rf skinlf-6.7
|
||||||
|
unzip skinlf-$VERSION.zip
|
||||||
|
rm skinlf-6.7/src/examples/Clock.java
|
||||||
|
#sed -i -e 's/patentedcodec.c//' libfoo-$VERSION/src/Makefile
|
||||||
|
|
||||||
|
tar -czvf skinlf-6.7-clean.tar.gz skinlf-6.7
|
123
java-skinlf.spec
Normal file
123
java-skinlf.spec
Normal file
@ -0,0 +1,123 @@
|
|||||||
|
Name: java-skinlf
|
||||||
|
Version: 6.7
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Skin Look And Feel
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: gil <puntogil@libero.it>
|
||||||
|
URL: http://skinlf.dev.java.net/
|
||||||
|
# wget https://skinlf.dev.java.net/files/documents/66/37801/skinlf-6.7-20060722.zip --no-check-certificate
|
||||||
|
Source0: skinlf-%{version}-clean.tar.gz
|
||||||
|
# invoke this script to regenerate the source archive
|
||||||
|
Source1: java-skinlf-generate-tarball.sh
|
||||||
|
License: Apache Software License 1.1, Apache Software License 2.0, zlib
|
||||||
|
Patch0: java-skinlf-6.7-nosun-jimi-patch.patch
|
||||||
|
Patch1: java-skinlf-6.7-build-xml-patch.patch
|
||||||
|
Patch2: java-skinlf-6.7-common-xml-patch.patch
|
||||||
|
Patch3: java-skinlf-6.7-sun-jdk1.5-xpath-patch.patch
|
||||||
|
|
||||||
|
BuildRequires: apache-ant
|
||||||
|
#BuildRequires: apache-ant-nodeps
|
||||||
|
BuildRequires: hd2u
|
||||||
|
#BuildRequires: java-laf-plugin
|
||||||
|
BuildRequires: jpackage-utils
|
||||||
|
BuildRequires: java-laf-plugin
|
||||||
|
Requires: jpackage-utils
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Skin Look And Feel is a java framework that is able to read GTK (The
|
||||||
|
Gimp ToolKit) and KDE (The K Desktop Environment) skins to enhance
|
||||||
|
your application.
|
||||||
|
SkinLF supports GUI controls such as Buttons, Checks, Radios, Scrollbars,
|
||||||
|
Progress Bar, Lists, Tables, Internal Frames, Colors, Background
|
||||||
|
Textures, Regular Windows.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
Group: Documentation
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
Skin Look And Feel is a java framework that is able to read GTK (The
|
||||||
|
Gimp ToolKit) and KDE (The K Desktop Environment) skins to enhance
|
||||||
|
your application.
|
||||||
|
SkinLF supports GUI controls such as Buttons, Checks, Radios, Scrollbars,
|
||||||
|
Progress Bar, Lists, Tables, Internal Frames, Colors, Background
|
||||||
|
Textures, Regular Windows.
|
||||||
|
|
||||||
|
This package contains javadoc for %{name}
|
||||||
|
|
||||||
|
%prep
|
||||||
|
|
||||||
|
%setup -q -n skinlf-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
for i in "CHANGES README LICENSE LICENSE_nanoxml" ;
|
||||||
|
do
|
||||||
|
dos2unix -T $i;
|
||||||
|
done
|
||||||
|
|
||||||
|
rm -f ./lib/examples.jar
|
||||||
|
rm -f ./lib/nativeskin.jar
|
||||||
|
rm -f ./lib/skinlf.jar
|
||||||
|
|
||||||
|
#rm due to dubious license
|
||||||
|
rm -f ./src/examples/Clock.java
|
||||||
|
|
||||||
|
JAR_files=""
|
||||||
|
for j in $(find -name \*.jar); do
|
||||||
|
if [ ! -L $j ] ; then
|
||||||
|
JAR_files="$JAR_files $j"
|
||||||
|
fi
|
||||||
|
done
|
||||||
|
|
||||||
|
if [ ! -z "$JAR_files" ] ; then
|
||||||
|
echo "These JAR files should be deleted and symlinked to system JAR files: $JAR_files"
|
||||||
|
#Uncomment this line before accepting package
|
||||||
|
exit 1
|
||||||
|
fi
|
||||||
|
|
||||||
|
%build
|
||||||
|
ant
|
||||||
|
|
||||||
|
pushd build/classes
|
||||||
|
jar cf skinlf-%{version}.jar .
|
||||||
|
popd
|
||||||
|
|
||||||
|
javadoc -d javadoc \
|
||||||
|
`find src/ -name \*.java`
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
mkdir -p %{buildroot}/%{_javadir}
|
||||||
|
install -pm 644 build/classes/skinlf-%{version}.jar \
|
||||||
|
%{buildroot}%{_javadir}/
|
||||||
|
|
||||||
|
(
|
||||||
|
cd %{buildroot}%{_javadir}
|
||||||
|
ln -sf skinlf-%{version}.jar skinlf.jar
|
||||||
|
|
||||||
|
)
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadocdir}/
|
||||||
|
cp -pr javadoc %{buildroot}%{_javadocdir}/skinlf-%{version}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/skinlf-%{version}.jar
|
||||||
|
%{_javadir}/skinlf.jar
|
||||||
|
%doc AUTHORS CHANGES LICENSE* README THANKS
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadocdir}/skinlf-%{version}
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Apr 22 2009 gil <puntogil@libero.it> 6.7-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user