rebuilt with java-gcj-compat support [release 9.1.0.7-3mamba;Fri Mar 25 2011]
This commit is contained in:
parent
9dfff708a9
commit
ed47947835
16
README.md
16
README.md
@ -1,2 +1,18 @@
|
|||||||
# java-saxon9
|
# java-saxon9
|
||||||
|
|
||||||
|
The Saxon XSLT and XQuery processor, developed by Michael Kay
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
The main components are:
|
||||||
|
- An XSLT processor, which implements the Version 1.0 XSLT and XPath Recommendations from the World Wide Web Consortium, found at
|
||||||
|
http://www.w3.org/TR/1999/REC-xslt-19991116 and
|
||||||
|
http://www.w3.org/TR/1999/REC-xpath-19991116 with a number of powerful
|
||||||
|
extensions. This version of Saxon also includes many of the new features
|
||||||
|
defined in the XSLT 1.1 working draft, but for conformance and portability
|
||||||
|
reasons these are not available if the stylesheet header specifies
|
||||||
|
version="1.0".
|
||||||
|
- A Java library, which supports a similar processing model to XSL, but allows
|
||||||
|
full programming capability, which you need if you want to perform complex
|
||||||
|
processing of the data or to access external services such as a relational
|
||||||
|
database.
|
||||||
|
So you can use SAXON with any SAX-compliant XML parser by writing XSLT stylesheets, by writing Java applications, or by any combination of the two.
|
||||||
|
|
||||||
|
19
java-saxon9.1.0.7-Configuration.patch
Normal file
19
java-saxon9.1.0.7-Configuration.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
--- src/net/sf/saxon/Configuration.java 2008-11-04 09:32:18.000000000 +0100
|
||||||
|
+++ src/net/sf/saxon/Configuration.java-gil 2010-01-22 15:47:34.000000000 +0100
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
package net.sf.saxon;
|
||||||
|
|
||||||
|
-/*DOTNETONLY*/ import net.sf.saxon.dotnet.DotNetPlatform;
|
||||||
|
+/*DOTNETONLY import net.sf.saxon.dotnet.DotNetPlatform;*/
|
||||||
|
|
||||||
|
import net.sf.saxon.event.*;
|
||||||
|
import net.sf.saxon.evpull.PullEventSource;
|
||||||
|
@@ -249,7 +249,7 @@
|
||||||
|
|
||||||
|
/*DOTNETONLY*/ /*JAVAONLY*/ if (System.getProperty("java.vendor").equals("Jeroen Frijters")) {
|
||||||
|
//System.err.println("Call to create .NET platform currently disabled in Configuration.java (needed for JDK1.4)");
|
||||||
|
- /*DOTNETONLY*/ platform = DotNetPlatform.getInstance();
|
||||||
|
+ /*DOTNETONLY platform = DotNetPlatform.getInstance();*/
|
||||||
|
/*DOTNETONLY*/ /*JAVAONLY*/ }
|
||||||
|
// System.err.println(System.getProperty("java.vendor"));
|
||||||
|
// System.err.println(platform.getClass().getName());
|
122
java-saxon9.build.script
Normal file
122
java-saxon9.build.script
Normal file
@ -0,0 +1,122 @@
|
|||||||
|
<!-- simple generic build file -->
|
||||||
|
|
||||||
|
<project name="saxon" default="all" basedir=".">
|
||||||
|
|
||||||
|
<!-- Properties -->
|
||||||
|
|
||||||
|
<property name="name" value="saxon9"/>
|
||||||
|
<property name="src" value="src"/>
|
||||||
|
<property name="build" value="build"/>
|
||||||
|
<property name="build.classes" value="${build}/classes"/>
|
||||||
|
<property name="build.doc" value="${build}/api"/>
|
||||||
|
<property name="build.lib" value="${build}/lib"/>
|
||||||
|
<property name="j2se.javadoc" value="/usr/share/javadoc/j2se"/>
|
||||||
|
<property name="jdom.javadoc" value="/usr/share/javadoc/jdom"/>
|
||||||
|
<property name="fop.javadoc" value="/usr/share/javadoc/fop"/>
|
||||||
|
|
||||||
|
<!-- Targets -->
|
||||||
|
|
||||||
|
<!-- Prepare build directories -->
|
||||||
|
<target name="prepare">
|
||||||
|
<mkdir dir="${src}"/>
|
||||||
|
<mkdir dir="${build}"/>
|
||||||
|
<mkdir dir="${build.classes}"/>
|
||||||
|
<mkdir dir="${build.lib}"/>
|
||||||
|
<mkdir dir="${build.doc}"/>
|
||||||
|
<copy todir="${src}">
|
||||||
|
<fileset dir="." includes="com/**,org/**"/>
|
||||||
|
</copy>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Kill all the created directories -->
|
||||||
|
<target name="clean">
|
||||||
|
<delete dir="${build}"/>
|
||||||
|
<delete dir="${src}"/>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build classes -->
|
||||||
|
<target name="classes" depends="prepare">
|
||||||
|
<javac srcdir="${src}" destdir="${build.classes}"/>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build jar archives -->
|
||||||
|
<!--
|
||||||
|
1973246 10-21-01 14:03 saxon9.jar
|
||||||
|
52121 10-21-01 14:03 saxon9-s9api.jar
|
||||||
|
50297 10-21-01 14:03 saxon9-xqj.jar
|
||||||
|
47959 10-21-01 14:03 saxon9-dom.jar
|
||||||
|
22111 10-21-01 14:03 saxon9-xom.jar
|
||||||
|
19797 10-21-01 14:03 saxon9-sql.jar
|
||||||
|
16002 10-21-01 14:03 saxon9-xpath.jar
|
||||||
|
14401 10-21-01 14:03 saxon9-jdom.jar
|
||||||
|
13282 10-21-01 14:03 saxon9-dom4j.jar
|
||||||
|
-->
|
||||||
|
<target name="jar" depends="classes">
|
||||||
|
<!-- dom4j -->
|
||||||
|
<jar destfile="${build.lib}/${name}-dom4j.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/dom4j/*"/>
|
||||||
|
<!-- dom -->
|
||||||
|
<jar destfile="${build.lib}/${name}-dom.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/dom/*"/>
|
||||||
|
<!-- jdom -->
|
||||||
|
<jar destfile="${build.lib}/${name}-jdom.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/jdom/*"/>
|
||||||
|
<!-- s9api -->
|
||||||
|
<jar destfile="${build.lib}/${name}-s9api.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/s9api/*"/>
|
||||||
|
<!-- sql -->
|
||||||
|
<jar destfile="${build.lib}/${name}-sql.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/sql/*"/>
|
||||||
|
<!-- xom -->
|
||||||
|
<jar destfile="${build.lib}/${name}-xom.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/xom/*"/>
|
||||||
|
<!-- xqj -->
|
||||||
|
<jar destfile="${build.lib}/${name}-xqj.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/xqj/*"/>
|
||||||
|
<!-- xpath -->
|
||||||
|
<jar destfile="${build.lib}/${name}-xpath.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
includes="net/sf/saxon/xpath/*">
|
||||||
|
<metainf dir="src/META-INF"
|
||||||
|
includes="services/javax.xml.xpath.*" />
|
||||||
|
</jar>
|
||||||
|
<!-- main -->
|
||||||
|
<jar jarfile="${build.lib}/${name}.jar"
|
||||||
|
basedir="${build.classes}"
|
||||||
|
excludes="net/sf/saxon/dom4j/,net/sf/saxon/dom/,net/sf/saxon/jdom/,net/sf/saxon/s9api/,net/sf/saxon/sql/,net/sf/saxon/xom/,net/sf/saxon/xqj/,net/sf/saxon/xpath/">
|
||||||
|
<metainf dir="src/META-INF"
|
||||||
|
includes="services/javax.xml.transform.*" />
|
||||||
|
<manifest>
|
||||||
|
<attribute name="Main-Class" value="net.sf.saxon.Transform" />
|
||||||
|
</manifest>
|
||||||
|
</jar>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build the full JavaDocs -->
|
||||||
|
<target name="javadoc" depends="prepare">
|
||||||
|
<javadoc sourcepath="${src}"
|
||||||
|
destdir="${build.doc}"
|
||||||
|
doctitle="${name} JavaDoc"
|
||||||
|
windowtitle="${name} JavaDoc"
|
||||||
|
package="true"
|
||||||
|
author="true"
|
||||||
|
version="true"
|
||||||
|
packagenames="net.sf.saxon.*,org.w3c.xsl.*"
|
||||||
|
>
|
||||||
|
<link href="${j2se.javadoc}"/>
|
||||||
|
<link href="${jdom.javadoc}"/>
|
||||||
|
<link href="${fop.javadoc}"/>
|
||||||
|
</javadoc>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
<!-- Build everything -->
|
||||||
|
<target name="all" depends="jar,javadoc"/>
|
||||||
|
|
||||||
|
</project>
|
315
java-saxon9.spec
Normal file
315
java-saxon9.spec
Normal file
@ -0,0 +1,315 @@
|
|||||||
|
%define pkgver %(echo %version | tr . -)
|
||||||
|
%define javahome %{_jvmdir}/jdk
|
||||||
|
Name: java-saxon9
|
||||||
|
Version: 9.1.0.7
|
||||||
|
Release: 3mamba
|
||||||
|
Summary: Saxon XSLT and XQuery Processor
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: gil <puntogil@libero.it>
|
||||||
|
URL: http://saxon.sourceforge.net
|
||||||
|
# http://saxon.svn.sourceforge.net/viewvc/saxon
|
||||||
|
Source0: http://downloads.sourceforge.net/project/saxon/Saxon-B/%{version}/saxonb%{pkgver}source.zip
|
||||||
|
Source1: java-saxon9-services.tar.gz
|
||||||
|
Source2: java-saxon9.build.script
|
||||||
|
Patch0: java-saxon9.1.0.7-Configuration.patch
|
||||||
|
License: MPL
|
||||||
|
BuildRequires: apache-ant
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
BuildRequires: apache-fop == 0.95
|
||||||
|
BuildRequires: apache-fop-javadoc == 0.95
|
||||||
|
%endif
|
||||||
|
BuildRequires: java-xom
|
||||||
|
BuildRequires: java-xqjapi
|
||||||
|
BuildRequires: java-dom
|
||||||
|
BuildRequires: java-dom-javadoc
|
||||||
|
BuildRequires: java-bea-stax
|
||||||
|
BuildRequires: java-bea-stax-api
|
||||||
|
BuildRequires: java-dom4j
|
||||||
|
BuildRequires: jpackage-utils
|
||||||
|
BuildRequires: xml-commons-apis
|
||||||
|
Requires: java-bea-stax
|
||||||
|
Requires: java-bea-stax-api
|
||||||
|
Requires: java-dom
|
||||||
|
Requires: java-dom4j
|
||||||
|
Requires: jpackage-utils
|
||||||
|
Requires: xml-commons-apis
|
||||||
|
Obsoletes: saxon9
|
||||||
|
Provides: saxon9
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The Saxon XSLT and XQuery processor, developed by Michael Kay
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
The main components are:
|
||||||
|
- An XSLT processor, which implements the Version 1.0 XSLT and XPath Recommendations from the World Wide Web Consortium, found at
|
||||||
|
http://www.w3.org/TR/1999/REC-xslt-19991116 and
|
||||||
|
http://www.w3.org/TR/1999/REC-xpath-19991116 with a number of powerful
|
||||||
|
extensions. This version of Saxon also includes many of the new features
|
||||||
|
defined in the XSLT 1.1 working draft, but for conformance and portability
|
||||||
|
reasons these are not available if the stylesheet header specifies
|
||||||
|
version="1.0".
|
||||||
|
- A Java library, which supports a similar processing model to XSL, but allows
|
||||||
|
full programming capability, which you need if you want to perform complex
|
||||||
|
processing of the data or to access external services such as a relational
|
||||||
|
database.
|
||||||
|
So you can use SAXON with any SAX-compliant XML parser by writing XSLT stylesheets, by writing Java applications, or by any combination of the two.
|
||||||
|
|
||||||
|
%package dom
|
||||||
|
Summary: DOM support for %{name}
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Obsoletes: saxon9-dom
|
||||||
|
Provides: saxon9-dom
|
||||||
|
|
||||||
|
%description dom
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
Provides additional classes enabling Saxon to be used with the DOM Document Object Model. Supports using a DOM as the input or output of transformations and queries, and calling extension functions that use DOM interfaces to access a Saxon tree structure. Requires DOM level 3 (dom.jar, part of JAXP 1.3) to be on the classpath, if not running under JDK 1.5.
|
||||||
|
|
||||||
|
%package jdom
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Summary: JDOM support for %{name}
|
||||||
|
Requires: java-dom
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Obsoletes: saxon9-jdom
|
||||||
|
Provides: saxon9-jdom
|
||||||
|
|
||||||
|
%description jdom
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
This package contains JDOM support for %{name}.
|
||||||
|
|
||||||
|
%package dom4j
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Summary: DOM4J support for %{name}
|
||||||
|
Requires: java-dom
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Obsoletes: saxon9-dom4j
|
||||||
|
Provides: saxon9-dom4j
|
||||||
|
|
||||||
|
%description dom4j
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
This package contains DOM4J support for %{name}.
|
||||||
|
|
||||||
|
%package sql
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Summary: SQL support for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Obsoletes: saxon9-sql
|
||||||
|
Provides: saxon9-sql
|
||||||
|
|
||||||
|
%description sql
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
This package contains supports XSLT extensions for accessing and updating a relational database from within a stylesheet.
|
||||||
|
|
||||||
|
%package s9api
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Summary: Java API for %{name}
|
||||||
|
Obsoletes: saxon9-s9api
|
||||||
|
Provides: saxon9-s9api
|
||||||
|
|
||||||
|
%description s9api
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
This package provides a Java API for %{name}
|
||||||
|
|
||||||
|
%package xom
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Summary: XOM support for %{name}
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: java-xom
|
||||||
|
Obsoletes: saxon9-xom
|
||||||
|
Provides: saxon9-xom
|
||||||
|
|
||||||
|
%description xom
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
Provides additional classes enabling Saxon to be used with XOM trees. Supports using a XOM document as the input or output of transformations and queries. Requires xom.jar on the classpath.
|
||||||
|
|
||||||
|
%package xpath
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Summary: XPATH support for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Obsoletes: saxon9-xpath
|
||||||
|
Provides: saxon9-xpath
|
||||||
|
|
||||||
|
%description xpath
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
Provides support for the JAXP 1.3 XPath API. Requires the JAXP 1.3 version of jaxp-api.jar on the classpath, if not running under JDK 1.5.
|
||||||
|
|
||||||
|
%package xqj
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Summary: XQUERY support for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Requires: java-xqjapi
|
||||||
|
Obsoletes: saxon9-xqj
|
||||||
|
Provides: saxon9-xqj
|
||||||
|
|
||||||
|
%description xqj
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
This package contains XQUERY support for %{name}.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Group: Documentation
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
Requires: java-dom-javadoc
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
|
This package contains javadoc for %{name}
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -c -n saxonb-%{version} -a 1
|
||||||
|
|
||||||
|
for j in $(find -name "*.jar"); do
|
||||||
|
mv $j $j.no
|
||||||
|
done
|
||||||
|
|
||||||
|
for j in $(find -name "*.class"); do
|
||||||
|
rm -rf $j
|
||||||
|
done
|
||||||
|
|
||||||
|
rm -rf docs/api
|
||||||
|
|
||||||
|
find -name "*.exe" -exec rm -rf {} \;
|
||||||
|
|
||||||
|
for j in $(find -name ".svn"); do
|
||||||
|
rm -rf $j
|
||||||
|
done
|
||||||
|
|
||||||
|
cp -p %{S:2} ./build.xml
|
||||||
|
|
||||||
|
# require for .NET compilation: IKVM
|
||||||
|
rm -rf bj/net/sf/saxon/dotnet
|
||||||
|
rm -rf net/sf/saxon/dotnet
|
||||||
|
|
||||||
|
mkdir -p build/classes
|
||||||
|
cp -pr net src/
|
||||||
|
|
||||||
|
%patch0
|
||||||
|
|
||||||
|
%build
|
||||||
|
export JAVA_HOME=%javahome
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
export CLASSPATH=$(build-classpath xml-commons-apis xom fop jdom dom4j bea-stax-ri bea-stax-api xqjapi):build/classes
|
||||||
|
%else
|
||||||
|
export CLASSPATH=$(build-classpath xml-commons-apis xom jdom dom4j bea-stax-ri bea-stax-api xqjapi):build/classes
|
||||||
|
%endif
|
||||||
|
ant \
|
||||||
|
-Dj2se.javadoc=%{_javadocdir}/java-gcj-compat \
|
||||||
|
-Djdom.javadoc=%{_javadocdir}/jdom \
|
||||||
|
-Dfop.javadoc=%{_javadocdir}/fop
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadir}
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-dom4j.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-dom4j-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-dom.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-dom-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-jdom.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-jdom-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-s9api.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-s9api-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-sql.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-sql-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-xom.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-xom-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-xqj.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-xqj-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9-xpath.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-xpath-%{version}.jar
|
||||||
|
|
||||||
|
install -m 644 build/lib/saxon9.jar \
|
||||||
|
%{buildroot}%{_javadir}/saxon9-%{version}.jar
|
||||||
|
|
||||||
|
(
|
||||||
|
cd %{buildroot}%{_javadir}
|
||||||
|
for jar in *-%{version}*; do
|
||||||
|
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||||
|
done
|
||||||
|
)
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadocdir}/saxon9-%{version}
|
||||||
|
cp -pr build/api/* %{buildroot}%{_javadocdir}/saxon9-%{version}
|
||||||
|
ln -sf saxon9-%{version} %{buildroot}%{_javadocdir}/saxon9
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-%{version}.jar
|
||||||
|
%{_javadir}/saxon9.jar
|
||||||
|
|
||||||
|
%files dom
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-dom-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-dom.jar
|
||||||
|
|
||||||
|
%files dom4j
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-dom4j-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-dom4j.jar
|
||||||
|
|
||||||
|
%files jdom
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-jdom-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-jdom.jar
|
||||||
|
|
||||||
|
%files s9api
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-s9api-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-s9api.jar
|
||||||
|
|
||||||
|
%files sql
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-sql-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-sql.jar
|
||||||
|
|
||||||
|
%files xom
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-xom-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-xom.jar
|
||||||
|
|
||||||
|
%files xpath
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-xpath-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-xpath.jar
|
||||||
|
|
||||||
|
%files xqj
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/saxon9-xqj-%{version}.jar
|
||||||
|
%{_javadir}/saxon9-xqj.jar
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadocdir}/saxon9-%{version}
|
||||||
|
%{_javadocdir}/saxon9
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Mar 25 2011 gil <puntogil@libero.it> 9.1.0.7-3mamba
|
||||||
|
- rebuilt with java-gcj-compat support
|
||||||
|
|
||||||
|
* Wed Nov 24 2010 gil <puntogil@libero.it> 9.1.0.7-2mamba
|
||||||
|
- rebuilt devel
|
||||||
|
|
||||||
|
* Fri May 08 2009 gil <puntogil@libero.it> 9.1.0.7-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user