update to 9.1.0.8 [release 9.1.0.8-1mamba;Sun Dec 12 2021]
This commit is contained in:
parent
ed47947835
commit
25db390066
@ -1,19 +0,0 @@
|
|||||||
--- src/net/sf/saxon/Configuration.java 2008-11-04 09:32:18.000000000 +0100
|
|
||||||
+++ src/net/sf/saxon/Configuration.java-gil 2010-01-22 15:47:34.000000000 +0100
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
package net.sf.saxon;
|
|
||||||
|
|
||||||
-/*DOTNETONLY*/ import net.sf.saxon.dotnet.DotNetPlatform;
|
|
||||||
+/*DOTNETONLY import net.sf.saxon.dotnet.DotNetPlatform;*/
|
|
||||||
|
|
||||||
import net.sf.saxon.event.*;
|
|
||||||
import net.sf.saxon.evpull.PullEventSource;
|
|
||||||
@@ -249,7 +249,7 @@
|
|
||||||
|
|
||||||
/*DOTNETONLY*/ /*JAVAONLY*/ if (System.getProperty("java.vendor").equals("Jeroen Frijters")) {
|
|
||||||
//System.err.println("Call to create .NET platform currently disabled in Configuration.java (needed for JDK1.4)");
|
|
||||||
- /*DOTNETONLY*/ platform = DotNetPlatform.getInstance();
|
|
||||||
+ /*DOTNETONLY platform = DotNetPlatform.getInstance();*/
|
|
||||||
/*DOTNETONLY*/ /*JAVAONLY*/ }
|
|
||||||
// System.err.println(System.getProperty("java.vendor"));
|
|
||||||
// System.err.println(platform.getClass().getName());
|
|
@ -1,122 +0,0 @@
|
|||||||
<!-- simple generic build file -->
|
|
||||||
|
|
||||||
<project name="saxon" default="all" basedir=".">
|
|
||||||
|
|
||||||
<!-- Properties -->
|
|
||||||
|
|
||||||
<property name="name" value="saxon9"/>
|
|
||||||
<property name="src" value="src"/>
|
|
||||||
<property name="build" value="build"/>
|
|
||||||
<property name="build.classes" value="${build}/classes"/>
|
|
||||||
<property name="build.doc" value="${build}/api"/>
|
|
||||||
<property name="build.lib" value="${build}/lib"/>
|
|
||||||
<property name="j2se.javadoc" value="/usr/share/javadoc/j2se"/>
|
|
||||||
<property name="jdom.javadoc" value="/usr/share/javadoc/jdom"/>
|
|
||||||
<property name="fop.javadoc" value="/usr/share/javadoc/fop"/>
|
|
||||||
|
|
||||||
<!-- Targets -->
|
|
||||||
|
|
||||||
<!-- Prepare build directories -->
|
|
||||||
<target name="prepare">
|
|
||||||
<mkdir dir="${src}"/>
|
|
||||||
<mkdir dir="${build}"/>
|
|
||||||
<mkdir dir="${build.classes}"/>
|
|
||||||
<mkdir dir="${build.lib}"/>
|
|
||||||
<mkdir dir="${build.doc}"/>
|
|
||||||
<copy todir="${src}">
|
|
||||||
<fileset dir="." includes="com/**,org/**"/>
|
|
||||||
</copy>
|
|
||||||
</target>
|
|
||||||
|
|
||||||
<!-- Kill all the created directories -->
|
|
||||||
<target name="clean">
|
|
||||||
<delete dir="${build}"/>
|
|
||||||
<delete dir="${src}"/>
|
|
||||||
</target>
|
|
||||||
|
|
||||||
<!-- Build classes -->
|
|
||||||
<target name="classes" depends="prepare">
|
|
||||||
<javac srcdir="${src}" destdir="${build.classes}"/>
|
|
||||||
</target>
|
|
||||||
|
|
||||||
<!-- Build jar archives -->
|
|
||||||
<!--
|
|
||||||
1973246 10-21-01 14:03 saxon9.jar
|
|
||||||
52121 10-21-01 14:03 saxon9-s9api.jar
|
|
||||||
50297 10-21-01 14:03 saxon9-xqj.jar
|
|
||||||
47959 10-21-01 14:03 saxon9-dom.jar
|
|
||||||
22111 10-21-01 14:03 saxon9-xom.jar
|
|
||||||
19797 10-21-01 14:03 saxon9-sql.jar
|
|
||||||
16002 10-21-01 14:03 saxon9-xpath.jar
|
|
||||||
14401 10-21-01 14:03 saxon9-jdom.jar
|
|
||||||
13282 10-21-01 14:03 saxon9-dom4j.jar
|
|
||||||
-->
|
|
||||||
<target name="jar" depends="classes">
|
|
||||||
<!-- dom4j -->
|
|
||||||
<jar destfile="${build.lib}/${name}-dom4j.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/dom4j/*"/>
|
|
||||||
<!-- dom -->
|
|
||||||
<jar destfile="${build.lib}/${name}-dom.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/dom/*"/>
|
|
||||||
<!-- jdom -->
|
|
||||||
<jar destfile="${build.lib}/${name}-jdom.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/jdom/*"/>
|
|
||||||
<!-- s9api -->
|
|
||||||
<jar destfile="${build.lib}/${name}-s9api.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/s9api/*"/>
|
|
||||||
<!-- sql -->
|
|
||||||
<jar destfile="${build.lib}/${name}-sql.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/sql/*"/>
|
|
||||||
<!-- xom -->
|
|
||||||
<jar destfile="${build.lib}/${name}-xom.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/xom/*"/>
|
|
||||||
<!-- xqj -->
|
|
||||||
<jar destfile="${build.lib}/${name}-xqj.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/xqj/*"/>
|
|
||||||
<!-- xpath -->
|
|
||||||
<jar destfile="${build.lib}/${name}-xpath.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
includes="net/sf/saxon/xpath/*">
|
|
||||||
<metainf dir="src/META-INF"
|
|
||||||
includes="services/javax.xml.xpath.*" />
|
|
||||||
</jar>
|
|
||||||
<!-- main -->
|
|
||||||
<jar jarfile="${build.lib}/${name}.jar"
|
|
||||||
basedir="${build.classes}"
|
|
||||||
excludes="net/sf/saxon/dom4j/,net/sf/saxon/dom/,net/sf/saxon/jdom/,net/sf/saxon/s9api/,net/sf/saxon/sql/,net/sf/saxon/xom/,net/sf/saxon/xqj/,net/sf/saxon/xpath/">
|
|
||||||
<metainf dir="src/META-INF"
|
|
||||||
includes="services/javax.xml.transform.*" />
|
|
||||||
<manifest>
|
|
||||||
<attribute name="Main-Class" value="net.sf.saxon.Transform" />
|
|
||||||
</manifest>
|
|
||||||
</jar>
|
|
||||||
</target>
|
|
||||||
|
|
||||||
<!-- Build the full JavaDocs -->
|
|
||||||
<target name="javadoc" depends="prepare">
|
|
||||||
<javadoc sourcepath="${src}"
|
|
||||||
destdir="${build.doc}"
|
|
||||||
doctitle="${name} JavaDoc"
|
|
||||||
windowtitle="${name} JavaDoc"
|
|
||||||
package="true"
|
|
||||||
author="true"
|
|
||||||
version="true"
|
|
||||||
packagenames="net.sf.saxon.*,org.w3c.xsl.*"
|
|
||||||
>
|
|
||||||
<link href="${j2se.javadoc}"/>
|
|
||||||
<link href="${jdom.javadoc}"/>
|
|
||||||
<link href="${fop.javadoc}"/>
|
|
||||||
</javadoc>
|
|
||||||
</target>
|
|
||||||
|
|
||||||
<!-- Build everything -->
|
|
||||||
<target name="all" depends="jar,javadoc"/>
|
|
||||||
|
|
||||||
</project>
|
|
160
java-saxon9.spec
160
java-saxon9.spec
@ -1,43 +1,27 @@
|
|||||||
%define pkgver %(echo %version | tr . -)
|
%define pkgver %(echo %version | tr . -)
|
||||||
%define javahome %{_jvmdir}/jdk
|
|
||||||
Name: java-saxon9
|
Name: java-saxon9
|
||||||
Version: 9.1.0.7
|
Version: 9.1.0.8
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: Saxon XSLT and XQuery Processor
|
Summary: Saxon XSLT and XQuery Processor
|
||||||
Group: Development/Libraries/Java
|
Group: Development/Libraries/Java
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: gil <puntogil@libero.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://saxon.sourceforge.net
|
URL: http://saxon.sourceforge.net
|
||||||
# http://saxon.svn.sourceforge.net/viewvc/saxon
|
Source0: https://sourceforge.net/projects/saxon/files/Saxon-B/%{version}/saxonb%{pkgver}j.zip
|
||||||
Source0: http://downloads.sourceforge.net/project/saxon/Saxon-B/%{version}/saxonb%{pkgver}source.zip
|
|
||||||
Source1: java-saxon9-services.tar.gz
|
|
||||||
Source2: java-saxon9.build.script
|
|
||||||
Patch0: java-saxon9.1.0.7-Configuration.patch
|
|
||||||
License: MPL
|
License: MPL
|
||||||
BuildRequires: apache-ant
|
## AUTOBUILDREQ-BEGIN
|
||||||
%if "%{stage1}" != "1"
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: apache-fop == 0.95
|
BuildRequires: javapackages
|
||||||
BuildRequires: apache-fop-javadoc == 0.95
|
#Requires: java-bea-stax
|
||||||
%endif
|
#Requires: java-bea-stax-api
|
||||||
BuildRequires: java-xom
|
#Requires: java-dom
|
||||||
BuildRequires: java-xqjapi
|
#Requires: java-dom4j
|
||||||
BuildRequires: java-dom
|
Requires: javapackages
|
||||||
BuildRequires: java-dom-javadoc
|
#Requires: xml-commons-apis
|
||||||
BuildRequires: java-bea-stax
|
|
||||||
BuildRequires: java-bea-stax-api
|
|
||||||
BuildRequires: java-dom4j
|
|
||||||
BuildRequires: jpackage-utils
|
|
||||||
BuildRequires: xml-commons-apis
|
|
||||||
Requires: java-bea-stax
|
|
||||||
Requires: java-bea-stax-api
|
|
||||||
Requires: java-dom
|
|
||||||
Requires: java-dom4j
|
|
||||||
Requires: jpackage-utils
|
|
||||||
Requires: xml-commons-apis
|
|
||||||
Obsoletes: saxon9
|
|
||||||
Provides: saxon9
|
Provides: saxon9
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
Obsoletes: saxon9 < 9.1.0.7
|
||||||
|
Provides: java-saxon9 = 9.1.0.7
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The Saxon XSLT and XQuery processor, developed by Michael Kay
|
The Saxon XSLT and XQuery processor, developed by Michael Kay
|
||||||
@ -60,61 +44,56 @@ So you can use SAXON with any SAX-compliant XML parser by writing XSLT styleshee
|
|||||||
Summary: DOM support for %{name}
|
Summary: DOM support for %{name}
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Obsoletes: saxon9-dom
|
|
||||||
Provides: saxon9-dom
|
Provides: saxon9-dom
|
||||||
|
Obsoletes: saxon9-dom < 9.1.0.7
|
||||||
|
|
||||||
%description dom
|
%description dom
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
Provides additional classes enabling Saxon to be used with the DOM Document Object Model. Supports using a DOM as the input or output of transformations and queries, and calling extension functions that use DOM interfaces to access a Saxon tree structure. Requires DOM level 3 (dom.jar, part of JAXP 1.3) to be on the classpath, if not running under JDK 1.5.
|
Provides additional classes enabling Saxon to be used with the DOM Document Object Model. Supports using a DOM as the input or output of transformations and queries, and calling extension functions that use DOM interfaces to access a Saxon tree structure. Requires DOM level 3 (dom.jar, part of JAXP 1.3) to be on the classpath, if not running under JDK 1.5.
|
||||||
|
|
||||||
%package jdom
|
%package jdom
|
||||||
Group: Development/Libraries/Java
|
Group: Development/Libraries/Java
|
||||||
Summary: JDOM support for %{name}
|
Summary: JDOM support for %{name}
|
||||||
Requires: java-dom
|
#Requires: java-dom
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Obsoletes: saxon9-jdom
|
|
||||||
Provides: saxon9-jdom
|
Provides: saxon9-jdom
|
||||||
|
Obsoletes: saxon9-jdom < 9.1.0.7
|
||||||
|
|
||||||
%description jdom
|
%description jdom
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
This package contains JDOM support for %{name}.
|
This package contains JDOM support for %{name}.
|
||||||
|
|
||||||
%package dom4j
|
%package dom4j
|
||||||
Group: Development/Libraries/Java
|
Group: Development/Libraries/Java
|
||||||
Summary: DOM4J support for %{name}
|
Summary: DOM4J support for %{name}
|
||||||
Requires: java-dom
|
#Requires: java-dom
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Obsoletes: saxon9-dom4j
|
Obsoletes: saxon9-dom4j < 9.1.0.7
|
||||||
Provides: saxon9-dom4j
|
Provides: saxon9-dom4j
|
||||||
|
|
||||||
%description dom4j
|
%description dom4j
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
This package contains DOM4J support for %{name}.
|
This package contains DOM4J support for %{name}.
|
||||||
|
|
||||||
%package sql
|
%package sql
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Summary: SQL support for %{name}
|
Summary: SQL support for %{name}
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Obsoletes: saxon9-sql
|
|
||||||
Provides: saxon9-sql
|
Provides: saxon9-sql
|
||||||
|
Obsoletes: saxon9-sql < 9.1.0.7
|
||||||
|
|
||||||
%description sql
|
%description sql
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
This package contains supports XSLT extensions for accessing and updating a relational database from within a stylesheet.
|
This package contains supports XSLT extensions for accessing and updating a relational database from within a stylesheet.
|
||||||
|
|
||||||
%package s9api
|
%package s9api
|
||||||
Group: Development/Libraries/Java
|
Group: Development/Libraries/Java
|
||||||
Summary: Java API for %{name}
|
Summary: Java API for %{name}
|
||||||
Obsoletes: saxon9-s9api
|
|
||||||
Provides: saxon9-s9api
|
Provides: saxon9-s9api
|
||||||
|
Obsoletes: saxon9-s9api < 9.1.0.7
|
||||||
|
|
||||||
%description s9api
|
%description s9api
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
This package provides a Java API for %{name}
|
This package provides a Java API for %{name}
|
||||||
|
|
||||||
%package xom
|
%package xom
|
||||||
@ -122,122 +101,72 @@ Group: Applications/Publishing
|
|||||||
Summary: XOM support for %{name}
|
Summary: XOM support for %{name}
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: java-xom
|
#Requires: java-xom
|
||||||
Obsoletes: saxon9-xom
|
|
||||||
Provides: saxon9-xom
|
Provides: saxon9-xom
|
||||||
|
Obsoletes: saxon9-xom < 9.1.0.7
|
||||||
|
|
||||||
%description xom
|
%description xom
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
Provides additional classes enabling Saxon to be used with XOM trees. Supports using a XOM document as the input or output of transformations and queries. Requires xom.jar on the classpath.
|
Provides additional classes enabling Saxon to be used with XOM trees. Supports using a XOM document as the input or output of transformations and queries. Requires xom.jar on the classpath.
|
||||||
|
|
||||||
%package xpath
|
%package xpath
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Summary: XPATH support for %{name}
|
Summary: XPATH support for %{name}
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Obsoletes: saxon9-xpath
|
|
||||||
Provides: saxon9-xpath
|
Provides: saxon9-xpath
|
||||||
|
Obsoletes: saxon9-xpath < 9.1.0.7
|
||||||
|
|
||||||
%description xpath
|
%description xpath
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
Provides support for the JAXP 1.3 XPath API. Requires the JAXP 1.3 version of jaxp-api.jar on the classpath, if not running under JDK 1.5.
|
Provides support for the JAXP 1.3 XPath API. Requires the JAXP 1.3 version of jaxp-api.jar on the classpath, if not running under JDK 1.5.
|
||||||
|
|
||||||
%package xqj
|
%package xqj
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Summary: XQUERY support for %{name}
|
Summary: XQUERY support for %{name}
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: java-xqjapi
|
#Requires: java-xqjapi
|
||||||
Obsoletes: saxon9-xqj
|
|
||||||
Provides: saxon9-xqj
|
Provides: saxon9-xqj
|
||||||
|
Obsoletes: saxon9-xqj < 9.1.0.7
|
||||||
|
|
||||||
%description xqj
|
%description xqj
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
The SAXON package is a collection of tools for processing XML documents.
|
||||||
|
|
||||||
This package contains XQUERY support for %{name}.
|
This package contains XQUERY support for %{name}.
|
||||||
|
|
||||||
%package javadoc
|
|
||||||
Group: Documentation
|
|
||||||
Summary: Javadoc for %{name}
|
|
||||||
Requires: java-dom-javadoc
|
|
||||||
|
|
||||||
%description javadoc
|
|
||||||
The SAXON package is a collection of tools for processing XML documents.
|
|
||||||
|
|
||||||
This package contains javadoc for %{name}
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -c -n saxonb-%{version} -a 1
|
%setup -q -c
|
||||||
|
|
||||||
for j in $(find -name "*.jar"); do
|
|
||||||
mv $j $j.no
|
|
||||||
done
|
|
||||||
|
|
||||||
for j in $(find -name "*.class"); do
|
|
||||||
rm -rf $j
|
|
||||||
done
|
|
||||||
|
|
||||||
rm -rf docs/api
|
|
||||||
|
|
||||||
find -name "*.exe" -exec rm -rf {} \;
|
|
||||||
|
|
||||||
for j in $(find -name ".svn"); do
|
|
||||||
rm -rf $j
|
|
||||||
done
|
|
||||||
|
|
||||||
cp -p %{S:2} ./build.xml
|
|
||||||
|
|
||||||
# require for .NET compilation: IKVM
|
|
||||||
rm -rf bj/net/sf/saxon/dotnet
|
|
||||||
rm -rf net/sf/saxon/dotnet
|
|
||||||
|
|
||||||
mkdir -p build/classes
|
|
||||||
cp -pr net src/
|
|
||||||
|
|
||||||
%patch0
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export JAVA_HOME=%javahome
|
|
||||||
%if "%{stage1}" != "1"
|
|
||||||
export CLASSPATH=$(build-classpath xml-commons-apis xom fop jdom dom4j bea-stax-ri bea-stax-api xqjapi):build/classes
|
|
||||||
%else
|
|
||||||
export CLASSPATH=$(build-classpath xml-commons-apis xom jdom dom4j bea-stax-ri bea-stax-api xqjapi):build/classes
|
|
||||||
%endif
|
|
||||||
ant \
|
|
||||||
-Dj2se.javadoc=%{_javadocdir}/java-gcj-compat \
|
|
||||||
-Djdom.javadoc=%{_javadocdir}/jdom \
|
|
||||||
-Dfop.javadoc=%{_javadocdir}/fop
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_javadir}
|
mkdir -p %{buildroot}%{_javadir}
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-dom4j.jar \
|
install -m 644 saxon9-dom4j.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-dom4j-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-dom4j-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-dom.jar \
|
install -m 644 saxon9-dom.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-dom-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-dom-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-jdom.jar \
|
install -m 644 saxon9-jdom.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-jdom-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-jdom-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-s9api.jar \
|
install -m 644 saxon9-s9api.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-s9api-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-s9api-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-sql.jar \
|
install -m 644 saxon9-sql.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-sql-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-sql-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-xom.jar \
|
install -m 644 saxon9-xom.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-xom-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-xom-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-xqj.jar \
|
install -m 644 saxon9-xqj.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-xqj-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-xqj-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9-xpath.jar \
|
install -m 644 saxon9-xpath.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-xpath-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-xpath-%{version}.jar
|
||||||
|
|
||||||
install -m 644 build/lib/saxon9.jar \
|
install -m 644 saxon9.jar \
|
||||||
%{buildroot}%{_javadir}/saxon9-%{version}.jar
|
%{buildroot}%{_javadir}/saxon9-%{version}.jar
|
||||||
|
|
||||||
(
|
(
|
||||||
@ -247,10 +176,6 @@ install -m 644 build/lib/saxon9.jar \
|
|||||||
done
|
done
|
||||||
)
|
)
|
||||||
|
|
||||||
mkdir -p %{buildroot}%{_javadocdir}/saxon9-%{version}
|
|
||||||
cp -pr build/api/* %{buildroot}%{_javadocdir}/saxon9-%{version}
|
|
||||||
ln -sf saxon9-%{version} %{buildroot}%{_javadocdir}/saxon9
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
@ -299,12 +224,13 @@ ln -sf saxon9-%{version} %{buildroot}%{_javadocdir}/saxon9
|
|||||||
%{_javadir}/saxon9-xqj-%{version}.jar
|
%{_javadir}/saxon9-xqj-%{version}.jar
|
||||||
%{_javadir}/saxon9-xqj.jar
|
%{_javadir}/saxon9-xqj.jar
|
||||||
|
|
||||||
%files javadoc
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_javadocdir}/saxon9-%{version}
|
|
||||||
%{_javadocdir}/saxon9
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 9.1.0.8-1mamba
|
||||||
|
- update to 9.1.0.8
|
||||||
|
|
||||||
|
* Sun Dec 12 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 9.1.0.7-4mamba
|
||||||
|
- rebuilt providing upstream jars
|
||||||
|
|
||||||
* Fri Mar 25 2011 gil <puntogil@libero.it> 9.1.0.7-3mamba
|
* Fri Mar 25 2011 gil <puntogil@libero.it> 9.1.0.7-3mamba
|
||||||
- rebuilt with java-gcj-compat support
|
- rebuilt with java-gcj-compat support
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user