rebuilt devel [release 3.0.2-2mamba;Mon Nov 29 2010]

This commit is contained in:
gil 2024-01-06 00:08:28 +01:00
parent 20148ed6a8
commit 961b08086f
21 changed files with 846 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# java-mx4j # java-mx4j
MX4J is an Open Source implementation of the Java Management Extensions technology, for both JSR 3 (JMX) and JSR 160 (JMX Remote API)

View File

@ -0,0 +1,10 @@
--- mx4j-3.0.1/src/docs/xsl/mx4j-chunk.xsl 2009-03-20 19:53:52.000000000 +0100
+++ mx4j-3.0.1/src/docs/xsl/mx4j-chunk.xsl-gil 2009-03-20 20:32:55.000000000 +0100
@@ -1,6 +1,6 @@
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version='1.0'>
- <xsl:import href="http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl"/>
+ <xsl:import href="/usr/share/sgml/docbook/xsl-stylesheets/html/chunk.xsl"/>
<xsl:import href="autotoc.xsl"/>
<xsl:param name="html.stylesheet">styles.css</xsl:param>

View File

@ -0,0 +1,52 @@
--- mx4j-3.0.1/src/core/mx4j/remote/resolver/iiop/Resolver.java 2005-03-01 11:14:14.000000000 +0100
+++ mx4j-3.0.1/src/core/mx4j/remote/resolver/iiop/Resolver.java-gil 2009-03-17 00:52:47.000000000 +0100
@@ -32,6 +32,7 @@
private static final String IOR_CONTEXT = "/ior/";
private ORB orb;
+ private static final String ORB_KEY = "java.naming.corba.orb";
//********************************************************************************************************************//
@@ -110,19 +111,29 @@
{
if (orb == null)
{
- Properties props = new Properties();
- // Using putAll() on a Properties is discouraged, since it expects only Strings
- for (Iterator i = environment.entrySet().iterator(); i.hasNext();)
- {
- Map.Entry entry = (Map.Entry)i.next();
- Object key = entry.getKey();
- Object value = entry.getValue();
- if (key instanceof String && value instanceof String)
- {
- props.setProperty((String)key, (String)value);
+ Object candidateORB = environment.get(ORB_KEY);
+ if (candidateORB != null)
+ {
+ // Throw as required by the spec
+ if (!(candidateORB instanceof ORB)) throw new IllegalArgumentException("Property " + ORB_KEY + " must specify a " + ORB.class.getName() + ", not " + candidateORB.getClass().getName());
+ orb = (ORB)candidateORB;
+ }
+ else
+ {
+ Properties props = new Properties();
+ // Using putAll() on a Properties is discouraged, since it expects only Strings
+ for (Iterator i = environment.entrySet().iterator(); i.hasNext();)
+ {
+ Map.Entry entry = (Map.Entry)i.next();
+ Object key = entry.getKey();
+ Object value = entry.getValue();
+ if (key instanceof String && value instanceof String)
+ {
+ props.setProperty((String)key, (String)value);
+ }
}
- }
- orb = ORB.init((String[])null, props);
+ orb = ORB.init((String[])null, props);
+ }
}
return orb;
}

View File

@ -0,0 +1,17 @@
--- mx4j-3.0.1/build/build.xml 2009-03-17 01:59:00.000000000 +0100
+++ mx4j-3.0.1/build/build.xml-gil 2009-03-17 02:01:13.000000000 +0100
@@ -254,12 +254,14 @@
</target>
<target name="rmic.iiop.poa" description="RMI compiles the remote JMX (JSR 160) classes using the -poa option" if="jdk14.present">
+<!--
<rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIServerImpl" classpathref="classpath" debug="yes" iiop="yes">
<compilerarg value="-poa"/>
</rmic>
<rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIConnectionImpl" classpathref="classpath" debug="yes" iiop="yes">
<compilerarg value="-poa"/>
</rmic>
+-->
</target>
<target name="rmic.iiop" description="RMI compiles the remote JMX (JSR 160) classes" unless="jdk14.present">

View File

@ -0,0 +1,20 @@
--- mx4j-3.0.1/build/build.xml 2009-03-17 02:05:57.000000000 +0100
+++ mx4j-3.0.1/build/build.xml-gil 2009-03-17 02:07:44.000000000 +0100
@@ -253,16 +253,7 @@
</jar>
</target>
- <target name="rmic.iiop.poa" description="RMI compiles the remote JMX (JSR 160) classes using the -poa option" if="jdk14.present">
- <rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIServerImpl" classpathref="classpath" debug="yes" iiop="yes">
- <compilerarg value="-poa"/>
- </rmic>
- <rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIConnectionImpl" classpathref="classpath" debug="yes" iiop="yes">
- <compilerarg value="-poa"/>
- </rmic>
- </target>
-
- <target name="rmic.iiop" description="RMI compiles the remote JMX (JSR 160) classes" unless="jdk14.present">
+ <target name="rmic.iiop" description="RMI compiles the remote JMX (JSR 160) classes">
<rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIServerImpl" classpathref="classpath" debug="yes" iiop="yes"/>
<rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIConnectionImpl" classpathref="classpath" debug="yes" iiop="yes"/>
</target>

View File

@ -0,0 +1,105 @@
--- mx4j-3.0.2/build/build.xml 2006-10-13 01:12:17.000000000 +0200
+++ mx4j-3.0.2/build/build.xml-gil 2009-09-07 19:44:29.000000000 +0200
@@ -55,6 +55,9 @@
<property name="rjmx.jar.file" value="${dist.lib.dir}/${name}-rjmx.jar"/>
<property name="rimpl.jar.file" value="${dist.lib.dir}/${name}-rimpl.jar"/>
<property name="rmx4j.jar.file" value="${dist.lib.dir}/${name}-remote.jar"/>
+ <property name="rjmx-boa.jar.file" value="${dist.lib.dir}/boa/${name}-rjmx-boa.jar"/>
+ <property name="rimpl-boa.jar.file" value="${dist.lib.dir}/boa/${name}-rimpl-boa.jar"/>
+ <property name="rmx4j-boa.jar.file" value="${dist.lib.dir}/boa/${name}-remote-boa.jar"/>
<property name="tools.jar.file" value="${dist.lib.dir}/${name}-tools.jar"/>
@@ -261,6 +264,25 @@
</javac>
<rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIServerImpl" classpathref="classpath" debug="yes" stubversion="1.2"/>
<rmic base="${core.classes.dir}" classname="javax.management.remote.rmi.RMIConnectionImpl" classpathref="classpath" debug="yes" stubversion="1.2"/>
+
+ <jar jarfile="${rjmx-boa.jar.file}" manifest="${etc.dir}/MANIFEST.MF">
+ <fileset dir="${core.classes.dir}">
+ <patternset refid="rjmx.classes"/>
+ </fileset>
+ </jar>
+
+ <jar jarfile="${rimpl-boa.jar.file}" manifest="${etc.dir}/MANIFEST.MF">
+ <fileset dir="${core.classes.dir}">
+ <patternset refid="rimpl.classes"/>
+ </fileset>
+ </jar>
+
+ <jar jarfile="${rmx4j-boa.jar.file}" manifest="${etc.dir}/MANIFEST.MF">
+ <fileset dir="${core.classes.dir}">
+ <patternset refid="rmx4j.classes"/>
+ </fileset>
+ </jar>
+
<antcall target="rmic.iiop"/>
<jar jarfile="${rjmx.jar.file}" manifest="${etc.dir}/MANIFEST.MF">
@@ -427,8 +449,6 @@
</target>
<target name="docs" description="Builds the MX4J documentation">
- <unzip src="${docbook.dtd.zip.file}" dest="${docs.src.dir}/docbook"/>
- <unzip src="${docbook.xsl.zip.file}" dest="${docs.src.dir}/docbookx"/>
<mkdir dir="${dist.docs.dir}"/>
<style processor="trax"
@@ -437,11 +457,13 @@
force="yes"
style="${docs.src.dir}/xsl/mx4j-chunk.xsl"
includes="${root.document.name}"
- classpathref="lib.classpath"
- />
-
- <delete dir="${docs.src.dir}/docbook" quiet="true"/>
- <delete dir="${docs.src.dir}/docbookx" quiet="true"/>
+ classpathref="lib.classpath">
+ <xmlcatalog>
+ <catalogpath>
+ <pathelement location="/etc/xml/catalog"/>
+ </catalogpath>
+ </xmlcatalog>
+ </style>>
<!-- Bug in Ant forces this move, since destdir of the style task does not work -->
<move todir="${dist.docs.dir}">
@@ -573,7 +595,8 @@
<include name="wsdl4j.jar"/>
<include name="commons-discovery.jar"/>
<include name="org.mortbay.jetty.jar"/>
- <include name="hessian-3.0.8.jar"/>
+ <include name="hessian.jar"/>
+ <include name="burlap3.jar"/>
<!-- Also jars downloaded apart -->
<include name="servlet.jar"/>
<include name="jython.jar"/>
@@ -602,7 +625,9 @@
<target name="single-test" description="Executes the test class defined by the system property 'testname'" depends="tests">
<junit printsummary="withOutAndErr" fork="yes" dir="${basedir}" showoutput="yes">
- <!--sysproperty key="mx4j.log.priority" value="debug"/-->
+ <sysproperty key="mx4j.log.priority" value="debug"/>
+ <sysproperty key="java.security.manager" value=""/>
+ <sysproperty key="java.security.policy" value="${basedir}/build/mx4j-build.policy"/>
<!--sysproperty key="java.security.debug" value="access.failure"/-->
<formatter type="plain" usefile="no"/>
<test name="${testname}" if="testname" fork="yes"/>
@@ -629,6 +654,8 @@
<junit printsummary="withOutAndErr" fork="yes" timeout="300000" dir="${basedir}" showoutput="yes">
<sysproperty key="mx4j.log.priority" value="warn"/>
+ <sysproperty key="java.security.manager" value=""/>
+ <sysproperty key="java.security.policy" value="${basedir}/build/mx4j-build.policy"/>
<!-- sysproperty key="java.security.debug" value="access.failure"/-->
<formatter type="xml"/>
<batchtest fork="yes" todir="${test.xml.dir}">
@@ -677,6 +704,8 @@
<junit printsummary="withOutAndErr" fork="yes" timeout="300000" dir="${basedir}" showoutput="yes">
<sysproperty key="mx4j.log.priority" value="warn"/>
+ <sysproperty key="java.security.manager" value=""/>
+ <sysproperty key="java.security.policy" value="${basedir}/build/mx4j-build.policy"/>
<!-- sysproperty key="java.security.debug" value="access.failure"/-->
<formatter type="xml"/>
<batchtest fork="yes" todir="${test.xml.dir}">

View File

@ -0,0 +1,15 @@
--- mx4j-3.0.2/build/build.xml 2009-09-07 19:57:00.000000000 +0200
+++ mx4j-3.0.2/build/build.xml-gil 2009-09-07 19:58:18.000000000 +0200
@@ -318,9 +318,9 @@
<exclude name="mx4j/tools/remote/**" unless="jaas.present"/>
<exclude name="mx4j/tools/remote/rmi/SSL*" unless="jdk14.present"/>
<exclude name="mx4j/tools/remote/http/jetty/**" unless="jetty.present"/>
- <exclude name="mx4j/tools/remote/caucho/**" unless="jdk14.present"/>
- <exclude name="mx4j/tools/remote/**/hessian/**" unless="jdk14.present"/>
- <exclude name="mx4j/tools/remote/**/burlap/**" unless="jdk14.present"/>
+ <exclude name="mx4j/tools/remote/caucho/**"/>
+ <exclude name="mx4j/tools/remote/**/hessian/**"/>
+ <exclude name="mx4j/tools/remote/**/burlap/**"/>
<classpath>
<path refid="classpath"/>
<pathelement location="${core.classes.dir}"/>

View File

@ -0,0 +1,21 @@
diff -Nru mx4j-3.0.2/src/docs/index.xml mx4j-3.0.2/src/docs-gil/index.xml
--- mx4j-3.0.2/src/docs/index.xml 2006-10-13 01:12:17.000000000 +0200
+++ mx4j-3.0.2/src/docs-gil/index.xml 2009-09-07 19:51:04.000000000 +0200
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="ISO-8859-1"?>
-<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "docbook/docbookx.dtd" [
+<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN" "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
<!ENTITY english SYSTEM "english/index.xml">
<!ENTITY license_en SYSTEM "english/license.xml">
diff -Nru mx4j-3.0.2/src/docs/xsl/mx4j-chunk.xsl mx4j-3.0.2/src/docs-gil/xsl/mx4j-chunk.xsl
--- mx4j-3.0.2/src/docs/xsl/mx4j-chunk.xsl 2006-10-13 01:12:17.000000000 +0200
+++ mx4j-3.0.2/src/docs-gil/xsl/mx4j-chunk.xsl 2009-09-07 19:52:29.000000000 +0200
@@ -1,6 +1,6 @@
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version='1.0'>
- <xsl:import href="../docbookx/html/chunk.xsl"/>
+ <xsl:import href="http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl"/>
<xsl:import href="autotoc.xsl"/>
<xsl:param name="html.stylesheet">styles.css</xsl:param>

View File

@ -0,0 +1,11 @@
--- mx4j-3.0.2/build/build.xml 2009-09-07 21:11:40.000000000 +0200
+++ mx4j-3.0.2/build/build.xml-gil 2009-09-07 21:12:56.000000000 +0200
@@ -512,7 +512,7 @@
<pathelement location="/etc/xml/catalog"/>
</catalogpath>
</xmlcatalog>
- </style>>
+ </style>
<!-- Bug in Ant forces this move, since destdir of the style task does not work -->
<move todir="${dist.docs.dir}">

View File

@ -0,0 +1,24 @@
--- mx4j-3.0.2/src/tools/mx4j/tools/adaptor/ssl/SSLAdaptorServerSocketFactory.java 2006-10-13 01:12:17.000000000 +0200
+++ mx4j-3.0.2/src/tools/mx4j/tools/adaptor/ssl/SSLAdaptorServerSocketFactory.java-gil 2009-09-07 19:26:25.000000000 +0200
@@ -21,9 +21,9 @@
import javax.net.ssl.SSLServerSocket;
import javax.net.ssl.SSLServerSocketFactory;
-import com.sun.net.ssl.KeyManagerFactory;
-import com.sun.net.ssl.SSLContext;
-import com.sun.net.ssl.TrustManagerFactory;
+import javax.net.ssl.KeyManagerFactory;
+import javax.net.ssl.SSLContext;
+import javax.net.ssl.TrustManagerFactory;
import mx4j.log.Log;
import mx4j.log.Logger;
@@ -60,7 +60,7 @@
{
static
{
- addProvider(new com.sun.net.ssl.internal.ssl.Provider());
+ //addProvider(new com.sun.net.ssl.internal.ssl.Provider());
}
private String m_keyStoreType = "JKS";

View File

@ -0,0 +1,93 @@
--- mx4j-3.0.2/build/build.xml 2009-09-07 20:02:13.000000000 +0200
+++ mx4j-3.0.2/build/build.xml-gil 2009-09-07 20:09:28.000000000 +0200
@@ -62,7 +62,9 @@
<property name="tools.jar.file" value="${dist.lib.dir}/${name}-tools.jar"/>
<property name="tests.jar.file" value="${dist.test.dir}/${name}-tests.jar"/>
-
+
+ <property name="tools.extra.jar.file" value="${dist.lib.dir}/${name}-tools-extra.jar"/>
+
<property name="examples.jar.file" value="${dist.examples.dir}/${name}-examples.jar"/>
<property name="mx4j.soap.war.file" value="${dist.lib.dir}/${name}-soap.war"/>
@@ -105,10 +107,34 @@
<patternset id="tools.classes">
<include name="mx4j/log/**"/>
<include name="mx4j/util/**"/>
- <include name="mx4j/tools/**"/>
+ <include name="mx4j/tools/adaptor/**"/>
+ <include name="mx4j/tools/config/**"/>
+ <include name="mx4j/tools/i18n/**"/>
+ <include name="mx4j/tools/mail/**"/>
+ <include name="mx4j/tools/naming/**"/>
+ <include name="mx4j/tools/remote/*.*"/>
+ <include name="mx4j/tools/remote/http/**"/>
+ <include name="mx4j/tools/remote/local/**"/>
+ <include name="mx4j/tools/remote/provider/local/**"/>
+ <include name="mx4j/tools/remote/proxy/**"/>
+ <include name="mx4j/tools/remote/resolver/local/**"/>
+ <include name="mx4j/tools/remote/rmi/**"/>
+ <include name="mx4j/tools/stats/**"/>
<include name="mx4j/remote/*.*"/>
</patternset>
+ <patternset id="tools.extra.classes">
+ <include name="mx4j/tools/jython/**"/>
+ <include name="mx4j/tools/remote/caucho/**"/>
+ <include name="mx4j/tools/remote/provider/burlap/**"/>
+ <include name="mx4j/tools/remote/provider/hessian/**"/>
+ <include name="mx4j/tools/remote/provider/soap/**"/>
+ <!--include name="mx4j/tools/remote/resolver/burlap/**"/-->
+ <!--include name="mx4j/tools/remote/resolver/hessian/**"/-->
+ <include name="mx4j/tools/remote/resolver/soap/**"/>
+ <include name="mx4j/tools/remote/soap/**"/>
+ </patternset>
+
<patternset id="tools.files">
<include name="mx4j/tools/adaptor/http/**/*.xsl"/>
<include name="mx4j/tools/adaptor/http/**/*.xml"/>
@@ -118,6 +144,9 @@
<include name="mx4j/tools/adaptor/http/**/*.gif"/>
<include name="mx4j/tools/adaptor/http/**/*.jpg"/>
<include name="mx4j/tools/adaptor/http/**/*.ico"/>
+ </patternset>
+
+ <patternset id="tools.extra.files">
<include name="mx4j/tools/jython/**/*.py"/>
<include name="mx4j/tools/remote/**/*.wsdd"/>
</patternset>
@@ -313,6 +342,7 @@
<javac srcdir="${tools.src.dir}" destdir="${tools.classes.dir}" debug="on" deprecation="on" encoding="US-ASCII" target="1.3" source="1.3">
<patternset refid="tools.classes"/>
+ <patternset refid="tools.extra.classes"/>
<exclude name="mx4j/tools/mail/**" unless="javamail.present"/>
<exclude name="mx4j/tools/jython/**" unless="jython.present"/>
<exclude name="mx4j/tools/remote/**" unless="jaas.present"/>
@@ -344,6 +374,25 @@
<zipfileset file="${etc.dir}/JMXConnectorServerProvider-tools.provider" fullpath="META-INF/services/javax.management.remote.JMXConnectorServerProvider"/>
</jar>
+ <jar jarfile="${tools.extra.jar.file}" manifest="${etc.dir}/MANIFEST.MF">
+ <fileset dir="${core.classes.dir}">
+ <patternset refid="tools.extra.classes"/>
+ </fileset>
+ <fileset dir="${tools.classes.dir}">
+ <patternset refid="tools.extra.classes"/>
+ </fileset>
+ <fileset dir="${core.src.dir}">
+ <patternset refid="tools.extra.files"/>
+ </fileset>
+ <fileset dir="${tools.src.dir}">
+ <patternset refid="tools.extra.files"/>
+ </fileset>
+<!--
+ <zipfileset file="${etc.dir}/JMXConnectorProvider-tools.provider" fullpath="META-INF/services/javax.management.remote.JMXConnectorProvider"/>
+ <zipfileset file="${etc.dir}/JMXConnectorServerProvider-tools.provider" fullpath="META-INF/services/javax.management.remote.JMXConnectorServerProvider"/>
+-->
+ </jar>
+
<war destfile="${mx4j.soap.war.file}" manifest="${etc.dir}/MANIFEST.MF" webxml="${etc.dir}/web.xml">
<lib dir="${lib.dir}">
<include name="axis.jar"/>

View File

@ -0,0 +1,61 @@
########################################################################
# CatalogManager provides an interface to the catalog properties.
# Properties can come from two places: from system properties or
# from a CatalogManager.properties file. This class provides a
# transparent interface to both, with system properties preferred
# over property file values.
#######################################################################
# Catalog Files:
# The semicolon-delimited list of catalog files.
# Example: catalogs=./xcatalog;/share/doctypes/catalog
catalogs=/etc/xml/catalog;/etc/sgml/catalog
#######################################################################
# Relative Catalogs:
# If false, relative catalog URIs are made absolute with respect to the
# base URI of the CatalogManager.properties file. This setting only
# applies to catalog URIs obtained from the catalogs property in the
# CatalogManager.properties file
# Example: relative-catalogs = [yes|no]
relative-catalogs=yes
#######################################################################
# Verbosity:
# If non-zero, the Catalog classes will print informative and debugging
# messages. The higher the number, the more messages.
# Example: verbosity = [0..99]
verbosity=0
#######################################################################
# Prefer:
# Which identifier is preferred, "public" or "system"?
# Example: xml.catalog.prefer = [public|system]
prefer=system
#######################################################################
# Static-catalog:
# Should a single catalog be constructed for all parsing, or should a
# different catalog be created for each parser?
# Example: static-catalog = [yes|no]
static-catalog=yes
#######################################################################
# Allow-oasis-xml-catalog-pi
# If the source document contains "oasis-xml-catalog" processing
# instructions, should they be used?
# Example: allow-oasis-xml-catalog-pi = [yes|no]
allow-oasis-xml-catalog-pi=yes
#######################################################################
# catalog-class-name
# If you're using the convenience classes
# org.apache.xml.resolver.tools.*, this setting allows you to specify
# an alternate class name to use for the underlying catalog.
# Example: catalog-class-name=org.apache.xml.resolver.Resolver

15
java-mx4j-build.policy Normal file
View File

@ -0,0 +1,15 @@
grant codeBase "file:/-" {
permission java.security.AllPermission;
};
grant {
permission java.util.PropertyPermission "*", "read";
permission java.io.FilePermission "/-", "read,write";
permission java.net.SocketPermission "*", "accept, connect, listen, resolve";
permission java.net.SocketPermission "127.0.0.1", "accept, connect, listen, resolve";
permission java.lang.RuntimePermission "createSecurityManager";
permission java.lang.RuntimePermission "setSecurityManager";
permission javax.management.MBeanPermission "*", "*";
permission javax.management.remote.SubjectDelegationPermission "*";
permission javax.security.auth.AuthPermission "getSubject";
};

330
java-mx4j.spec Normal file
View File

@ -0,0 +1,330 @@
%define bootstrap 0
%define with_test 0
Name: java-mx4j
Version: 3.0.2
Release: 2mamba
Summary: Open Source implementation of the Java(TM) Management Extensions (JMX)
Group: Development/Libraries/Java
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://mx4j.sourceforge.net/
# cvs -d:pserver:anonymous@mx4j.cvs.sourceforge.net:/cvsroot/mx4j login
# cvs -z3 -d:pserver:anonymous@mx4j.cvs.sourceforge.net:/cvsroot/mx4j co -P mx4j
Source0: mx4j-%{version}-src-cvs.tar.gz
Source1: java-mx4j-build.policy
Source2: java-mx4j-CatalogManager.properties
Source3: http://mirrors.ibiblio.org/pub/mirrors/maven2/mx4j/mx4j/%{version}/mx4j-%{version}.pom
Source4: http://mirrors.ibiblio.org/pub/mirrors/maven2/mx4j/mx4j-remote/%{version}/mx4j-remote-%{version}.pom
Source5: mx4j-impl-%{version}.pom
Source6: mx4j-jmx-%{version}.pom
Source7: mx4j-rimpl-%{version}.pom
Source8: mx4j-rjmx-%{version}.pom
Source9: mx4j-tools-%{version}.pom
Patch0: java-mx4j-3.0.2-javaxssl.patch
Patch1: java-mx4j-3.0.1-iiop-Resolver.patch
Patch2: java-mx4j-3.0.2-build_xml.patch
Patch3: java-mx4j-3.0.2-docbook.patch
Patch4: java-mx4j-3.0.1-no-poa.patch
Patch5: java-mx4j-3.0.2-caucho-build.patch
Patch6: java-mx4j-3.0.1-no-iiop.patch
Patch7: java-mx4j-3.0.1-alt-local-xsl-stylesheets.patch
Patch8: java-mx4j-3.0.2-fix-build_xml.patch
Patch9: java-mx4j-3.0.2-split-extratools.patch
License: Apache Software License 2.0
BuildRequires: apache-ant
BuildRequires: apache-ant-junit
BuildRequires: apache-ant-resolver
BuildRequires: apache-ant-trax
BuildRequires: apache-log4j
BuildRequires: apache-ws-axis
BuildRequires: coreutils
BuildRequires: docbook-dtds
BuildRequires: docbook-xsl
BuildRequires: jakarta-bcel
BuildRequires: jakarta-commons-discovery
BuildRequires: jakarta-commons-logging
BuildRequires: java-classpathx-mail
BuildRequires: java-classpathx-jaf
BuildRequires: java-hessian
BuildRequires: java-sun-jaas
BuildRequires: java-sun-jaf
BuildRequires: java-sun-mail-1.4-api
BuildRequires: java-sun-saaj-1.3-api
BuildRequires: java-wsdl4j
BuildRequires: java-xdoclet
BuildRequires: jpackage-utils
BuildRequires: jython
BuildRequires: libjetty5
BuildRequires: xalan-j2
BuildRequires: xerces-j2
BuildRequires: xjavadoc
BuildRequires: xml-commons
BuildRequires: xml-commons-apis
BuildRequires: xml-commons-resolver
BuildRequires: xmlunit
#BuildRequires: jsse
#BuildRequires: jce
#Requires: jsse
#Requires: jce
Requires: apache-log4j
Requires: apache-ws-axis
Requires: jakarta-bcel
Requires: jakarta-commons-logging
Requires: java-classpathx-jaf
Requires: java-classpathx-mail
Requires: xml-commons
Requires: xml-commons-apis
Requires: xml-commons-resolver
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
MX4J is an Open Source implementation of the Java Management Extensions technology, for both JSR 3 (JMX) and JSR 160 (JMX Remote API)
%package javadoc
Group: Documentation
Summary: Javadoc for %{name}
%description javadoc
MX4J is an Open Source implementation of the Java Management Extensions technology, for both JSR 3 (JMX) and JSR 160 (JMX Remote API)
This package contains javadoc for %{name}
%package manual
Group: Documentation
Summary: Manual for %{name}
%description manual
MX4J is an Open Source implementation of the Java Management Extensions technology, for both JSR 3 (JMX) and JSR 160 (JMX Remote API)
This package contains manual for %{name}.
%prep
%setup -q -n mx4j-%{version}
for j in $(find . -name "*.jar"); do
mv $j ${j}.no
done
for j in $(find . -name "CVS"); do
rm -rf $j
done
# To enable iiop when rmic becomes available
# turn off patch6 and turn on patch4
# Patch4 is a backport of upstream changes (MX4J) and may go
# away on future releases
%patch0 -p1
%patch2 -p1
%patch3 -p1
#%patch4 -p1
%patch5 -p1
#%patch6 -p1
#%patch7 -p1
%patch8 -p1
%patch9 -p1
cp %{SOURCE1} build/build.policy
cp %{SOURCE2} build/CatalogManager.properties
pushd build
ln -sf $(build-classpath ant-1.7.1) ant.jar
ln -sf $(build-classpath ant-launcher) ant-launcher.jar
ln -sf $(build-classpath ant/ant-junit) ant-junit.jar
ln -sf $(build-classpath ant/ant-trax) ant-1.7.1.jar
popd
pushd lib
%if %with_test
ln -sf $(build-classpath junit-3.8.2) junit.jar
ln -sf $(build-classpath xmlunit) .
%endif
# build
ln -sf $(build-classpath xml-commons-apis) xml-apis.jar
ln -sf $(build-classpath xercesImpl) xercesImpl.jar
ln -sf $(build-classpath xalan-j2) xalan.jar
ln -sf $(build-classpath commons-logging) .
ln -sf $(build-classpath log4j) .
ln -sf $(build-classpath servletapi5) servlet.jar
ln -sf $(build-classpath bcel) .
ln -sf $(build-classpath xml-commons-resolver) .
# ln -sf /opt/java/jre/lib/jsse.jar .
%if ! %bootstrap
ln -sf $(build-classpath hessian) hessian.jar
ln -sf $(build-classpath hessian) burlap.jar
ln -sf $(build-classpath hessian) caucho-services.jar
ln -sf $(build-classpath axis/axis) .
ln -sf $(build-classpath axis/jaxrpc) .
ln -sf $(build-classpath axis/saaj) .
ln -sf $(build-classpath wsdl4j) .
ln -sf $(build-classpath commons-discovery) .
ln -sf $(build-classpath jython) .
ln -sf $(build-classpath jetty5/jetty) org.mortbay.jetty.jar
ln -sf $(build-classpath sun-mail-api) mail.jar
ln -sf $(build-classpath xdoclet/xdoclet) .
ln -sf $(build-classpath xdoclet/xdoclet-jmx-module) .
ln -sf $(build-classpath xdoclet/xdoclet-mx4j-module) .
ln -sf $(build-classpath jaas) .
ln -sf $(build-classpath sun-jaf) activation.jar
%endif
popd
%build
mkdir -p dist/lib/boa
cd build
export CLASSPATH=$(build-classpath junit-3.8.2 xml-commons-resolver xmlunit \
axis/axis xalan-j2-serializer ant/ant-apache-resolver ant/ant-trax)
%if %bootstrap
echo "#################################### BOOTSTRAP ###########################################"
ant \
-Dant.build.javac.source=1.4 \
-Dant.build.javac.target=1.4 \
-Dbuild.sysclasspath=first \
compile.jmx compile.rjmx
%else
%if %with_test
echo "#################################### TEST ###########################################"
ant \
-Dant.build.javac.source=1.4 \
-Dant.build.javac.target=1.4 \
-Dbuild.sysclasspath=first \
compile.jmx compile.rjmx compile.tools tests-report javadocs docs
%else
ant \
-Dant.build.javac.source=1.4 \
-Dant.build.javac.target=1.4 \
-Dbuild.sysclasspath=first \
compile.jmx compile.rjmx compile.tools javadocs docs
%endif
%endif
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
mkdir -p %{buildroot}%{_javadir}/mx4j/boa
mkdir -p %{buildroot}%{_datadir}/mx4j
mkdir -p %{buildroot}%{_datadir}/mx4j-%{version}
install -m 644 dist/lib/mx4j-impl.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-impl-%{version}.jar
install -m 644 dist/lib/mx4j-jmx.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-jmx-%{version}.jar
install -m 644 dist/lib/mx4j.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-%{version}.jar
%if ! %bootstrap
install -m 644 dist/lib/mx4j-tools.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-tools-%{version}.jar
install -m 644 dist/lib/mx4j-tools-extra.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-tools-extra-%{version}.jar
install -m 644 dist/lib/mx4j-soap.war \
%{buildroot}%{_datadir}/mx4j-%{version}
%endif
install -m 644 dist/lib/mx4j-rjmx.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-rjmx-%{version}.jar
install -m 644 dist/lib/mx4j-rimpl.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-rimpl-%{version}.jar
install -m 644 dist/lib/mx4j-remote.jar \
%{buildroot}%{_javadir}/mx4j/mx4j-remote-%{version}.jar
install -m 644 dist/lib/boa/mx4j-rjmx-boa.jar \
%{buildroot}%{_javadir}/mx4j/boa/mx4j-rjmx-boa-%{version}.jar
install -m 644 dist/lib/boa/mx4j-rimpl-boa.jar \
%{buildroot}%{_javadir}/mx4j/boa/mx4j-rimpl-boa-%{version}.jar
install -m 644 dist/lib/boa/mx4j-remote-boa.jar \
%{buildroot}%{_javadir}/mx4j/boa/mx4j-remote-boa-%{version}.jar
(
cd %{buildroot}%{_javadir}/mx4j
for jar in *-%{version}.jar ; do
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
done
)
mkdir -p %{buildroot}%{_datadir}/maven2/poms
%add_to_maven_depmap mx4j mx4j %{version} JPP/mx4j mx4j
install -pm 644 %{SOURCE3} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j.pom
%add_to_maven_depmap mx4j mx4j-remote %{version} JPP/mx4j mx4j-remote
install -pm 644 %{SOURCE4} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j-remote.pom
%add_to_maven_depmap mx4j mx4j-impl %{version} JPP/mx4j mx4j-impl
install -pm 644 %{SOURCE5} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j-impl.pom
%add_to_maven_depmap mx4j mx4j-jmx %{version} JPP/mx4j mx4j-jmx
install -pm 644 %{SOURCE6} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j-jmx.pom
%add_to_maven_depmap mx4j mx4j-rimpl %{version} JPP/mx4j mx4j-rimpl
install -pm 644 %{SOURCE7} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j-rimpl.pom
%add_to_maven_depmap mx4j mx4j-rjmx %{version} JPP/mx4j mx4j-rjmx
install -pm 644 %{SOURCE8} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j-rjmx.pom
%add_to_maven_depmap mx4j mx4j-tools %{version} JPP/mx4j mx4j-tools
install -pm 644 %{SOURCE9} %{buildroot}%{_datadir}/maven2/poms/JPP.mx4j-mx4j-tools.pom
%if ! %{bootstrap}
mkdir -p %{buildroot}%{_javadocdir}/mx4j-%{version}
cp -r dist/docs/api/* %{buildroot}%{_javadocdir}/mx4j-%{version}
ln -s mx4j-%{version} %{buildroot}%{_javadocdir}/mx4j
%endif
#%{_bindir}/aot-compile-rpm
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%{_javadir}/mx4j/boa/mx4j-remote-boa-%{version}.jar
%{_javadir}/mx4j/boa/mx4j-rimpl-boa-%{version}.jar
%{_javadir}/mx4j/boa/mx4j-rjmx-boa-%{version}.jar
%{_javadir}/mx4j/mx4j-%{version}.jar
%{_javadir}/mx4j/mx4j.jar
%{_javadir}/mx4j/mx4j-impl-%{version}.jar
%{_javadir}/mx4j/mx4j-impl.jar
%{_javadir}/mx4j/mx4j-jmx-%{version}.jar
%{_javadir}/mx4j/mx4j-jmx.jar
%{_javadir}/mx4j/mx4j-remote-%{version}.jar
%{_javadir}/mx4j/mx4j-remote.jar
%{_javadir}/mx4j/mx4j-rimpl-%{version}.jar
%{_javadir}/mx4j/mx4j-rimpl.jar
%{_javadir}/mx4j/mx4j-rjmx-%{version}.jar
%{_javadir}/mx4j/mx4j-rjmx.jar
%if ! %bootstrap
%{_javadir}/mx4j/mx4j-tools-%{version}.jar
%{_javadir}/mx4j/mx4j-tools.jar
%{_javadir}/mx4j/mx4j-tools-extra-%{version}.jar
%{_javadir}/mx4j/mx4j-tools-extra.jar
%{_datadir}/mx4j-%{version}
%endif
%{_datadir}/maven2/poms
%{_mavendepmapfragdir}
#%doc README.txt
%if ! %bootstrap
%files javadoc
%defattr(-,root,root)
%{_javadocdir}/mx4j-%{version}
%{_javadocdir}/mx4j
%files manual
%defattr(-,root,root)
%doc dist/docs/*
%endif
%changelog
* Mon Nov 29 2010 gil <puntogil@libero.it> 3.0.2-2mamba
- rebuilt devel
* Mon Sep 07 2009 gil <puntogil@libero.it> 3.0.2-1mamba
- update to 3.0.2
* Mon Sep 07 2009 gil <puntogil@libero.it> 3.0.1-3mamba
- add maven2 poms
* Thu Mar 12 2009 gil <puntogil@libero.it> 3.0.1-2mamba
- add java-hessian support
* Thu Mar 12 2009 gil <puntogil@libero.it> 3.0.1-1mamba
- package created by autospec
- bootstrap

20
mx4j-3.0.2.pom Normal file
View File

@ -0,0 +1,20 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j</artifactId>
<version>3.0.2</version>
<packaging>jar</packaging>
<name>MX4J</name>
<url>http://mx4j.sourceforge.net</url>
<description>MX4J JMX API and implementation</description>
<licenses>
<license>
<name>The Apache Software License, Version 2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<url>http://mx4j.cvs.sourceforge.net/mx4j/</url>
</scm>
</project>

6
mx4j-impl-3.0.2.pom Normal file
View File

@ -0,0 +1,6 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j-impl</artifactId>
<version>3.0.2</version>
</project>

6
mx4j-jmx-3.0.2.pom Normal file
View File

@ -0,0 +1,6 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j-jmx</artifactId>
<version>3.0.2</version>
</project>

20
mx4j-remote-3.0.2.pom Normal file
View File

@ -0,0 +1,20 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j-remote</artifactId>
<version>3.0.2</version>
<packaging>jar</packaging>
<name>MX4J JMX Remote</name>
<url>http://mx4j.sourceforge.net</url>
<description>MX4J Remote</description>
<licenses>
<license>
<name>The Apache Software License, Version 2.0</name>
<url>http://www.apache.org/licenses/LICENSE-2.0.txt</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<url>http://mx4j.cvs.sourceforge.net/mx4j/</url>
</scm>
</project>

6
mx4j-rimpl-3.0.2.pom Normal file
View File

@ -0,0 +1,6 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j-rimpl</artifactId>
<version>3.0.2</version>
</project>

6
mx4j-rjmx-3.0.2.pom Normal file
View File

@ -0,0 +1,6 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j-rjmx</artifactId>
<version>3.0.2</version>
</project>

6
mx4j-tools-3.0.2.pom Normal file
View File

@ -0,0 +1,6 @@
<project>
<modelVersion>4.0.0</modelVersion>
<groupId>mx4j</groupId>
<artifactId>mx4j-tools</artifactId>
<version>3.0.2</version>
</project>