diff --git a/java-jfree-libserializer-1.1.3-build.patch b/java-jfree-libserializer-1.1.3-build.patch
new file mode 100644
index 0000000..6f39e55
--- /dev/null
+++ b/java-jfree-libserializer-1.1.3-build.patch
@@ -0,0 +1,8 @@
+--- java-jfree-libserializer-1.1.3/build.properties.orig 2021-12-10 21:29:27.879764097 +0100
++++ java-jfree-libserializer-1.1.3/build.properties 2021-12-10 21:29:43.940062856 +0100
+@@ -1,4 +1,4 @@
+-project.revision=TRUNK-SNAPSHOT
++project.revision=1.1.3
+ ivy.artifact.group=pentaho-library
+ ivy.artifact.id=libserializer
+ impl.title=LibSerializer
diff --git a/java-jfree-libserializer-1.1.3-build_properties.patch b/java-jfree-libserializer-1.1.3-build_properties.patch
deleted file mode 100644
index cdb70cf..0000000
--- a/java-jfree-libserializer-1.1.3-build_properties.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- build.properties 2009-11-16 10:19:34.000000000 +0100
-+++ build.properties-gil 2011-01-22 15:14:20.000000000 +0100
-@@ -1,7 +1,9 @@
--project.revision=TRUNK-SNAPSHOT
-+project.revision=1.1.3
- ivy.artifact.group=pentaho-library
- ivy.artifact.id=libserializer
- impl.title=LibSerializer
- impl.productID=libserializer
- src.dir=${basedir}/source
- dependency.libbase.revision=1.1.3
-+antcontrib.available=true
-+build.cache.dir=lib
-\ Manca newline alla fine del file
diff --git a/java-jfree-libserializer-1.1.3-java11.patch b/java-jfree-libserializer-1.1.3-java11.patch
new file mode 100644
index 0000000..ef6ca98
--- /dev/null
+++ b/java-jfree-libserializer-1.1.3-java11.patch
@@ -0,0 +1,13 @@
+--- java-jfree-libserializer-1.1.3/common_build.xml.orig 2021-12-10 21:27:01.142034301 +0100
++++ java-jfree-libserializer-1.1.3/common_build.xml 2021-12-10 21:27:13.630266633 +0100
+@@ -136,8 +136,8 @@
+
+-
+-
++
++
+
+
+
+-
+
+@@ -325,68 +322,6 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
++ depends="svnant.download-check">
+
+
+
+@@ -491,58 +426,13 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+
++ depends="ivy.download-check">
+
+
+
+@@ -602,7 +492,7 @@ TYPICAL TARGET SEQUENCE
+ Verifies that there are no SNAPSHOT dependencies defined in the ivy xml.
+ If there are SNAPSHOTS, fail the release build.
+ ====================================================================-->
+-
++
+
+
+
+@@ -769,7 +659,7 @@ TYPICAL TARGET SEQUENCE
+ Publishes the jar file for this project to a Maven2 repository.
+ ====================================================================-->
+
++ depends="create-pom,ivy.deliver">
+
+
+
+@@ -1038,12 +928,11 @@ TYPICAL TARGET SEQUENCE
+ - compile.pre : anything needed to prep for compile
+ - compile.compile : the actual compilation step
+ - compile.src_copy : copying the source into the bin directory
+- - compile.res_copy : copying the resources into the bin directory
+ - compile.lic_copy : copying the license information into the bin directory
+ - compile.post : anything needed after the compile is done
+ ====================================================================-->
+
+
+
+@@ -1074,37 +963,6 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+-
+
+-
++
+
+
+
+@@ -1164,7 +1022,7 @@ TYPICAL TARGET SEQUENCE
+ Creates a new manifest file if one is not specified, or updates
+ an existing manifest file if one is specified.
+ ====================================================================-->
+-
++
+
+
+
+@@ -1648,4 +1506,4 @@ TYPICAL TARGET SEQUENCE
+
+
+
+-
+\ No newline at end of file
++
diff --git a/java-jfree-libserializer-1.1.3-remove-commons-logging.patch b/java-jfree-libserializer-1.1.3-remove-commons-logging.patch
new file mode 100644
index 0000000..52ee76a
--- /dev/null
+++ b/java-jfree-libserializer-1.1.3-remove-commons-logging.patch
@@ -0,0 +1,31 @@
+diff -ru libserializer-1.1.2.orig/source/org/pentaho/reporting/libraries/serializer/SerializerHelper.java libserializer-1.1.2/source/org/pentaho/reporting/libraries/serializer/SerializerHelper.java
+--- libserializer-1.1.2.orig/source/org/pentaho/reporting/libraries/serializer/SerializerHelper.java 2021-04-07 11:22:05.509434457 +0100
++++ libserializer-1.1.2/source/org/pentaho/reporting/libraries/serializer/SerializerHelper.java 2021-04-07 11:23:19.102343782 +0100
+@@ -25,8 +25,7 @@
+ import java.util.HashMap;
+ import java.util.Iterator;
+
+-import org.apache.commons.logging.Log;
+-import org.apache.commons.logging.LogFactory;
++import java.util.logging.Logger;
+ import org.pentaho.reporting.libraries.base.config.Configuration;
+ import org.pentaho.reporting.libraries.base.util.ObjectUtilities;
+ import org.pentaho.reporting.libraries.base.util.DebugLog;
+@@ -41,7 +40,7 @@
+ */
+ public class SerializerHelper
+ {
+- private static final Log logger = LogFactory.getLog(SerializerHelper.class);
++ private static final Logger logger = Logger.getLogger(SerializerHelper.class.getName());
+ /**
+ * The singleton instance of the serialize helper.
+ */
+@@ -124,7 +123,7 @@
+ }
+ else
+ {
+- logger.warn("Invalid SerializeMethod implementation: " + c);
++ logger.warning("Invalid SerializeMethod implementation: " + c);
+ }
+ }
+ }
diff --git a/java-jfree-libserializer.spec b/java-jfree-libserializer.spec
index fba3af0..1220d30 100644
--- a/java-jfree-libserializer.spec
+++ b/java-jfree-libserializer.spec
@@ -1,87 +1,55 @@
-%define with_gcj 1
-%define javahome %{_jvmdir}/jdk
Name: java-jfree-libserializer
Version: 1.1.3
-Release: 1mamba
+Release: 2mamba
Summary: JFree Java General Serialization Framework Library
Group: Development/Libraries/Java
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco
-URL: http://reporting.pentaho.org/
-Source: http://sourceforge.net/projects/jfreereport/files/02.%20Libraries/1.1.3-stable/libserializer-1.1.3.zip
-Patch0: java-jfree-libserializer-1.1.3-build_properties.patch
+URL: https://community.hitachivantara.com/home
+Source: http://sourceforge.net/projects/jfreereport/files/02.%20Libraries/%{version}-stable/libserializer-%{version}.zip
+Patch0: java-jfree-libserializer-1.1.3-remove-antcontrib-support.patch
+Patch1: java-jfree-libserializer-1.1.3-remove-commons-logging.patch
+Patch2: java-jfree-libserializer-1.1.3-java11.patch
+Patch3: java-jfree-libserializer-1.1.3-build.patch
License: LGPL
-BuildRequires: ant-contribb3
+## AUTOBUILDREQ-BEGIN
+## AUTOBUILDREQ-END
+BuildRequires: javapackages
BuildRequires: apache-ant
-BuildRequires: jakarta-commons-logging
BuildRequires: java-jfree-libbase
-BuildRequires: java-junit3
-BuildRequires: jpackage-utils
-Requires: jakarta-commons-logging
Requires: java-jfree-libbase
-Requires: jpackage-utils
-BuildRoot: %{_tmppath}/%{name}-%{version}-root
+Requires: javapackages
%description
This library module contains a general serialization framework. It simplifies the task of writing custom serialization handlers for non-serializable classes.
-%if %with_gcj
-%package gcj
-Group: System/Libraries/Java
-Summary: GCJ support for %{name}
-## AUTOBUILDREQ-BEGIN
-BuildRequires: glibc-devel
-BuildRequires: java-gcj-compat
-BuildRequires: libgcc
-BuildRequires: libgcj4-devel
-BuildRequires: libz-devel
-## AUTOBUILDREQ-END
-Requires: java-gcj-compat
-
-%description gcj
-JFree Java General Serialization Framework Library.
-
-This package contains GCJ support for %{name}.
-%endif
-
%package javadoc
Group: Documentation
Summary: Javadoc for %{name}
%description javadoc
JFree Java General Serialization Framework Library.
-
This package contains documentation for %{name}.
%prep
-%setup -q -c %{name}-%{version}
-%patch0
-for j in $(find . -name "*.jar"); do
- rm -rf $j
-done
+%setup -q -c
+%patch0 -p1 -b .remove-antcontrib-support
+%patch1 -p1 -b .remove-commons-logging
+%patch2 -p1 -b .java11
+%patch3 -p1 -b .build
-for txt in ChangeLog.txt licence-LGPL.txt README.txt; do
- %{__perl} -pi -e 's/\r$//g' $txt
-done
-
-mkdir -p lib/ant-contrib
-ln -sf $(build-classpath commons-logging-api) lib/commons-logging-api-1.0.4.jar
-ln -sf $(build-classpath libbase) lib/libbase-%{version}.jar
-ln -s %{_javadir}/ant/* lib/ant-contrib
+find . -name "*.jar" -exec rm -f {} \;
+mkdir -p lib
+build-jar-repository -s -p lib libbase
%build
-unset JAVA_HOME
-export JAVA_HOME=%{javahome}
-export CLASSPATH=$(build-classpath ant-contribb3 junit-3.8.2 libbase commons-logging commons-logging-api)
-ant \
- jar javadoc
+ant jar javadoc
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
mkdir -p %{buildroot}%{_javadir}
-
install -pm 644 dist/libserializer-%{version}.jar %{buildroot}%{_javadir}/libserializer-%{version}.jar
(
@@ -94,10 +62,6 @@ install -pm 644 dist/libserializer-%{version}.jar %{buildroot}%{_javadir}/libser
mkdir -p %{buildroot}%{_javadocdir}/libserializer
cp -pr bin/javadoc/docs/api/* %{buildroot}%{_javadocdir}/libserializer
-%if %with_gcj
-%{_bindir}/aot-compile-rpm
-%endif
-
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
@@ -105,30 +69,16 @@ cp -pr bin/javadoc/docs/api/* %{buildroot}%{_javadocdir}/libserializer
%defattr(-,root,root)
%{_javadir}/libserializer-%{version}.jar
%{_javadir}/libserializer.jar
-%doc ChangeLog.txt licence-LGPL.txt README.txt
-
-%if %with_gcj
-%post gcj
-if [ -x %{_bindir}/rebuild-gcj-db ] ; then
- %{_bindir}/rebuild-gcj-db
-fi
-
-%postun gcj
-if [ -x %{_bindir}/rebuild-gcj-db ] ; then
- %{_bindir}/rebuild-gcj-db
-fi
-
-%files gcj
-%defattr(-,root,root)
-%{_libdir}/gcj/java-jfree-libserializer/libserializer-%{version}.jar.db
-%{_libdir}/gcj/java-jfree-libserializer/libserializer-%{version}.jar.so
-%endif
+%doc licence-LGPL.txt
%files javadoc
%defattr(-,root,root)
%{_javadocdir}/libserializer
%changelog
+* Fri Dec 10 2021 Silvan Calarco 1.1.3-2mamba
+- rebuilt without gcj and with java11
+
* Sat Jan 22 2011 gil 1.1.3-1mamba
- update to 1.1.3