diff --git a/README.md b/README.md
index 64a135a..526f517 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,4 @@
# java-jfree-libloader
+LibLoader is a general purpose resource loading framework. It has been designed to allow to load resources from any physical location and to allow the processing of that content data in a generic way, totally transparent to the user of that library.
+
diff --git a/java-jfree-libloader-1.1.3-01-common_build_xml.patch b/java-jfree-libloader-1.1.3-01-common_build_xml.patch
new file mode 100644
index 0000000..6afb890
--- /dev/null
+++ b/java-jfree-libloader-1.1.3-01-common_build_xml.patch
@@ -0,0 +1,20 @@
+--- common_build.xml 2009-11-16 10:25:34.000000000 +0100
++++ common_build.xml-gil 2011-01-22 14:12:08.000000000 +0100
+@@ -1071,6 +1071,7 @@
+
+
+
++
+
+
+
+@@ -1356,6 +1357,9 @@
+ doctitle="${impl.title} documentation">
+
+
++
++
++
+
+
+
diff --git a/java-jfree-libloader-1.1.3-build_properties.patch b/java-jfree-libloader-1.1.3-build_properties.patch
new file mode 100644
index 0000000..988f9d8
--- /dev/null
+++ b/java-jfree-libloader-1.1.3-build_properties.patch
@@ -0,0 +1,18 @@
+--- build.properties 2009-11-16 10:25:34.000000000 +0100
++++ build.properties-gil 2011-01-22 13:50:48.000000000 +0100
+@@ -1,4 +1,4 @@
+-project.revision=TRUNK-SNAPSHOT
++project.revision=1.1.3
+ ivy.artifact.group=pentaho-library
+ ivy.artifact.id=libloader
+ impl.title=LibLoader
+@@ -6,4 +6,6 @@
+ src.dir=${basedir}/source
+ dependency.libbase.revision=1.1.3
+ dependency.libpixie.revision=1.1.3
+-testsrc.dir=${basedir}/test
+\ Manca newline alla fine del file
++testsrc.dir=${basedir}/test
++antcontrib.available=true
++build.cache.dir=lib
+\ Manca newline alla fine del file
diff --git a/java-jfree-libloader-1.1.3-common_build_xml.patch b/java-jfree-libloader-1.1.3-common_build_xml.patch
new file mode 100644
index 0000000..4c921d1
--- /dev/null
+++ b/java-jfree-libloader-1.1.3-common_build_xml.patch
@@ -0,0 +1,20 @@
+--- common_build.xml 2009-11-16 10:25:34.000000000 +0100
++++ common_build.xml-gil 2011-01-22 13:54:13.000000000 +0100
+@@ -1071,6 +1071,7 @@
+
+
+
++
+
+
+
+@@ -1356,6 +1357,9 @@
+ doctitle="${impl.title} documentation">
+
+
++
++
++
+
+
+
diff --git a/java-jfree-libloader.spec b/java-jfree-libloader.spec
new file mode 100644
index 0000000..3c9bea9
--- /dev/null
+++ b/java-jfree-libloader.spec
@@ -0,0 +1,184 @@
+%define with_gcj 1
+%define javahome %{_jvmdir}/jdk
+Name: java-jfree-libloader
+Version: 1.1.3
+Release: 1mamba
+Summary: LibLoader is a resource loading framework
+Group: Development/Libraries/Java
+Vendor: openmamba
+Distribution: openmamba
+Packager: Silvan Calarco
+URL: http://reporting.pentaho.org/
+# http://sourceforge.net/projects/jfreereport/
+# cvs -d:pserver:anonymous@jfreereport.cvs.sourceforge.net:/cvsroot/jfreereport login
+# cvs -z3 -d:pserver:anonymous@jfreereport.cvs.sourceforge.net:/cvsroot/jfreereport co -P libloader
+#Source: http://downloads.sourceforge.net/project/jfreereport/30.%20OpenOffice%20Branches/OOo31/libloader-%{version}-OOo31.zip
+Source: http://downloads.sourceforge.net/project/jfreereport/02.%20Libraries/1.1.3-stable/libloader-1.1.3.zip
+Patch0: java-jfree-libloader-1.1.3-build_properties.patch
+# disable echache support (require hibernate3, ..., jboss, ..., spring, ...)
+Patch1: java-jfree-libloader-1.1.3-common_build_xml.patch
+# add batik & libpixie support only
+Patch2: java-jfree-libloader-1.1.3-01-common_build_xml.patch
+License: LGPL
+BuildRequires: ant-contribb3
+BuildRequires: apache-ant
+BuildRequires: jakarta-commons-logging
+BuildRequires: java-jfree-libbase
+BuildRequires: apache-batik
+#BuildRequires: java-backport-util-concurrent
+#BuildRequires: java-ehcache
+#BuildRequires: java-jsr107cache
+BuildRequires: java-jfree-libpixie
+BuildRequires: java-junit3
+BuildRequires: jpackage-utils
+BuildRequires: xml-commons-apis
+Requires: java-jfree-libbase
+Requires: jpackage-utils
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+
+%description
+LibLoader is a general purpose resource loading framework. It has been designed to allow to load resources from any physical location and to allow the processing of that content data in a generic way, totally transparent to the user of that library.
+
+%if %with_gcj
+%package gcj
+Group: System/Libraries/Java
+Summary: GCJ support for %{name}
+## AUTOBUILDREQ-BEGIN
+BuildRequires: glibc-devel
+BuildRequires: java-gcj-compat
+BuildRequires: libgcc
+BuildRequires: libgcj4-devel
+BuildRequires: libz-devel
+## AUTOBUILDREQ-END
+Requires: java-gcj-compat
+
+%description gcj
+LibLoader is a resource loading framework.
+
+This package contains GCJ support for %{name}.
+%endif
+
+%package javadoc
+Group: Documentation
+Summary: Javadoc for %{name}
+
+%description javadoc
+LibLoader is a resource loading framework.
+
+This package contains documentation for %{name}.
+
+%prep
+
+%setup -q -c -n libloader
+%patch0
+#%patch1
+%patch2
+
+for j in $(find . -name "*.jar"); do
+ rm -rf $j
+done
+
+mkdir -p lib test-lib
+
+ln -sf $(build-classpath commons-logging) lib/commons-logging.jar
+ln -sf $(build-classpath commons-logging-api) lib/commons-logging-api-1.0.4.jar
+ln -sf $(build-classpath libbase) lib/libbase-%{version}.jar
+ln -sf $(build-classpath libpixie) lib/libpixie-%{version}.jar
+
+#ln -sf $(build-classpath junit-3.8.2) test-lib/junit-3.8.1.jar
+#ln -sf $(build-classpath backport-util-concurrent) lib/backport-util-concurrent-3.0.jar
+#ln -sf $(build-classpath jsr107cache) lib/jsr107cache-1.0.jar
+#ln -sf $(build-classpath ehcache-1.4.1) lib/ehcache-1.4.1.jar
+ln -sf $(build-classpath batik-awt-util) lib/batik-awt-util-1.6.jar
+ln -sf $(build-classpath batik-bridge) lib/batik-bridge-1.6.jar
+ln -sf $(build-classpath batik-css) lib/batik-css-1.6.jar
+ln -sf $(build-classpath batik-dom) lib/batik-dom-1.6.jar
+ln -sf $(build-classpath batik-ext) lib/batik-ext-1.6.jar
+ln -sf $(build-classpath batik-gui-util) lib/batik-gui-util-1.6.jar
+ln -sf $(build-classpath batik-gvt) lib/batik-gvt-1.6.jar
+ln -sf $(build-classpath batik-parser) lib/batik-parser-1.6.jar
+ln -sf $(build-classpath batik-script) lib/batik-script-1.6.jar
+ln -sf $(build-classpath batik-svg-dom) lib/batik-svg-dom-1.6.jar
+ln -sf $(build-classpath batik-util) lib/batik-util-1.6.jar
+ln -sf $(build-classpath batik-xml) lib/batik-xml-1.6.jar
+ln -sf $(build-classpath xml-commons-apis-ext) lib/xml-apis-1.0.b2.jar
+
+ln -s %{_javadir}/ant lib/ant-contrib
+
+for txt in ChangeLog.txt licence-LGPL.txt README.txt; do
+ %{__perl} -pi -e 's/\r$//g' $txt
+done
+
+%build
+unset JAVA_HOME
+export JAVA_HOME=%{javahome}
+export CLASSPATH=$(build-classpath ant-contribb3 batik-all libpixie junit-3.8.2 commons-logging xml-commons-apis-ext)
+ant \
+ jar javadoc
+
+%install
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+
+mkdir -p %{buildroot}%{_javadir}
+
+install -pm 644 dist/libloader-%{version}.jar %{buildroot}%{_javadir}/libloader-%{version}.jar
+
+(
+ cd %{buildroot}%{_javadir}
+ for jar in *-%{version}*; do
+ ln -sf ${jar} ${jar/-%{version}/}
+ done
+)
+
+mkdir -p %{buildroot}%{_javadocdir}/libloader
+cp -pr bin/javadoc/docs/api/* %{buildroot}%{_javadocdir}/libloader
+
+%if %with_gcj
+%{_bindir}/aot-compile-rpm
+%endif
+
+%clean
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+
+%files
+%defattr(-,root,root)
+%{_javadir}/libloader-%{version}.jar
+%{_javadir}/libloader.jar
+%doc ChangeLog.txt licence-LGPL.txt README.txt
+
+%if %with_gcj
+%post gcj
+if [ -x %{_bindir}/rebuild-gcj-db ] ; then
+ %{_bindir}/rebuild-gcj-db
+fi
+
+%postun gcj
+if [ -x %{_bindir}/rebuild-gcj-db ] ; then
+ %{_bindir}/rebuild-gcj-db
+fi
+
+%files gcj
+%defattr(-,root,root)
+%{_libdir}/gcj/java-jfree-libloader/libloader-%{version}.jar.db
+%{_libdir}/gcj/java-jfree-libloader/libloader-%{version}.jar.so
+%endif
+
+%files javadoc
+%defattr(-,root,root)
+%{_javadocdir}/libloader
+
+%changelog
+* Sat Jan 22 2011 gil 1.1.3-1mamba
+- update to 1.1.3
+
+* Wed Dec 09 2009 gil 1.0.0-3mamba
+- rebuilt
+
+* Wed Dec 09 2009 gil 1.0.0-2mamba
+- rebuilt
+
+* Wed Dec 09 2009 gil 1.0.0-1mamba
+- update to 1.0.0
+
+* Tue Dec 08 2009 gil 0.3.4-1mamba
+- package created by autospec