89 lines
2.6 KiB
RPMSpec
89 lines
2.6 KiB
RPMSpec
Name: java-jfree-libformula
|
|
Version: 1.1.3
|
|
Release: 2mamba
|
|
Summary: Formula Parser
|
|
Group: Development/Libraries/Java
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://community.hitachivantara.com/home
|
|
Source: https://sourceforge.net/projects/jfreereport/files/02.%20Libraries/%{version}-stable/libformula-%{version}.zip
|
|
Patch0: java-jfree-libformula-1.1.3-build.patch
|
|
Patch1: java-jfree-libformula-1.1.3-java11.patch
|
|
Patch2: java-jfree-libformula-1.1.3-remove-ant-contrib-support.patch
|
|
Patch3: java-jfree-libformula-1.1.3-remove-commons-logging.patch
|
|
License: LGPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: javapackages
|
|
BuildRequires: apache-ant
|
|
BuildRequires: java-jfree-libbase
|
|
Requires: java-jfree-libbase
|
|
Requires: javapackages
|
|
|
|
%description
|
|
LibFormula provides Excel-Style-Expressions. The implementation provided here is very generic and can be used in any application that needs to compute formulas.
|
|
The syntax is based on the OpenFormula-specifications, but with carefully pruning away all the spreadsheet specific parts (like references to cell-ranges).
|
|
|
|
%package javadoc
|
|
Group: Documentation
|
|
Summary: Javadoc for %{name}
|
|
|
|
%description javadoc
|
|
JFree Base Services.
|
|
|
|
This package contains documentation for %{name}.
|
|
|
|
%prep
|
|
%setup -q -c
|
|
%patch0 -p1 -b .build
|
|
%patch1 -p1 -b .java11
|
|
%patch2 -p1 -b .remove-ant-contrib-support
|
|
%patch3 -p1 -b .remove-commons-logging
|
|
|
|
find . -name "*.jar" -exec rm -f {} \;
|
|
mkdir -p lib
|
|
build-jar-repository -s -p lib libbase
|
|
|
|
%build
|
|
ant jar javadoc
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
mkdir -p %{buildroot}%{_javadir}
|
|
install -pm 644 dist/libformula-%{version}.jar %{buildroot}%{_javadir}/libformula-%{version}.jar
|
|
|
|
(
|
|
cd %{buildroot}%{_javadir}
|
|
for jar in *-%{version}*; do
|
|
ln -sf ${jar} ${jar/-%{version}/}
|
|
done
|
|
)
|
|
|
|
mkdir -p %{buildroot}%{_javadocdir}/libformula
|
|
cp -pr bin/javadoc/docs/api/* %{buildroot}%{_javadocdir}/libformula
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_javadir}/libformula-%{version}.jar
|
|
%{_javadir}/libformula.jar
|
|
%doc licence-LGPL.txt
|
|
|
|
%files javadoc
|
|
%defattr(-,root,root)
|
|
%{_javadocdir}/libformula
|
|
|
|
%changelog
|
|
* Fri Dec 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.1.3-2mamba
|
|
- rebuilt without gcj and with java11
|
|
|
|
* Sat Jan 22 2011 gil <puntogil@libero.it> 1.1.3-1mamba
|
|
- update to 1.1.3
|
|
|
|
* Wed Dec 09 2009 gil <puntogil@libero.it> 0.2.0-1mamba
|
|
- package created by autospec
|