update to 1.1.3 [release 1.1.3-1mamba;Sat Jan 22 2011]
This commit is contained in:
parent
cc9ae99288
commit
d637cf9fee
@ -1,2 +1,5 @@
|
||||
# java-jfree-libfonts
|
||||
|
||||
LibFonts is a library developed to support advanced layouting in JFreeReport.
|
||||
This library allows to read TrueType-Font files to extract layouting specific informations.
|
||||
|
||||
|
17
java-jfree-libfonts-1.1.3-build_properties.patch
Normal file
17
java-jfree-libfonts-1.1.3-build_properties.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- build.properties 2009-11-16 10:26:48.000000000 +0100
|
||||
+++ build.properties-gil 2011-01-22 15:39:16.000000000 +0100
|
||||
@@ -1,8 +1,10 @@
|
||||
-project.revision=TRUNK-SNAPSHOT
|
||||
+project.revision=1.1.3
|
||||
ivy.artifact.group=pentaho-library
|
||||
ivy.artifact.id=libfonts
|
||||
impl.title=LibFonts
|
||||
impl.productID=libfonts
|
||||
src.dir=${basedir}/source
|
||||
dependency.libloader.revision=1.1.3
|
||||
-testsrc.dir=${basedir}/test
|
||||
\ Manca newline alla fine del file
|
||||
+testsrc.dir=${basedir}/test
|
||||
+antcontrib.available=true
|
||||
+build.cache.dir=lib
|
||||
\ Manca newline alla fine del file
|
153
java-jfree-libfonts.spec
Normal file
153
java-jfree-libfonts.spec
Normal file
@ -0,0 +1,153 @@
|
||||
%define with_gcj 1
|
||||
%define javahome %{_jvmdir}/jdk
|
||||
Name: java-jfree-libfonts
|
||||
Version: 1.1.3
|
||||
Release: 1mamba
|
||||
Summary: TrueType Font Layouting
|
||||
Group: Development/Libraries/Java
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://reporting.pentaho.org/
|
||||
# http://sourceforge.net/projects/jfreereport/
|
||||
# cvs -d:pserver:anonymous@jfreereport.cvs.sourceforge.net:/cvsroot/jfreereport login
|
||||
# cvs -z3 -d:pserver:anonymous@jfreereport.cvs.sourceforge.net:/cvsroot/jfreereport co -P libfonts
|
||||
Source: http://sourceforge.net/projects/jfreereport/files/02.%20Libraries/1.1.3-stable/libfonts-1.1.3.zip
|
||||
Patch0: java-jfree-libfonts-1.1.3-build_properties.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: java-gcj-compat
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcj4-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: ant-contribb3
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: jakarta-commons-logging
|
||||
BuildRequires: java-iText
|
||||
BuildRequires: java-jfree-libbase
|
||||
BuildRequires: java-jfree-libloader
|
||||
BuildRequires: java-junit3
|
||||
BuildRequires: jpackage-utils
|
||||
Requires: java-iText
|
||||
Requires: java-jfree-libloader
|
||||
Requires: jpackage-utils
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
LibFonts is a library developed to support advanced layouting in JFreeReport.
|
||||
This library allows to read TrueType-Font files to extract layouting specific informations.
|
||||
|
||||
%if %with_gcj
|
||||
%package gcj
|
||||
Group: System/Libraries/Java
|
||||
Summary: GCJ support for %{name}
|
||||
Requires: java-gcj-compat
|
||||
|
||||
%description gcj
|
||||
JFree Java General Serialization Framework Library.
|
||||
|
||||
This package contains GCJ support for %{name}.
|
||||
%endif
|
||||
|
||||
%package javadoc
|
||||
Group: Documentation
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
libFonts is a layouting support library used to read and manage fonts.
|
||||
|
||||
This package contains documentation for %{name}.
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -c -n libfonts
|
||||
%patch0
|
||||
for j in $(find . -name "*.jar"); do
|
||||
rm -rf $j
|
||||
done
|
||||
|
||||
for txt in ChangeLog.txt licence-LGPL.txt README.txt; do
|
||||
%{__perl} -pi -e 's/\r$//g' $txt
|
||||
done
|
||||
|
||||
mkdir -p lib/ant-contrib
|
||||
ln -sf $(build-classpath commons-logging-api) lib/commons-logging-api-1.0.4.jar
|
||||
ln -sf $(build-classpath itext) lib/itext-1.5.2.jar
|
||||
ln -sf $(build-classpath libbase) lib/libbase-%{version}.jar
|
||||
ln -sf $(build-classpath libloader) lib/libloader-%{version}.jar
|
||||
ln -sf $(build-classpath junit-3.8.2) test-lib/junit-3.8.1.jar
|
||||
ln -s %{_javadir}/ant/* lib/ant-contrib
|
||||
|
||||
%build
|
||||
|
||||
unset JAVA_HOME
|
||||
export JAVA_HOME=%{javahome}
|
||||
export CLASSPATH=$(build-classpath ant-contribb3 commons-logging-api junit-3.8.2 libbase libloader itext)
|
||||
ant \
|
||||
jar javadoc
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
|
||||
install -pm 644 dist/libfonts-%{version}.jar %{buildroot}%{_javadir}/libfonts-%{version}.jar
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_javadir}
|
||||
for jar in *-%{version}*; do
|
||||
ln -sf ${jar} ${jar/-%{version}/}
|
||||
done
|
||||
)
|
||||
|
||||
mkdir -p %{buildroot}%{_javadocdir}/libfonts
|
||||
cp -pr bin/javadoc/docs/api/* %{buildroot}%{_javadocdir}/libfonts
|
||||
|
||||
%if %with_gcj
|
||||
%{_bindir}/aot-compile-rpm
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_javadir}/libfonts-%{version}.jar
|
||||
%{_javadir}/libfonts.jar
|
||||
%doc ChangeLog.txt licence-LGPL.txt README.txt
|
||||
|
||||
%if %with_gcj
|
||||
%post gcj
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ] ; then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
|
||||
%postun gcj
|
||||
if [ -x %{_bindir}/rebuild-gcj-db ] ; then
|
||||
%{_bindir}/rebuild-gcj-db
|
||||
fi
|
||||
|
||||
%files gcj
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/gcj/java-jfree-libfonts/libfonts-%{version}.jar.db
|
||||
%{_libdir}/gcj/java-jfree-libfonts/libfonts-%{version}.jar.so
|
||||
%endif
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root)
|
||||
%{_javadocdir}/libfonts
|
||||
|
||||
%changelog
|
||||
* Sat Jan 22 2011 gil <puntogil@libero.it> 1.1.3-1mamba
|
||||
- update to 1.1.3
|
||||
|
||||
* Wed Dec 09 2009 gil <puntogil@libero.it> 1.0.0-2mamba
|
||||
- rebuilt
|
||||
|
||||
* Wed Dec 09 2009 gil <puntogil@libero.it> 1.0.0-1mamba
|
||||
- update to 1.0.0
|
||||
|
||||
* Wed Dec 09 2009 gil <puntogil@libero.it> 0.2.7-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user