rebuilt devel [release 1.1-4mamba;Thu Nov 25 2010]

This commit is contained in:
gil 2024-01-06 00:04:14 +01:00
parent 231a53658e
commit acbc3b0cfe
11 changed files with 615 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# java-hamcrest
Provides a library of matcher objects (also known as constraints or predicates) allowing 'match' rules to be defined declaratively, to be used in other frameworks.
Typical scenarios include testing frameworks, mocking libraries and UI validation rules.

12
hamcrest-all-1.1.pom Normal file
View File

@ -0,0 +1,12 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-all</artifactId>
<packaging>jar</packaging>
<name>Hamcrest All</name>
</project>

View File

@ -0,0 +1,12 @@
Manifest-Version: 1.0
Bundle-Vendor: %providerName
Bundle-ActivationPolicy: lazy
Bundle-Localization: plugin
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Bundle-Name: %pluginName
Bundle-SymbolicName: org.hamcrest.core
Export-Package: org.hamcrest;version="1.1.0";core=split;mandatory:=cor
e,org.hamcrest.core;version="1.1.0",org.hamcrest.internal;version="1.
1.0";x-internal:=true
Bundle-Version: 1.1.0.v20090501071000
Bundle-ManifestVersion: 2

12
hamcrest-core-1.1.pom Normal file
View File

@ -0,0 +1,12 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-core</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Core</name>
</project>

View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-generator</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Generator</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-integration</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Integration</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

20
hamcrest-library-1.1.pom Normal file
View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-library</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Library</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

170
hamcrest-parent-1.1.pom Normal file
View File

@ -0,0 +1,170 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<packaging>pom</packaging>
<version>1.1</version>
<name>Hamcrest Parent</name>
<inceptionYear>2006</inceptionYear>
<organization>
<name>Hamcrest</name>
<url>http://code.google.com/p/hamcrest</url>
</organization>
<licenses>
<license>
<name>BSD style</name>
<url>http://www.opensource.org/licenses/bsd-license.php</url>
<distribution>repo</distribution>
</license>
</licenses>
<scm>
<developerConnection>scm:svn:https://hamcrest.googlecode.com/svn/tags/hamcrest-packaging-maven-1.1</developerConnection>
<url>https://hamcrest.googlecode.com/svn/tags/hamcrest-packaging-maven-1.1</url>
</scm>
<modules>
<module>hamcrest-all</module>
<module>hamcrest-core</module>
<module>hamcrest-generator</module>
<module>hamcrest-integration</module>
<module>hamcrest-library</module>
</modules>
<!-- NOTE: all dependencies are declared at scope provided as they are optional -->
<dependencyManagement>
<dependencies>
<dependency>
<groupId>jmock</groupId>
<artifactId>jmock</artifactId>
<version>1.1.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.0</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
<version>2.2</version>
<scope>provided</scope>
</dependency>
</dependencies>
</dependencyManagement>
<dependencies>
<dependency>
<groupId>jmock</groupId>
<artifactId>jmock</artifactId>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
</dependency>
</dependencies>
<distributionManagement>
<!--
The id used must match a server id defined in ~/.m2/settings.xml
-->
<repository>
<id>hamcrest@repo1.maven.org</id>
<name>Central Maven Repository</name>
<url>scp://repo1.maven.org/home/projects/hamcrest/repository</url>
</repository>
</distributionManagement>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-jar-plugin</artifactId>
<version>2.1</version>
<configuration>
<archive>
<compress>false</compress>
</archive>
</configuration>
</plugin>
<plugin>
<groupId>org.codehaus.mojo.groovy</groupId>
<artifactId>groovy-maven-plugin</artifactId>
<version>1.0-alpha-3</version>
<executions>
<execution>
<phase>generate-resources</phase>
<goals>
<goal>execute</goal>
</goals>
<configuration>
<source>
<body>
def ant = new AntBuilder()
def script = "${basedir}/src/script/download-jars.sh"
def version = "${release.version}"
if ( version == "null" ){
println("ERROR: 'release.version' property not set.")
} else {
println("Using release version ${release.version}")
}
if ( new File(script).exists() ){
// we are in top-level module
println("Found script "+script)
ant.exec(executable: script, dir: "${basedir}",
spawn: false, failifexecutionfails: true, failonerror: true){
arg(value: "http://hamcrest.googlecode.com/files/")
arg(value: "hamcrest-${release.version}.zip" )
arg(value: "target")
arg(value: "hamcrest-${release.version}")
}
} else {
// we are in child module
ant.copy(file: "${download.artifact.dir}/${artifact.name}.jar",
tofile: "${project.build.directory}/downloaded.jar", verbose: true)
ant.unjar(src: "${project.build.directory}/downloaded.jar",
dest: "${project.build.outputDirectory}")
}
</body>
</source>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
<version>2.0-beta-6</version>
<configuration>
<autoVersionSubmodules>true</autoVersionSubmodules>
<tagBase>https://hamcrest.googlecode.com/svn/tags</tagBase>
</configuration>
</plugin>
</plugins>
<extensions>
<extension>
<groupId>org.apache.maven.wagon</groupId>
<artifactId>wagon-webdav</artifactId>
<version>1.0-beta-2</version>
</extension>
</extensions>
</build>
<properties>
<release.version>1.1</release.version>
<download.dir>target</download.dir>
<download.name>hamcrest-${release.version}</download.name>
<artifact.name>${artifactId}-${release.version}</artifact.name>
<download.artifact.dir>${basedir}/../${download.dir}/${download.name}/${download.name}</download.artifact.dir>
</properties>
</project>

20
hamcrest-text-1.1.pom Normal file
View File

@ -0,0 +1,20 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.hamcrest</groupId>
<artifactId>hamcrest-parent</artifactId>
<version>1.1</version>
</parent>
<artifactId>hamcrest-text</artifactId>
<packaging>jar</packaging>
<name>Hamcrest Text</name>
<dependencies>
<dependency>
<groupId>${pom.groupId}</groupId>
<artifactId>hamcrest-core</artifactId>
<version>${pom.version}</version>
</dependency>
</dependencies>
</project>

View File

@ -0,0 +1,96 @@
--- hamcrest-1.1/build.xml 2007-06-30 15:03:43.000000000 +0200
+++ hamcrest-1.1/build.xml-gil 2009-03-06 13:46:42.000000000 +0100
@@ -26,17 +26,17 @@
<java-to-jar srcdir="hamcrest-generator/src/main/java"
destjar="build/temp/hamcrest-generator-${version}-nodeps.jar"
classpath="
- lib/generator/qdox-1.6.1.jar;
+ lib/generator/qdox.jar;
"/>
<taskdef name="jarjar"
classname="com.tonicsystems.jarjar.JarJarTask"
- classpath="lib/generator/jarjar-1.0rc3.jar"/>
+ classpath="lib/generator/jarjar.jar"/>
<!-- Bundle QDox classes in hamcrest-generator.jar so user doesn't need to care
about it's existence. Uses JarJar to place classes under a different package
to prevent conflict. -->
<jarjar jarfile="build/hamcrest-generator-${version}.jar">
<zipfileset src="build/temp/hamcrest-generator-${version}-nodeps.jar"/>
- <zipfileset src="lib/generator/qdox-1.6.1.jar"/>
+ <zipfileset src="lib/generator/qdox.jar"/>
<rule pattern="com.thoughtworks.qdox.**"
result="org.hamcrest.generator.qdox.@1"/>
</jarjar>
@@ -94,16 +94,16 @@
classpath="build/hamcrest-core-${version}.jar"/>
</target>
- <target name="text"
- depends="core, library"
- description="Build text pattern matcher">
- <java-to-jar srcdir="hamcrest-text/src/main/java"
- destjar="build/hamcrest-text-${version}.jar"
- classpath="
- build/hamcrest-core-${version}.jar;
- build/hamcrest-library-${version}.jar"/>
- </target>
-
+ <target name="text"
+ depends="core, library"
+ description="Build text pattern matcher">
+ <java-to-jar srcdir="hamcrest-text/src/main/java"
+ destjar="build/hamcrest-text-${version}.jar"
+ classpath="
+ build/hamcrest-core-${version}.jar;
+ build/hamcrest-library-${version}.jar"/>
+ </target>
+
<target name="integration"
depends="core, library"
description="Build integration with external tools">
@@ -121,7 +121,7 @@
destjar="build/hamcrest-unit-test-${version}.jar"
classpath="
build/hamcrest-core-${version}.jar;
- build/hamcrest-library-${version}.jar;
+ build/hamcrest-library-${version}.jar;
build/hamcrest-text-${version}.jar;
build/hamcrest-integration-${version}.jar;
build/hamcrest-generator-${version}.jar"/>
@@ -164,7 +164,7 @@
<jar jarfile="build/hamcrest-all-${version}.jar" duplicate="preserve">
<zipfileset src="build/hamcrest-core-${version}.jar"/>
<zipfileset src="build/hamcrest-library-${version}.jar"/>
- <zipfileset src="build/hamcrest-text-${version}.jar"/>
+ <zipfileset src="build/hamcrest-text-${version}.jar"/>
<zipfileset src="build/hamcrest-generator-${version}.jar"/>
<zipfileset src="build/hamcrest-integration-${version}.jar"/>
</jar>
@@ -211,7 +211,7 @@
<target name="javadoc" depends="library">
<mkdir dir="build/javadoc"/>
<javadoc destdir="build/javadoc" source="1.5" failonerror="yes"
- overview="overview.html">
+ >
<classpath>
<fileset dir="lib/integration">
@@ -221,9 +221,10 @@
<packageset dir="hamcrest-core/src/main/java"/>
<packageset dir="hamcrest-library/src/main/java" excludes="org/hamcrest/internal"/>
- <packageset dir="hamcrest-text/src/main/java" excludes="**/internal/**"/>
+ <packageset dir="hamcrest-text/src/main/java" excludes="**/internal/**"/>
<packageset dir="hamcrest-integration/src/main/java"/>
- <packageset dir="build/generated-code"/>
+ <packageset dir="build/temp/hamcrest-core/generated-code"/>
+ <packageset dir="build/temp/hamcrest-library/generated-code"/>
<group title="Hamcrest API and Utility Classes" packages="org.hamcrest"/>
<group title="Matcher Library" packages="org.hamcrest.*"/>
@@ -261,4 +262,4 @@
</sequential>
</macrodef>
-</project>
+</project>

230
java-hamcrest.spec Normal file
View File

@ -0,0 +1,230 @@
Name: java-hamcrest
Version: 1.1
Release: 4mamba
Summary: Hamcrest - library of matchers for building test expressions
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://code.google.com/p/hamcrest/
Source0: http://hamcrest.googlecode.com/files/hamcrest-%{version}.tgz
Source1: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-parent/%{version}/hamcrest-parent-%{version}.pom
Source2: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-library/%{version}/hamcrest-library-%{version}.pom
Source3: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-integration/%{version}/hamcrest-integration-%{version}.pom
Source4: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-generator/%{version}/hamcrest-generator-%{version}.pom
Source5: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-core/%{version}/hamcrest-core-%{version}.pom
Source6: http://repo1.maven.org/maven2/org/hamcrest/hamcrest-all/%{version}/hamcrest-all-%{version}.pom
Source7: hamcrest-text-1.1.pom
Source8: hamcrest-core-1.1-MANIFEST.MF
Patch0: java-hamcrest-1.1-build.patch
License: BSD
BuildRequires: java-qdox16
BuildRequires: java-jmock1
BuildRequires: java-easymock2
# with tests
# testng 4.6 eclipse plugin
%if "%{stage1}" != "1"
BuildRequires: java-junit45
%endif
BuildRequires: java-jarjar1
BuildRequires: java-testng
BuildRequires: apache-ant
BuildRequires: apache-ant-junit
BuildRequires: java-junit3
BuildRequires: jpackage-utils
Requires: jpackage-utils
Requires: java-easymock2
Requires: java-jmock1
Requires: java-qdox16
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Provides a library of matcher objects (also known as constraints or predicates) allowing 'match' rules to be defined declaratively, to be used in other frameworks.
Typical scenarios include testing frameworks, mocking libraries and UI validation rules.
%package demo
Group: Documentation
Summary: Samples for %{name}
Requires: %{name} = %{version}-%{release}
%description demo
Provides a library of matcher objects (also known as constraints or predicates) allowing 'match' rules to be defined declaratively, to be used in other frameworks.
Typical scenarios include testing frameworks, mocking libraries and UI validation rules..
This package contains samples for %{name}.
%package javadoc
Group: Documentation
Summary: Javadoc for %{name}
%description javadoc
Provides a library of matcher objects (also known as constraints or predicates) allowing 'match' rules to be defined declaratively, to be used in other frameworks.
Typical scenarios include testing frameworks, mocking libraries and UI validation rules.
This package contains javadoc for %{name}.
%prep
%setup -q -n hamcrest-%{version}
for j in $(find . -name "*.jar"); do
mv $j ${j}.no
done
pushd lib
pushd generator
ln -sf $(build-classpath jarjar1) jarjar.jar
ln -sf $(build-classpath qdox16) qdox.jar
popd
# with integration
pushd integration
ln -sf $(build-classpath easymock2) easymock-2.2.jar
ln -sf $(build-classpath jmock1) jmock-1.10RC1.jar
ln -sf $(build-classpath junit-3.8.2) junit-3.8.1.jar
ln -sf $(build-classpath junit45) junit-4.0.jar
ln -sf $(build-classpath testng-jdk15) testng-4.6-jdk15.jar
popd
popd
%patch0 -p1
perl -pi -e 's/\r$//g' LICENSE.txt README.txt
%build
%if "%{stage1}" != "1"
export CLASSPATH=$(build-classpath jarjar1 qdox16 ant/ant-junit):$PWD/build/hamcrest-core-%{version}.jar
%else
rm -f lib/integration/junit-4.0.jar
mv lib/integration/junit-4.0.jar.no lib/integration/junit-4.0.jar
export CLASSPATH=$(build-classpath qdox16 ant/ant-junit):$PWD/build/hamcrest-core-%{version}.jar
%endif
ant \
-Dant.build.javac.source=1.5 \
-Dversion=%{version} \
-Dbuild.sysclasspath=first \
clean package javadoc
mkdir -p META-INF
cp -p %{SOURCE8} META-INF/MANIFEST.MF
touch META-INF/MANIFEST.MF
zip -u build/hamcrest-core-%{version}.jar META-INF/MANIFEST.MF
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
mkdir -p %{buildroot}%{_javadir}/hamcrest
mkdir -p %{buildroot}%{_datadir}/maven2/poms
install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-parent.pom
%add_to_maven_depmap org.hamcrest hamcrest-parent %{version} JPP/hamcrest parent
install -m 644 build/hamcrest-all-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/all-%{version}.jar
install -m 644 %{SOURCE6} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-all.pom
%add_to_maven_depmap org.hamcrest hamcrest-all %{version} JPP/hamcrest all
install -m 644 build/hamcrest-core-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/core-%{version}.jar
install -m 644 %{SOURCE5} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-core.pom
%add_to_maven_depmap org.hamcrest hamcrest-core %{version} JPP/hamcrest core
install -m 644 build/hamcrest-generator-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/generator-%{version}.jar
install -m 644 %{SOURCE4} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-generator.pom
%add_to_maven_depmap org.hamcrest hamcrest-generator %{version} JPP/hamcrest generator
install -m 644 build/hamcrest-library-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/library-%{version}.jar
install -m 644 %{SOURCE2} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-library.pom
%add_to_maven_depmap org.hamcrest hamcrest-library %{version} JPP/hamcrest library
install -m 644 build/hamcrest-text-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/text-%{version}.jar
install -m 644 %{SOURCE7} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-text.pom
%add_to_maven_depmap org.hamcrest hamcrest-text %{version} JPP/hamcrest text
# with integration
install -m 644 build/hamcrest-integration-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/integration-%{version}.jar
install -m 644 %{SOURCE3} %{buildroot}%{_datadir}/maven2/poms/JPP.hamcrest-integration.pom
%add_to_maven_depmap org.hamcrest hamcrest-integration %{version} JPP/hamcrest integration
# with tests
install -m 644 build/hamcrest-unit-test-%{version}.jar \
%{buildroot}%{_javadir}/hamcrest/unit-test-%{version}.jar
(
cd %{buildroot}%{_javadir}/hamcrest
for jar in *-%{version}.jar; do
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
done
)
mkdir -p %{buildroot}%{_javadocdir}/hamcrest-%{version}
cp -pr build/javadoc/* %{buildroot}%{_javadocdir}/hamcrest-%{version}
ln -s hamcrest-%{version} %{buildroot}%{_javadocdir}/hamcrest
mkdir -p %{buildroot}%{_datadir}/hamcrest-%{version}
# with integration
install -m 644 build/hamcrest-examples-%{version}.jar \
%{buildroot}%{_datadir}/hamcrest-%{version}
cp -pr hamcrest-examples %{buildroot}%{_datadir}/hamcrest-%{version}/
ln -s hamcrest-%{version} %{buildroot}%{_datadir}/hamcrest
#%{_bindir}/aot-compile-rpm
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files
%defattr(-,root,root)
%dir %{_javadir}/hamcrest
%{_javadir}/hamcrest/all-%{version}.jar
%{_javadir}/hamcrest/all.jar
%{_javadir}/hamcrest/core-%{version}.jar
%{_javadir}/hamcrest/core.jar
%{_javadir}/hamcrest/generator-%{version}.jar
%{_javadir}/hamcrest/generator.jar
%{_javadir}/hamcrest/integration-%{version}.jar
%{_javadir}/hamcrest/integration.jar
%{_javadir}/hamcrest/library-%{version}.jar
%{_javadir}/hamcrest/library.jar
%{_javadir}/hamcrest/text-%{version}.jar
%{_javadir}/hamcrest/text.jar
%{_javadir}/hamcrest/unit-test-%{version}.jar
%{_javadir}/hamcrest/unit-test.jar
%{_datadir}/maven2/poms
%{_mavendepmapfragdir}
%doc LICENSE.txt README.txt
%files javadoc
%defattr(-,root,root)
%{_javadocdir}/hamcrest-%{version}
%{_javadocdir}/hamcrest
%files demo
%defattr(-,root,root)
%{_datadir}/hamcrest-%{version}
%{_datadir}/hamcrest
%changelog
* Thu Nov 25 2010 gil <puntogil@libero.it> 1.1-4mamba
- rebuilt devel
* Thu Mar 18 2010 gil <puntogil@libero.it> 1.1-3mamba
- added: maven poms; hamcrest core OSGi MANIFEST
* Thu Jul 23 2009 gil <puntogil@libero.it> 1.1-2mamba
- added java-testng support
* Fri Mar 06 2009 gil <puntogil@libero.it> 1.1-1mamba
- package created by autospec