rebuilt with java-openjdk support [release 2.3-4mamba;Thu Mar 24 2011]
This commit is contained in:
parent
df77cffc83
commit
c59668f84e
@ -1,2 +1,7 @@
|
|||||||
# jakarta-commons-lang
|
# jakarta-commons-lang
|
||||||
|
|
||||||
|
The standard Java libraries fail to provide enough methods for manipulation of its core classes. The Lang Component provides these extra methods.
|
||||||
|
|
||||||
|
The Lang Component provides a host of helper utilities for the java.lang API, notably String manipulation methods, basic numerical methods, object reflection, creation and serialization, and System properties. Additionally it contains an inheritable enum type, an exception structure that supports multiple types of nested-Exceptions, basic enhancements to java.util.
|
||||||
|
Date and a series of utilities dedicated to help with building methods, such as hashCode, toString and equals.
|
||||||
|
|
||||||
|
21
jakarta-commons-2.3-lang-addosgimanifest.patch
Normal file
21
jakarta-commons-2.3-lang-addosgimanifest.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up ./src/conf/MANIFEST.MF.osgi ./src/conf/MANIFEST.MF
|
||||||
|
--- ./src/conf/MANIFEST.MF.osgi 2008-07-24 16:38:38.000000000 -0400
|
||||||
|
+++ ./src/conf/MANIFEST.MF 2008-07-24 16:39:13.000000000 -0400
|
||||||
|
@@ -10,3 +10,17 @@ Implementation-Title: Commons Lang
|
||||||
|
Implementation-Vendor-Id: org.apache
|
||||||
|
X-Compile-Source-JDK: @compile.source@
|
||||||
|
X-Compile-Target-JDK: @compile.target@
|
||||||
|
+Bundle-RequiredExecutionEnvironment: JRE-1.1
|
||||||
|
+Bundle-SymbolicName: org.apache.commons.lang
|
||||||
|
+Bundle-ManifestVersion: 2
|
||||||
|
+Bundle-Name: %pluginName
|
||||||
|
+Bundle-Localization: plugin
|
||||||
|
+Bundle-Version: 2.3.0.v200803061910
|
||||||
|
+Bundle-Vendor: %providerName
|
||||||
|
+Export-Package: org.apache.commons.lang;version="2.3.0",org.apache.com
|
||||||
|
+ mons.lang.builder;version="2.3.0",org.apache.commons.lang.enum;versio
|
||||||
|
+ n="2.3.0",org.apache.commons.lang.enums;version="2.3.0",org.apache.co
|
||||||
|
+ mmons.lang.exception;version="2.3.0",org.apache.commons.lang.math;ver
|
||||||
|
+ sion="2.3.0",org.apache.commons.lang.mutable;version="2.3.0",org.apac
|
||||||
|
+ he.commons.lang.text;version="2.3.0",org.apache.commons.lang.time;ver
|
||||||
|
+ sion="2.3.0"
|
20
jakarta-commons-2.3-lang-notarget.patch
Normal file
20
jakarta-commons-2.3-lang-notarget.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- build.xml.orig 2008-01-22 22:02:04.000000000 -0500
|
||||||
|
+++ build.xml 2008-01-22 22:02:26.000000000 -0500
|
||||||
|
@@ -62,7 +62,7 @@
|
||||||
|
</copy>
|
||||||
|
</target>
|
||||||
|
<target name="compile" depends="static" description="Compile shareable components">
|
||||||
|
- <javac srcdir="${source.home}" destdir="${build.home}/classes" debug="${compile.debug}" deprecation="${compile.deprecation}" target="${compile.target}" source="${compile.source}" excludes="${compile.excludes}" optimize="${compile.optimize}">
|
||||||
|
+ <javac srcdir="${source.home}" destdir="${build.home}/classes" debug="${compile.debug}" deprecation="${compile.deprecation}" source="${compile.source}" excludes="${compile.excludes}" optimize="${compile.optimize}">
|
||||||
|
<classpath refid="compile.classpath"/>
|
||||||
|
</javac>
|
||||||
|
<copy todir="${build.home}/classes" filtering="on">
|
||||||
|
@@ -70,7 +70,7 @@
|
||||||
|
</copy>
|
||||||
|
</target>
|
||||||
|
<target name="compile.tests" depends="compile" description="Compile unit test cases">
|
||||||
|
- <javac srcdir="${test.home}" destdir="${build.home}/tests" debug="${compile.debug}" deprecation="off" target="${compile.target}" source="${compile.source}" optimize="${compile.optimize}">
|
||||||
|
+ <javac srcdir="${test.home}" destdir="${build.home}/tests" debug="${compile.debug}" deprecation="off" source="${compile.source}" optimize="${compile.optimize}">
|
||||||
|
<classpath refid="test.classpath"/>
|
||||||
|
</javac>
|
||||||
|
<copy todir="${build.home}/tests" filtering="on">
|
397
jakarta-commons-lang-2.3.pom
Normal file
397
jakarta-commons-lang-2.3.pom
Normal file
@ -0,0 +1,397 @@
|
|||||||
|
<?xml version="1.0"?>
|
||||||
|
<!--
|
||||||
|
Licensed to the Apache Software Foundation (ASF) under one or more
|
||||||
|
contributor license agreements. See the NOTICE file distributed with
|
||||||
|
this work for additional information regarding copyright ownership.
|
||||||
|
The ASF licenses this file to You under the Apache License, Version 2.0
|
||||||
|
(the "License"); you may not use this file except in compliance with
|
||||||
|
the License. You may obtain a copy of the License at
|
||||||
|
|
||||||
|
http://www.apache.org/licenses/LICENSE-2.0
|
||||||
|
|
||||||
|
Unless required by applicable law or agreed to in writing, software
|
||||||
|
distributed under the License is distributed on an "AS IS" BASIS,
|
||||||
|
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
|
||||||
|
See the License for the specific language governing permissions and
|
||||||
|
limitations under the License.
|
||||||
|
-->
|
||||||
|
<project
|
||||||
|
xmlns="http://maven.apache.org/POM/4.0.0"
|
||||||
|
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||||
|
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||||
|
<parent>
|
||||||
|
<groupId>org.apache.commons</groupId>
|
||||||
|
<artifactId>commons-parent</artifactId>
|
||||||
|
<version>1</version>
|
||||||
|
</parent>
|
||||||
|
<modelVersion>4.0.0</modelVersion>
|
||||||
|
<groupId>commons-lang</groupId>
|
||||||
|
<artifactId>commons-lang</artifactId>
|
||||||
|
<version>2.3</version>
|
||||||
|
<name>Lang</name>
|
||||||
|
|
||||||
|
<inceptionYear>2001</inceptionYear>
|
||||||
|
<description>
|
||||||
|
Commons.Lang, a package of Java utility classes for the
|
||||||
|
classes that are in java.lang's hierarchy, or are considered to be so
|
||||||
|
standard as to justify existence in java.lang.
|
||||||
|
</description>
|
||||||
|
|
||||||
|
<url>http://jakarta.apache.org/commons/lang/</url>
|
||||||
|
|
||||||
|
<issueManagement>
|
||||||
|
<system>jira</system>
|
||||||
|
<url>http://issues.apache.org/jira/browse/LANG</url>
|
||||||
|
</issueManagement>
|
||||||
|
|
||||||
|
<scm>
|
||||||
|
<connection>scm:svn:https://svn.apache.org/repos/asf/jakarta/commons/proper/lang/trunk</connection>
|
||||||
|
<developerConnection>scm:svn:https://svn.apache.org/repos/asf/jakarta/commons/proper/lang/trunk</developerConnection>
|
||||||
|
<url>http://svn.apache.org/viewvc/jakarta/commons/proper/lang/trunk</url>
|
||||||
|
</scm>
|
||||||
|
|
||||||
|
<developers>
|
||||||
|
<developer>
|
||||||
|
<name>Daniel Rall</name>
|
||||||
|
<id>dlr</id>
|
||||||
|
<email>dlr@finemaltcoding.com</email>
|
||||||
|
<organization>CollabNet, Inc.</organization>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Stephen Colebourne</name>
|
||||||
|
<id>scolebourne</id>
|
||||||
|
<email>scolebourne@joda.org</email>
|
||||||
|
<organization>SITA ATS Ltd</organization>
|
||||||
|
<timezone>0</timezone>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Henri Yandell</name>
|
||||||
|
<id>bayard</id>
|
||||||
|
<email>bayard@generationjava.com</email>
|
||||||
|
<organization/>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Steven Caswell</name>
|
||||||
|
<id>scaswell</id>
|
||||||
|
<email>stevencaswell@apache.org</email>
|
||||||
|
<organization/>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
<timezone>-5</timezone>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Robert Burrell Donkin</name>
|
||||||
|
<id>rdonkin</id>
|
||||||
|
<email>rdonkin@apache.org</email>
|
||||||
|
<organization/>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Gary D. Gregory</name>
|
||||||
|
<id>ggregory</id>
|
||||||
|
<email>ggregory@seagullsw.com</email>
|
||||||
|
<organization>Seagull Software</organization>
|
||||||
|
<timezone>-8</timezone>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Phil Steitz</name>
|
||||||
|
<id>psteitz</id>
|
||||||
|
<email>phil@steitz.com</email>
|
||||||
|
<organization/>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>Fredrik Westermarck</name>
|
||||||
|
<id>fredrik</id>
|
||||||
|
<email/>
|
||||||
|
<organization/>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
<developer>
|
||||||
|
<name>James Carman</name>
|
||||||
|
<id>jcarman</id>
|
||||||
|
<email>jcarman@apache.org</email>
|
||||||
|
<organization>Carman Consulting, Inc.</organization>
|
||||||
|
<roles>
|
||||||
|
<role>Java Developer</role>
|
||||||
|
</roles>
|
||||||
|
</developer>
|
||||||
|
</developers>
|
||||||
|
<contributors>
|
||||||
|
<contributor>
|
||||||
|
<name>C. Scott Ananian</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Chris Audley</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Stephane Bailliez</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Michael Becke</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Ola Berg</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Nathan Beyer</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Stefan Bodewig</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Janek Bogucki</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Mike Bowler</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Sean Brown</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Alexander Day Chaffee</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Al Chou</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Greg Coladonato</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Maarten Coene</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Justin Couch</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Michael Davey</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Norm Deane</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Ringo De Smet</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Russel Dittmar</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Steve Downey</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Matthias Eichel</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Christopher Elkins</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Chris Feldhacker</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Pete Gieser</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Jason Gritman</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Matthew Hawthorne</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Michael Heuer</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Oliver Heger</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Chris Hyzer</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Marc Johnson</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Shaun Kalley</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Tetsuya Kaneuchi</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Nissim Karpenstein</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Ed Korthof</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Holger Krauth</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Rafal Krupinski</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Rafal Krzewski</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Craig R. McClanahan</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Rand McNeely</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Nikolay Metchev</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Kasper Nielsen</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Tim O'Brien</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Brian S O'Neill</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Andrew C. Oliver</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Alban Peignier</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Moritz Petersen</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Dmitri Plotnikov</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Neeme Praks</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Eric Pugh</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Stephen Putman</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Travis Reeder</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Antony Riley</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Scott Sanders</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Ralph Schaer</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Henning P. Schmiedehausen</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Sean Schofield</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Reuben Sivan</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Ville Skytta</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Jan Sorensen</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Glen Stampoultzis</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Scott Stanchfield</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Jon S. Stevens</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Sean C. Sullivan</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Ashwin Suresh</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Helge Tesgaard</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Arun Mammen Thomas</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Masato Tezuka</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Jeff Varszegi</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Chris Webb</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Mario Winterer</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Stepan Koltsov</name>
|
||||||
|
</contributor>
|
||||||
|
<contributor>
|
||||||
|
<name>Holger Hoffstatte</name>
|
||||||
|
</contributor>
|
||||||
|
</contributors>
|
||||||
|
|
||||||
|
<!-- Lang should depend on very little -->
|
||||||
|
<dependencies>
|
||||||
|
<dependency>
|
||||||
|
<groupId>junit</groupId>
|
||||||
|
<artifactId>junit</artifactId>
|
||||||
|
<version>3.8.1</version>
|
||||||
|
<scope>test</scope>
|
||||||
|
</dependency>
|
||||||
|
</dependencies>
|
||||||
|
|
||||||
|
<build>
|
||||||
|
<sourceDirectory>src/java</sourceDirectory>
|
||||||
|
<testSourceDirectory>src/test</testSourceDirectory>
|
||||||
|
<resources>
|
||||||
|
<resource>
|
||||||
|
<directory>.</directory>
|
||||||
|
<targetPath>META-INF</targetPath>
|
||||||
|
<includes>
|
||||||
|
<include>NOTICE.txt</include>
|
||||||
|
<include>LICENSE.txt</include>
|
||||||
|
</includes>
|
||||||
|
</resource>
|
||||||
|
</resources>
|
||||||
|
<plugins>
|
||||||
|
<plugin>
|
||||||
|
<groupId>org.apache.maven.plugins</groupId>
|
||||||
|
<artifactId>maven-surefire-plugin</artifactId>
|
||||||
|
<configuration>
|
||||||
|
<includes>
|
||||||
|
<include>**/*TestSuite.java</include>
|
||||||
|
</includes>
|
||||||
|
<excludes>
|
||||||
|
<exclude>**/AllLangTestSuite.java</exclude>
|
||||||
|
</excludes>
|
||||||
|
</configuration>
|
||||||
|
</plugin>
|
||||||
|
</plugins>
|
||||||
|
</build>
|
||||||
|
|
||||||
|
</project>
|
127
jakarta-commons-lang.spec
Normal file
127
jakarta-commons-lang.spec
Normal file
@ -0,0 +1,127 @@
|
|||||||
|
%define javahome %{_jvmdir}/jdk
|
||||||
|
Name: jakarta-commons-lang
|
||||||
|
Version: 2.3
|
||||||
|
Release: 4mamba
|
||||||
|
Summary: Jakarta Commons Lang Package
|
||||||
|
Group: Development/Libraries/Java
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://commons.apache.org/lang/
|
||||||
|
Source0: http://archive.apache.org/dist/commons/lang/source/commons-lang-%{version}-src.tar.gz
|
||||||
|
Source1: jakarta-commons-lang-2.3.pom
|
||||||
|
Patch0: jakarta-commons-2.3-lang-notarget.patch
|
||||||
|
Patch1: jakarta-commons-2.3-lang-addosgimanifest.patch
|
||||||
|
License: Apache License Version 2.0
|
||||||
|
BuildRequires: apache-ant
|
||||||
|
BuildRequires: apache-ant-junit
|
||||||
|
BuildRequires: java-junit3
|
||||||
|
BuildRequires: jpackage-utils
|
||||||
|
Requires: jpackage-utils
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
The standard Java libraries fail to provide enough methods for manipulation of its core classes. The Lang Component provides these extra methods.
|
||||||
|
|
||||||
|
The Lang Component provides a host of helper utilities for the java.lang API, notably String manipulation methods, basic numerical methods, object reflection, creation and serialization, and System properties. Additionally it contains an inheritable enum type, an exception structure that supports multiple types of nested-Exceptions, basic enhancements to java.util.
|
||||||
|
Date and a series of utilities dedicated to help with building methods, such as hashCode, toString and equals.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Group: Documentation
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
The standard Java libraries fail to provide enough methods for manipulation of its core classes. The Lang Component provides these extra methods.
|
||||||
|
|
||||||
|
The Lang Component provides a host of helper utilities for the java.lang API, notably String manipulation methods, basic numerical methods, object reflection, creation and serialization, and System properties. Additionally it contains an inheritable enum type, an exception structure that supports multiple types of nested-Exceptions, basic enhancements to java.util.
|
||||||
|
Date and a series of utilities dedicated to help with building methods, such as hashCode, toString and equals.
|
||||||
|
|
||||||
|
This package contains javadoc for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n commons-lang-%{version}-src
|
||||||
|
perl -pi -e 's/\r//g' *.txt
|
||||||
|
sed -i 's/\r//' STATUS.html
|
||||||
|
%patch0
|
||||||
|
%patch1
|
||||||
|
|
||||||
|
%build
|
||||||
|
export JAVA_HOME=%javahome
|
||||||
|
export CLASSPATH=$(build-classpath junit-3.8.2 ant/ant-junit):target/classes:target/tests
|
||||||
|
ant \
|
||||||
|
-Djunit.jar=$(find-jar junit-3.8.2) \
|
||||||
|
-Djdk.javadoc=%{_javadocdir}/java \
|
||||||
|
-Dfinal.name=commons-lang \
|
||||||
|
-Dtest.failonerror=false \
|
||||||
|
jar javadoc \
|
||||||
|
%if "%{stage1}" != "1"
|
||||||
|
test
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadir}
|
||||||
|
mkdir -p %{buildroot}%{_datadir}/maven2/poms
|
||||||
|
|
||||||
|
install -p -m 644 dist/commons-lang.jar %{buildroot}%{_javadir}/%{name}-%{version}.jar
|
||||||
|
|
||||||
|
install -pm 644 %{SOURCE1} %{buildroot}%{_datadir}/maven2/poms/JPP-jakarta-commons-lang.pom
|
||||||
|
%add_to_maven_depmap commons-lang commons-lang %{version} JPP commons-lang
|
||||||
|
|
||||||
|
(
|
||||||
|
cd %{buildroot}%{_javadir}
|
||||||
|
for jar in *-%{version}*; do
|
||||||
|
ln -sf ${jar} `echo $jar| sed "s|jakarta-||g"`
|
||||||
|
done
|
||||||
|
)
|
||||||
|
(
|
||||||
|
cd %{buildroot}%{_javadir}
|
||||||
|
for jar in *-%{version}*; do
|
||||||
|
ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`
|
||||||
|
done
|
||||||
|
)
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_javadocdir}/jakarta-commons-lang-%{version}
|
||||||
|
cp -pr dist/docs/api/* %{buildroot}%{_javadocdir}/jakarta-commons-lang-%{version}
|
||||||
|
ln -s jakarta-commons-lang-%{version} %{buildroot}%{_javadocdir}/jakarta-commons-lang
|
||||||
|
|
||||||
|
##%{_bindir}/aot-compile-rpm
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
%update_maven_depmap
|
||||||
|
|
||||||
|
%postun
|
||||||
|
%update_maven_depmap
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadir}/jakarta-commons-lang-%{version}.jar
|
||||||
|
%{_javadir}/jakarta-commons-lang.jar
|
||||||
|
%{_javadir}/commons-lang-%{version}.jar
|
||||||
|
%{_javadir}/commons-lang.jar
|
||||||
|
%{_datadir}/maven2/poms
|
||||||
|
%{_mavendepmapfragdir}
|
||||||
|
%doc STATUS.html LICENSE.txt NOTICE.txt RELEASE-NOTES.txt
|
||||||
|
|
||||||
|
%files javadoc
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_javadocdir}/jakarta-commons-lang-%{version}
|
||||||
|
%{_javadocdir}/jakarta-commons-lang
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Mar 24 2011 gil <puntogil@libero.it> 2.3-4mamba
|
||||||
|
- rebuilt with java-openjdk support
|
||||||
|
|
||||||
|
* Sat Oct 30 2010 gil <puntogil@libero.it> 2.3-3mamba
|
||||||
|
- rebuilt in devel
|
||||||
|
|
||||||
|
* Fri Jan 08 2010 gil <puntogil@libero.it> 2.3-2mamba
|
||||||
|
- add maven pom
|
||||||
|
- add OSGi support
|
||||||
|
|
||||||
|
* Fri Mar 06 2009 gil <puntogil@libero.it> 2.3-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user