rebuilt with java-openjdk support [release 3.2.1-6mamba;Thu Mar 24 2011]
This commit is contained in:
parent
45fc9d5e6e
commit
7e5919524f
@ -1,2 +1,8 @@
|
||||
# jakarta-commons-collections
|
||||
|
||||
The introduction of the Collections API by Sun in JDK 1.2 has been a boon to quick and effective Java programming. Ready access to powerful data structures has accelerated development by reducing the need for custom container classes around each core object. Most Java2 APIs are significantly easier to use because of the Collections API.
|
||||
However, there are certain holes left unfilled by Sun's implementations, and the Jakarta-Commons Collections Component strives to fulfill them. Among the features of this package are:
|
||||
- special-purpose implementations of Lists and Maps for fast access
|
||||
- adapter classes from Java1-style containers (arrays, enumerations) to Java2-style collections.
|
||||
- methods to test or create typical set-theory properties of collections such as union, intersection, and closure.
|
||||
|
||||
|
41
jakarta-commons-collections-3.2.1-addosgimanifest.patch
Normal file
41
jakarta-commons-collections-3.2.1-addosgimanifest.patch
Normal file
@ -0,0 +1,41 @@
|
||||
--- src/conf/MANIFEST.MF 2008-04-11 16:36:02.000000000 +0200
|
||||
+++ src/conf/MANIFEST.MF-gil 2010-01-09 03:13:09.000000000 +0100
|
||||
@@ -9,4 +9,35 @@
|
||||
Implementation-Title: Commons Collections
|
||||
Implementation-Vendor-Id: org.apache
|
||||
X-Compile-Source-JDK: 1.2
|
||||
-X-Compile-Target-JDK: 1.2
|
||||
\ No newline at end of file
|
||||
+X-Compile-Target-JDK: 1.2
|
||||
+Export-Package: org.apache.commons.collections.iterators;version="3.2.
|
||||
+ 1",org.apache.commons.collections.keyvalue;version="3.2.1",org.apache
|
||||
+ .commons.collections.comparators;version="3.2.1",org.apache.commons.c
|
||||
+ ollections.map;version="3.2.1",org.apache.commons.collections.bag;ver
|
||||
+ sion="3.2.1",org.apache.commons.collections;version="3.2.1",org.apach
|
||||
+ e.commons.collections.buffer;version="3.2.1",org.apache.commons.colle
|
||||
+ ctions.bidimap;version="3.2.1",org.apache.commons.collections.list;ve
|
||||
+ rsion="3.2.1",org.apache.commons.collections.functors;version="3.2.1"
|
||||
+ ,org.apache.commons.collections.collection;version="3.2.1",org.apache
|
||||
+ .commons.collections.set;version="3.2.1"
|
||||
+Tool: Bnd-0.0.238
|
||||
+Bundle-Name: Commons Collections
|
||||
+Bundle-Vendor: The Apache Software Foundation
|
||||
+Bundle-Version: 3.2.1
|
||||
+Bnd-LastModified: 1263002820105
|
||||
+Bundle-ManifestVersion: 2
|
||||
+Bundle-License: http://www.apache.org/licenses/LICENSE-2.0.txt
|
||||
+Bundle-Description: Types that extend and augment the Java Collections
|
||||
+ Framework.
|
||||
+Import-Package: org.apache.commons.collections;version="3.2.1",org.apa
|
||||
+ che.commons.collections.bag;version="3.2.1",org.apache.commons.collec
|
||||
+ tions.bidimap;version="3.2.1",org.apache.commons.collections.buffer;v
|
||||
+ ersion="3.2.1",org.apache.commons.collections.collection;version="3.2
|
||||
+ .1",org.apache.commons.collections.comparators;version="3.2.1",org.ap
|
||||
+ ache.commons.collections.functors;version="3.2.1",org.apache.commons.
|
||||
+ collections.iterators;version="3.2.1",org.apache.commons.collections.
|
||||
+ keyvalue;version="3.2.1",org.apache.commons.collections.list;version=
|
||||
+ "3.2.1",org.apache.commons.collections.map;version="3.2.1",org.apache
|
||||
+ .commons.collections.set;version="3.2.1"
|
||||
+Bundle-SymbolicName: org.apache.commons.collections
|
||||
+Bundle-DocURL: http://commons.apache.org/collections/
|
||||
\ No newline at end of file
|
29
jakarta-commons-collections-3.2.1-build_xml.patch
Normal file
29
jakarta-commons-collections-3.2.1-build_xml.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- commons-collections-3.2.1-src/build.xml 2008-04-11 16:36:25.000000000 +0200
|
||||
+++ commons-collections-3.2.1-src/build.xml-gil 2009-02-28 13:26:20.000000000 +0100
|
||||
@@ -286,7 +286,7 @@
|
||||
<!-- Runs all tests -->
|
||||
<target name="-test-all" depends="compile.tests" unless="testcase">
|
||||
<mkdir dir="${build.test.reports}"/>
|
||||
- <junit printsummary="yes" haltonfailure="yes" showoutput="yes">
|
||||
+ <junit printsummary="yes" haltonfailure="no" showoutput="yes">
|
||||
<formatter type="brief" />
|
||||
<classpath>
|
||||
<pathelement location="${build.classes}"/>
|
||||
@@ -312,7 +312,7 @@
|
||||
|
||||
<!-- Runs a single test -->
|
||||
<target name="-test-single" depends="compile.tests" if="testcase">
|
||||
- <junit printsummary="yes" haltonfailure="yes" showoutput="yes">
|
||||
+ <junit printsummary="yes" haltonfailure="no" showoutput="yes">
|
||||
<formatter type="brief" />
|
||||
<classpath>
|
||||
<pathelement location="${build.classes}"/>
|
||||
@@ -331,7 +331,7 @@
|
||||
<target name="testjar" depends="compile.tests,jar"
|
||||
description="Run all unit test cases">
|
||||
<echo message="Running collections tests against built jar ..."/>
|
||||
- <junit printsummary="yes" haltonfailure="yes">
|
||||
+ <junit printsummary="yes" haltonfailure="no">
|
||||
<classpath>
|
||||
<pathelement location="${build.jar.name}"/>
|
||||
<pathelement location="${build.tests}"/>
|
26
jakarta-commons-collections-3.2.1-javadoc-nonet.patch
Normal file
26
jakarta-commons-collections-3.2.1-javadoc-nonet.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- commons-collections-3.2.1-src/build.xml 2008-04-11 16:36:25.000000000 +0200
|
||||
+++ commons-collections-3.2.1-src/build.xml-gil 2009-02-28 13:12:56.000000000 +0100
|
||||
@@ -85,7 +85,6 @@
|
||||
|
||||
<!-- Javadoc -->
|
||||
<property name="javadoc.access" value="protected"/>
|
||||
- <property name="javadoc.links" value="http://java.sun.com/j2se/1.3/docs/api/"/>
|
||||
|
||||
<!-- JUnit -->
|
||||
<property name="test.failonerror" value="true"/>
|
||||
@@ -361,7 +360,6 @@
|
||||
author="true"
|
||||
version="true"
|
||||
use="true"
|
||||
- link="${javadoc.links}"
|
||||
overview="${source.java}/org/apache/commons/collections/overview.html"
|
||||
doctitle="${component.title} ${component.version} API;"
|
||||
windowtitle="${component.title} ${component.version} API"
|
||||
@@ -456,7 +454,6 @@
|
||||
access="protected"
|
||||
author="false"
|
||||
version="false"
|
||||
- link="${javadoc.links}"
|
||||
overview="${source.test}/org/apache/commons/collections/overview.html"
|
||||
doctitle="${tf.title} ${tf.version} API;"
|
||||
windowtitle="${tf.title} ${tf.version} API"
|
10
jakarta-commons-collections-3.2.1-project_xml.patch
Normal file
10
jakarta-commons-collections-3.2.1-project_xml.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- commons-collections-3.2.1-src/project.xml 2008-04-11 16:36:25.000000000 +0200
|
||||
+++ commons-collections-3.2.1-src/project.xml-gil 2009-02-28 13:15:32.000000000 +0100
|
||||
@@ -455,7 +455,6 @@
|
||||
<nagEmailAddress>dev@commons.apache.org</nagEmailAddress>
|
||||
<sourceDirectory>src/java</sourceDirectory>
|
||||
<unitTestSourceDirectory>src/test</unitTestSourceDirectory>
|
||||
- <integrationUnitTestSourceDirectory/>
|
||||
<aspectSourceDirectory/>
|
||||
<unitTest>
|
||||
<includes>
|
70
jakarta-commons-collections-3.2.1-tomcat5-build.xml
Normal file
70
jakarta-commons-collections-3.2.1-tomcat5-build.xml
Normal file
@ -0,0 +1,70 @@
|
||||
<project name="commons-collections-tomcat5" default="build" basedir=".">
|
||||
|
||||
<property name="tomcat-collections.home" value="collections-tomcat5"/>
|
||||
<property name="commons-collections.home" value="."/>
|
||||
<property name="tomcat-collections.jar" value="commons-collections-tomcat5.jar"/>
|
||||
|
||||
<!-- Java Options -->
|
||||
<property name="compile.debug" value="true"/>
|
||||
<property name="compile.deprecation" value="false"/>
|
||||
<property name="compile.source" value="1.4"/>
|
||||
|
||||
<target name="clean">
|
||||
<delete dir="${tomcat-collections.home}"/>
|
||||
</target>
|
||||
|
||||
<target name="build">
|
||||
<copy todir="${tomcat-collections.home}">
|
||||
<fileset dir="${commons-collections.home}" >
|
||||
<include name="**/collections/CursorableLinkedList.java" />
|
||||
<include name="**/collections/KeyValue.java" />
|
||||
<include name="**/collections/LRUMap.java" />
|
||||
<include name="**/collections/SequencedHashMap.java" />
|
||||
</fileset>
|
||||
<!-- <fileset dir="${commons-pool.home}">
|
||||
<include name="**/*.java" />
|
||||
<exclude name="**/Stack*.java" />
|
||||
<exclude name="**/SoftReferenceObjectPool.java" />
|
||||
<exclude name="**/test/**" />
|
||||
</fileset>
|
||||
<fileset dir="${commons-dbcp.home}">
|
||||
<include name="**/*.java" />
|
||||
<exclude name="**/test/**" />
|
||||
<exclude name="${tomcat-dbcp.home}/**"/>
|
||||
</fileset> -->
|
||||
</copy>
|
||||
<replace dir="${tomcat-collections.home}/src/java/org/apache/commons">
|
||||
<replacefilter token="return UnmodifiableList.decorate(l);"
|
||||
value="return l;" />
|
||||
<replacefilter token="import org.apache.commons.collections.list.UnmodifiableList;"
|
||||
value=" " />
|
||||
</replace>
|
||||
<replace dir="${tomcat-collections.home}/src/java/org/apache/commons" >
|
||||
<replacefilter token="org.apache.commons"
|
||||
value="org.apache.tomcat.dbcp" />
|
||||
</replace>
|
||||
<mkdir dir="${tomcat-collections.home}/src/java/org/apache/tomcat/dbcp" />
|
||||
<move todir="${tomcat-collections.home}/src/java/org/apache/tomcat/dbcp">
|
||||
<fileset dir="${tomcat-collections.home}/src/java/org/apache/commons" />
|
||||
</move>
|
||||
<mkdir dir="${tomcat-collections.home}/classes"/>
|
||||
<javac destdir="${tomcat-collections.home}/classes"
|
||||
optimize="off"
|
||||
debug="${compile.debug}"
|
||||
deprecation="${compile.deprecation}"
|
||||
source="${compile.source}"
|
||||
sourcepath="${tomcat-collections.home}/src/java"
|
||||
srcdir="${tomcat-collections.home}/src/java" >
|
||||
<include name="**" />
|
||||
</javac>
|
||||
<jar destfile="${tomcat-collections.home}/${tomcat-collections.jar}"
|
||||
index="true">
|
||||
<fileset dir="${tomcat-collections.home}/classes">
|
||||
<include name="**/*.class" />
|
||||
<include name="**/*.properties" />
|
||||
</fileset>
|
||||
</jar>
|
||||
</target>
|
||||
|
||||
</project>
|
||||
|
6
jakarta-commons-collections-testframework-3.2.1.pom
Normal file
6
jakarta-commons-collections-testframework-3.2.1.pom
Normal file
@ -0,0 +1,6 @@
|
||||
<project>
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>commons-collections</groupId>
|
||||
<artifactId>commons-collections-testframework</artifactId>
|
||||
<version>3.2.1</version>
|
||||
</project>
|
6
jakarta-commons-collections-tomcat5-3.2.1.pom
Normal file
6
jakarta-commons-collections-tomcat5-3.2.1.pom
Normal file
@ -0,0 +1,6 @@
|
||||
<project>
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>commons-collections</groupId>
|
||||
<artifactId>commons-collections-tomcat5</artifactId>
|
||||
<version>3.2.1</version>
|
||||
</project>
|
303
jakarta-commons-collections.spec
Normal file
303
jakarta-commons-collections.spec
Normal file
@ -0,0 +1,303 @@
|
||||
%define repodir %{_javadir}/repository.jboss.com/apache-collections/%{version}-brew
|
||||
%define repodirlib %{repodir}/lib
|
||||
%define repodirsrc %{repodir}/src
|
||||
%define maven 0
|
||||
%define javahome %{_jvmdir}/jdk
|
||||
Name: jakarta-commons-collections
|
||||
Version: 3.2.1
|
||||
Release: 6mamba
|
||||
Summary: Jakarta Commons Collections Package
|
||||
Group: Development/Libraries/Java
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://jakarta.apache.org/commons/collections
|
||||
Source0: http://www.apache.org/dist/commons/collections/source/commons-collections-%{version}-src.tar.gz
|
||||
Source1: jakarta-commons-collections-3.2.1-build.tar.gz
|
||||
Source2: jakarta-commons-collections-3.2.1-tomcat5-build.xml
|
||||
Source3: java-component-info3.xml
|
||||
Source4: maven2-2.2.0-settings.xml
|
||||
Source5: jakarta-commons-collections-testframework-3.2.1.pom
|
||||
Source6: jakarta-commons-collections-tomcat5-3.2.1.pom
|
||||
Patch0: jakarta-commons-collections-3.2.1-javadoc-nonet.patch
|
||||
Patch1: jakarta-commons-collections-3.2.1-project_xml.patch
|
||||
Patch2: jakarta-commons-collections-3.2.1-build_xml.patch
|
||||
Patch3: jakarta-commons-collections-3.2.1-addosgimanifest.patch
|
||||
License: Apache Software License 2.0
|
||||
BuildRequires: apache-ant
|
||||
BuildRequires: apache-ant-junit
|
||||
%if %maven
|
||||
BuildRequires: apache-maven2
|
||||
BuildRequires: apache-maven2-ant-plugin
|
||||
BuildRequires: apache-maven2-compiler-plugin
|
||||
BuildRequires: apache-maven2-jar-plugin
|
||||
BuildRequires: apache-maven2-javadoc-plugin
|
||||
%endif
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: apache-tomcat5-servletapi5
|
||||
%endif
|
||||
#BuildRequires: java-clirr
|
||||
BuildRequires: java-junit3
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: objectweb-asm
|
||||
BuildRequires: xml-commons-apis
|
||||
Requires: jpackage-utils
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The introduction of the Collections API by Sun in JDK 1.2 has been a boon to quick and effective Java programming. Ready access to powerful data structures has accelerated development by reducing the need for custom container classes around each core object. Most Java2 APIs are significantly easier to use because of the Collections API.
|
||||
However, there are certain holes left unfilled by Sun's implementations, and the Jakarta-Commons Collections Component strives to fulfill them. Among the features of this package are:
|
||||
- special-purpose implementations of Lists and Maps for fast access
|
||||
- adapter classes from Java1-style containers (arrays, enumerations) to Java2-style collections.
|
||||
- methods to test or create typical set-theory properties of collections such as union, intersection, and closure.
|
||||
|
||||
%package testframework
|
||||
Group: Development/Tools
|
||||
Summary: Testframework for %{name}
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description testframework
|
||||
Provides new interfaces, implementations and utilities for Java Collections.
|
||||
|
||||
%package tomcat5
|
||||
Group: Development/Libraries/Java
|
||||
Summary: Jakarta Commons Collection dependency for Tomcat5
|
||||
|
||||
%description tomcat5
|
||||
A package that is specifically designed to fulfill to a Tomcat5 dependency.
|
||||
|
||||
%package javadoc
|
||||
Group: Documentation
|
||||
Summary: Javadoc for %{name}
|
||||
|
||||
%description javadoc
|
||||
Types that extend and augment the Java Collections Framework.
|
||||
|
||||
This package contains javadoc for %{name}
|
||||
|
||||
%package testframework-javadoc
|
||||
Group: Documentation
|
||||
Summary: Javadoc for %{name}-testframework
|
||||
|
||||
%description testframework-javadoc
|
||||
Types that extend and augment the Java Collections Framework.
|
||||
|
||||
This package contains javadoc for %{name}-testframework.
|
||||
|
||||
%package repolib
|
||||
Group: Development/Libraries/Java
|
||||
Summary: Artifacts to be uploaded to a repository library
|
||||
|
||||
%description repolib
|
||||
Types that extend and augment the Java Collections Framework.
|
||||
|
||||
This package contains artifacts to be uploaded to a repository library.
|
||||
This package is not meant to be installed but so its contents
|
||||
can be extracted through rpm2cpio
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -n commons-collections-%{version}-src
|
||||
|
||||
perl -pi -e 's/\r//g' *.txt
|
||||
sed -i 's/\r//' PROPOSAL.html
|
||||
|
||||
%if %maven
|
||||
cp %{SOURCE4} settings.xml
|
||||
|
||||
mkdir -p .m2/repository/JPP/maven2
|
||||
|
||||
sed -i -e "s|<localRepository>__INTERNAL_REPO_PLACEHOLDER__</localRepository>|<localRepository>file://`pwd`/external_repo</localRepository>|g" settings.xml
|
||||
sed -i -e "s|<url>__EXTERNAL_REPO_PLACEHOLDER__</url>|<url>file://`pwd`/.m2/repository</url>|g" settings.xml
|
||||
%else
|
||||
|
||||
gzip -dc %{S:1} | tar xf -
|
||||
|
||||
for j in $(find . -name "*.jar"); do
|
||||
rm -rf $j
|
||||
done
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
# gcj support
|
||||
#% patch2 -p1
|
||||
%patch3
|
||||
cp %{S:2} collections-tomcat5-build.xml
|
||||
%endif
|
||||
|
||||
sed -i 's/\r//' LICENSE.txt
|
||||
sed -i 's/\r//' PROPOSAL.html
|
||||
sed -i 's/\r//' RELEASE-NOTES.html
|
||||
sed -i 's/\r//' README.txt
|
||||
sed -i 's/\r//' NOTICE.txt
|
||||
|
||||
%build
|
||||
export JAVA_HOME=%javahome
|
||||
%if %maven
|
||||
|
||||
export MAVEN_REPO_LOCAL=$PWD/.m2/repository
|
||||
export MAVEN_SETTINGS=$PWD/settings.xml
|
||||
|
||||
mkdir external_repo
|
||||
ln -s %{_javadir} external_repo/JPP
|
||||
|
||||
mvn-jpp \
|
||||
-e \
|
||||
-s $MAVEN_SETTINGS \
|
||||
-Dmaven.test.failure.ignore=true \
|
||||
-Dmaven.repo.local=$MAVEN_REPO_LOCAL \
|
||||
-Dmaven.javadoc.source=1.4 \
|
||||
install javadoc:javadoc
|
||||
%else
|
||||
# See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28423
|
||||
# gcj support
|
||||
# ant -Djava.io.tmpdir=. jar javadoc tf.validate tf.jar dist.bin dist.src tf.javadoc
|
||||
# clirr-core
|
||||
export CLASSPATH=$(build-classpath xml-commons-jaxp-1.3-apis servletapi5)
|
||||
CLASSPATH=$CLASSPATH:$(build-classpath junit-3.8.2 ant/ant-junit objectweb-asm/asm):build/classes
|
||||
ant -Djava.io.tmpdir=. -Dmaven.repo test dist tf.javadoc
|
||||
ant -f collections-tomcat5-build.xml
|
||||
%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
mkdir -p %{buildroot}%{_javadir}
|
||||
mkdir -p %{buildroot}%{_datadir}/maven2/poms
|
||||
|
||||
install -m 644 build/commons-collections-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-%{version}.jar
|
||||
|
||||
install -m 644 pom.xml %{buildroot}%{_datadir}/maven2/poms/JPP-jakarta-commons-collections.pom
|
||||
%add_to_maven_depmap commons-collections commons-collections %{version} JPP commons-collections
|
||||
|
||||
install -m 644 %{SOURCE5} %{buildroot}%{_datadir}/maven2/poms/JPP-jakarta-commons-collections-testframework.pom
|
||||
%add_to_maven_depmap commons-collections commons-collections-testframework %{version} JPP commons-collections-testframework
|
||||
|
||||
install -m 644 build/commons-collections-testframework-%{version}.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-testframework-%{version}.jar
|
||||
|
||||
install -m 644 %{SOURCE6} %{buildroot}%{_datadir}/maven2/poms/JPP-jakarta-commons-collections-tomcat5.pom
|
||||
%add_to_maven_depmap commons-collections commons-collections-tomcat5 %{version} JPP commons-collections-tomcat5
|
||||
|
||||
install -m 644 collections-tomcat5/commons-collections-tomcat5.jar \
|
||||
%{buildroot}%{_javadir}/%{name}-tomcat5-%{version}.jar
|
||||
|
||||
(
|
||||
cd %{buildroot}%{_javadir}
|
||||
for jar in *-%{version}*; do
|
||||
ln -s ${jar} `echo $jar | sed "s|jakarta-||g"`
|
||||
done
|
||||
)
|
||||
(
|
||||
cd %{buildroot}%{_javadir}
|
||||
for jar in *-%{version}*; do
|
||||
ln -s ${jar} `echo $jar | sed "s|-%{version}||g"`
|
||||
done
|
||||
)
|
||||
|
||||
mkdir -p %{buildroot}%{_javadocdir}/commons-collections-%{version}
|
||||
cp -pr build/docs/apidocs/* %{buildroot}%{_javadocdir}/commons-collections-%{version}
|
||||
ln -s commons-collections-%{version} %{buildroot}%{_javadocdir}/commons-collections
|
||||
rm -rf target/docs/apidocs
|
||||
|
||||
mkdir -p %{buildroot}%{_javadocdir}/commons-collections-testframework-%{version}
|
||||
cp -pr build/docs/testframework/* %{buildroot}%{_javadocdir}/commons-collections-testframework-%{version}
|
||||
ln -s commons-collections-testframework-%{version} %{buildroot}%{_javadocdir}/commons-collections-testframework
|
||||
|
||||
mkdir -p %{buildroot}%{repodir}
|
||||
mkdir -p %{buildroot}%{repodirlib}
|
||||
install -m 644 %{SOURCE3} %{buildroot}%{repodir}/component-info.xml
|
||||
tag=`echo %{name}-%{version}-%{release} | sed 's|\.|_|g'`
|
||||
sed -i "s/@NAME@/apache-commons-collections/g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@ID@/apache-collections/g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@TAG@/$tag/g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@VERSION@/%{version}-brew/g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@LICENSE@/%{license}/g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s|@PROJECTHOME@|%{url}|g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@DESCRIPTION@/Jakarta Commons Collections Package: extensions to java.util type of collections/g" \
|
||||
%{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@ARTIFACTID@/commons-codec.jar/g" %{buildroot}%{repodir}/component-info.xml
|
||||
sed -i "s/@INCLUDEINPUT@/commons-codec.jar/g" %{buildroot}%{repodir}/component-info.xml
|
||||
mkdir -p %{buildroot}%{repodirsrc}
|
||||
install -m 644 %{SOURCE0} %{buildroot}%{repodirsrc}
|
||||
install -m 644 %{SOURCE1} %{buildroot}%{repodirsrc}
|
||||
install -m 644 %{SOURCE2} %{buildroot}%{repodirsrc}
|
||||
install -m 644 %{PATCH0} %{buildroot}%{repodirsrc}
|
||||
install -m 644 %{PATCH1} %{buildroot}%{repodirsrc}
|
||||
install -m 644 %{PATCH2} %{buildroot}%{repodirsrc}
|
||||
cp %{buildroot}%{_javadir}/jakarta-commons-collections-%{version}.jar %{buildroot}%{repodirlib}/commons-collections.jar
|
||||
|
||||
# gcj support
|
||||
#%{_bindir}/aot-compile-rpm
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
%update_maven_depmap
|
||||
|
||||
%postun
|
||||
%update_maven_depmap
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_javadir}/commons-collections-%{version}.jar
|
||||
%{_javadir}/commons-collections.jar
|
||||
%{_javadir}/jakarta-commons-collections-%{version}.jar
|
||||
%{_javadir}/jakarta-commons-collections.jar
|
||||
%{_datadir}/maven2/poms/JPP-jakarta-commons-collections.pom
|
||||
%{_mavendepmapfragdir}
|
||||
%doc LICENSE.txt NOTICE.txt
|
||||
%doc PROPOSAL.html README.txt RELEASE-NOTES.html
|
||||
|
||||
%files testframework
|
||||
%defattr(-,root,root)
|
||||
%{_javadir}/commons-collections-testframework-%{version}.jar
|
||||
%{_javadir}/commons-collections-testframework.jar
|
||||
%{_javadir}/jakarta-commons-collections-testframework-%{version}.jar
|
||||
%{_javadir}/jakarta-commons-collections-testframework.jar
|
||||
%{_datadir}/maven2/poms/JPP-jakarta-commons-collections-testframework.pom
|
||||
|
||||
%files tomcat5
|
||||
%defattr(-,root,root)
|
||||
%{_javadir}/commons-collections-tomcat5-%{version}.jar
|
||||
%{_javadir}/commons-collections-tomcat5.jar
|
||||
%{_javadir}/jakarta-commons-collections-tomcat5-%{version}.jar
|
||||
%{_javadir}/jakarta-commons-collections-tomcat5.jar
|
||||
%{_datadir}/maven2/poms/JPP-jakarta-commons-collections-tomcat5.pom
|
||||
%doc LICENSE.txt NOTICE.txt
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root)
|
||||
%{_javadocdir}/commons-collections-%{version}
|
||||
%{_javadocdir}/commons-collections
|
||||
|
||||
%files testframework-javadoc
|
||||
%defattr(-,root,root)
|
||||
%{_javadocdir}/commons-collections-testframework-%{version}
|
||||
%{_javadocdir}/commons-collections-testframework
|
||||
|
||||
%files repolib
|
||||
%defattr(-,root,root)
|
||||
%{repodir}
|
||||
|
||||
%changelog
|
||||
* Thu Mar 24 2011 gil <puntogil@libero.it> 3.2.1-6mamba
|
||||
- rebuilt with java-openjdk support
|
||||
|
||||
* Sat Oct 30 2010 gil <puntogil@libero.it> 3.2.1-5mamba
|
||||
- rebuilt devel
|
||||
|
||||
* Sat Jan 09 2010 gil <puntogil@libero.it> 3.2.1-4mamba
|
||||
- added maven poms
|
||||
- added osgi manifest
|
||||
|
||||
* Tue Oct 20 2009 gil <puntogil@libero.it> 3.2.1-3mamba
|
||||
- added new sub package: repolib
|
||||
|
||||
* Mon Mar 09 2009 gil <puntogil@libero.it> 3.2.1-2mamba
|
||||
- added new sub package: tomcat5
|
||||
|
||||
* Thu Feb 19 2009 gil <puntogil@libero.it> 3.2.1-1mamba
|
||||
- package created by autospec
|
16
java-component-info3.xml
Normal file
16
java-component-info3.xml
Normal file
@ -0,0 +1,16 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<project name="@NAME@">
|
||||
<component id="@ID@"
|
||||
licenseType="@LICENSE@"
|
||||
version="@VERSION@"
|
||||
projectHome="@PROJECTHOME@"
|
||||
description="@DESCRIPTION@"
|
||||
tag="@TAG@"
|
||||
>
|
||||
|
||||
<artifact id="@ARTIFACTID@"/>
|
||||
<export>
|
||||
<include input="@INCLUDEINPUT@"/>
|
||||
</export>
|
||||
</component>
|
||||
</project>
|
245
maven2-2.2.0-settings.xml
Normal file
245
maven2-2.2.0-settings.xml
Normal file
@ -0,0 +1,245 @@
|
||||
<!--
|
||||
Licensed to the Apache Software Foundation (ASF) under one
|
||||
or more contributor license agreements. See the NOTICE file
|
||||
distributed with this work for additional information
|
||||
regarding copyright ownership. The ASF licenses this file
|
||||
to you under the Apache License, Version 2.0 (the
|
||||
"License"); you may not use this file except in compliance
|
||||
with the License. You may obtain a copy of the License at
|
||||
|
||||
http://www.apache.org/licenses/LICENSE-2.0
|
||||
|
||||
Unless required by applicable law or agreed to in writing,
|
||||
software distributed under the License is distributed on an
|
||||
"AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
|
||||
KIND, either express or implied. See the License for the
|
||||
specific language governing permissions and limitations
|
||||
under the License.
|
||||
-->
|
||||
|
||||
<!--
|
||||
| This is the configuration file for Maven. It can be specified at two levels:
|
||||
|
|
||||
| 1. User Level. This settings.xml file provides configuration for a single user,
|
||||
| and is normally provided in $HOME/.m2/settings.xml.
|
||||
|
|
||||
| NOTE: This location can be overridden with the system property:
|
||||
|
|
||||
| -Dorg.apache.maven.user-settings=/path/to/user/settings.xml
|
||||
|
|
||||
| 2. Global Level. This settings.xml file provides configuration for all maven
|
||||
| users on a machine (assuming they're all using the same maven
|
||||
| installation). It's normally provided in
|
||||
| ${maven.home}/conf/settings.xml.
|
||||
|
|
||||
| NOTE: This location can be overridden with the system property:
|
||||
|
|
||||
| -Dorg.apache.maven.global-settings=/path/to/global/settings.xml
|
||||
|
|
||||
| The sections in this sample file are intended to give you a running start at
|
||||
| getting the most out of your Maven installation. Where appropriate, the default
|
||||
| values (values used when the setting is not specified) are provided.
|
||||
|
|
||||
|-->
|
||||
<settings xmlns="http://maven.apache.org/settings/1.0.0"
|
||||
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||
xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
|
||||
<!-- localRepository
|
||||
| The path to the local repository maven will use to store artifacts.
|
||||
|
|
||||
| Default: ~/.m2/repository-->
|
||||
<localRepository>__INTERNAL_REPO_PLACEHOLDER__</localRepository>
|
||||
|
||||
|
||||
|
||||
<!-- interactiveMode
|
||||
| This will determine whether maven prompts you when it needs input. If set to false,
|
||||
| maven will use a sensible default value, perhaps based on some other setting, for
|
||||
| the parameter in question.
|
||||
|
|
||||
| Default: true
|
||||
<interactiveMode>true</interactiveMode>
|
||||
-->
|
||||
|
||||
<!-- offline
|
||||
| Determines whether maven should attempt to connect to the network when executing a build.
|
||||
| This will have an effect on artifact downloads, artifact deployment, and others.
|
||||
|
|
||||
| Default: false
|
||||
<offline>false</offline>
|
||||
-->
|
||||
|
||||
<!-- proxies
|
||||
| This is a list of proxies which can be used on this machine to connect to the network.
|
||||
| Unless otherwise specified (by system property or command-line switch), the first proxy
|
||||
| specification in this list marked as active will be used.
|
||||
|-->
|
||||
<proxies>
|
||||
<!-- proxy
|
||||
| Specification for one proxy, to be used in connecting to the network.
|
||||
|
|
||||
<proxy>
|
||||
<id>optional</id>
|
||||
<active>true</active>
|
||||
<protocol>http</protocol>
|
||||
<username>proxyuser</username>
|
||||
<password>proxypass</password>
|
||||
<host>proxy.host.net</host>
|
||||
<port>80</port>
|
||||
<nonProxyHosts>local.net|some.host.com</nonProxyHosts>
|
||||
</proxy>
|
||||
-->
|
||||
</proxies>
|
||||
|
||||
<!-- servers
|
||||
| This is a list of authentication profiles, keyed by the server-id used within the system.
|
||||
| Authentication profiles can be used whenever maven must make a connection to a remote server.
|
||||
|-->
|
||||
<servers>
|
||||
<!-- server
|
||||
| Specifies the authentication information to use when connecting to a particular server, identified by
|
||||
| a unique name within the system (referred to by the 'id' attribute below).
|
||||
|
|
||||
| NOTE: You should either specify username/password OR privateKey/passphrase, since these pairings are
|
||||
| used together.
|
||||
|
|
||||
<server>
|
||||
<id>deploymentRepo</id>
|
||||
<username>repouser</username>
|
||||
<password>repopwd</password>
|
||||
</server>
|
||||
-->
|
||||
|
||||
<!-- Another sample, using keys to authenticate.
|
||||
<server>
|
||||
<id>siteServer</id>
|
||||
<privateKey>/path/to/private/key</privateKey>
|
||||
<passphrase>optional; leave empty if not used.</passphrase>
|
||||
</server>
|
||||
-->
|
||||
</servers>
|
||||
|
||||
<!-- mirrors
|
||||
| This is a list of mirrors to be used in downloading artifacts from remote repositories.
|
||||
|
|
||||
| It works like this: a POM may declare a repository to use in resolving certain artifacts.
|
||||
| However, this repository may have problems with heavy traffic at times, so people have mirrored
|
||||
| it to several places.
|
||||
|
|
||||
| That repository definition will have a unique id, so we can create a mirror reference for that
|
||||
| repository, to be used as an alternate download site. The mirror site will be the preferred
|
||||
| server for that repository.
|
||||
|-->
|
||||
<mirrors>
|
||||
<!-- mirror
|
||||
| Specifies a repository mirror site to use instead of a given repository. The repository that
|
||||
| this mirror serves has an ID that matches the mirrorOf element of this mirror. IDs are used
|
||||
| for inheritance and direct lookup purposes, and must be unique across the set of mirrors.
|
||||
|
|
||||
-->
|
||||
<mirror>
|
||||
<id>mirrorId</id>
|
||||
<mirrorOf>repositoryId</mirrorOf>
|
||||
<name>Human Readable Name for this Mirror.</name>
|
||||
<url>__EXTERNAL_REPO_PLACEHOLDER__</url>
|
||||
</mirror>
|
||||
|
||||
</mirrors>
|
||||
|
||||
<!-- profiles
|
||||
| This is a list of profiles which can be activated in a variety of ways, and which can modify
|
||||
| the build process. Profiles provided in the settings.xml are intended to provide local machine-
|
||||
| specific paths and repository locations which allow the build to work in the local environment.
|
||||
|
|
||||
| For example, if you have an integration testing plugin - like cactus - that needs to know where
|
||||
| your Tomcat instance is installed, you can provide a variable here such that the variable is
|
||||
| dereferenced during the build process to configure the cactus plugin.
|
||||
|
|
||||
| As noted above, profiles can be activated in a variety of ways. One way - the activeProfiles
|
||||
| section of this document (settings.xml) - will be discussed later. Another way essentially
|
||||
| relies on the detection of a system property, either matching a particular value for the property,
|
||||
| or merely testing its existence. Profiles can also be activated by JDK version prefix, where a
|
||||
| value of '1.4' might activate a profile when the build is executed on a JDK version of '1.4.2_07'.
|
||||
| Finally, the list of active profiles can be specified directly from the command line.
|
||||
|
|
||||
| NOTE: For profiles defined in the settings.xml, you are restricted to specifying only artifact
|
||||
| repositories, plugin repositories, and free-form properties to be used as configuration
|
||||
| variables for plugins in the POM.
|
||||
|
|
||||
|-->
|
||||
<profiles>
|
||||
<!-- profile
|
||||
| Specifies a set of introductions to the build process, to be activated using one or more of the
|
||||
| mechanisms described above. For inheritance purposes, and to activate profiles via <activatedProfiles/>
|
||||
| or the command line, profiles have to have an ID that is unique.
|
||||
|
|
||||
| An encouraged best practice for profile identification is to use a consistent naming convention
|
||||
| for profiles, such as 'env-dev', 'env-test', 'env-production', 'user-jdcasey', 'user-brett', etc.
|
||||
| This will make it more intuitive to understand what the set of introduced profiles is attempting
|
||||
| to accomplish, particularly when you only have a list of profile id's for debug.
|
||||
|
|
||||
| This profile example uses the JDK version to trigger activation, and provides a JDK-specific repo.
|
||||
<profile>
|
||||
<id>jdk-1.4</id>
|
||||
|
||||
<activation>
|
||||
<jdk>1.4</jdk>
|
||||
</activation>
|
||||
|
||||
<repositories>
|
||||
<repository>
|
||||
<id>jdk14</id>
|
||||
<name>Repository for JDK 1.4 builds</name>
|
||||
<url>http://www.myhost.com/maven/jdk14</url>
|
||||
<layout>default</layout>
|
||||
<snapshotPolicy>always</snapshotPolicy>
|
||||
</repository>
|
||||
</repositories>
|
||||
</profile>
|
||||
-->
|
||||
|
||||
<!--
|
||||
| Here is another profile, activated by the system property 'target-env' with a value of 'dev',
|
||||
| which provides a specific path to the Tomcat instance. To use this, your plugin configuration
|
||||
| might hypothetically look like:
|
||||
|
|
||||
| ...
|
||||
| <plugin>
|
||||
| <groupId>org.myco.myplugins</groupId>
|
||||
| <artifactId>myplugin</artifactId>
|
||||
|
|
||||
| <configuration>
|
||||
| <tomcatLocation>${tomcatPath}</tomcatLocation>
|
||||
| </configuration>
|
||||
| </plugin>
|
||||
| ...
|
||||
|
|
||||
| NOTE: If you just wanted to inject this configuration whenever someone set 'target-env' to
|
||||
| anything, you could just leave off the <value/> inside the activation-property.
|
||||
|
|
||||
<profile>
|
||||
<id>env-dev</id>
|
||||
|
||||
<activation>
|
||||
<property>
|
||||
<name>target-env</name>
|
||||
<value>dev</value>
|
||||
</property>
|
||||
</activation>
|
||||
|
||||
<properties>
|
||||
<tomcatPath>/path/to/tomcat/instance</tomcatPath>
|
||||
</properties>
|
||||
</profile>
|
||||
-->
|
||||
</profiles>
|
||||
|
||||
<!-- activeProfiles
|
||||
| List of profiles that are active for all builds.
|
||||
|
|
||||
<activeProfiles>
|
||||
<activeProfile>alwaysActiveProfile</activeProfile>
|
||||
<activeProfile>anotherAlwaysActiveProfile</activeProfile>
|
||||
</activeProfiles>
|
||||
-->
|
||||
</settings>
|
Loading…
Reference in New Issue
Block a user