add wrapper script jackdbus2qjackctl to launch qjackctl via dbus if installed
built with new libopus requirement [release 1.9.9.5-2mamba;Thu Jul 25 2013]
This commit is contained in:
parent
a5b9d1cf8c
commit
8063faef39
@ -1,2 +1,7 @@
|
||||
# jack
|
||||
|
||||
JACK is a low-latency audio server, written for POSIX conformant operating systems such as GNU/Linux and Apple's OS X.
|
||||
It can connect a number of different applications to an audio device, as well as allowing them to share audio between themselves.
|
||||
Its clients can run in their own processes (ie. as normal applications), or can they can run within the JACK server (ie. as a "plugin").
|
||||
JACK was designed from the ground up for professional audio work, and its design focuses on two key areas: synchronous execution of all clients, and low latency operation.
|
||||
|
||||
|
30
jack-1.9.6-libcelt-0.8.1.patch
Normal file
30
jack-1.9.6-libcelt-0.8.1.patch
Normal file
@ -0,0 +1,30 @@
|
||||
diff -rupN jack-1.9.5.old/common/JackNetOneDriver.cpp jack-1.9.5/common/JackNetOneDriver.cpp
|
||||
--- jack-1.9.5.old/common/JackNetOneDriver.cpp 2010-02-12 05:57:48.000000000 -0500
|
||||
+++ jack-1.9.5/common/JackNetOneDriver.cpp 2010-07-20 01:26:44.000000000 -0400
|
||||
@@ -709,9 +709,9 @@ JackNetOneDriver::render_payload_to_jack
|
||||
|
||||
CELTDecoder *decoder = (CELTDecoder *)src_node->data;
|
||||
if( !packet_payload )
|
||||
- celt_decode_float( decoder, NULL, net_period_down, buf );
|
||||
+ celt_decode_float( decoder, NULL, net_period_down, buf, NULL );
|
||||
else
|
||||
- celt_decode_float( decoder, packet_bufX, net_period_down, buf );
|
||||
+ celt_decode_float( decoder, packet_bufX, net_period_down, buf, NULL );
|
||||
|
||||
src_node = jack_slist_next (src_node);
|
||||
}
|
||||
diff -rupN jack-1.9.5.old/common/netjack_packet.c jack-1.9.5/common/netjack_packet.c
|
||||
--- jack-1.9.5.old/common/netjack_packet.c 2010-02-12 05:57:47.000000000 -0500
|
||||
+++ jack-1.9.5/common/netjack_packet.c 2010-07-20 01:12:42.000000000 -0400
|
||||
@@ -1428,9 +1428,9 @@ render_payload_to_jack_ports_celt (void
|
||||
|
||||
CELTDecoder *decoder = src_node->data;
|
||||
if( !packet_payload )
|
||||
- celt_decode_float( decoder, NULL, net_period_down, buf );
|
||||
+ celt_decode_float( decoder, NULL, net_period_down, buf, NULL );
|
||||
else
|
||||
- celt_decode_float( decoder, packet_bufX, net_period_down, buf );
|
||||
+ celt_decode_float( decoder, packet_bufX, net_period_down, buf, NULL );
|
||||
|
||||
src_node = jack_slist_next (src_node);
|
||||
}
|
22
jack-1.9.6-suspend_resume.patch
Normal file
22
jack-1.9.6-suspend_resume.patch
Normal file
@ -0,0 +1,22 @@
|
||||
Index: /jack2/trunk/jackmp/linux/alsa/JackAlsaDriver.cpp
|
||||
===================================================================
|
||||
--- /jack2/trunk/jackmp/linux/alsa/JackAlsaDriver.cpp (revision 4081)
|
||||
+++ /jack2/trunk/jackmp/linux/alsa/JackAlsaDriver.cpp (revision 4088)
|
||||
@@ -1189,4 +1189,17 @@
|
||||
}
|
||||
}
|
||||
+
|
||||
+ if (snd_pcm_status_get_state(status) == SND_PCM_STATE_SUSPENDED) {
|
||||
+ jack_error("**** alsa_pcm: pcm in suspended state, resuming it" );
|
||||
+ if (driver->capture_handle) {
|
||||
+ if ((res = snd_pcm_prepare(driver->capture_handle)) < 0) {
|
||||
+ jack_error("error preparing after suspend: %s", snd_strerror(res));
|
||||
+ }
|
||||
+ } else {
|
||||
+ if ((res = snd_pcm_prepare(driver->playback_handle)) < 0) {
|
||||
+ jack_error("error preparing after suspend: %s", snd_strerror(res));
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
|
||||
if (snd_pcm_status_get_state(status) == SND_PCM_STATE_XRUN
|
12
jack-1.9.7-documentation_build_error.patch
Normal file
12
jack-1.9.7-documentation_build_error.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru jack-1.9.7.orig//wscript jack-1.9.7/wscript
|
||||
--- jack-1.9.7.orig//wscript 2011-07-02 19:10:08.689007485 +0200
|
||||
+++ jack-1.9.7/wscript 2011-07-02 19:10:43.066635582 +0200
|
||||
@@ -316,7 +316,7 @@
|
||||
|
||||
if bld.env['BUILD_DOXYGEN_DOCS'] == True:
|
||||
share_dir = bld.env.get_destdir() + bld.env['PREFIX'] + '/share/jack-audio-connection-kit'
|
||||
- html_docs_source_dir = "build/default/html"
|
||||
+ html_docs_source_dir = "html"
|
||||
html_docs_install_dir = share_dir + '/reference/html/'
|
||||
if Options.commands['install']:
|
||||
if os.path.isdir(html_docs_install_dir):
|
12
jack-1.9.7-trivial_build_fix.patch
Normal file
12
jack-1.9.7-trivial_build_fix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -Nru jack-1.9.7.orig//linux/freebob/JackFreebobDriver.cpp jack-1.9.7/linux/freebob/JackFreebobDriver.cpp
|
||||
--- jack-1.9.7.orig//linux/freebob/JackFreebobDriver.cpp 2011-07-02 19:00:56.240767437 +0200
|
||||
+++ jack-1.9.7/linux/freebob/JackFreebobDriver.cpp 2011-07-02 19:00:00.207375101 +0200
|
||||
@@ -768,7 +768,7 @@
|
||||
}
|
||||
port = fGraphManager->GetPort(port_index);
|
||||
// Add one buffer more latency if "async" mode is used...
|
||||
- range.min = range.max = (driver->period_size * (driver->device_options.nb_buffers - 1)) + ((fEngineControl->fSyncMode) ? 0 : fEngineControl->fBufferSize) + driver->playback_frame_latency);
|
||||
+ range.min = range.max = (driver->period_size * (driver->device_options.nb_buffers - 1)) + ((fEngineControl->fSyncMode) ? 0 : fEngineControl->fBufferSize) + driver->playback_frame_latency;
|
||||
port->SetLatencyRange(JackPlaybackLatency, &range);
|
||||
fPlaybackPortList[i] = port_index;
|
||||
jack_log("JackFreebobDriver::Attach fPlaybackPortList[i] %ld ", port_index);
|
61
jack-1.9.8-signal-device-error-via-dbus.patch
Normal file
61
jack-1.9.8-signal-device-error-via-dbus.patch
Normal file
@ -0,0 +1,61 @@
|
||||
From 983421cbdc41dd5b2006155c4108d042df15bc57 Mon Sep 17 00:00:00 2001
|
||||
From: Robin Gareus <robin@gareus.org>
|
||||
Date: Sun, 20 Feb 2011 14:50:06 +0100
|
||||
Subject: [PATCH 3/3] signal device-error via dbus
|
||||
|
||||
* qNd: send org.jackaudio.JackControl.DeviceError
|
||||
on audio-device-disconnect/error
|
||||
---
|
||||
common/JackAudioDriver.cpp | 13 ++++++++++++-
|
||||
dbus/controller_iface_control.c | 4 ++++
|
||||
2 files changed, 16 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/common/JackAudioDriver.cpp b/common/JackAudioDriver.cpp
|
||||
index 9748b46..783ce98 100644
|
||||
--- a/common/JackAudioDriver.cpp
|
||||
+++ b/common/JackAudioDriver.cpp
|
||||
@@ -203,7 +203,18 @@ int JackAudioDriver::ProcessNull()
|
||||
|
||||
int JackAudioDriver::Process()
|
||||
{
|
||||
- return (fEngineControl->fSyncMode) ? ProcessSync() : ProcessAsync();
|
||||
+ int rv = (fEngineControl->fSyncMode) ? ProcessSync() : ProcessAsync();
|
||||
+ if (rv) {
|
||||
+#if defined(JACK_DBUS)
|
||||
+ jack_error("Process returned %i -> send dbus signal\n", rv);
|
||||
+ /* send dbus notification
|
||||
+ * note: this is a realtime-thread in libjackserver
|
||||
+ * TODO: Notify jackdbus to send the message.
|
||||
+ */
|
||||
+ system("dbus-send --session /org/jackaudio/Controller org.jackaudio.JackControl.DeviceError"); // XXX quick'n'dirty
|
||||
+#endif
|
||||
+ }
|
||||
+ return rv;
|
||||
}
|
||||
|
||||
/*
|
||||
diff --git a/dbus/controller_iface_control.c b/dbus/controller_iface_control.c
|
||||
index 22cd398..66fb801 100644
|
||||
--- a/dbus/controller_iface_control.c
|
||||
+++ b/dbus/controller_iface_control.c
|
||||
@@ -395,6 +395,9 @@ JACK_DBUS_METHODS_BEGIN
|
||||
JACK_DBUS_METHOD_DESCRIBE(RemoveSlave, NULL)
|
||||
JACK_DBUS_METHODS_END
|
||||
|
||||
+JACK_DBUS_SIGNAL_ARGUMENTS_BEGIN(DeviceError)
|
||||
+JACK_DBUS_SIGNAL_ARGUMENTS_END
|
||||
+
|
||||
JACK_DBUS_SIGNAL_ARGUMENTS_BEGIN(ServerStarted)
|
||||
JACK_DBUS_SIGNAL_ARGUMENTS_END
|
||||
|
||||
@@ -402,6 +405,7 @@ JACK_DBUS_SIGNAL_ARGUMENTS_BEGIN(ServerStopped)
|
||||
JACK_DBUS_SIGNAL_ARGUMENTS_END
|
||||
|
||||
JACK_DBUS_SIGNALS_BEGIN
|
||||
+ JACK_DBUS_SIGNAL_DESCRIBE(DeviceError)
|
||||
JACK_DBUS_SIGNAL_DESCRIBE(ServerStarted)
|
||||
JACK_DBUS_SIGNAL_DESCRIBE(ServerStopped)
|
||||
JACK_DBUS_SIGNALS_END
|
||||
--
|
||||
1.7.2.3
|
||||
|
38
jack-1.9.9.5-doxygen.patch
Normal file
38
jack-1.9.9.5-doxygen.patch
Normal file
@ -0,0 +1,38 @@
|
||||
diff -Nru jack-1.9.9.5.orig/wscript jack-1.9.9.5/wscript
|
||||
--- jack-1.9.9.5.orig/wscript 2013-06-19 03:47:29.667724339 +0200
|
||||
+++ jack-1.9.9.5/wscript 2013-06-19 03:50:31.364005330 +0200
|
||||
@@ -356,10 +356,10 @@
|
||||
bld.add_subdirs('dbus')
|
||||
|
||||
if bld.env['BUILD_DOXYGEN_DOCS'] == True:
|
||||
- share_dir = bld.env.get_destdir() + bld.env['PREFIX'] + '/share/jack-audio-connection-kit'
|
||||
html_docs_source_dir = "html"
|
||||
- html_docs_install_dir = share_dir + '/reference/html/'
|
||||
- if Options.commands['install']:
|
||||
+ if bld.cmd == 'install':
|
||||
+ share_dir = bld.options.destdir + bld.env['PREFIX'] + '/share/jack-audio-connection-kit'
|
||||
+ html_docs_install_dir = share_dir + '/reference/html/'
|
||||
if os.path.isdir(html_docs_install_dir):
|
||||
Logs.pprint('CYAN', "Removing old doxygen documentation installation...")
|
||||
shutil.rmtree(html_docs_install_dir)
|
||||
@@ -367,17 +367,17 @@
|
||||
Logs.pprint('CYAN', "Installing doxygen documentation...")
|
||||
shutil.copytree(html_docs_source_dir, html_docs_install_dir)
|
||||
Logs.pprint('CYAN', "Installing doxygen documentation done.")
|
||||
- elif Options.commands['uninstall']:
|
||||
+ elif bld.cmd =='uninstall':
|
||||
Logs.pprint('CYAN', "Uninstalling doxygen documentation...")
|
||||
if os.path.isdir(share_dir):
|
||||
shutil.rmtree(share_dir)
|
||||
Logs.pprint('CYAN', "Uninstalling doxygen documentation done.")
|
||||
- elif Options.commands['clean']:
|
||||
+ elif bld.cmd =='clean':
|
||||
if os.access(html_docs_source_dir, os.R_OK):
|
||||
Logs.pprint('CYAN', "Removing doxygen generated documentation...")
|
||||
shutil.rmtree(html_docs_source_dir)
|
||||
Logs.pprint('CYAN', "Removing doxygen generated documentation done.")
|
||||
- elif Options.commands['build']:
|
||||
+ elif bld.cmd =='build':
|
||||
if not os.access(html_docs_source_dir, os.R_OK):
|
||||
os.popen("doxygen").read()
|
||||
else:
|
8
jack-1.9.9.5-jackdbus2qjackctl.patch
Normal file
8
jack-1.9.9.5-jackdbus2qjackctl.patch
Normal file
@ -0,0 +1,8 @@
|
||||
diff -Nru jack-1.9.9.5.orig/dbus/org.jackaudio.service.in jack-1.9.9.5/dbus/org.jackaudio.service.in
|
||||
--- jack-1.9.9.5.orig/dbus/org.jackaudio.service.in 2012-12-10 10:26:56.000000000 +0100
|
||||
+++ jack-1.9.9.5/dbus/org.jackaudio.service.in 2013-07-25 14:30:49.747453071 +0200
|
||||
@@ -1,3 +1,3 @@
|
||||
[D-BUS Service]
|
||||
Name=org.jackaudio.service
|
||||
-Exec=@BINDIR@/jackdbus auto
|
||||
+Exec=@BINDIR@/jackdbus2qjackctl
|
26
jack-asound.conf
Normal file
26
jack-asound.conf
Normal file
@ -0,0 +1,26 @@
|
||||
pcm.!default {
|
||||
type plug
|
||||
slave { pcm "jack" }
|
||||
hint {
|
||||
show on
|
||||
description "System default (recommended)"
|
||||
}
|
||||
|
||||
}
|
||||
|
||||
pcm.jack {
|
||||
type jack
|
||||
playback_ports {
|
||||
0 system:playback_1
|
||||
1 system:playback_2
|
||||
}
|
||||
capture_ports {
|
||||
0 system:capture_1
|
||||
1 system:capture_2
|
||||
}
|
||||
}
|
||||
|
||||
ctl.mixer0 {
|
||||
type hw
|
||||
card 0
|
||||
}
|
371
jack.spec
Normal file
371
jack.spec
Normal file
@ -0,0 +1,371 @@
|
||||
### AUTOUPDATE-OFF: 8
|
||||
Name: jack
|
||||
Epoch: 1
|
||||
Version: 1.9.9.5
|
||||
Release: 2mamba
|
||||
Summary: A low-latency audio server that can connect a number of different applications to an audio device
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://jackaudio.org
|
||||
Source: http://jackaudio.org/downloads/jack-%{version}.tar.bz2
|
||||
Source1: %{name}-asound.conf
|
||||
Source2: jackdbus2qjackctl
|
||||
Patch0: %{name}-1.9.6-suspend_resume.patch
|
||||
Patch1: %{name}-1.9.6-libcelt-0.8.1.patch
|
||||
Patch2: %{name}-1.9.7-trivial_build_fix.patch
|
||||
Patch3: %{name}-1.9.7-documentation_build_error.patch
|
||||
Patch4: %{name}-1.9.8-signal-device-error-via-dbus.patch
|
||||
Patch5: jack-1.9.9.5-doxygen.patch
|
||||
Patch6: jack-1.9.9.5-jackdbus2qjackctl.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libcelt-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffado-devel
|
||||
BuildRequires: libfreebob-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libopus-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libsamplerate-devel
|
||||
BuildRequires: libsndfile-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: ffado
|
||||
BuildRequires: pkg-config
|
||||
BuildRequires: libcap-devel >= 1.10
|
||||
BuildRequires: libflac-devel >= 1.1.2
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: libopus-devel >= 1.0.3-2mamba
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||
Requires: libjack == %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: ffado
|
||||
Obsoletes: oss2jack
|
||||
Requires: libalsa-plugins
|
||||
|
||||
%description
|
||||
JACK is a low-latency audio server, written for POSIX conformant operating systems such as GNU/Linux and Apple's OS X.
|
||||
It can connect a number of different applications to an audio device, as well as allowing them to share audio between themselves.
|
||||
Its clients can run in their own processes (ie. as normal applications), or can they can run within the JACK server (ie. as a "plugin").
|
||||
JACK was designed from the ground up for professional audio work, and its design focuses on two key areas: synchronous execution of all clients, and low latency operation.
|
||||
|
||||
%package -n libjack
|
||||
Group: System/Tools
|
||||
Summary: Jack audio connection kit tools
|
||||
|
||||
%description -n libjack
|
||||
JACK is a low-latency audio server, written for POSIX conformant operating systems such as GNU/Linux and Apple's OS X.
|
||||
It can connect a number of different applications to an audio device, as well as allowing them to share audio between themselves.
|
||||
Its clients can run in their own processes (ie. as normal applications), or can they can run within the JACK server (ie. as a "plugin").
|
||||
JACK was designed from the ground up for professional audio work, and its design focuses on two key areas: synchronous execution of all clients, and low latency operation.
|
||||
|
||||
%package -n libjack-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for %{name}
|
||||
Requires: libjack == %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libjack-devel
|
||||
JACK is a low-latency audio server, written for POSIX conformant operating systems such as GNU/Linux and Apple's OS X.
|
||||
It can connect a number of different applications to an audio device, as well as allowing them to share audio between themselves.
|
||||
Its clients can run in their own processes (ie. as normal applications), or can they can run within the JACK server (ie. as a "plugin").
|
||||
JACK was designed from the ground up for professional audio work, and its design focuses on two key areas: synchronous execution of all clients, and low latency operation.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p4
|
||||
#%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%patch6 -p1
|
||||
|
||||
for file in ChangeLog README TODO; do
|
||||
sed 's|\r||' $file > $file.tmp
|
||||
iconv -f ISO-8859-1 -t UTF8 $file.tmp > $file.tmp2
|
||||
touch -r $file $file.tmp2
|
||||
mv -f $file.tmp2 $file
|
||||
done
|
||||
|
||||
%build
|
||||
LINKFLAGS="-lncurses" \
|
||||
./waf configure \
|
||||
--prefix=%{_prefix} \
|
||||
--libdir=%{_libdir} \
|
||||
--alsa \
|
||||
--dbus \
|
||||
--doxygen \
|
||||
--firewire \
|
||||
--freebob
|
||||
|
||||
./waf %{?_smp_mflags} build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
./waf install --destdir=%{buildroot}
|
||||
|
||||
chmod 755 %{buildroot}%{_libdir}/jack/*.so %{buildroot}%{_libdir}/libjack*.so.*.*.*
|
||||
|
||||
mv %{buildroot}%{_datadir}/jack-audio-connection-kit/reference .
|
||||
|
||||
install -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/asound.conf.jack
|
||||
install -D -m0755 %{SOURCE2} %{buildroot}%{_bindir}/jackdbus2qjackctl
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
/usr/sbin/alternatives --install \
|
||||
%{_sysconfdir}/asound.conf asound.conf %{_sysconfdir}/asound.conf.jack 10
|
||||
exit 0
|
||||
|
||||
%preun
|
||||
/sbin/ldconfig
|
||||
# erase
|
||||
if [ $1 -eq 0 ]; then
|
||||
/usr/sbin/update-alternatives --remove asound.conf %{_sysconfdir}/asound.conf.jack
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%posttrans
|
||||
/usr/sbin/alternatives --install \
|
||||
%{_sysconfdir}/asound.conf asound.conf %{_sysconfdir}/asound.conf.jack 10
|
||||
exit 0
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config %{_sysconfdir}/asound.conf.jack
|
||||
%{_bindir}/alsa_in
|
||||
%{_bindir}/alsa_out
|
||||
%{_bindir}/jack_*
|
||||
%{_bindir}/jackdbus
|
||||
%{_bindir}/jackdbus2qjackctl
|
||||
%{_datadir}/dbus-1/services/org.jackaudio.service
|
||||
%{_mandir}/man1/alsa_in.1.gz
|
||||
%{_mandir}/man1/alsa_out.1.gz
|
||||
%{_mandir}/man1/jackd.1.gz
|
||||
%{_mandir}/man1/jackrec.1.gz
|
||||
%{_mandir}/man1/jack_*.1.gz
|
||||
|
||||
%files -n libjack
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libjack.so.*
|
||||
%{_libdir}/libjacknet.so.*
|
||||
%{_libdir}/libjackserver.so.*
|
||||
%dir %{_libdir}/jack
|
||||
%{_libdir}/jack/*.so
|
||||
|
||||
%files -n libjack-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/jack
|
||||
%{_includedir}/jack/*.h
|
||||
%{_libdir}/libjack.so
|
||||
%{_libdir}/libjacknet.so
|
||||
%{_libdir}/libjackserver.so
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc reference/*
|
||||
%doc README TODO ChangeLog
|
||||
|
||||
%changelog
|
||||
* Thu Jul 25 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.9.5-2mamba
|
||||
- add wrapper script jackdbus2qjackctl to launch qjackctl via dbus if installed
|
||||
- built with new libopus requirement
|
||||
|
||||
* Thu Jun 20 2013 Automatic Build System <autodist@mambasoft.it> 1.9.9.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Oct 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.8-3mamba
|
||||
- added requirement for ffado
|
||||
|
||||
* Tue Oct 16 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.8-2mamba
|
||||
- move documentation to -devel package
|
||||
|
||||
* Wed Jun 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.8-1mamba
|
||||
- update to 1.9.8
|
||||
|
||||
* Sat Jul 02 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.7-1mamba
|
||||
- update to 1.9.7
|
||||
- asound.conf.jack: replace alsa_pcm: with system: and 'card 0' with 'card 1' in ctl.mixer0
|
||||
|
||||
* Sat Mar 26 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.6-6mamba
|
||||
- removed requirement for alsaplayer-output-jack
|
||||
|
||||
* Thu Mar 24 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.6-5mamba
|
||||
- added asound.conf for jack as an alternative
|
||||
|
||||
* Tue Dec 14 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.6-4mamba
|
||||
- merge from devel-gil
|
||||
- rebuilt with system libfreebob & new libcelt
|
||||
- build documentation
|
||||
|
||||
* Mon Dec 13 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.6-3mamba
|
||||
- added upstream patch to fix resume after suspend (http://trac.jackaudio.org/changeset/4088)
|
||||
|
||||
* Sun Dec 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.6-2mamba
|
||||
- fixed libreadline detection
|
||||
|
||||
* Sat Dec 11 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.9.6-1mamba
|
||||
- update to 1.9.6
|
||||
|
||||
* Sun Dec 27 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.118.0-1mamba
|
||||
- update to 0.118.0
|
||||
- obsolete oss2jack
|
||||
|
||||
* Sun Jan 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.116.1-4mamba
|
||||
- enable and disable entries moved to openmamba menu to prevent confusion with qjackctl
|
||||
|
||||
* Tue Dec 30 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.116.1-3mamba
|
||||
- reset to default sysconfig configuration to disable server startup
|
||||
|
||||
* Mon Dec 22 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.116.1-2mamba
|
||||
- sysconfig/sound: disable startup by default
|
||||
- asound.conf: remove from this package; it is now provided by alsa-utils
|
||||
|
||||
* Sun Dec 21 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.116.1-1mamba
|
||||
- update to 0.116.1
|
||||
- jackstart.user: removed -m -u and other minor confiuration changes
|
||||
- asound.conf: rewritten for use of alsa redirection to jack
|
||||
- sysconfig/sound: disabled oss2jack by default
|
||||
|
||||
* Sun Oct 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.109.2-5mamba
|
||||
- added xprofile startup script
|
||||
|
||||
* Thu Sep 18 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.109.2-4mamba
|
||||
- added support for promiscuous mode by adding a initscript
|
||||
- added support to 2.6.25+ kernels (enable realtime for root in promiscuous mode)
|
||||
|
||||
* Wed Sep 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.109.2-3mamba
|
||||
- resynced with version 0.103.0
|
||||
|
||||
* Tue Feb 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.109.2-2mamba
|
||||
- jackstart.user: wait for alsaplayer processes before starting
|
||||
|
||||
* Tue Feb 12 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.109.2-2mamba
|
||||
- added patch to libjack that fixes an infinite loop
|
||||
|
||||
* Sun Feb 10 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.109.2-1mamba
|
||||
- update to 0.109.2
|
||||
|
||||
* Wed Nov 14 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-8mamba
|
||||
- asound.conf: disable by default use of jack slave (problematic on some hardware)
|
||||
|
||||
* Wed Nov 07 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-7mamba
|
||||
- added requirement for libalsa-plugins
|
||||
|
||||
* Wed Nov 07 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-6mamba
|
||||
- asound.conf: enable default use of jack slave
|
||||
|
||||
* Thu Oct 25 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-5mamba
|
||||
- added default asound.conf for ALSA <-> jack plug
|
||||
|
||||
* Sat Sep 15 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-4mamba
|
||||
- set server to 44,1khz by default
|
||||
|
||||
* Sat Jul 21 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-3mamba
|
||||
- removed enable-capabilities causing excessive CPU load when using audacity with jack via portaudio
|
||||
|
||||
* Thu May 31 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-2mamba
|
||||
- added jack-enable and jack-disable desktop menu entries
|
||||
|
||||
* Sun May 13 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.103.0-1mamba
|
||||
- update to 0.103.0
|
||||
- jackstart.user: create kde directory and files to disable arts if not existing
|
||||
|
||||
* Sat Mar 10 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.102.20-6qilnx
|
||||
- removed jackplayer; added requirement for alsaplayer-output-jack
|
||||
|
||||
* Sat Feb 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.102.20-5qilnx
|
||||
- change userdir name to avoid a conflict with register files
|
||||
|
||||
* Tue Jan 30 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.102.20-4qilnx
|
||||
- rebuilt
|
||||
|
||||
* Thu Jan 04 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.102.20-3qilnx
|
||||
- jackstart.user: launch jackd with -S switch to enable 16-bit samples
|
||||
|
||||
* Wed Oct 11 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.102.20-2qilnx
|
||||
- add more options in /etc/sysconfig/sound
|
||||
- re-enable tmp dir on /dev/shm
|
||||
|
||||
* Mon Oct 09 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.102.20-1qilnx
|
||||
- update to version 0.102.20 by autospec
|
||||
|
||||
* Fri Oct 06 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-7qilnx
|
||||
- add default tmp dir and set it to /dev/shm
|
||||
|
||||
* Wed Oct 04 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-6qilnx
|
||||
- rebuild disabling mmx, altivec and other platform specific options
|
||||
- jackstart.user: use schedtool to launch oss2jack
|
||||
|
||||
* Sat Jul 08 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-5qilnx
|
||||
- added --enable-preemption-check configure option
|
||||
- removed --enable-sse and --enable-mmx configure options
|
||||
|
||||
* Sun May 21 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-4qilnx
|
||||
- add build requirement for alsa
|
||||
|
||||
* Sat May 20 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-3qilnx
|
||||
- jackstart.user: fixed an error when setting NPERIODS value
|
||||
- sysconfig/sound: set PERIOD=512 and NPERIODS=4 as default
|
||||
- jack-configure: this devices in order
|
||||
|
||||
* Tue May 16 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-2qilnx
|
||||
- use a more conservative default NPERIODS value (was 256, use default [1024])
|
||||
|
||||
* Tue Apr 11 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.101.1-1qilnx
|
||||
- update to version 0.101.1 by autospec
|
||||
- jack-configure fix: install with execution permission
|
||||
|
||||
* Thu Mar 09 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.9-5qilnx
|
||||
- add more configuration variables in /etc/sysconfig/sound
|
||||
- start arts by default with realtime and network transparency support
|
||||
|
||||
* Thu Feb 23 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.9-4qilnx
|
||||
- fixed permission on script jack-configure
|
||||
|
||||
* Thu Feb 23 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.9-2qilnx
|
||||
- added configuration script jack-configure
|
||||
|
||||
* Wed Jan 04 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.9-1qilnx
|
||||
- update to version 0.100.9 by autospec
|
||||
|
||||
* Thu Dec 14 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-7qilnx
|
||||
- jackstart.user: start jack leaving memory unlocked
|
||||
- jackstart.user: add support for timidity
|
||||
- disable oss support
|
||||
|
||||
* Wed Dec 14 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-6qilnx
|
||||
- jackstart.user: another syntax fix
|
||||
|
||||
* Wed Nov 07 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-5qilnx
|
||||
- jackstart.user: fix a syntax error
|
||||
- jackstart.user: check jackd startup watching /dev/shm/jack-0
|
||||
|
||||
* Tue Nov 06 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-4qilnx
|
||||
- jackstart.user: add support for user arts configuration
|
||||
|
||||
* Mon Nov 05 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-3qilnx
|
||||
- apply a fix to jackstart.user because jackd starts asynchronously
|
||||
|
||||
* Mon Nov 05 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-2qilnx
|
||||
- added user oriented start and stop script with oss2jack support
|
||||
- mmx and sse support enabled again
|
||||
|
||||
* Wed Oct 26 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.100.0-1qilnx
|
||||
- update to version 0.100.0 by autospec
|
||||
|
||||
* Sun Feb 20 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.0-2qilnx
|
||||
|
||||
* Thu Jan 27 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.99.0-2qilnx
|
||||
- added missing build requirement
|
||||
- some fixes in HTML documentation
|
||||
|
||||
* Wed Oct 13 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.0-1qilnx
|
||||
- package created by autospec
|
10
jackdbus2qjackctl
Normal file
10
jackdbus2qjackctl
Normal file
@ -0,0 +1,10 @@
|
||||
#!/bin/sh
|
||||
QJACKCTLPID=`pidof qjackctl`
|
||||
|
||||
if [ "$QJACKCTLPID" -o ! -e /usr/bin/qjackctl ]; then
|
||||
/usr/bin/jackdbus auto &
|
||||
exit 0
|
||||
else
|
||||
/usr/bin/qjackctl -s &
|
||||
exit 1
|
||||
fi
|
Loading…
Reference in New Issue
Block a user