67 lines
2.7 KiB
Diff
67 lines
2.7 KiB
Diff
diff -Nru isdn4k-utils-CVS-2007-11-27/imontty/Makefile isdn4k-utils-CVS-2007-11-27.patched/imontty/Makefile
|
|
--- isdn4k-utils-CVS-2007-11-27/imontty/Makefile 2006-01-15 16:08:55.000000000 +0100
|
|
+++ isdn4k-utils-CVS-2007-11-27.patched/imontty/Makefile 2009-05-26 20:14:35.000000000 +0200
|
|
@@ -52,10 +52,10 @@
|
|
mkdir -p $(DESTDIR)$(MAN8DIR)
|
|
$(INSTALL_MAN) $< $(DESTDIR)$(MAN8DIR)/$(MANPAGE)
|
|
|
|
-install: $(PROGS) rootperm install-man
|
|
+install: $(PROGS) install-man
|
|
install -s -o 0 -g 0 -m 0755 $(PROGS) $(DESTDIR)$(CONFIG_SBINDIR)
|
|
|
|
-uninstall: rootperm
|
|
+uninstall:
|
|
for i in $(PROGS) ; do rm -f $(DESTDIR)$(CONFIG_SBINDIR)/$$i; done
|
|
|
|
clean:
|
|
diff -Nru isdn4k-utils-CVS-2007-11-27/isdnlog/Makefile.in isdn4k-utils-CVS-2007-11-27.patched/isdnlog/Makefile.in
|
|
--- isdn4k-utils-CVS-2007-11-27/isdnlog/Makefile.in 2007-01-05 05:23:57.000000000 +0100
|
|
+++ isdn4k-utils-CVS-2007-11-27.patched/isdnlog/Makefile.in 2009-05-26 20:06:38.000000000 +0200
|
|
@@ -2058,7 +2058,7 @@
|
|
$(DESTDIR)$(DATADIR)/dest.cdb
|
|
|
|
|
|
-installdirs: rootperm
|
|
+installdirs:
|
|
$(INSTALL_DIR) $(DESTDIR)$(I4LCONFDIR)
|
|
$(INSTALL_DIR) $(DESTDIR)$(BINDIR)
|
|
$(INSTALL_DIR) $(DESTDIR)$(SBINDIR)
|
|
@@ -2067,7 +2067,7 @@
|
|
$(INSTALL_DIR) $(DESTDIR)$(MAN8DIR)
|
|
$(INSTALL_DIR) $(DESTDIR)$(DATADIR)
|
|
|
|
-install: all rootperm installdirs install-conf install-data install-progs
|
|
+install: all installdirs install-conf install-data install-progs
|
|
|
|
install-old-conf:
|
|
@if [ -n "$(DESTDIR)$(OLDCONFDIR)" -a "$(DESTDIR)$(OLDCONFDIR)" != '/' ] ; then \
|
|
@@ -2150,9 +2150,6 @@
|
|
$(INSTALL_DATA) $$f $(DESTDIR)$(DATADIR); \
|
|
echo Installing $(DESTDIR)$(DATADIR)/$$f; \
|
|
done
|
|
- @(grep isdnlog $(SERVICEFILE) >/dev/null) || \
|
|
- (echo "";echo "";echo "Add a line to the file $(SERVICEFILE)" ;echo "";echo ""; \
|
|
- echo "isdnlog $(SERV_PORT)/tcp isdnlog" >> $(SERVICEFILE))
|
|
|
|
install-strip:
|
|
$(MAKE) INSTALL_BIN='$(INSTALL_BIN) -s' \
|
|
diff -Nru isdn4k-utils-CVS-2007-11-27/Makefile isdn4k-utils-CVS-2007-11-27.patched/Makefile
|
|
--- isdn4k-utils-CVS-2007-11-27/Makefile 2007-11-26 14:13:44.000000000 +0100
|
|
+++ isdn4k-utils-CVS-2007-11-27.patched/Makefile 2009-05-26 20:00:36.000000000 +0200
|
|
@@ -130,14 +130,8 @@
|
|
exit 1; \
|
|
fi
|
|
|
|
-install: rootperm
|
|
+install:
|
|
set -e; for i in `echo $(SUBDIRS)`; do $(MAKE) -C $$i install; done
|
|
- @if [ -c $(DESTDIR)/dev/isdnctrl0 ] && ls -l $(DESTDIR)/dev/isdnctrl0 | egrep "[[:space:]]45,[[:space:]]+64[[:space:]]" > /dev/null; \
|
|
- then \
|
|
- /bin/echo -e '(some) ISDN devices already exist, not creating them.\nUse scripts/makedev.sh manually if necessary.'; \
|
|
- else \
|
|
- sh scripts/makedev.sh $(DESTDIR) ; \
|
|
- fi
|
|
|
|
uninstall: rootperm
|
|
set -e; for i in `echo $(SUBDIRS)`; do $(MAKE) -C $$i uninstall; done
|