update to 3.27 [release 3.27-1mamba;Mon Dec 29 2014]

This commit is contained in:
Silvan Calarco 2024-01-05 23:58:52 +01:00
parent e16012fb56
commit 6124654ea0
4 changed files with 61 additions and 2 deletions

View File

@ -0,0 +1,18 @@
Description: fix build failure with GCC5:
build isdnlog with -fgnu89-inline
Origin: vendor
Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=777920
Author: gregor herrmann <gregoa@debian.org>
Last-Update: 2015-07-20
--- a/isdnlog/Makefile.in
+++ b/isdnlog/Makefile.in
@@ -1719,7 +1719,7 @@
# export CFLAGS = -Wall -pipe -O6 -fomit-frame-pointer -fforce-mem -fforce-addr -funroll-loops -fstrength-reduce
-export CFLAGS = -Wall -pipe
+export CFLAGS = -Wall -pipe -fgnu89-inline
ifndef _CC
export _CC = gcc
endif

View File

@ -0,0 +1,21 @@
diff -u -r -N isdn4k-utils-3.25_20130409.orig/ipppd/main.c isdn4k-utils-3.25_20130409/ipppd/main.c
--- isdn4k-utils-3.25_20130409.orig/ipppd/main.c 2013-01-05 14:59:12.000000000 +0100
+++ isdn4k-utils-3.25_20130409/ipppd/main.c 2014-09-21 13:36:09.104294210 +0200
@@ -1205,7 +1205,7 @@
unsigned long val=0;
char *str, *f, *buf0;
unsigned char *p;
- va_list a;
+ void *a;
char num[32];
time_t t;
static char hexchars[] = "0123456789abcdef";
@@ -1297,7 +1297,7 @@
break;
case 'r':
f = va_arg(args, char *);
- a = va_arg(args, va_list);
+ a = va_arg(args, void *);
#ifdef __alpha__ /* always do this? */
n = fmtmsg(buf, buflen + 1, f, a);
#else

View File

@ -0,0 +1,11 @@
--- isdn4k-utils-3.27/vbox/src/script.c.orig 2016-04-07 21:18:19.739200807 +0200
+++ isdn4k-utils-3.27/vbox/src/script.c 2016-04-07 21:17:28.845252962 +0200
@@ -19,6 +19,8 @@
#include <stdio.h>
#include <stdlib.h>
+#define USE_INTERP_RESULT 1
+#define USE_INTERP_ERRORLINE 1
#include <tcl.h>
#include <unistd.h>
#include <string.h>

View File

@ -1,6 +1,6 @@
%define pkgver %(echo %version | cut -d. -f3-5 | tr . -)
Name: isdn4k-utils
Version: 3.25_20130409
Version: 3.27
Release: 1mamba
Summary: Bundled Utilities for configuring an using ISDN4Linux
Group: Applications/Networking
@ -8,10 +8,13 @@ Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.isdn4linux.de/
Source: http://archlinux.c3sl.ufpr.br/other/isdn4k-utils/isdn4k-utils-%{version}.tar.gz
Source: git://git.misdn.eu/isdn4k-utils.git/v%{version}/isdn4k-utils-%{version}.tar.bz2
Source1: isdn4k-utils-config
Patch0: %{name}-3.0.2007.11.27-install.patch
Patch1: isdn4k-utils-3.25_20130409-missing_include_from_cvs.patch
Patch2: isdn4k-utils-3.27-gcc-5.patch
Patch3: isdn4k-utils-3.27-glibc-2.23.patch
Patch4: isdn4k-utils-3.27-tcl-8.6.5.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -57,6 +60,9 @@ This package contains static libraries, include files and other resources you ca
%setup -q
#%patch0 -p1
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
find . -name Makefile.in -exec sed -i "s|-o 0 -g 0||" {} \;
find . -name Makefile -exec sed -i "s|-o 0 -g 0||" {} \;
find . -name Makefile.in -exec sed -i "s|-o root -g root||" {} \;
@ -141,6 +147,9 @@ rm -f %{buildroot}%{_mandir}/xmonisdn.1x
%{_libdir}/pkgconfig/capi20.pc
%changelog
* Mon Dec 29 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.27-1mamba
- update to 3.27
* Sat May 18 2013 Automatic Build System <autodist@mambasoft.it> 3.25_20130409-1mamba
- automatic version update by autodist