fix installation of irdadump [release 0.9.18-4mamba;Wed Aug 03 2016]
This commit is contained in:
parent
742f064ead
commit
f0acdf22e0
65
irda-utils-0.9.18-gcc-6.1.0.patch
Normal file
65
irda-utils-0.9.18-gcc-6.1.0.patch
Normal file
@ -0,0 +1,65 @@
|
||||
diff -ru irda-utils-0.9.18.orig/findchip/nsc.c irda-utils-0.9.18/findchip/nsc.c
|
||||
--- irda-utils-0.9.18.orig/findchip/nsc.c 2006-07-11 08:16:06.000000000 +0200
|
||||
+++ irda-utils-0.9.18/findchip/nsc.c 2016-08-03 19:02:00.555842438 +0200
|
||||
@@ -33,7 +33,7 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
-#include <asm/io.h>
|
||||
+#include <sys/io.h>
|
||||
|
||||
#include "findchip.h"
|
||||
|
||||
diff -ru irda-utils-0.9.18.orig/findchip/smc.c irda-utils-0.9.18/findchip/smc.c
|
||||
--- irda-utils-0.9.18.orig/findchip/smc.c 2006-07-11 08:16:06.000000000 +0200
|
||||
+++ irda-utils-0.9.18/findchip/smc.c 2016-08-03 19:01:45.991854499 +0200
|
||||
@@ -32,7 +32,7 @@
|
||||
#include <string.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
-#include <asm/io.h>
|
||||
+#include <sys/io.h>
|
||||
|
||||
#include "findchip.h"
|
||||
|
||||
diff -ru irda-utils-0.9.18.orig/findchip/winbond.c irda-utils-0.9.18/findchip/winbond.c
|
||||
--- irda-utils-0.9.18.orig/findchip/winbond.c 2006-07-11 08:16:06.000000000 +0200
|
||||
+++ irda-utils-0.9.18/findchip/winbond.c 2016-08-03 19:02:21.066824772 +0200
|
||||
@@ -32,7 +32,7 @@
|
||||
#include <stdio.h>
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
-#include <asm/io.h>
|
||||
+#include <sys/io.h>
|
||||
|
||||
#include "findchip.h"
|
||||
|
||||
diff -ru irda-utils-0.9.18.orig/irdadump/Makefile irda-utils-0.9.18/irdadump/Makefile
|
||||
--- irda-utils-0.9.18.orig/irdadump/Makefile 2006-07-11 08:16:06.000000000 +0200
|
||||
+++ irda-utils-0.9.18/irdadump/Makefile 2016-08-03 19:07:28.023483245 +0200
|
||||
@@ -21,7 +21,7 @@
|
||||
|
||||
CFLAGS= -O2 -W -Wall -I. `pkg-config --cflags glib-2.0`
|
||||
|
||||
-LIBIRDADUMP_OBJS = irdadump.o irlap.o irlmp.o obex.o ircomm.o netbuf.o capture.o
|
||||
+LIBIRDADUMP_OBJS = irdadump.o irlmp.o irlap.o obex.o ircomm.o netbuf.o capture.o
|
||||
IRDADUMP_OBJS = main.o
|
||||
|
||||
LIBIRDADUMP_TARGET = lib_irdadump.a
|
||||
diff -ru irda-utils-0.9.18.orig/irdadump/irdadump.h irda-utils-0.9.18/irdadump/irdadump.h
|
||||
--- irda-utils-0.9.18.orig/irdadump/irdadump.h 2006-07-11 08:16:06.000000000 +0200
|
||||
+++ irda-utils-0.9.18/irdadump/irdadump.h 2016-08-03 19:14:59.839855966 +0200
|
||||
@@ -219,10 +219,10 @@
|
||||
guint8 caddr; /* LAP connection address (for garbage collect) */
|
||||
};
|
||||
|
||||
-inline void parse_obex(GNetBuf *buf, GString *str, int cmd);
|
||||
-inline void parse_irlmp(GNetBuf *buf, GString *str,
|
||||
+void parse_obex(GNetBuf *buf, GString *str, int cmd);
|
||||
+void parse_irlmp(GNetBuf *buf, GString *str,
|
||||
guint8 caddr, int type, int cmd);
|
||||
-inline void parse_ui_irlmp(GNetBuf *buf, GString *str, int type);
|
||||
+void parse_ui_irlmp(GNetBuf *buf, GString *str, int type);
|
||||
void parse_ircomm_params(guint8 clen, GNetBuf *buf, GString *str);
|
||||
void parse_ircomm_connect(GNetBuf *buf, GString *str);
|
||||
void parse_ircomm_lmp(GNetBuf *buf, GString *str);
|
@ -1,6 +1,6 @@
|
||||
Name: irda-utils
|
||||
Version: 0.9.18
|
||||
Release: 3mamba
|
||||
Release: 4mamba
|
||||
Summary: Utilities for infrared communication between devices
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -9,11 +9,12 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://irda.sourceforge.net
|
||||
Source: http://downloads.sourceforge.net/sourceforge/irda/irda-utils-%{version}.tar.gz
|
||||
Patch0: %{name}-0.9.18-fix_installroot.patch
|
||||
Patch1: irda-utils-0.9.18-gcc-6.1.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: bash
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libpci-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
@ -29,9 +30,9 @@ Most IrDA features are implemented in the kernel, so IrDA support must be enable
|
||||
Some configuration outside the kernel is required, however, and some IrDA features, like IrOBEX, are actually implemented outside the kernel.
|
||||
|
||||
%prep
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
make %{_smp_mflags} MANDIR=%{_mandir}
|
||||
@ -52,19 +53,22 @@ make install ROOT=%{buildroot} MANDIR=%{buildroot}%{_mandir}
|
||||
%{_bindir}/irkbd
|
||||
%{_bindir}/irpsion5
|
||||
%{_sbindir}/dongle_attach
|
||||
#%{_sbindir}/findchip
|
||||
%{_sbindir}/findchip
|
||||
%{_sbindir}/irattach
|
||||
#%{_sbindir}/irdadump
|
||||
%{_sbindir}/irdadump
|
||||
%{_sbindir}/irdaping
|
||||
%{_sbindir}/irnetd
|
||||
#%{_sbindir}/smcinit
|
||||
#%{_sbindir}/tosh1800-smcinit
|
||||
#%{_sbindir}/tosh2450-smcinit
|
||||
%{_mandir}/man4/irnet.4.gz
|
||||
%{_mandir}/man7/irda.7.gz
|
||||
%{_mandir}/man8/*.8.gz
|
||||
%{_sbindir}/smcinit
|
||||
%{_sbindir}/tosh1800-smcinit
|
||||
%{_sbindir}/tosh2450-smcinit
|
||||
%{_mandir}/man4/irnet.4*
|
||||
%{_mandir}/man7/irda.7*
|
||||
%{_mandir}/man8/*.8*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 03 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.18-4mamba
|
||||
- fix installation of irdadump
|
||||
|
||||
* Mon Aug 19 2013 Automatic Build System <autodist@mambasoft.it> 0.9.18-3mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user